Авторские права

Этот документ является автономной версией одного из документов библиотеки проекта Находка.ру (http://www.nakhodka.ru/library/).

Создание библиотеки обусловлено благой целью показать общественности уже опубликованные произведения литературы. Проект библиотеки полностью некоммерческий. Все тексты, представленные в библиотеке проекта Находка.ру были взяты из открытых источников. Библиотека руководствуется принципами уважения авторских прав на произведения и их соблюдения. В случае, если авторы и/или владельцы авторских прав на некоторые из этих произведений будут возражать против их нахождения в открытом доступе, просьба незамедлительно связаться с администрацией библиотеки по адресу: admin@nakhodka.ru

Создатель библиотеки рад сотрудничеству с авторами и/или владельцами авторских прав на произведения, тексты которых находятся в данной библиотеке.


Аннотация

Книга "Дорога в будущее", после выхода в свет в конце 1995 года сразу же стала бестселлером. Она была переведена практически на все основные языки мира, в том числе и на русский. Электронная версия появилась в октябре 1997 года.

Билл Гейтс (Bill Gates), глава корпорации Microsoft, на страницах этой книги размышляет об удивительных возможностях и непростых проблемах наступающего информационного века. Он раскрывает перед читателем свое видение будущего, рассказывает об основах информатики, развитии мировой компьютерной индустрии, о влиянии вычислительной техники на все стороны жизни общества, в том числе на бизнес и образование. В книге уделяется много внимания прошлому, настоящему и будущему глобальной информационной сети Internet. Читатели узнают и о знаменитом доме Билла Гейтса, куда он переехал в конце 1996 года.

Книга состоит из предисловия, 12 глав, послесловия и рассчитана на самый широкий круг читателей.

© Билл Гейтс, 1995
© Я. В. Злобин, составление, общая редакция, автор и создатель библиотеки, 2003


Об авторе

Уильям (Билл) Гейтс - председатель правления и президент корпорации Microsoft, ведущего мирового производителя программного обеспечения для персональных компьютеров. Доходы компании Microsoft за 1997 финансовый год составили более 11 миллиардов долларов. В отделениях компании, расположенных в 56 странах мира, работает более 22 тысяч человек.

Билл Гейтс родился 28 октября 1955 года. Он и две его сестры выросли в Сиэтле. Их отец, Уилльям Гейтс II, - адвокат. Мать г-на Гейтса, Мэри Гейтс, была школьной учительницей, членом правления в Университете штата Вашингтон (University of Washington) и председателем благотворительной организации United Way International.

Сначала Билл Гейтс учился в муниципальной начальной школе, а затем - в частной школе Lakeside School. Там, в возрасте 13 лет, он начал программировать на языке Basic.

В 1973 году г-н Гейтс поступил на первый курс Гарвардского университета. В Гарварде он познакомился со Стивом Баллмером (Steve Ballmer), который сегодня занимает пост вице-президента Microsoft по продажам и поддержке. Во время своего пребывания в Гарварде Билл Гейтс разработал версию языка программирования Basic для первого миникомпьютера - MITS Altair.

На третьем курсе Билл Гейтс оставил учебу в Гарварде, решив полностью посвятить себя Microsoft, компании, которую он основал в 1975 году совместно с Полом Алленом (Paul Allen). Твердо уверенные в том, что персональный компьютер станет незаменимым на каждом рабочем месте и в каждом доме, они начали разрабатывать программное обеспечение для персональных компьютеров.

Дар предвидения Билла Гейтса относительно развития персональных компьютеров стал ключевым фактором успеха Microsoft и индустрии программного обеспечения в целом. Г-н Гейтс активно занимается управлением и принятием стратегических решений в Microsoft и играет важную роль в технической разработке новых продуктов. Значительная часть его времени посвящена встречам с клиентами, а также общению по электронной почте с сотрудниками Microsoft во всем мире.

Под руководством Билла Гейтса, Microsoft постоянно развивает и совершенствует информационные технологии и продукты. Залог успеха Microsoft - стремление сделать работу с компьютером более простой, экономичной и приятной. Не упускаются из виду и долгосрочные перспективы - в 1997 финансовом году на научно-исследовательские работы было израсходовано более 2 миллиардов долларов.

В 1995 году Билл Гейтс написал книгу "Дорога в будущее" (The Road Ahead), в которой изложил свои взгляды на то, в каком направлении движется общество в связи с развитием информационных технологий. Книга была написана в соавторстве с Натаном Мирволдом (Nathan Myhrvold), вице-президентом Microsoft, и журналистом Питером Райнарсоном (Peter Rinearson). На протяжении семи недель "Дорога в будущее" занимала первое место в списке бестселлеров газеты New York Times. Книга была опубликована в США в издательстве Viking и продержалась в списке бестселлеров New York Times в общей сложности 18 недель. За пределами США "Дорога в будущее" была опубликована более чем в 20 странах. Только в Китае было продано свыше 400 тысяч экземпляров.

В 1996 году, когда корпорация Microsoft была переориентирована на Интернет-технологии, Гейтс внес в книгу значительные коррективы. Во второй редакции нашла отражение идея о том, что появление интерактивных сетей - важная веха в истории развития человечества. Вторая редакция книги, вышедшая в мягкой обложке, также стала бестселлером. Доходы от книги г-н Гейтс перечисляет в благотворительный фонд, направленный на поддержку учителей по всему миру, которые используют компьютерные технологии в учебном процессе.

Помимо увлечения компьютерными технологиями, Билл Гейтс интересуется еще и биотехнологией. Он входит в правление компании Icos Corporation и владеет акциями компании Darwin Molecular, которая является подразделением британской компании Chiroscience. Он также основал компанию Corbis Corporation, которая занимается разработкой крупнейшего источника визуальной информации в мире - это всеохватывающий цифровой архив произведений искусства и фотографий из государственных и частных коллекций, хранящихся в разных странах. Билл Гейтс также вложил средства в компанию Teledesic, которая работает над реализацией грандиозного проекта по запуску на низкую орбиту вокруг земного шара нескольких сотен спутников. Задача этих спутников - обеспечивать всемирные двусторонние широкополосные телекоммуникации.

В течение 11 лет, которые прошли с тех пор, как акции Microsoft были выпущены на открытый рынок, г-н Гейтс пожертвовал на благотворительные цели более 500 миллионов долларов. Основные области, в которые поступают эти средства: образование, демографические проблемы и доступ к технологиям.

1 января 1994 года Билл Гейтс женился на Мелинде Френч. В 1996 году у них родилась дочь, Дженнифер Кэтрин Гейтс.

10 - 11 октября 1997 года Билл Гейтс находился в Москве, куда приехал с деловым визитом. Он провел встречи с вице-премьером российского правительства Анатолием Чубайсом и председателем Центробанка Дубининым. Также г-н Гейтс встретился с российским премьером Виктором Черномырдиным и представителями Сбербанка России. Кроме всего прочего, Билл Гейтс дал пресс-конференцию, где рассказал о своем видении перспектив развития информационных технологий, а также ответил на ряд интересных вопросов. Побывав в России, Гейтс, несомненно придал новый импульс процессу развития компьютерного, информационного и телекоммуникационного рынков в нашей стране, и выразил надежду, что Россия еще сыграет далеко не последнюю роль в построении всемирной информационной магистрали.

Билл Гейтс много читает, а также любит играть в гольф и бридж.


Эпиграф

Следующая глава

Билл Гейтс

Дорога в будущее

Накануне XXI-го века на нас обрушился нескончаемый поток разговоров и рассуждений на тему информационной магистрали (information highway) и наступающей эры технологии. Сегодня Билл Гейтс - человек, который построил Microsoft и превратил ее в одну из самых процветающих компаний мира, - хочет поделиться своим видением того, что ждет нас в скором времени. Его книга - взгляд с высоты птичьего полета на неизведанные земли, по которым вскоре пройдет информационная магистраль; авторитетный, будоражащий воображение и легко читаемый путеводитель в будущее. Книга Билла Гейтса очень убедительна и реалистична. Он, обладая даром предвидения, заглядывает чуточку вперед, чтобы показать нам, как изменят мир грядущие цифровые технологии. Как говорит сам Билл, мы на пороге новой революции и сейчас пересекаем технологический барьер, за которым все станет иначе: мы будем по-другому покупать, по-другому работать, по-другому учиться, по-другому общаться. В книге ДОРОГА В БУДУЩЕЕ, оборачиваясь назад, Гейтс вспоминает и о том времени, когда он решил бросить Гарвард ради того, чтобы основать свою программистскую фирму и способствовать наступлению эры персональных компьютеров, которую он предвидел. Персональные компьютеры коренным образом изменили стиль нашей работы, но инструменты информационного века (появляющиеся уже сейчас) кардинально изменят и нашу жизнь. Гонорар от этой книги Билл Гейтс передает на финансирование грантов, присуждаемых National Foundation for Improvement in Education, по информационным технологиям в образовании.

Следующая глава


Предисловие

Следующая глава

Предисловие

Последние двадцать лет обернулись для меня одним сплошным приключением. А началось все в тот день, когда я и мой друг Пол Аллен (Paul Allen), студенты-второкурсники, стояли на Harvard Square и в журнале Popular Electronics сосредоточенно изучали описание сборного компьютера. С волнением читая о первом, действительно персональном компьютере, мы с Полом, конечно же, не представляли всех его возможностей, но в том, что он изменит и нас, и мир вычислительной техники были уверены точно. Так и случилось. Наступление эры персональных компьютеров вызвало подлинную революцию, которая затронула миллионы людей. Она привела нас туда, куда мы поначалу и вообразить не могли.

Сегодня мы все отправляемся в новый великий путь. Никто не знает наверняка, куда мы попадем на этот раз, но я вновь уверен, что эта революция коснется еще большего числа людей и продвинет общество гораздо дальше. Кардинальные перемены произойдут прежде всего в общении людей. Выгоды и проблемы, которые сулит грядущая революция в области связи, очевидно, окажутся грандиознее тех, что принесла с собой эра персональных компьютеров. Для неисследованных земель надежных карт нет, но мы можем извлечь важные уроки из становления и развития индустрии персональных компьютеров, суммарный оборот которой достиг сегодня 120 миллиардов долларов. Персональные компьютеры и их оборудование, деловые приложения, оперативные службы, Internet, электронная почта, мультимедийные продукты, авторские инструментальные средства, игры - все это послужит фундаментом для следующей революции.

Пока индустрия персональных компьютеров пребывала в младенчестве, средства массовой информации практически не обращали внимания на то, что происходило в этой абсолютно новой отрасли. Люди, увлеченные компьютерами и возможностями, которые они открывали, оставались неизвестны за пределами своего круга и явно не воспринимались всерьез.

Но предстоящая дорога - к так называемой информационной магистрали - теперь уже предмет нескончаемых газетных и журнальных статей, радио- и телепередач, научных конференций и невежественных спекуляций. В последние несколько лет к этой теме проявляют невероятный интерес самые разные люди - занятые в компьютерной индустрии и непричастные к ней. Кстати, это относится не только к развитым странам, но и к таким, которые не входят в огромную армию пользователей персональных компьютеров.

Тысячи информированных (и неинформированных) людей теперь публично рассуждают на тему "информационной магистрали". И меня поражает полное непонимание этой технологии и ее возможных недостатков. Одни полагают, что магистраль (ее еще называют сетью) - это всего лишь сегодняшний Internet или сразу 500 каналов по телевидению. Другие надеются (или опасаются), что прогресс приведет к появлению компьютеров с интеллектом на уровне человеческого. Когда-нибудь так и будет, но к информационной магистрали все это не имеет никакого отношения.

Революция в области связи только начинается. Она растянется на несколько десятилетий, и ее движущей силой станут новые "приложения" - новые инструменты, отвечающие тем потребностям, которые сейчас трудно даже представить. В течение следующих нескольких лет правительствам, компаниям и отдельным лицам придется принять ряд крупных решений. Эти решения определят и само строительство информационной магистрали, и в конечном счете - выгоду от него. Очень важно, чтобы в дискуссиях о будущем компьютерной технологии участвовал широкий круг людей, а не только те, кто к ней причастен. И если этого удастся добиться, магистраль будет такой, какой ее хотят видеть пользователи. Только тогда она получит широкое признание и станет реальностью.

Я хочу, чтобы эта книга была моим вкладом в публичные дебаты, и надеюсь - хотя это и не очень скромно, - что она послужит путеводителем в предстоящей всем нам дороге. Признаюсь, что пишу ее не без трепета. Ведь сегодня мы все смеемся над прошлыми предсказаниями, которые на поверку оказались не более чем наивными фантазиями. Пролистайте старые подшивки журнала Popular Science и почитайте о комфортабельном семейном вертолете или о ядерной энергии - "такой дешевой, что ее расход никто не будет измерять". История полна подобных курьезов: оксфордский профессор, в 1878 году считавший электричество шарлатанством; представитель американской патентной службы, в 1899 году предложивший закрыть ее, так как "все, что можно было изобрести, уже изобретено".

Стремясь к тому, чтобы книга получилась серьезной, я в то же время хорошо понимаю, что спустя лет десять она, возможно, такой уже не покажется. Что из сказанного мной сбудется, станут считать очевидным, а что не сбудется, - смешным. Тем не менее я уверен, что строительство информационной магистрали во многом отразит историю создания и развития индустрии персональных компьютеров.

Я включил в книгу и кусочек своей биографии, расскажу (хотя об этом было уже немало разговоров) о своем доме, поговорю о вычислительной технике вообще, что, надеюсь, поможет прояснить некоторые концепции и извлечь уроки прошлых лет. Если Вы ждете подробных мемуаров или трактата о том, каково быть таким счастливчиком, Вы разочаруетесь. Может быть, когда удалюсь от дел, я и напишу что-нибудь в таком духе. Но эта книга обращена главным образом в будущее.

Тот, кто рассчитывает на техническую монографию, тоже разочаруется. Информационная магистраль коснется каждого, значит, все должны понимать ее смысл. Вот почему я с самого начала решил написать книгу, доступную самому широкому кругу людей.

Размышления над ДОРОГОЙ В БУДУЩЕЕ и ее написание заняли гораздо больше времени, чем я ожидал. Оказалось, что выпустить книгу ничуть не легче, чем подготовить план разработки крупного программного проекта. Даже при талантливой помощи Питера Райнарсона и Натана Мирволда эта книга шла весьма трудно. Единственное, с чем мы справились быстро, - с фотографией Энни Лейбович (Annie Leibovitz) для обложки. Она была готова значительно раньше самой книги. Я всегда охотно сочинял разнообразные спичи и думал, что книга пишется так же. Я воображал, что написать главу - то же самое, что написать очередную речь. Это заблуждение свойственно и начинающим программистам, которые не подозревают, что создание в 10 раз большей программы в 100 раз труднее. Мне-то следовало это знать. Чтобы закончить книгу, пришлось выкроить время и уединиться в летнем домике на пару с компьютером.

И вот книга у Вас в руках. Надеюсь, она поможет Вам понять, как воспользоваться преимуществами всего того, что, я уверен, ждет нас в ближайшем десятилетии, натолкнет на какие-то конструктивные идеи и заставит со мной поспорить.

Следующая глава


Глава 1 - Революция начинается

Глава 1
Революция начинается

Свою первую программу я написал в 13 лет - для игры в крестики-нолики. Компьютер, с которым я тогда работал, был медлительным и громоздким, но очень притягательным.

Приучать подростков к компьютеру - такая идея возникла в Клубе матерей в Лейксайде, частной школе, где я учился. На выручку от благотворительного базара купили терминал и компьютерное время. Дать школьникам поработать с компьютером в конце шестидесятых - для Сиэтла это было что-то ! Такое не забывается !

У нашего терминала не было экрана. Нам приходилось набирать свои ходы на клавиатуре, похожей на пишущую машинку, и терпеливо дожидаться результатов - бумажной ленты, выползавшей из натужно грохотавшего печатающего устройства. Мы все толпились вокруг этой ленты, чтобы узнать, кто победил, или придумывали следующий ход. Игра в крестики-нолики, на которую обычно уходит едва ли секунд тридцать, занимала большую часть обеденного перерыва. Но кого это волновало ? Было в этой машине что-то такое, что неодолимо притягивало.

Впоследствии я, кажется, понял причину нашего увлечения. Представьте: вот сложнейшая, дорогая "взрослая" машина, а мы, юнцы, умеем ею управлять. Мы были слишком малы, чтобы водить автомобиль или заниматься чем-то еще интересным, чем обычно занимаются взрослые, зато могли отдавать этой огромной машине приказы, и она всегда подчинялась. Компьютеры хороши тем, что Вы тут же узнаете, правильна Ваша программа или нет. Иначе говоря, здесь проявляется четкая обратная связь, которой трудно добиться в других вещах. Вот так и началось мое увлечение программированием. И по сей день я, как в детстве, волнуюсь, правильно ли я сделал программу, будет ли она работать - именно так, как я задумал.

Когда нам стали доверять, мы смогли чаще вертеться возле компьютера, сочиняя более быстрые программы и усложняя игры. Один из моих друзей по Лейксайду составил программу на Бейсике, которая имитировала игру в монополию. Бейсик (Beginner's All-purpose Symbolic Instruction Code - универсальный символьный программный код для начинающих), как и говорит его название, сравнительно простой в освоении язык программирования, на котором мы разрабатывали все более сложные программы. Благодаря ему мы поняли, как заставить компьютер действительно быстро "играть" в сотни игр. Мы пичкали машину всякими программами, проверяя разные методы игры. Мы хотели выяснить, какая стратегия побеждает чаще. И - чух-чух, чух-чух - компьютер отвечал нам.

Но мы не только играли в свои игрушки - как и все дети, мы изменяли их. Если Вы когда-нибудь наблюдали за ребенком, который превращает листы картона в космический корабль, а цветными мелками рисует панель современных приборов, или слышали, как дети изобретают свои правила ("Красные машины могут расталкивать остальных"), то знаете, что желание сделать из игрушки нечто большее лежит в основе любых познавательных игр. Это - суть творчества.

Конечно, тогда мы просто убивали время у компьютера или, по крайней мере, так думали. Но игрушка, которая попала нам в руки, что ж, она оказалась непростой. Мало кто в Лейксайде отказался бы с ней поиграть. Постепенно вся школа стала связывать нас с компьютером, а его - с нами. Например, как-то раз один учитель попросил меня помочь ему освоить программирование компьютера, и никто не увидел в этом ничего зазорного. Но когда я сыграл главную роль в школьной пьесе Black Comedy, кое-кто начал ворчать: "И чего мы взяли этого компьютерщика ?" Меня до сих пор иногда так называют.

Такое впечатление, что нас - повзрослевших, но не расставшихся со своей любимой игрушкой - по всему миру набралось на целое поколение. Тем самым мы совершили что-то вроде революции (мирной, конечно), и теперь компьютеры прочно обосновались в наших офисах и домах. Компьютеры сильно уменьшились в размерах, солидно прибавили в мощности и фантастически подешевели. И все это произошло за довольно короткое время, хотя и не так быстро, как я когда-то думал. Недорогие компьютерные "чипы" теперь где только не встречаются: в машинах, часах, антиблокировочных тормозах, факсимильных аппаратах, лифтах, бензонасосах, фотоаппаратах, термостатах, тренажерах, торговых автоматах, системах противоугонной сигнализации и даже в "говорящих" открытках. В наши дни школьники делают замечательные вещи на персональных компьютерах, по размеру не больших книги, но превосходящих по своей мощи самые крупные компьютеры прошлого поколения.

Сегодня, когда вычислительная техника доступна по цене и может использоваться в повседневной жизни, мы стоим на пороге новой революции. Она связана с беспрецедентным удешевлением связи; все компьютеры будут постепенно соединены друг с другом, чтобы общаться с нами и для нас. Глобально взаимосвязанные, они образуют грандиозную сеть - так называемую информационную магистраль (information highway). Прямой ее предок - нынешний Internet, объединяющий большую группу компьютеров, которые обмениваются информацией на базе современной технологии.

Возможно ли создание этой новой сети ? Каково ее применение ? Перспективы ? Какие опасности она таит в себе ? Все эти вопросы рассматриваются в данной книге.

Нас волнует любой аспект того, что не сегодня-завтра станет реальностью. Когда мне было девятнадцать, я уловил образ будущего и построил свою карьеру на том, что сумел увидеть. Как оказалось, я был прав. Но девятнадцатилетний Билл Гейтс занимал совсем другую общественную ступень. Тогда я был самоуверен, как, впрочем, и все подростки, никто за моими высказываниями не следил, и если бы у меня ничего не вышло - ну и что ? Сегодня мое положение куда ближе к компьютерным гигантам семидесятых, хотя, надеюсь, мне удалось извлечь уроки из их опыта.

В колледже одно время мне казалось, что я выберу основным предметом экономику. В конце концов я передумал, но весь мой опыт работы в компьютерной индустрии - в какой-то мере серия уроков по экономике. Я на собственном примере не раз убеждался во влиянии "положительных спиралей" и моделей негибкого ведения бизнеса. Я наблюдал, по какому пути пошло развитие промышленных стандартов. Я был свидетелем тому, насколько важна совместимость в технологиях, обратная связь и постоянное новаторство. И уверен, что все мы вот-вот увидим наконец реализацию модели идеального рынка по Адаму Смиту.

Но я использую эти уроки не только для того, чтобы предугадывать будущее, - я делаю на него ставку. Еще подростком я предвидел, как повлияют на нашу жизнь недорогие компьютеры. "Компьютер на каждый стол и в каждый дом" - стало девизом корпорации Microsoft, и мы работали над тем, чтобы это сбылось. Теперь такие компьютеры соединены друг с другом, а мы создаем программы (инструкции, заставляющие компьютер делать то-то и то-то), которые помогут получить выгоду от коммуникационной мощи объединенных компьютеров. Сейчас еще нельзя предсказать, каким образом будут использовать эту сеть. Мы будем "общаться" с ней с помощью множества разных устройств: одни будут чем-то вроде телевизионных приемников, другие - чем-то вроде нынешних персональных компьютеров; третьи будут напоминать современные телефоны, а четвертые нечто такое, что по размеру и форме похоже на бумажник. И внутри каждого из них будет мощный компьютер, невидимо соединенный с миллионами других компьютеров.

Не за горами то время, когда вести дела, заниматься бизнесом, изучать мир и его культуры, присутствовать на грандиозном представлении, заводить друзей, "посещать" магазины и демонстрировать фотографии дальним родственникам можно будет не вставая из-за стола или с кресла. Связь с сетью не прекратится даже в том случае, когда Вы уйдете из офиса или из школьного класса. Устройство, обеспечивающее эту связь, будет чем-то большим, чем карманный аппаратик, купленный Вами в ближайшем магазине. Оно станет пропуском к новому, опосредованному стилю жизни.

Жизненный опыт каждого человека - вещь чисто индивидуальная. Никто во имя прогресса не отнимет у Вас удовольствия полежать на пляже, побродить по лесу, посетить театр или поторговаться на блошином рынке. Но не всякий опыт полезен. Скажем, стояние в очередях - опыт сугубо личный, но мы всегда пытались избавиться от него, - еще с тех пор, как встали в первую очередь.

Человечество прогрессировало в основном потому, что кто-то изобретал инструмент получше и помощнее. Механические инструменты ускоряли работу и избавляли от тяжелого ручного труда. Плуг и колесо, подъемный кран и бульдозер умножают физические способности тех, кто ими пользуется.

Инструменты обработки информации - посредники, умножающие интеллект, а не мускульную силу. Например, читая эту книгу, Вы приобретаете опосредованный опыт: Вас нет рядом со мной, но Вы узнаете, о чем я думаю. Сегодня в любой деятельности для принятия серьезных решений требуются обширные знания, поэтому основное внимание изобретателей смещается именно на инструменты обработки информации (а в будущем это проявится еще больше !). Точно так же, как любой текст можно представить набором букв, эти инструменты позволяют и любую информацию представить в цифровой форме, набором электрических импульсов, легко "воспринимаемых" компьютером. Сегодня в мире уже более 100 миллионов компьютеров, назначение которых - обрабатывать информацию. В наше время они упрощают хранение и передачу информации, находящейся в цифровой форме, а вскоре обеспечат доступ практически к любой информации, накопленной в мире.

В США соединение всех компьютеров сравнивают с другим крупным проектом, реализация которого началась еще во времена Эйзенхауэра, прокладкой по всей стране сети автомобильных магистралей, связавших разные штаты. Вот почему новую сеть окрестили "информационной супермагистралью". Это понятие популяризировал тогдашний сенатор Эл Гор (Al Gore), отец которого в 1956 году внес на рассмотрение в Сенат Federal Aid Highway Act (Федеральный Закон о поддержке строительства автомобильных магистралей).

Однако метафора, основанная на сходстве с дорогой, не совсем точна. Она вызывает ассоциации с ландшафтом и географией, неким расстоянием между двумя точками, подразумевает, что надо ехать из одного места в другое. А в действительности одна из самых примечательных сторон новой коммуникационной технологии как раз в том и состоит, что она устраняет расстояния. При этом не важно, где находится тот, с кем Вы общаетесь: в соседней комнате или на другом континенте, - ведь эту высокоопосредованную сеть не сдерживают ни мили, ни километры.

Понятие "магистраль" также предполагает, что все движутся по одному маршруту. А эта сеть больше похожа на паутинку из лесных тропинок, где каждый может забрести в самые дебри и делать там то, что ему заблагорассудится. Еще один недостаток упомянутой метафоры: в ней содержится намек на участие правительства, а это, как мне кажется, было бы крупной ошибкой для большинства стран. Однако настоящая проблема все-таки в том, что метафора подчеркивает прежде всего инфраструктуру, а не область применения. Мы в Microsoft говорим об "информации на кончиках пальцев", делая акцент не на самой сети, а на выгодах, которые она принесет.

Другая метафора, на мой взгляд, удачнее передает суть будущей кипучей деятельности - "универсальный рынок" (ultimate market). Рынки, где торгуют всем - от стройматериалов до деревянных молотков для игры в шары, - фундамент человеческого общества, и я считаю, что этот новый рынок в конце концов станет центральным универмагом всего мира. Именно там мы, существа общественные, будем торговать, торговаться, вкладывать деньги, подбирать персонал, спорить, знакомиться и просто "толкаться". Так что при словах "информационная магистраль" не думайте о дороге, а представьте рынок или биржу. Вообразите суету нью-йоркской фондовой биржи, или сутолоку фермерского рынка, или толчею в книжном магазине. На этом рынке будут представлены все виды человеческой деятельности - от миллиардных сделок до флирта. Покупки станут оплачиваться деньгами в цифровой форме, а не наличными. Но главное, в роли всеобщего эквивалента будут выступать не только деньги, но и разнообразная цифровая информация.

Глобальный информационный рынок объединит все способы обмена товарами, услугами и идеями. На практике это еще больше расширит возможности выбора многих вещей, включая то, как Вы зарабатываете себе на жизнь и куда вкладываете деньги, что покупаете и сколько за это платите, кто Ваши друзья и как Вы проводите свободное время, где и насколько безопасно живете Вы и Ваша семья. Рабочее место, да и само представление о том, что значит быть "образованным", трансформируются - скорее всего за пределы узнаваемости. Ваше самосознание, т.е. ощущение себя как личности, того, кто Вы и где Ваши корни, может измениться кардинальным образом. Короче говоря, почти все будет иначе. Едва ли это произойдет завтра, но я делаю все, что в моих силах, чтобы приблизить этот день.

Вы сомневаетесь в таком будущем ? Или не хотите в него поверить ? Тогда не исключено, что Вы просто не склонны в нем участвовать. Так часто бывает с людьми, когда какая-нибудь новая технология угрожает сломать привычный и потому удобный порядок. Поначалу и велосипед был глупой штуковиной, автомобиль - шумной игрушкой, карманный калькулятор - угрозой изучению математики, а радио - концом образования.

Но вдруг что-то случилось. Прошло время, и эти машины нашли свое место в нашей повседневной жизни, потому что они не только удобны и экономят время, но и вдохновляют на взятие новых высот. Общество к ним потеплело. Они присоединились к другим нашим инструментам. Потом выросло новое поколение, которое изменяло и очеловечивало их, т.е. играло с ними.

Крупным достижением в двусторонней связи был телефон. Но поначалу даже о нем отзывались как о чистом мучении ! Люди чувствовали себя неуютно и неловко, когда в их дома вторгся этот механический пришелец. Но в конце концов и мужчины, и женщины осознали, что этот аппарат не просто новая машина, а новый вид связи. Разговор по телефону, обычно краткий, не требовал соблюдения всех тонкостей этикета, как живая беседа, лицом к лицу. Это было непривычно и многих обескураживало. До изобретения телефона любой основательный разговор требовал визита, часто с угощением и вполне мог занять все время после полудня или целый вечер. Когда же в большинстве домов и на многих предприятиях установили телефоны, люди стали думать, как лучше воспользоваться уникальными преимуществами этого средства связи. По мере того как телефон все шире и шире входил в нашу жизнь, появлялись особые выражения, развивалась особая культура общения - "телефонный этикет". Александер Грейам Белл определенно не предвидел глупых административных игр вроде "пусть-мой-секретарь-поставит-его-в-очередь-ко-мне-на-прием". Пока я пишу эту книгу, современная форма связи - электронная почта (e-mail) - проходит примерно тот же путь: в ней тоже устанавливаются свои правила, складываются свои обычаи.

"Постепенно машина станет частью человечества", - писал в 1939 году французский авиатор и писатель Антуан де Сент-Экзюпери в своих мемуарах. Он рассуждал о том, как люди обычно реагируют на новую технологию, и привел пример - отношение к железной дороге в девятнадцатом веке. Поначалу дымящие, демонически шумные, примитивные паровые локомотивы воспринимались не иначе, как железные монстры. Но с течением времени прокладывались все новые и новые пути, в городах начали строить красивые здания железнодорожных вокзалов. Там предлагалось все больше товаров и услуг. Постепенно вокруг нового вида транспорта сложилась своя культура, презрение сменилось приятием, даже одобрением. То, что раньше считали железным монстром, стало могучим средством перевозки. И вновь смена общественного восприятия отразилась в языке. Мы начали называть его уважительно - "железным конем".

Единственное событие, которое так же существенно, как и телефон, повлияло на историю связи, произошло где-то в 1450 году, когда Иоганн Гутенберг (Johann Gutenberg), золотых дел мастер из Майнца (Германия), изобрел подвижную литеру и создал первый печатный пресс в Европе (в Китае и Корее такие прессы уже были). Это событие навсегда изменило западную культуру. Подготовка первого печатного набора для Библии отняла у Гутенберга около двух лет, зато потом он смог напечатать целый ее "тираж". До Гутенберга все книги переписывали от руки. Монахи, которые обычно занимались этим, редко умудрялись переписать более одного текста в год. По сравнению с ними печатный пресс Гутенберга был чем-то вроде скоростного лазерного принтера.

Печатный пресс дал Западу больше, чем простое ускорение репродукции книг. До того времени, несмотря на то, что одно поколение сменялось другим, жизнь была общинной и шла своим чередом. Большинство знало только то, что они сами видели или слышали от других. Немногие отваживались далеко уходить от своих деревень - отчасти потому, что без точных карт почти невозможно было найти дорогу домой. Об этом хорошо сказал Джеймс Берк (James Burke), мой любимый журналист: "В том мире весь опыт был исключительно личным: горизонты были узкими, община - замкнута на себя. О том, что существовало за ее границами, знали лишь понаслышке".

Печатное слово все преобразило. Оно явилось первым средством массовой информации; впервые знания, мнения и опыт можно было передавать в компактном, долговечном и доступном виде. Когда печатное слово расширило горизонты общины далеко за пределы деревни, люди начали интересоваться тем, что происхосходит в мире. В торговых городах, как грибы, выросли книжные лавки, которые превратились в центры обмена интеллектуальными ценностями. Грамотность стала насущной потребностью, что вызвало революцию в образовании и изменило социальную структуру общества.

До Гутенберга в Европе существовало около 30000 книг, почти все Библии или комментарии к ним. А к 1500 году насчитывалось уже более 9 миллионов книг на самые разнообразные темы. Они влияли на политику, религию, науку и литературу. Впервые доступ к письменной информации получили и те, кто не принадлежал к церковной элите.

Информационная магистраль трансформирует нашу культуру не менее кардинально, чем книгопечатный пресс Гутенберга - средневековую.

Персональные компьютеры уже изменили наш стиль работы, но пока они мало что изменили в нашей жизни. Когда к магистрали подключатся завтрашние мощные устройства обработки информации, станет доступно все: люди, машины, развлечения, информационные услуги. Где бы Вы ни находились, Вы не потеряете контакт с тем, кто не хочет терять контакта с Вами, Вы сможете "рыться" на полках тысяч библиотек в любое время дня и ночи. Потерянный или украденный фотоаппарат сам сообщит Вам свои координаты - даже из другого города. Находясь в офисе, Вы сможете отвечать на звонки в квартиру, а из дома - на офисную почту. Информация, которую сегодня очень трудно найти, завтра станет доступна:

Не опаздывает ли Ваш автобус ?

Не случилось ли чего на маршруте, по которому Вы обычно ездите на работу ?

Не хочет ли кто поменять свои билеты в театр на четверг на Ваши - на среду ?

Что записано у ребенка и школьном дневнике ?

Как приготовить вкусное блюдо из палтуса ?

Какой магазин (где бы он ни был) может к завтрашнему утру доставить на дом по самой низкой цене наружные часы с измерителем пульса ?

Сколько можно выручить за старый "Мустанг" с откидным верхом ?

Как делают ушки в иголках ?

Готовы ли рубашки в прачечной ?

Где самая дешевая подписка на The Wall Street Journal ?

Каковы симптомы сердечного приступа ?

Нет ли сегодня в окружном суде интересных слушаний ?

Видят ли рыбы в цвете ?

Как выглядят сейчас Елисейские Поля ?

Где Вы были в 21.02 в прошлый четверг ?

Допустим, Вы подумываете, - а не попробовать ли кухню нового ресторана ?.. Тогда надо узнать его меню, в том числе набор вин и особых блюд, предлагаемых в определенные дни. Может быть, Вас интересует мнение ресторанного критика ? Может быть, Вам небезразлична и оценка санитарного состояния этого места, данная департаментом здравоохранения ? А если Вы побаиваетесь района, в котором находится ресторан, то неплохо бы просмотреть рейтинг безопасности по полицейским сводкам. Еще не расхотелось идти в ресторан ? Нет ? Тогда закажите столик, возьмите карту и узнайте, как сейчас лучше к нему проехать. Маршрут можно распечатать или заставить компьютер проговорить (и уточнить) его прямо в пути.

Вся эта информация будет легко доступна и абсолютно персональна - Вы сможете изучать любую ее часть, в любой форме и тогда, когда Вам захочется. Нужные передачи Вы посмотрите в то время, когда это удобно Вам, а не телестудии. Вы будете делать покупки, заказывать еду, обнародовать информацию, связываться с приятелями по хобби так, как только пожелаете. Ежевечерние передачи новостей будут начинаться в определенное Вами время и длиться столько, сколько нужно Вам. В них будут затрагиваться только те темы, которые отобраны Вами или службой, знающей о Ваших интересах. Вы сможете запрашивать репортажи из Токио, Бостона или Сиэтла, требовать дополнительных подробностей по увиденным сюжетам или узнавать, не прокомментировал ли какое-то событие Ваш любимый фельетонист. А если захотите, новости доставят в письменном виде, на бумаге.

Перемены таких масштабов всегда пугают. Каждый день во всем мире люди задают вопросы, вопросы... Многие не могут избавиться от дурных предчувствий. Каково предназначение создаваемой сети ? Что будет с нашими рабочими местами ? Не уход ли это от физического мира, не получится ли так, что благодаря компьютерам мы проживем не свою, а чужую жизнь ? Не станет ли непреодолимым разрыв между имущими и неимущими ? Поможет ли компьютер лишенным гражданских прав в Сен-Луи или голодающим в Эфиопии ? Проблемы и сложности, достаточно серьезные, сеть, безусловно, принесет. В двенадцатой главе я остановлюсь на том, что обоснованно тревожит очень многих и о чем мне приходится слышать снова и снова.

Я много думал об этом и в конечном счете понял, что испытываю главным образом уверенность и оптимизм. Отчасти потому, что у меня просто такой характер, а отчасти потому, что воодушевлен перспективами, открывающимися моему поколению, которое взрослело вместе с компьютерами. Я из тех, кто считает: раз прогресс неумолим, надо извлекать из него лучшее. Тем не менее я очень волнуюсь, сознавая, что подсматриваю за будущим, улавливаю первые признаки революционных преобразований. Мне невероятно повезло, что уже второй раз мне выпадает шанс сыграть свою роль в начале эпохальных перемен.

Впервые я испытал такую эйфорию еще подростком, поняв, насколько мощными и недорогими станут компьютеры. Тот компьютер, на котором в 1968 году мы играли в крестики-нолики, да и все другие компьютеры в то время были большими ЭВМ: своенравными монстрами в коконах с искусственным климатом. Когда кончились деньги, выделенные Клубом матерей, мне и моему школьному приятелю Полу Аллену (с которым я впоследствии основал Microsoft) пришлось потратить немало времени, чтобы получить доступ к компьютерам. По нынешним меркам, они обладали весьма скромными характеристиками, но вызывали благоговение, потому что были огромны, сложны и стоили не один миллион долларов каждый. По телефонным линиям они подключались к лязгающим терминалам Teletype, так что с компьютером могли одновременно работать несколько человек в разных местах. С настоящими большими ЭВМ (теперь их обычно называют мэйнфреймами) мы почти не имели дела. Компьютерное время было слишком дорогим. Когда я учился в школе, час работы на терминале с таким компьютером обходился примерно в 40 долларов - за эту сумму Вы получали лишь малую толику драгоценного внимания компьютера. Сегодня, когда у некоторых не одна "персоналка" и они уже не знают, чем их "занять", это кажется удивительным. Правда, и в то время можно было завести собственный компьютер. Если Вы могли раскошелиться на 18000 долларов, пожалуйста - Digital Equipment Corporation (DEC) выпускала PDP-8. Хотя эту модель и называли "мини-компьютером", по нынешним стандартам, она была весьма громоздкой. Компьютер размещался на двухметровой стойке (площадь ее основания около половины квадратного метра), а весил 120 килограммов. Одно время такой компьютер стоял у нас в школе, и я часто вертелся вокруг него. По сравнению с мэйнфреймами, с которыми легко было связаться по телефону, PDP-8 обладал весьма ограниченными возможностями: его вычислительная мощность меньше, чем у некоторых современных наручных часов. Но программировать их можно было так же, как и самые большие и дорогостоящие ЭВМ. Несмотря на все свои ограничения, PDP-8 вселял в нас надежду, что когда-нибудь собственные дешевые компьютеры появятся у миллионов людей, и с каждым годом эта вера во мне укреплялась. Вероятно, одна из причин - желание самому иметь персональный компьютер.

Программное обеспечение, как и аппаратное, в то время стоило недешево. Его разрабатывали специально под определенную модель компьютера. Вдобавок оборудование каждого компьютера постоянно заменялось, из-за чего приходилось регулярно переписывать почти все его программы. Фирмы-изготовители поставляли вместе с компьютерами кое-какие программные компоненты - блоки для построения стандартных программ (например, библиотеки математических функций), но создание большей части программ, предназначенных для конкретных задач, было проблемой самого заказчика. Отдельные программы мы доставали бесплатно, а какие-то (в основном общего назначения) покупали у нескольких компаний. Однако готовых программных продуктов, которые Вы могли приобрести в магазине, было очень мало.

Мои родители платили за обучение в Лейксайде, давали деньги на книги, но о счетах за компьютерное время я должен был беспокоиться сам. Пришлось задуматься над коммерческой стороной программистского бизнеса. Вместе с Полом Алленом мы собрали небольшую группу и начали разрабатывать простейшие программы. Для школьников заработок был весьма внушительным - около 5000 долларов каждое лето (часть наличными, остальное - компьютерным временем). Мы заключили также договоры с несколькими компаниями, по которым могли бесплатно пользоваться их компьютерами, если выявим ошибки в программном обеспечении.

Одна из программ, написанных мной, составляла для классов списки учащихся. Тайком я добавил в нее несколько операторов и оказался чуть ли не единственным парнем в классе среди симпатичных девушек. Так что от машины, которая позволяла добиваться столь явных успехов, меня нельзя было оторвать: я уже был помешан на компьютерах.

Об аппаратной части компьютеров, самих машинах Пол знал куда больше меня. В один из летних дней 1972 года (мне было шестнадцать, а Полу девятнадцать) он показал мне небольшую статью, затерявшуюся на 143-й странице журнала Electronics. В ней сообщалось, что молодая фирма Intel выпустила микропроцессор с названием 8008.

Микропроцессор - чип (интегральная схема), в котором заключен "мозг" всего компьютера. Мы решили, что этот первый микропроцессор весьма ограничен, но Пол уверял, что чипы станут мощнее, а компьютеры, построенные на них, будут очень быстро совершенствоваться.

В то время в компьютерной индустрии никто и не думал создавать реальные компьютеры на каких-то микропроцессорах. Например, в статье из Electronics микропроцессор 8008 описывался как устройство, "пригодное для арифметических вычислений, систем управления и интеллектуальных терминалов". Авторы статьи даже и не предполагали, что микропроцессор когда-нибудь "вырастет" в универсальный компьютер. Микропроцессоры тогда были медленными и могли обрабатывать очень ограниченные объемы информации. Ни один из языков, известных программистам, не был доступен для 8008, что практически не позволяло разрабатывать для него сколько-нибудь сложные программы. Приложения приходилось программировать несколькими десятками простых инструкций, "понятных" этому микропроцессору. Обреченный на жизнь "рабочей лошадки", он снова и снова выполнял одни и те же простенькие задачи. Особенно часто его использовали в лифтах и калькуляторах.

Иными словами, простой микропроцессор, применяемый, скажем, в системе управления лифтом, - всего лишь отдельный инструмент, барабан или рожок, который в руках неискушенного музыканта вполне способен вывести несложную мелодию или выделить основной ритм. А мощный микропроцессор, поддерживающий языки программирования, подобен профессиональному оркестру. Под управлением нужных программ он может сыграть сложнейшие вещи.

Мы с Полом заинтересовались, какие программы можно сделать на 8008 микропроцессоре. Пол связался с Intel и попросил выслать документацию. Слегка удивившись, когда ее действительно прислали, мы с головой зарылись в нее. Я разработал версию Бейсика, "ходившую" на DEC PDP-8, и думал, что мне удастся сделать то же самое и для крошечного чипа фирмы Intel. Но, изучая документацию, понял, что не стоит и пытаться. Слишком он прост, слишком мало в нем транзисторов.

Однако мы придумали, как использовать этот маленький чип для устройства, которое анализировало информацию, снимаемую с уличных мониторов. Многие муниципалитеты, замеряя интенсивность транспортного потока, делали так: поперек улицы протягивали резиновую кишку. Когда ее переезжал автомобиль, она пробивала бумажную ленту в металлическом ящике, закрепленном на конце этой кишки. Мы увидели, что для обработки лент можно использовать 8008 микропроцессор - чтобы с его помощью печатать диаграммы и другую статистику. Свое первое детище мы окрестили "Traf-O-Data". В то время это звучало весьма поэтично.

Большую часть программного обеспечения для устройства Traf-O-Data я написал в автобусе, в поездках из Сиэтла в Пулмен (штат Вашингтон), где Пол учился в колледже. Прототип работал прекрасно, и мы уже представляли, как по всей стране будут продаваться тысячи наших машин... В конце концов нам удалось опробовать их у нескольких заказчиков, но покупателей мы так и не нашли - кому охота связываться с подростками ?!

Несмотря на разочарование, мы все так же верили в свое будущее - если не с аппаратными средствами, оно все равно будет связано с микропроцессорами. В 1973 году я поступил в Harvard College, а Пол, который каким-то образом ухитрился дотянуть на своем старом громыхающем "Крайслере" из Вашингтона до Бостона, начал работать в корпорации Honeywell программистом мини-компьютеров. Он часто ездил в Кембридж, так что мы по-прежнему встречались и подолгу обсуждали планы на будущее.

Весной 1974 года в журнале Electronics появилось сообщение о новом чипе Intel 8080 - в 10 раз более мощном, чем микропроцессор 8008 в машине Traf-O-Data. Микропроцессор 8080 не превышал по размерам 8008, но содержал на 2700 транзисторов больше. Он уже подходил для сердца настоящего компьютера, а стоил меньше 200 долларов. Мы набросились на документацию. "DEC больше не продаст ни одного PDP-8", - сказал я Полу. Нам казалось очевидным: раз крошечный чип стал настолько мощнее, значит, конец этих неуклюжих машин совсем близок.

Однако изготовители компьютеров не сочли микропроцессор угрозой ЭВМ. Они просто представить не могли, что какой-то там чип заменит "настоящий" компьютер. Даже ученые из Intel не до конца понимали его потенциальные возможности. Для них микропроцессор 8080 значил не более чем еще одно достижение в технологии производства микросхем. В краткосрочной перспективе "компьютерный истэблишмент" был прав. Микропроцессор 8080 - не более чем еще один шажок вперед. Но мы с Полом, невзирая на ограниченные возможности нового чипа, увидели другой тип компьютера, который идеально подошел бы и нам, и любому другому, - персональный и приемлемый по цене и параметрам. Нам было совершенно ясно, что новые чипы перспективны, поскольку очень дешевы.

Нам казалось, что аппаратные средства, выбор которых пока невелик, вскоре появятся в широком ассортименте, и доступ к компьютерам больше не будет таким дорогостоящим; что вычислительной технике, когда она станет дешевой, найдут новое применение. И вот тогда программное обеспечение сыграет ключевую роль в реализации огромного потенциала этих машин. Пол и я считали, что большую часть аппаратных средств будут выпускать японские компании и IBM. Мы же предложили бы новое, даже новаторское программное обеспечение. А почему бы и нет ? Микропроцессор наверняка изменит структуру компьютерной индустрии, и, быть может, в ней найдется место и нам.

Такие разговоры отвечали самому духу колледжа. Здесь Вы живете новыми ощущениями, предаетесь, казалось бы, безумным мечтам. Но мы были молоды и считали, что впереди у нас уйма времени. Я продолжал учиться в Гарварде и все время думал, как раскрутить программистскую фирму. Один план был очень прост. Из моего общежития мы разослали письма всем крупным компьютерным фирмам. В них мы предлагали версию Бейсика для нового чипа Intel. Никто на это не клюнул. К декабрю мы совсем отчаялись и закисли. На праздники я собирался слетать домой в Сиэтл, а Пол оставался в Бостоне. За несколько дней до вылета, пронзительно холодным массачусетсским утром мы с Полом стояли перед газетным киоском на Harvard Square. Пол взял в руки январский выпуск журнала Popular Electronics... Это как раз тот момент, о котором я упомянул в предисловии. С этого момента наши мечты стали обретать реальные очертания.

На обложке журнала была помещена фотография очень маленького компьютера, размером с тостер. Назывался он чуть-чуть достойнее нашей Traf-O-Data: Altair 8800 (заимствовано из кинофильма Star Trek). Его продавали по цене 397 долларов за сборный комплект (без клавиатуры и дисплея). У него было 16 адресных переключателей и 16 световых индикаторов. Вы могли заставить индикаторы перемигиваться на передней панели, вот, собственно, и все. Основная его проблема - отсутствие программного обеспечения. Altair 8800 нельзя было программировать, что превращало его скорее в новинку-игрушку, чем в серьезный инструмент.

Но что у "Альтаира" действительно было, так это микропроцессорный чип Intel 8080. Нас охватила паника: "Как же так ? Без нас ?! Теперь все кинутся писать настоящие программы для этого чипа !" Я был уверен, что революция, связанная с применением персональных компьютеров, близка, но хотел участвовать в ней с самого начала. Такой шанс выпадает раз в жизни, я не мог упустить его и не упустил.

Спустя 20 лет я испытываю похожие чувства. Правда, тогда я боялся, что и другие увидят будущее так же, как и мы; сегодня я знаю, что тысячи людей мыслят в этом направлении. Наследие той революции - ежегодные продажи 50 миллионов персональных компьютеров по всему миру и полное перераспределение капиталов в компьютерной индустрии. Кто-то победил, кто-то проиграл. В новой революции стремятся участвовать многие компании: перемены всегда открывают широчайшие возможности, главное - не опоздать.

Если оглянуться на последние 20 лет, станет очевидным: взгляды и привычки большинства крупных компаний так закоснели, что они не сумели должным образом перестроиться и, как результат, проиграли. Пройдет еще лет двадцать, и когда мы вновь обернемся, увидим похожую картину. Набирая эти строки, я знаю: где-то уже есть (хотя бы один !) человек, который хочет создать новую крупную фирму. Он (или она) уверен в правильности своего видения революции в области связи. И грядущие перемены, безусловно, вызовут к жизни тысячи инновационных компаний.

В 1975 году, когда Пол и я бесстрашно решили основать свою фирму, мы уподобились персонажам из фильмов Джуди Гарленд (Judy Garland) и Микки Руни (Mickey Rooney), которые в упоении кричали: "Мы поставим шоу хоть в сарае !" Больше нельзя было терять времени. Наш первый проект заключался в том, чтобы создать версию Бейсика для "Альтаира".

Нужно было очень многое втиснуть в крошечную память этого компьютера. У типичного "Альтаира" память примерно на 4 тысячи символов. А сегодня у большинства персональных компьютеров - на 4 или 8 миллионов символов. Задача осложнялась тем, что у нас не было "Альтаира", мы его даже не видели. Хотя это не имело особого значения, поскольку прежде всего нас интересовал новый микропроцессор Intel 8080. Впрочем, "живьем" мы его тоже не видели ! Однако, не сомневаясь ни минуты, Пол изучил документацию на этот чип, а затем написал программу, заставлявшую мэйнфрейм в Гарварде "строить из себя" крошечный "Альтаир". Не правда ли, очень похоже на то, как если бы у Вас был большой оркестр, а Вы заставили его играть простой дуэт ? Но это сработало.

Написание хорошей программы требует больших усилий, и создание Бейсика для "Альтаира" оказалось делом изнурительным. Иногда я часами ходил по комнате или раскачивался на кресле - так мне легче сосредоточиться на какой-нибудь идее - и думал, думал, думал. Зимой 1975 года я немало походил по своей комнате в общежитии. В тот период мы с Полом мало спали и путали день с ночью. Когда меня сваливал сон, я засыпал за столом или на полу. В отдельные дни я вообще ничего не ел и ни с кем не виделся. Но спустя 5 недель мы написали свой Бейсик - и родилась первая в мире компания, разрабатывающая программы для микрокомпьютеров. Чуть позже мы назвали ее "Microsoft".

Мы знали, что основать фирму - значит пойти на немалые жертвы. Но в то же время понимали, что делать это нужно сейчас, - иначе упустим свой шанс в программировании для микрокомпьютеров. Весной 1975 года Пол уволился с работы, а я решил оставить Гарвард.

Этот шаг я обговорил с родителями, которые здорово соображали в бизнесе. Они поняли, насколько сильно мое желание открыть свою программистскую фирму, и поддержали меня. План был таков: взять академический отпуск, организовать фирму и уже потом вернуться в Гарвард и закончить колледж. Я вовсе не собирался отказываться от степени, а просто брал довольно продолжительный отпуск. В отличие от некоторых студентов, я любил колледж. Мне нравилось сидеть на занятиях, беседовать с умными сверстниками. Однако я чувствовал, что случай организовать свою фирму может больше и не подвернуться. Так, в 19 лет я окунулся в мир бизнеса.

С самого начала мы с Полом платили за все сами. Каждый из нас накопил определенную сумму. Полу хорошо платили в Honeywell, а часть этих денег перекочевала в мой карман, когда мы с ним допоздна играли в покер в моей комнате. К счастью, наша фирма не требовала значительных капиталов.

Меня часто просят объяснить секрет успеха Microsoft. Все хотят знать, как удалось превратить фирму из двух человек с ничтожным капиталом в крупную компанию с 17000 сотрудников и объемом ежегодных продаж более чем на 6 миллиардов долларов. Разумеется, простого рецепта нет, и удача сыграла свою роль, но думаю, что самое важное - наше видение будущего.

Мы поняли, что открывает чип Intel 8080, и действовали соответственно. Мы спросили себя: "А что если вычислительная техника станет доступна почти всем ?" Мы верили в то, что компьютеры проникнут в каждый дом - благодаря дешевизне своей вычислительной мощи и новым грандиозным программам, способным воспользоваться преимуществами этой техники. Мы создали предприятие, поставив на первое, и занялись последним, когда этого не делал никто. То, что мы видели будущее, чуточку облегчило нашу задачу. Мы оказались в нужное время в нужном месте. Мы начали первыми и, быстро добившись успеха, получили шанс нанять многих умных людей. Мы создали торговую сеть по всему миру и вкладывали получаемую прибыль в новые продукты. С самого начала мы шли в правильном направлении.

Теперь перед нами новые горизонты и новый вопрос: "А что если средства связи станут доступны почти всем ?" Идея объединить все дома и офисы высокоскоростной сетью поразила воображение американской нации так же, как некогда космическая программа. И не только американской. Эти взгляды разделяют тысячи компаний по всему миру, и теперь их успех зависит от того, как именно они представляют будущее, какие шаги предпримут для реализации своих планов и насколько им это удастся.

Я потратил немало времени, размышляя о своем бизнесе, потому что он мне не безразличен. А сегодня я думаю прежде всего о магистрали. Лет двадцать назад, раздумывая о будущем персональных компьютеров на микропроцессорах, я, конечно, не догадывался, к чему оно приведет меня. Однако я не сворачивал с курса и был уверен, что мы поступаем правильно и будем там, где хотим быть, когда все прояснится. Сейчас на карту поставлено гораздо больше, но я снова испытываю тот же азарт. Ситуация держит в напряжении, зато приятно щекочет нервы.

Компании разных профилей и отдельные лица связывают свое будущее с созданием тех элементов, которые превратят информационную магистраль в реальность. Мы в Microsoft упорно работаем над тем, чтобы с нынешних позиций достигнуть той точки, где можно раскрыть весь потенциал новых достижений технологии. Время наступает интересное, и не только для тех, кто участвует в этом процессе, но и для всех, кто поймет выгоды этой революции.


Глава 2 - Начало информационного века

Глава 2
Начало информационного века

Впервые услышав выражение "информационный век", я основательно призадумался. Я знал о железном и бронзовом веках - исторических периодах, названных так по тем новым материалам, из которых тогда делали инструменты и оружие. Тут все понятно. Но вот я читаю пророчества ученых о том, что скоро государства будут бороться за контроль над информацией, а не над природными ресурсами. Звучит весьма интригующе, но что подразумевается под "информацией" ?

Утверждение о том, что будущее за информацией, напомнило мне знаменитую сцену из фильма The Graduate (Выпускник), вышедшего на экраны в 1967 году. Некий бизнесмен трогает за пуговицу Бенджамена, выпускника колледжа (его играл Дастин Хофман), и произносит всего одно слово: "Пластмассы". Так он напутствует молодого человека в начале его карьеры. Интересно, если бы эту сцену написали несколько десятилетий спустя, не сказал бы тот бизнесмен иначе: "Информация" ?!

Представляю, какие абсурдные разговоры могли бы вестись в деловом мире: "Сколько у Вас информации ?", "Швейцария - великая страна, у них столько информации !", "Я слышал, индекс стоимости информации пошел вверх !" Абсурдны они потому, что информация, хотя и играет все более значимую роль в нашей жизни, не является чем-то осязаемым и не поддается точному измерению, как материалы - "лица" прежних эпох.

Информационная революция только начинается. Средства связи неизбежно подешевеют - так же резко, как в свое время вычислительная техника. Когда их стоимость достаточно снизится и "срезонирует" с другими достижениями технологии, ретивые администраторы и нервные политики перестанут упоминать выражение "информационная магистраль" просто потому, что оно модно и престижно. Магистраль станет реальностью и, как электричество, вызовет далеко идущие последствия. Чтобы понять, почему информация становится и центр всего и вся, важно понять, как технология изменяет способы ее обработки.

Об этом главным образом и пойдет речь в данной главе. Слабо подготовленные читатели, не знающие принципов работы вычислительной техники и истории ее развития, получат необходимый минимум сведений, чтобы продолжить чтение книги. А если Вы знаете, как работают цифровые компьютеры, можете спокойно пролистать несколько страниц и перейти сразу к третьей главе.

Самая фундаментальная отличительная черта информации в будущем - почти вся она станет цифровой. Уже сейчас во многих библиотеках печатные материалы сканируют и хранят как электронные данные на обычных или на компакт-дисках. Газеты и журналы теперь зачастую готовят в электронной форме, а печатают на бумаге только для распространения. Электронную информацию можно хранить вечно - или столько, сколько нужно - в компьютерных базах данных. Гигантские объемы репортерской информации легко доступны через оперативные службы. Фотографии, фильмы и видеозаписи тоже преобразуются в цифровую информацию. С каждым годом совершенствуются методы сбора информации и превращения ее в квадрильоны крошечных пакетов данных. Как только цифровая информация помещается в то или иное "хранилище", любой, у кого есть персональный компьютер и средства доступа к базам данных, может мгновенно обратиться к ней и использовать ее по своему усмотрению. Характерная особенность нашего периода истории как раз в том и заключается, что информацию мы изменяем и обрабатываем совершенно новыми способами и гораздо быстрее. Появление компьютеров, "быстро и дешево" обрабатывающих и передающих цифровые данные, обязательно приведет к трансформации обычных средств связи в домах и офисах.

Идея применять для манипуляций с числами какой-нибудь инструмент не нова. До 1642 года, когда девятнадцатилетний французский ученый Блез Паскаль изобрел механическое счетное устройство - суммирующую машину, в Азии уже почти 5000 лет пользовались счетами. Три десятилетия спустя немецкий математик Готфрид Лейбниц усовершенствовал конструкцию машины Паскаля. Его "шаговый вычислитель" позволял умножать, делить и вычислять квадратные корни. Весьма надежные механические арифмометры, напичканные шестеренками и наборными счетчиками, наследники шагового вычислителя, служили главной опорой бизнесу вплоть до их замены электронными аналогами. Например, кассовые аппараты в годы моего детства, по сути, были арифмометрами с отделениями для наличности.

Более полутора столетий назад видного британского математика озарила гениальная идея, которая прославила его имя уже при жизни. Чарлз Беббидж (Charles Babbage), профессор математики Кембриджского университета, понял, что можно построить механическое устройство, способное выполнять последовательность взаимосвязанных вычислений, - своего рода компьютер ! Где-то в начале тридцатых годов прошлого столетия он пришел к выводу, что машина сможет манипулировать информацией, если только ту удастся преобразовать в числа. Беббидж видел машину, приводимую в действие паром, состоящую из штифтов, зубчатых колес, цилиндров и других механических частей - в общем, настоящее детище начинавшегося тогда индустриального века. По мысли Беббиджа, "аналитическая машина" должна была избавить человечество от монотонных вычислений и ошибок, с ними связанных.

Для описания устройства машины ему, конечно, не хватало терминов - тех, которыми мы пользуемся сегодня. Центральный процессор, или "рабочие внутренности" этой машины, он называл "мельницей", а память - "хранилищем". Беббиджу казалось, что информацию будут обрабатывать так же, как хлопок: подавать со склада (хранилища) и превращать во что-то новое.

Аналитическая машина задумывалась как механическая, но ученый предвидел, что она сможет следовать варьируемым наборам инструкций и тем самым служить разным целям. В том же и смысл программного обеспечения. Современная программа - это внушительный набор правил, посредством которых машину "инструктируют", как решать ту или иную задачу. Беббидж понимал, что для ввода таких инструкций нужен совершенно новый тип языка, и он изобрел его, использовав цифры, буквы, стрелки и другие символы. Этот язык позволил бы "программировать" аналитическую машину длинными сериями условных инструкций, что, в свою очередь, позволило бы машине реагировать на изменение ситуации. Он - первый, кто увидел, что одна машина способна выполнять разные функции.

Следующее столетие ученые математики работали над идеями, высказанными Беббиджем, и к середине сороковых годов нашего века электронный компьютер наконец был построен - на основе принципов аналитической машины. Создателей современного компьютера выделить трудно, поскольку все исследования проводились во время второй мировой войны под покровом полной секретности, главным образом - в Соединенных Штатах и Великобритании. Основной вклад внесли три человека: Алан Тьюринг (Alan Turing), Клод Шеннон (Claude Shannon) и Джон фон Нейман (John von Neumann).

В середине тридцатых годов Алан Тьюринг - блестящий британский математик, как и Беббидж, получивший образование в Кембридже, предложил свой вариант универсальной вычислительной машины, которая могла бы в зависимости от конкретных инструкций работать практически с любым видом информации. Сегодня она известна как машина Тьюринга.

А в конце тридцатых Клод Шеннон, тогда еще студент, доказал, что машина, исполняющая логические инструкции, может манипулировать информацией. В своей магистерской диссертации он рассмотрел, как с помощью электрических цепей компьютера выполнять логические операции, где единица - "истина" (цепь замкнута), а нуль - "ложь" (цепь разомкнута).

Здесь речь идет о двоичной системе счисления, иначе говоря, о коде. Двоичная система - это азбука электронных компьютеров, основа языка, на который переводится и с помощью которого хранится и используется вся информация в компьютере. Эта система очень проста и в то же время настолько важна для понимания того, как работают компьютеры, что, пожалуй, стоит на этом задержаться.

Представьте, что в Вашей комнате должна гореть лампа мощностью в 250 ватт. Однако Вы хотите регулировать освещение от 0 ватт (полная темнота) до максимума. Один из способов добиться этого - воспользоваться выключателем с регулятором. Чтобы погасить лампу, Вы поворачиваете ручку против часовой стрелки в положение "выкл" (0 ватт), а чтобы включить ее "на всю катушку", - по часовой стрелке до упора (250 ватт). Ну а чтобы добиться полумрака или просто уменьшить яркость, Вы устанавливаете регулятор в какое-то промежуточное положение.

Такая система проста, но имеет свои ограничения. Если регулятор находится в промежуточном положении - скажем, Вы приглушили свет для ужина в интимной обстановке, - останется лишь гадать, каков сейчас уровень освещения. Вам не известно ни то, какую мощность "берет" лампа в данный момент, ни то, как точно описать настройку регулятора. Ваша информация приблизительна, что затрудняет ее сохранение и воспроизведение.

Вдруг на следующей неделе Вам захочется создать то же освещение ? Конечно, можно поставить отметку на шкале регулятора, но навряд ли это получится точно. А что делать, если понадобится воспроизвести другую настройку ? Или кто-то придет к Вам в гости и захочет отрегулировать свет ? Допустим, Вы скажете: "Поверни ручку примерно на пятую часть по часовой стрелке" или "Поверни ручку, пока стрелка не окажется примерно на двух часах". Однако то, что сделает Ваш гость, будет лишь приблизительно соответствовать Вашей настройке. А может случиться и так, что Ваш друг передаст эту информацию своему знакомому, а тот - еще кому-нибудь. При каждой передаче информации шансы на то, что она останется точной, убывают.

Это был пример информации, хранимой в "аналоговом" виде. Положение ручки регулятора соответствует уровню освещения. Если ручка повернута наполовину, можно предположить, что и лампа будет гореть вполнакала. Измеряя или описывая то, насколько повернута ручка, Вы на самом деле сохраняете информацию не об уровне освещения, а о его аналоге - положении ручки. Аналоговую информацию можно накапливать, хранить и воспроизводить, но она неточна и, что хуже, при каждой передаче становится все менее точной.

Теперь рассмотрим не аналоговый, а цифровой метод хранения и передачи информации. Любой вид информации можно преобразовать в числа, пользуясь только нулями и единицами. Такие числа (состоящие из нулей и единиц) называются двоичными. Каждый нуль или единица - это бит. Преобразованную таким образом информацию можно передать компьютерам и хранить в них как длинные строки бит. Эти-то числа и подразумеваются под "цифровой информацией".

Пусть вместо одной 250-ваттной лампы у Вас будет 8 ламп, каждая из которых в 2 раза мощнее предыдущей - от 1 до 128 ватт. Кроме того, каждая лампа соединена со своим выключателем, причем самая слабая расположена справа.

Включая и выключая эти выключатели, Вы регулируете уровень освещенности с шагом в 1 ватт от нуля (все выключатели выключены) до 255 ватт (все включены), что дает 256 возможных вариантов. Если Вам нужен 1 ватт, Вы включаете только самый правый выключатель, и загорается 1-ваттная лампа. Для 2 ватт Вы зажигаете 2-ваттную лампу. Если Вам нужно 3 ватта, Вы включаете 1- и 2-ваттную лампы, поскольку 1 плюс 2 дает желаемые 3 ватта. Хотите 4 ватта, включите 4-ваттную лампу, 5 ватт - 4- и 1-ваттную лампы, 250 ватт - все, кроме 4- и 1-ваттной ламп.

Если Вы считаете, что для ужина идеально подойдет освещение в 137 ватт, включите 128-, 8- и 1-ваттную лампы.

Такая система обеспечивает точную запись уровней освещенности для использования в будущем или передачи другим, у кого в комнате аналогичный порядок подключения ламп. Поскольку способ записи двоичной информации универсален (младшие разряды справа, старшие - слева, каждая последующая позиция удваивает значение разряда), нет нужды указывать мощность конкретных ламп. Вы просто определяете состояние выключателей: "вкл-выкл-выкл-выкл-вкл-выкл-выкл-вкл". Имея такую информацию, Ваш знакомый точно отрегулирует освещение в комнате на 137 ватт. В сущности, если каждый будет внимателен, это сообщение без искажений пройдет через миллионы рук и на конце цепочки кто-то получит первоначальный результат - 137 ватт.

Чтобы еще больше сократить обозначения, можно заменить "выкл" нулем (0), а "вкл" - единицей (1).

Тем самым вместо "вкл-выкл-выкл-выкл-вкл-выкл-выкл-вкл" (подразумевая, что надо включить первую, пятую и восьмую лампы, а остальные выключить), Вы запишете то же самое иначе: 1, 0, 0, 0, 1, 0, 0, 1 или двоичным числом 10001001. Оно равно десятичному 137. Теперь Вы скажете своему знакомому: "Я подобрал изумительное освещение ! 10001001. Попробуй". И он точно воспроизведет Вашу настройку, зажигая и гася соответствующие лампы.

Может показаться, что этот способ чересчур сложен для описания яркости ламп, но он иллюстрирует теорию двоичного представления информации, лежащую в основе любого современного компьютера.

Двоичное представление чисел позволяет составление чисел позволяет создавать калькуляторы, пользуясь преимуществами электрических цепей. Именно так и поступила во время второй мировой войны группа математиков из Moore School of Electrical Engineering при Пенсильванском университете, возглавляемая Дж. Преспером Эккертом (J. Presper Eckert) и Джоном Моучли (John Mauchly), начав разработку электронно-вычислительной машины ENIAC (Electronic Numerical Integrator And Calculator - электронный числовой интегратор и калькулятор). Перед учеными поставили цель - ускорить расчеты таблиц для наведения артиллерии. ENIAC больше походил на электронный калькулятор, чем на компьютер, но двоичные числа представляли уже не примитивными колесиками, как в арифмометрах, а электронными лампами - "переключателями".

Солдаты, приписанные к этой огромной машине, постоянно носились вокруг нее, скрипя тележками, доверху набитыми электронными лампами. Стоило перегореть хотя бы одной лампе, как ENIAC тут же вставал и начиналась суматоха: все спешно искали сгоревшую лампу. Одной из причин - возможно, и не слишком достоверной - столь частой замены ламп считалась такая: их тепло и свечение привлекают мотыльков, которые залетают внутрь машины и вызывают короткое замыкание. Если это правда, то термин "жучки" (bugs), под которым имеются в виду ошибки в программных и аппаратных средствах компьютеров, приобретает новый смысл.

Когда все лампы работали, инженерный персонал мог настроить ENIAC на какую-нибудь задачу, вручную изменив подключения 6000 проводов. Все эти провода приходилось вновь переключать, когда вставала другая задача. В решении этой проблемы основную заслугу приписывают Джону фон Нейману, американцу венгерского происхождения, блестящему ученому, известному многими достижениями - от разработки теории игр до вклада в создание ядерного оружия. Он придумал схему, которой до сих пор следуют все цифровые компьютеры. "Архитектура фон Неймана", как ее теперь называют, базируется на принципах, сформулированных им в 1945 году. В их число входит и такой: в компьютере не придется изменять подключения проводов, если все инструкции будут храниться в его памяти. И как только эту идею воплотили на практике, родился современный компьютер.

Сегодня "мозги" большинства компьютеров - дальние потомки того микропроцессора, которым мы с Полом так восхищались в семидесятых, а "рейтинг" персональных компьютеров зачастую определяется тем, сколько бит информации (переключателей - в нашем примере со светом) способен единовременно обрабатывать их микропроцессор и сколько у них байт (групп из восьми бит) памяти и места на диске. ENIAC весил 30 тонн и занимал большое помещение. "Вычислительные" импульсы бегали в нем по 1500 электромеханическим реле и 17000 электронным лампам. Он потреблял 150000 ватт электроэнергии и при этом хранил объем информации, эквивалентный всего лишь 80 символам.

К началу шестидесятых годов транзисторы начали вытеснять электронные лампы из бытовой электроники. Это произошло через десятилетие после того, как в Bell Labs открыли, что крошечный кусочек кремния способен делать то же, что и электронная лампа. Транзисторы - подобно электронным лампам - действуют как электрические переключатели, потребляя при этом намного меньше электроэнергии, в результате выделяя гораздо меньше тепла и занимая меньше места. Несколько транзисторных схем можно объединить на одной плате, создав тем самым интегральную схему (чип). Чипы, используемые в современных компьютерах, представляют собой интегральные схемы, эквивалентные миллионам транзисторов, размещенных на кусочке кремния площадью менее пяти квадратных сантиметров.

В 1977 году Боб Нойс (Bob Noyce), один из основателей фирмы Intel, в журнале Scientific American сравнил трехсотдолларовый микропроцессор с ENIAC, кишащим насекомыми мастодонтом. Крошка-микропроцессор не только мощнее, но и, как заметил Нойс, "в 20 раз быстрее, обладает большей памятью, в 1000 раз надежнее, потребляет энергии столько же, сколько лампочка, а не локомотив, занимает 1/30000 объема и стоит в 10000 раз дешевле. Его можно заказать по почте или купить в местном магазине".

Конечно, микропроцессор 1977 года теперь кажется просто игрушкой. Ведь сегодня во многих недорогих игрушках "сидят" более мощные компьютерные чипы, чем микропроцессоры семидесятых, с которых начиналась микрокомпьютерная революция. Но все современные компьютеры, каков бы ни был их размер или мощность, оперируют с информацией в виде двоичных чисел.

Двоичные числа используются для хранения текста в персональных компьютерах, музыки на компакт-дисках и денег в сети банковских автоматов. Прежде чем отправить информацию в компьютер, ее надо преобразовать в двоичный вид. А машины, цифровые устройства, возвращают информации ее первоначальную форму. Каждое такое устройство можно представить как набор переключателей, управляющих потоком электронов. Эти переключатели, обычно изготавливаемые из кремния, крайне малы и срабатывают под действием электрических зарядов чрезвычайно быстро - тем самым воспроизводя текст на экране персонального компьютера, музыку на проигрывателе компакт-дисков и команды банковскому автомату, который выдает Вам наличность.

Пример с выключателями ламп продемонстрировал, что любое число можно представить в двоичном виде. А вот как то же самое сделать с текстом. По соглашению, число 65 кодирует заглавную латинскую букву A, 66 - B и т.д. В компьютере каждое из этих чисел выражается двоичным кодом, поэтому заглавная латинская буква A (десятичное число 65) превращается в 01000001, а буква B (66) - в 01000010. Пробел кодируется числом 32, или 00100000. Таким образом, выражение "Socrates is a man" ("Сократ есть человек") становится 136-разрядной последовательностью единиц и нулей.

Здесь легко проследить, как строка текста превратилась в набор двоичных чисел. Чтобы понять, как преобразуют другие виды данных в двоичную форму, разберем еще один пример. Запись на виниловой пластинке - это аналоговое представление звуковых колебаний. Аудиоинформация хранится на ней в виде микроскопических бугорков, расположенных в длинных спиральных канавках. Если в каком-то месте музыка звучит громче, бугорки глубже врезаются в канавку, а при высокой ноте бугорки располагаются теснее. Эти бугорки являются аналогами исходных колебаний звуковых волн, улавливаемых микрофоном. Двигаясь по канавке, иголка проигрывателя попадает на бугорки и вибрирует. Ее вибрация - все то же аналоговое представление исходного звука - усиливается и звучит из динамиков как музыка.

Виниловой пластинке, подобно всякому аналоговому устройству хранения информации, свойствен ряд недостатков. Пыль, следы пальцев или царапины на поверхности пластинки могут приводить к неадекватным колебаниям иглы, вызывая в динамиках потрескивание и другие шумы. Если скорость вращения пластинки хотя бы немного отклоняется от заданной, высота звука сразу же меняется. При каждом проигрывании пластинки игла постепенно "снашивавает" бугорки в канавке, и качество звучания соответственно ухудшается. Если же какую-нибудь песню записать с виниловой пластинки на кассетный магнитофон, то все "шероховатости" переносятся на пленку, а со временем к ним добавятся новые, потому что обычные магнитофоны сами являются аналоговыми устройствами. Таким образом, при каждой перезаписи или передаче информация теряет в качестве.

На компакт-диске музыка хранится как последовательность двоичных чисел, каждый бит которых представлен микроскопической впадинкой на поверхности диска. На современных компакт-дисках таких впадинок более 5 миллиардов. Отраженный лазерный луч внутри проигрывателя компакт-дисков - цифрового устройства - проходит по каждой впадинке, а специальный датчик определяет ее состояние (0 или 1). Полученную информацию проигрыватель реконструирует в исходную музыку, генерируя определенные электрические сигналы, которые динамики преобразуют в звуковые волны. И сколько бы такой диск ни проигрывали, его звучание не меняется.

Было бы удобно преобразовать всю информацию в цифровую форму, но возникает проблема обработки ее больших объемов. Слишком большое число бит может переполнить память компьютера или потребовать много времени на передачу между компьютерами. Вот почему так важна (и становится все важнее) способность компьютера сжимать цифровые данные и хранить или передавать их в таком виде, а затем вновь разворачивать сжатые данные в исходную форму.

Рассмотрим вкратце, как компьютер справляется с этим. Для этого надо вернуться к Клоду Шеннону, математику, который в тридцатых годах осознал, как выражать информацию в двоичной форме. Во время второй мировой войны он начал разрабатывать математическое описание информации и основал новую область науки, впоследствии названную теорией информации. Шеннон трактовал информацию как уменьшение неопределенности. Например, Вы не получаете никакой информации, если кто-то сообщает Вам, что сегодня воскресенье, а Вы это знаете. С другой стороны, если Вы не уверены, какой сегодня день недели, и кто-то говорит Вам - воскресенье, Вы получаете информацию, так как неопределенность уменьшается.

Теория информации Шеннона привела в конечном счете к значительным прорывам в познании. Один из них - эффективное сжатие данных, принципиально важное как в вычислительной технике, так и в области связи. Сказанное Шенноном, на первый взгляд, кажется очевидным: элементы данных, не передающие уникальную информацию, избыточны и могут быть отброшены. Так поступают репортеры, исключая несущественные слова, или те, кто платит за каждое слово, отправляя телеграмму или давая рекламу. Шеннон привел пример: в английском языке буква U лишняя в тех местах, где она стоит после буквы Q. Поэтому, зная, что U следует за каждой Q, в сообщении ее можно опустить.

Принципы Шеннона применяли к сжатию и звуков, и фильмов. В тридцати кадрах, из которых состоит секунда видеозаписи, избыточной информации чрезвычайно много. Эту информацию при передаче можно сжать примерно с 27 миллионов бит до 1 миллиона, и она не потеряет ни смысла, ни красок.

Однако сжатие не безгранично, а объемы передаваемой информации все возрастают и возрастают. В скором будущем биты будут передаваться и по медным проводам, и в эфире, и по информационной магистрали, в основу которой лягут волоконно-оптические кабели. Волоконно-оптический кабель представляет собой пучок стеклянных или пластмассовых проводов настолько однородных и прозрачных, что на другом конце стокилометрового кабеля Вы сможете разглядеть горящую свечу. Двоичные сигналы в виде модулированных световых волн смогут без затухания распространяться по этим кабелям на очень длинные расстояния. Естественно, по волоконно-оптическим кабелям сигналы идут не быстрее, чем по медным проводам: скорость движения не может превысить скорость света. Колоссальное преимущество волоконно-оптического кабеля над медным проводом - в полосе пропускания. Полоса пропускания - это количество бит, передаваемых по одной линии в секунду. Такой кабель подобен широкой автомагистрали. Восьмирядная магистраль, проложенная между штатами, пропускает больше автомобилей, чем узкая грунтовая дорога. Чем шире полоса пропускания кабеля (чем больше рядов у дороги), тем больше бит (машин) могут пройти по нему в секунду. Кабели с ограниченной полосой пропускания, используемые для передачи текста или речи, называются узкополосными; с более широкими возможностями, несущие изображения и фрагменты с ограниченной анимацией, - среднеполосными. А кабели с высокой пропускной способностью, позволяющие передавать множество видео- и аудиосигналов, принято называть широкополосными.

Информационная магистраль, немыслимая без сжатия данных, потребует применения кабелей с очень высокой пропускной способностью. Тут-то и кроется одна из главных причин, почему информационная магистраль до сих пор не построена: современные коммуникационные сети не могут обеспечить нужной полосы пропускания. И не обеспечат, пока их не заменят волоконно-оптические линии. Волоконная оптика - пример технологии, выходящей далеко за рамки того, что могли предвидеть Беббидж или даже Эккерт и Моучли. То же относится и к темпам, с которыми улучшается быстродействие и емкость микросхем.

В 1965 году Гордон Мур (Gordon Moore), впоследствии вместе с Бобом Нойсом основавший фирму Intel, предсказал, что число транзисторов в компьютерных чипах ежегодно будет удваиваться. Его предсказание базировалось на соотношении "цена/качество" компьютерных чипов за предыдущие 3 года и предположении, что в ближайшее время эта тенденция сохранится. Правда, Мур не очень-то верил, что такая скорость эволюции чипов продлится долго. Но прошло 10 лет, предсказание сбылось, и тогда он заявил, что теперь емкость будет удваиваться каждые 2 года. Его слова оправдываются и по сей день: число транзисторов в микропроцессорах удваивается в среднем каждые 18 месяцев. Среди инженеров эту зависимость принято называть законом Мура.

Опыт повседневной жизни бессилен перед скрытым смыслом периодически удваивающихся чисел - экспоненциальной прогрессией. Мы попытаемся вникнуть в этот смысл, вспомнив древнюю легенду.

Правитель Индии Ширхам (Shirham) так обрадовался, когда один из его министров изобрел шахматы, что разрешил ему выбрать любую награду.

"Владыка, - сказал министр, - дай мне столько зерен пшеницы, сколько уместится на шахматной доске: одно зернышко - на первую клетку, на вторую клетку - 2 зернышка, на третью - 4 и пусть так удваивают число зернышек на каждой клетке вплоть до шестьдесят четвертой". Правитель немало удивился такой скромности, но велел принести мешок пшеницы.

И вот зернышки стали отсчитывать на шахматной доске. На первую клетку в первом ряду положили одно маленькое зернышко. На вторую - 2 зернышка, на третью - 4 и далее: 8, 16, 32, 64, 128. Когда первый ряд был заполнен, кладовщик насчитал в нем всего 255 зернышек.

Правитель, наверное, еще ничего не подозревал. Разве что зернышек на первом ряду оказалось многовато, но волноваться вроде бы не о чем. Допустим, на одно зернышко уходила одна секунда, значит, подсчет пока занял не более четырех минут. А если на один ряд потребовалось четыре минуты, попробуйте догадаться, сколько времени нужно на подсчет зернышек пшеницы на всех клетках. Четыре часа ? Четыре дня ? Четыре года ?

К тому времени, когда покончили со вторым рядом, кладовщик трудился уже 18 часов, отсчитав 65535 зернышек. На третий из восьми рядов, чтобы отсчитать 16,8 миллионов зернышек (24 клетки), понадобилось 194 дня. А ведь оставалось еще 40 пустых клеток.

Думаю, Вы понимаете: правитель отказался от своего обещания ! На последней клетке должна была вырасти гора из 18446744073709551615 зернышек пшеницы, и на их отсчитывание ушло бы 584 миллиарда лет. Сравните: возраст Земли оценивают где-то в 4,5 миллиарда лет. Согласно большинству версий этой легенды, правитель Ширхам в конце концов понял, как ловко его провели, и велел казнить этого министра-умника. Так что экспоненциальная прогрессия, даже когда ее поймешь, кажется чистым фокусом.

Число транзисторов в микропроцессорах Intel удваивалось примерно каждые 18 месяцев - в соответствии с законом Мура.

Закон Мура, по всей видимости, будет действовать еще лет двадцать. И тогда вычисления, занимающие сегодня сутки, будут проводиться в 10000 раз быстрее, т.е. не потребуют более десяти секунд.

Лаборатории уже работают с так называемыми "баллистическими" транзисторами, время переключения которых порядка фемтосекунды. Это 1/1000000000000000 секунды, т.е. такие транзисторы в 10 миллионов раз быстрее современных. Однако необходимо так уменьшить размер чипа и протекающий в нем ток, чтобы движущиеся электроны ни с чем не сталкивались - и друг с другом тоже. В этом вся сложность. Следующий этап - создание "одноэлектронного транзистора", в котором единственный бит информации представлен одиночным электроном. Это абсолютный предел для низкоэнергетической вычислительной техники, по крайней мере, в соответствии с нашим нынешним пониманием физических законов. Чтобы воспользоваться преимуществами невероятного быстродействия на молекулярном уровне, компьютеры должны стать очень маленькими, даже микроскопическими. Наука уже объяснила, как строить супербыстрые компьютеры. Пока недостает одного - технологического рывка, но за этим, как показывает история, дело не станет.

Когда мы перейдем на такие скорости работы, хранение всех этих бит информации уже не будет проблемой. Весной 1983 года корпорация IBM выпустила PC/XT, первый персональный компьютер с внутренним жестким диском. Этот диск (встроенный накопитель) вмещал 10 мегабайт (Мб) информации, что составляет около 10 миллионов символов, или 80 миллионов бит. Клиентам, которые хотели дополнить свои "персоналки" 10-мегабайтовым диском, это обходилось весьма недешево. IBM предлагала комплект из жесткого диска с отдельным источником питания за 3000 долларов, т.е. один мегабайт стоил 300 долларов. Сегодня, благодаря "экспоненциальному" прогрессу, показанному законом Мура, персональные компьютеры оснащаются жесткими дисками емкостью 1,2 гигабайт (1,2 миллиарда символов) всего за 250 долларов - по 21 центу за мегабайт ! А впереди нас ждет такая экзотика, как голографическая память, которая позволит хранить терабайты символов на кубический дюйм (порядка 16 кубических сантиметров). При такой емкости голографическая память объемом с кулак вместит все содержимое Библиотеки Конгресса.

По мере того как технология связи становится цифровой, она тоже начинает прогрессировать по экспоненте - той самой, что сделала нынешний "лэптоп" за 2000 долларов мощнее, чем мэйнфрейм IBM двадцатилетней давности за 10 миллионов долларов.

Уже недалеко время, когда по единственному кабелю к каждому дому пойдут все нужные цифровые данные. Этот кабель будет или волоконно-оптическим, как на нынешних междугородных телефонных линиях, или коаксиальным, по которому сейчас передают сигналы кабельного телевидения. Интерпретирует компьютер биты как речевой вызов - зазвонит телефон. Появятся видеоизображения - включится телевизор. Поступят новости от оперативных сллслужб - Вы увидите информационный текст и снимки на экране компьютера.

По этому кабелю, "несущему на себе" всю сеть, определенно будут передавать не только телефонные звонки, фильмы и новости. Как человек каменного века с примитивным ножом не мог представить великолепия дверей баптистерия Гиберти во Флоренции, так и мы сейчас не можем представить, что именно будет нести информационная магистраль через 25 лет. Только тогда, когда она действительно появится, мы оценим ее реальные возможности. Однако история достижений цифровой технологии за последние 20 лет все же позволяет уловить некоторые из ее будущих ключевых принципов и возможностей.


Глава 3 - Уроки компьютерной индустрии

Глава 3
Уроки компьютерной индустрии

Успех - скверный учитель. Он кружит голову. Он ненадежен. Бизнес-план или новейшая технология - верх совершенства сегодня, завтра могут так же безнадежно устареть, как восьмидорожечные магнитофоны, телевизоры на электронных лампах или мэйнфреймы. Я пристально следил за тем, как это происходило. Долгое и внимательное наблюдение за множеством компаний помогло извлечь неплохие уроки, научило, как планировать на годы вперед.

Компании, вкладывающие деньги в информационную магистраль, попытаются избежать ошибок, допущенных в компьютерной индустрии за последние 20 лет. Думаю, что в большей части этих ошибок можно разобраться, если учесть несколько критических факторов. Среди них отрицательные и положительные спирали развития бизнеса, необходимость создавать прецеденты, а не следовать им, значение программных средств на фоне аппаратных, роль совместимости и генерируемой ею положительной обратной связи.

На одну житейскую мудрость здесь нельзя полагаться. Она нужна лишь на обычных рынках. А прошедшие 3 десятилетия показали, что рынок компьютерного оборудования и программ обычным никак не назовешь. Огромные и признанные компании с оборотом в сотни миллионов долларов и множеством клиентов вдруг исчезали в мгновение ока. А новые компании вроде Apple, Compaq, Lotus, Oracle, Sun и Microsoft, начиная с нуля, так же внезапно достигали миллиардных доходов. Одна из причин такого уcпеха в том, что я называю "положительной спиралью".

Когда у Вас на руках "горячий" продукт, со всех сторон сбегаются инвесторы, жаждущие вложить деньги в Вашу компанию. Ребята с головой начинают подумывать: "Гм, все только и говорят о его компании. Я бы тоже не отказался у него поработать". А когда в компанию приходит один умный человек, вскоре появляется и другой - талантливые люди любят работать в кругу себе равных. Возникает чувство общего подъема. Потенциальные партнеры и клиенты обращают на Вас все большее внимание, и спираль устремляется к следующему витку, расчищая путь новому успеху.

Но можно угодить и в отрицательную спираль. Если компания в положительной спирали действует так, словно ее ведет сама Фортуна, то от компании в отрицательной спирали веет обреченностью. Когда какая-то фирма начинает сдавать свои позиции на рынке или выпускает один плохой продукт, тут же возникают разговоры: "Почему ты работаешь там ?", "Почему ты вкладываешь в нее деньги ?", "Не советую покупать у них что-нибудь". Пресса и аналитики, почуяв запах крови, бросаются выяснять, кто с кем поссорился, кто отвечает за промахи и т.д. Клиенты озадачены: стоит ли покупать продукцию этой фирмы ? В самой компании тоже неспокойно, сомневаются уже во всем - даже в том, что делается отлично. (А ведь аргументом из серии "Вы просто цепляетесь за старое" можно угробить самую распрекрасную стратегию и наделать еще больше ошибок !) И тогда компания спускается по спирали еще ниже. Поэтому лидеры типа Ли Якокка (Lee Iacocca), способные обратить ход спирали, заслуживают высших почестей.

В годы моей юности одной из самых "горячих" компьютерных фирм была Digital Equipment Corporation, известная под аббревиатурой DEC. На протяжении двадцати лет ее положительная спираль неуклонно росла и казалась нескончаемой. Кен Оулсен (Ken Olsen), основатель этой компании и легендарный разработчик компьютерного оборудования, был моим героем, почти Богом. В 1960 году он создал индустрию мини-компьютеров, начав с первого "маленького" компьютера PDP-1 (предшественника моего школьного PDP-8). Покупатель - вместо того чтобы выкладывать миллионы за "Big Iron" от IBM - мог приобрести у Оулсена PDP-1 за 120000 долларов. Конечно, его возможности далеко уступали возможностям мэйнфреймов, но он вполне годился для решения целого ряда задач. Предлагая широкий спектр компьютеров самых разных размеров, DEC за 8 лет превратилась в компанию с оборотом в 6,7 миллиарда долларов.

Однако 2 десятилетия спустя чутье изменило Оулсену. Он не понял, что будущее за небольшими настольными компьютерами. В конце концов его вынудили уйти из DEC, и теперь за ним закрепилась слава человека, который до сих пор публично не признает персональных компьютеров, считая их кратковременным увлечением. Грустно, когда такие истории случаются с людьми масштаба Оулсена. Блестящий организатор, на многое смотревший по-новому, и вдруг - после стольких лет новаторства - не заметить крутой поворот на дороге.

Еще один потерпевший неудачу провидец, Ан Вэнь (An Wang) - иммигрант-китаец, в шестидесятые годы превративший Wang Laboratories в ведущего поставщика электронных калькуляторов. В семидесятых, вопреки многочисленным советам, он прекратил заниматься калькуляторами - как раз перед резким падением цен на них. Это был блестящий ход. Он избежал неминуемого разорения, переориентировав свою компанию на выпуск электронных машин - текстовых процессоров. И здесь он добился лидирующих позиций. В семидесятые годы пишущие машинки и офисах всего мира заменяли текстовыми процессорами. У них был свой микропроцессор, но эти машины не имели ничего общего с настоящими персональными компьютерами, поскольку выполняли только одну операцию - обрабатывали тексты.

Вэнь был дальновидным инженером. Казалось бы, интуиция, которая не подвела его в истории с калькуляторами, должна была и в восьмидесятые годы привести его к успеху в области программного обеспечения для персональных компьютеров, но на этот раз очередной поворот в индустрии он проглядел. Вэнь по-прежнему разрабатывал прекрасные программы, но не осознавал, что они обречены, так как были привязаны к его "текстовым" машинам. А на рынке уже появились универсальные персональные компьютеры, способные выполнять множество приложений, в том числе текстовые процессоры WoedStar, WordPerfect и Multimate (последний фактически имитировал программное обеспечение Вэня). Если бы Вэнь вовремя оценил принципиальное значение совместимости программ, не исключено, что сегодня не было бы Microsoft. Я бы стал математиком или адвокатом, а мои юношеские наскоки на персональные компьютеры остались бы просто далеким воспоминанием.

IBM - другой пример крупной компании, не заметившей технологических перемен в начале революции персональных компьютеров. В то время ею руководил весьма напористый Томас Дж. Уотсон (Thomas J. Watson), бывший торговец кассовыми аппаратами. Основателем IBM он не был, но благодаря именно его агрессивному стилю управления эта компания в начале тридцатых доминировала на рынке счетно-аналитических машин. Над компьютерами IBM работала с середины пятидесятых. Она была одной из многих компаний, стремившихся к лидерству в этой области.

Вплоть до 1964 года каждая модель компьютера, даже от одного изготовителя, была уникальна и требовала своей операционной системы и прикладного программного обеспечения. Операционная система [иногда называемая дисковой операционной системой (Disk-Operating System) или просто DOS] - фундаментальная программа, управляющая компонентами компьютерной системы, координирующая их взаимодействие и выполняющая другие функции. Без операционной системы компьютер бесполезен. Она служит той платформой, на которой работают все прочие программы - будь то текстовые процессоры, электронные таблицы или бухгалтерские приложения.

Компьютеры разных ценовых уровней служат разным целям. Некоторые модели ориентированы на научные институты, другие - на коммерцию. Занимаясь разработкой Бейсика для различных персональных компьютеров, я обнаружил, что перенос программного обеспечения с одного компьютера на другой требует немалых усилий. Это относится даже к тем случаям, когда программы написаны на стандартном языке, например Коболе или Фортране.

Под руководством Тома - так все звали сына и преемника Уотсона - компания рискнула 5 миллиардами долларов на разработку масштабируемой архитектуры (само это понятие в то время еще не существовало). Все компьютеры семейства System/360, независимо от размера, должны были оперировать с одним и тем же набором команд. Модели, построенные по разным технологиям - от медленных до самых быстрых, от компактных, располагаемых в обычном офисе, до гигантов с водяным охлаждением, устанавливаемых в стеклянных помещениях с искусственным климатом, должны были работать под управлением одной и той же операционной системы. Тогда заказчики смогут переносить программы с одной машины на другую, а периферия и такие аксессуары, как диски, ленточные накопители и принтеры, стали бы универсальными для разных моделей.

Масштабируемая архитектура полностью изменила компьютерную индустрию. System/360 пользовалась колоссальным успехом, и в течение тридцати лет IBM сохраняла сильные позиции в производстве мэйнфреймов. Заказчики делали крупные инвестиции в 360 серию, уверенные в том, что их затраты на программы и обучение персонала не пропадут даром. Если им был нужен более мощный компьютер, они покупали его у IBM, и тот работал с той же операционной системой и обладал той же архитектурой.

Масштабируемая архитектура System/З60 и ее преемницы System/370 вывела из игры многих действующих и потенциальных конкурентов IBM.

Однако в 1977 году DEC внедрила собственную платформу с масштабируемой архитектурой - VAX. Семейство VAX было широко представлено: от настольных компьютеров до мэйнфреймов. Эти системы дали DEC то же, что System/360 корпорации IBM. DEC вышла в лидеры на рынке миникомпьютеров.

В 1970 году Юджин Амдал (Eugene Amdahl), старший инженер IBM, стремясь реализовать свои идеи, основал новую компанию. Она стала поставлять оборудование, не только работающее с той же операционной системой и программным обеспечением, что и IBM, но и превосходящее - благодаря применению новой технологии - сравнимые по цене системы IBM. Вскоре фирмы Control Data, Hitachi и Itel тоже начали предлагать мэйнфреймы, совместимые с IBM. К середине семидесятых важность совместимости с З60 серией стала очевидной. Преуспевали только те производители мэйнфреймов, чье оборудование работало с операционными системами корпорации IBM.

До появления 360 серии изготовители намеренно делали архитектуры компьютеров несовместимыми с аналогичными моделями других компаний, поскольку стремились привязать клиентов именно к своему оборудованию - чтобы переход на компьютеры иных марок обходился "перебежчикам" подороже. Как только заказчик связывал себя с какой-то машиной, изготовитель диктовал ему (или ей), какими программами пользоваться - сменить программное обеспечение было можно, но очень трудно. Амдал и другие положили конец этому произволу. Поэтому совместимость, прийти к которой вынудил рынок, для индустрии персональных компьютеров служит важнейшим примером и одновременно - уроком на будущее. Его должны помнить и нынешние создатели информационной магистрали. Клиенты предпочитают те системы, которые дают им свободу в выборе поставщиков аппаратных и программных средств.

Когда происходили все эти события, я учился в школе и только начинал экспериментировать с компьютерами. В Гарвард я поступил осенью 1973 года. Ни для кого не секрет, что в колледже все рисуются друг перед другом, и чем больше прогуливаешь, тем круче тебя считают. Не был исключением и я. С первого же курса я принципиально пропускал большую часть занятий и лихорадочно готовился к зачетам в конце семестра. Это даже стало игрой. Вам ведь она тоже знакома ? Получить оценку повыше, а времени затратить поменьше ?! Досуг я проводил в основном за игрой в покер, которая по-своему привлекала меня. В покере игрок собирает обрывки информации - кто уверенно делает ставку, что показывают карты, насколько противник умеет блефовать - а потом, сложив два и два, вырабатывает свой план действий. В обработке такой информации я всегда был на высоте.

Опыт игры в покер (и выигранные деньги) помог мне в бизнесе, а вот привычка все откладывать на завтра - совсем наоборот. Но тогда я об этом не думал. Я радовался, что у моего нового друга, Стива Балмера, математика со старшего курса, та же слабость. С ним я познакомился еще в первый год обучения в колледже: мы жили в одной комнате, в общежитии Currier House. Стив и я вели совершенно разный образ жизни, но оба пытались тратить как можно меньше времени на то, чтобы заработать высокие оценки. Стив, человек неуемной энергии, был очень общителен. Кипучая деятельность поглощала его целиком. К концу второго курса он уже был менеджером футбольной команды, менеджером по рекламе в Harvard Crimson и президентом литературного журнала. Он также был членом общественного клуба, гарвардского эквивалента студенческого братства.

И он, и я почти не обращали внимания на занятия, а перед экзаменами сутками напролет зубрили учебники. Однажды мы проштудировали курс по экономике, рассчитанный на выпускников, "Экономика 2010". Профессор разрешил сдавать его экстерном. Естественно, мы со Стивом весь семестр занимались совсем другими делами и не вспоминали про этот курс до последней минуты. За неделю до экзамена мы засели за учебники как сумасшедшие и в конце концов получили по оценке A.

Однако впоследствии, когда мы с Полом основали Microsoft, я обнаружил, что такие оттяжки не лучший стиль управления компанией. Среди первых клиентов Microsoft были японцы, такие пунктуальные, что за минутное отставание от графика присылали кого-нибудь наблюдать за нами. Конечно, все понимали, что "наблюдатель" ничем нам не поможет, но все равно они заставляли его просиживать в нашем офисе по 18 часов. Серьезные парни ! Вполне могли спросить: "Почему изменены сроки ? Нам надо знать причину. Тогда мы исправим то, что вызвало задержку". Я до сих пор помню, каково нам приходилось, когда мы опаздывали с некоторыми проектами. Постепенно мы сами исправились. Правда, и сейчас мы иногда затягиваем отдельные проекты, однако это происходит гораздо реже, чем могло бы, - спасибо тем суровым сидельцам.

Свою деятельность Microsoft начала в 1975 году в Альбукерке (штат Нью-Мексико), потому что именно там находится MITS. MITS - та самая компания, чей сборный комплект персонального компьютера Altair 8800 красовался на обложке журнала Popular Electronics. Мы сотрудничали, поскольку она была первой компанией, которая продавала широкой публике недорогие персональные компьютеры. К 1977 году в этот бизнес включились Apple, Commodore и Radio Shack. Мы поставляли Бейсик для большинства выпускавшихся тогда персональных компьютеров. В то время этот программный ингредиент был чрезвычайно важен, так как позволял писать на Бейсике свои программы, а не тратиться на готовые.

Продажа Бейсика являлась одной из моих многочисленных обязанностей. В течение первых трех лет большинство других специалистов в Microsoft сосредоточилось исключительно на технической работе, а я взял на себя основную нагрузку по продажам, финансовым делам и маркетингу, впрочем, программированием тоже занимался. Ведь мне едва стукнуло двадцать, и торговля меня не очень-то привлекала.

Стратегия Microsoft была направлена на то, чтобы компьютерные компании вроде Radio Shack приобретали лицензии на поставку нашего программного обеспечения вместе со своими персональными компьютерами (у Radio Shack, например, это был TRS-80), платя нам определенный процент. Причина, заставившая нас пойти по такому пути, - пиратство.

Поначалу объем продаж Бейсика для "Альтаиров" был намного ниже, чем мы ожидали, зная его повсеместное распространение. Я опубликовал открытое письмо, в котором призывал всех пользователей персональных компьютеров прекратить красть наше программное обеспечение, иначе мы не сможем заработать денег на создание новых программ. "Для меня нет ничего приятнее, чем нанять десяток программистов и наводнить рынок хорошими программами", - писал я. Но мои аргументы мало кого убедили; похоже, Бейсик всем нравился, им пользовались, но его предпочитали "одалживать" друг у друга.

К счастью, сегодня большинство пользователей понимает, что программные продукты защищены авторским правом. Однако пиратское копирование программ - по-прежнему крупная проблема. Поэтому Соединенные Штаты добиваются от правительств других стран принятия более действенных законов по охране авторских прав (или их соблюдения) на книги, фильмы, компакт-диски и программные продукты. Надо принять максимум законодательных мер, чтобы будущая магистраль не стала раем для пиратов.

Несмотря на то что мы добились неплохих успехов в продаже программных продуктов американским компаниям - изготовителям аппаратных средств, к 1979 году почти половину наших заказов обеспечивала Япония; последнее - заслуга Кацухико (Кай) Ниси [Kazuhiko (Kay) Nishi]. В 1978 году он позвонил мне и представился на английском. Прочитав о Microsoft, он решил с нами сотрудничать. Как потом выяснилось, у нас было много общего. Мы одногодки, оба студенты колледжа в академическом отпуске, увлеченные персональными компьютерами.

Встретились мы лишь несколько месяцев спустя на конференции в Анахайме (штат Калифорния), а потом он полетел вместе со мной в Альбукерке. Там мы подписали полуторастраничный контракт, по которому Кай получал исключительные права на распространение Microsoft BASIC в Восточной Азии. Никаких адвокатов не было, только Кай и я, две родственные души. По тому контракту мы провели сделок на сумму свыше 150 миллионов долларов - раз в десять больше, чем ожидали.

Манера ведения бизнеса у Кая была чем-то средним между тем, что принято в Японии, и тем, что принято в Соединенных Штатах. Одевался он очень экстравагантно, и нам это было на руку, так как укрепляло японских бизнесменов в впечатлении о нас как о ребятах энергичных, современных. Когда я был в Японии, мы не вылезали из гостиничного номера: ему беспрестанно звонили, даже ночью, делая заказы. Это было поразительно. Одно время, между тремя и пятью утра, телефон молчал, а когда в пять он зазвонил, Кай, снимая трубку, буркнул: "Что-то сегодня ночью бизнес идет вяло". В общем, поездка получилась впечатляющей.

В следующие 8 лет Кай не упустил ни одной возможности. Так, в 1981 году, перелетая из Сиэтла в Токио, он случайно узнал, что сидит рядом с Кацуо Инамори (Kazuo Inamori), президентом гигантской Kyocera Corporation с оборотом в 650 миллионов долларов. Кай (которому принадлежала ASCII, его японская компания), уверенный в поддержке Microsoft, протолкнул Инамори новую идею - выпуск портативного компьютера со встроенным программным обеспечением. Кай и я спроектировали эту машину. В то время Microsoft была еще небольшой компанией, и я тоже участвовал в разработке программного обеспечения. В 1983 году продвижением этой машины на рынок США под маркой Model 100 (она стоила всего 799 долларов) занималась Radio Shack. В Японии ее продавали под маркой NEC PC-8200, а в Европе как Olivetti M-10. Вот так, благодаря энтузиазму Кая, появился первый "лэптоп", пользовавшийся спросом у журналистов.

Несколько лет спустя, в 1986 году, наши пути разошлись. Кай решил изменить профиль своей фирмы, поэтому Microsoft открыла в Японии собственное подразделение. Компания Кая продолжает играть важную роль в распространении программных продуктов на японском рынке. Ну а сам Кай, по-прежнему мой близкий друг, одевается все так же кричаще и так же предан идее превратить персональные компьютеры в универсальный инструмент.

Рынок персональных компьютеров по своей природе глобален, что, безусловно, скажется на развитии информационной магистрали. Сотрудничество американских, европейских и азиатских компаний в индустрии персональных компьютеров приобретает первостепенное значение. Государства или компании, которым не удастся выйти на глобальный уровень, уже не смогут лидировать.

В январе 1979 года Microsoft переехала из Альбукерке в пригород Сиэтла (штат Вашингтон). Пол и я вернулись домой, приведя за собой почти всех из дюжины своих сотрудников. Мы сосредоточились на разработке языков программирования для той массы новых машин, которые появились с зарождением индустрии персональных компьютеров. К нам часто приходили с интересными проектами, которые могли вылиться во что-то крупное. Спрос на услуги Microsoft все время превышал наши возможности.

Мне требовался помощник, и я обратился к старому гарвардскому приятелю по курсу "Экономика 2010", Стиву Балмеру. Окончив колледж, Стив работал младшим менеджером по производству на фирме Procter & Gamble в Цинциннати. Через несколько лет он поступил в Стэнфордскую школу бизнеса (Stanford Business School). К тому времени, когда я ему позвонил, он уже окончил первый курс и хотел продолжить учебу, но, услышав мое предложение стать совладельцем Microsoft, Стив без колебаний пополнил список "вечных студентов". Долевая собственность, которую Microsoft передавала большинству своих сотрудников через права на покупку акций, оказалась настолько эффективным механизмом, что и вообразить никто не мог. В руках сотрудников находились акции буквально на миллиарды долларов. Я уверен, что такая практика (передачи прав на акции), воспринимаемая всеми с энтузиазмом, - одно из преимуществ Соединенных Штатов, которое позволяет начинающим компаниям в этой стране добиваться успеха.

Где-то через 3 недели после приезда Стива в Microsoft мы первый раз крупно поспорили. Тогда Microsoft наняла около тридцати человек, и Стив решил, что нам нужно немедленно взять еще человек пятьдесят.

"Ни в коем случае", - сказал я. Многие из наших прежних заказчиков обанкротились, и волне естественный страх остаться без цента в момент всеобщего бума делал меня осторожным. Мне не хотелось, чтобы мы "проедали" все доходы. Но Стив стоял на своем, и я уступил: "Ладно, продолжай нанимать талантливых сотрудников, но я скажу, когда мы больше не сможем себе этого позволить". Однако я так ничего и не сказал, потому что доходы росли быстрее, чем Стиву удавалось находить таланты.

Главное, чего я боялся в те годы, - вынырнет откуда-нибудь другая компания и отобьет у нас рынок. Особенно меня беспокоило несколько маленьких фирм, занимавшихся разработкой либо микропроцессорных чипов, либо программного обеспечения, но, к счастью для нас, ни одна из них не видела рынок программных продуктов так, как видели его мы.

Кроме того, всегда существовала и такая угроза: кто-то из крупных производителей вычислительной техники возьмет да и смасштабирует программное обеспечение своих больших машин под компьютеры на базе микропроцессоров. IBM и DEC имели целые библиотеки мощных программ. Но Фортуна вновь не отвернулась от Microsoft: ни один из серьезных игроков так и не стал переносить архитектуру и программное обеспечение своих компьютеров в индустрию "персоналок". Единственный критический момент был в 1979 году, когда DEC предложила архитектуру мини-компьютера PDP-11 для персонального компьютера, который продавала компания HeathKit. Однако у DEC не было особой веры в персональные компьютеры, и она, по сути, почти не продвигала этот проект.

Цель Microsoft состояла в том, чтобы создавать и поставлять программное обеспечение для большинства персональных компьютеров, не включаясь непосредственно в разработку или продажу их аппаратных средств. Microsoft продавала лицензии на программные продукты по чрезвычайно низким ценам, делая ставку на объем продаж. Мы адаптировали наши языки программирования - тот же Бейсик - к каждой машине и моментально реагировали на любую просьбу изготовителей оборудования. Мы не хотели давать им повод искать другого партнера. Мы стремились к тому, чтобы программы Microsoft выбирали не задумываясь.

Наша стратегия оправдалась. Почти все изготовители персональных компьютеров лицензировали у нас какой-нибудь язык программирования. Даже если оборудование разных фирм отличалось, тот факт, что на них работает Microsoft BASIC, уже означал - в какой-то мере компьютеры совместимы. Эта совместимость сама по себе стала весьма важным фактором; это было нечто, что люди как бы покупали вместе с компьютерами. Многие фирмы в своей рекламе стали указывать, что для их "персоналок" имеются языки программирования от Microsoft, включая Бейсик.

Вот так Microsoft BASIC превратился в промышленный стандарт программного обеспечения.

Некоторые технологии не зависят от всеобщего признания их значимости. Прекрасная непригорающая сковорода - вещь очень полезная, даже если Вы единственный, кто ее приобрел. Но ценность средств связи и других продуктов, пользоваться которыми в одиночку бессмысленно, обусловлена именно их распространенностью. Если придется выбирать между красивым почтовым ящиком ручной работы с узкой щелью для конвертов только одного размера и старой картонкой, в которую кидают всю почту, Вы предпочтете последнюю, выбрав совместимость.

Иногда правительства или комитеты устанавливают какие-то стандарты, призванные обеспечивать совместимость. Их называют стандартами de jure, они имеют силу закона. Однако большая часть удачных стандартов складывается de facto - так, как их определяет рынок. Аналоговые часы отсчитывают время по часовой стрелке. В пишущих машинках и компьютерных клавиатурах для англоязычных стран используется раскладка, на которой буквы в верхнем ряду слева направо образуют слово QWERTY. Ни один закон не гласит, что должно быть именно так. Но все придерживаются этих стандартов, и никому не приходит в голову от них отказываться.

Поскольку стандарты de facto поддерживает рынок, а не закон, они диктуются необходимостью и меняются только с появлением чего-то действительно лучшего; например, компакт-диски вытеснили виниловые пластинки.

Стандарты de facto зачастую действуют на рынке через экономический механизм, весьма схожий с положительной спиралью - движущей силой успешного бизнеса, - при которой один успех влечет за собой другой. Эта концепция, называемая положительной обратной связью, объясняет, почему стандарты de facto нередко появляются именно тогда, когда возникает потребность в совместимости.

Цикл положительной обратной связи начинается в тот момент, когда на развивающемся секторе рынка какой-то способ делать то-то и то-то оказывается лучше, чем принятый до сих пор. С большей степенью вероятности это относится к высокотехнологичным продуктам, которые можно выпускать в больших объемах при крайне незначительном росте их стоимости и отчасти получать выигрыш от совместимости. Один из примеров тому - игровые видеоприставки. Это специализированный компьютер со специализированной операционной системой, служащей платформой для игровых программ. Совместимость здесь чрезвычайно важна: чем больше программ (в данном случае игр) доступно этой машине, тем ценнее она для покупателя. В то же время, чем больше покупают эту машину, тем больше программ создают именно для нее. Когда модель достигает высокого уровня популярности, начинается цикл положительной обратной связи, и объем продаж еще больше возрастает.

По-видимому, в промышленности самой известной демонстрацией силы, присущей положительной обратной связи, была битва за формат видеокассет, развернувшаяся в конце семидесятых - начале восьмидесятых. Принято считать, будто одна только положительная обратная связь привела к победе формата VHS над форматом Beta, невзирая на технические преимущества последнего. На самом деле первые кассеты формата Beta позволяли записывать всего один час (сравните с тремя часами на VHS), этого времени явно не хватало на запись фильма или футбольного матча. Клиентов больше интересовала емкость кассет, а не какие-то там технические усовершенствования. В итоге формат VHS получил некоторое преимущество перед форматом Beta, который Sony использовала в своем видеоплейере Betamax. JVC, разработавшая стандарт VHS, разрешала применять его другим изготовителям видеомагнитофонов за весьма низкий процент отчислений. По мере того как на рынке стали преобладать VHS-совместимые видеоплейеры, в магазинах чаще стали покупать кассеты именно в этом формате. Владельцам такого видеоплейера было проще найти интересующий их фильм, а значит, формат VHS стал выгоднее, и число его потенциальных покупателей росло. Это в свою очередь заставило розничных торговцев закупать преимущественно VHS-видеотехнику. И с этого момента формат Beta потерпел крах. Цикл положительной обратной связи дал VHS дополнительные преимущества. Успех рождает успех. Но не в ущерб качеству.

Пока проходила дуэль между форматами Betamax и VHS, объем годовых продаж предварительно записанных видеокассет - дилерам системы видеопроката - в США достиг без малого нескольких миллионов копий. Как только VHS, перейдя некий Рубикон, стал явным стандартом (это произошло где-то в 1983 году), производство ориентированной на него видеотехники, если судить по продажам видеокассет, резко пошло вверх. В тот год было продано свыше 9,5 миллионов видеокассет, на 50% больше, чем год назад. В 1984 году объем продаж достиг 22 миллионов штук и последовательно возрастал - 52, 84 и 110 миллионов - вплоть до 1987 года. Ну а к тому времени прокат видеофильмов стал одной из наиболее популярных форм досуга, и VHS-видеотехника окончательно вытеснила с рынка модели, рассчитанные на другой формат. Вот так количественные изменения в уровне восприятия новой технологии могут перерасти в качественные изменения той роли, которую играет эта технология.

Телевидение - это еще один пример на ту же тему. В США в 1946 году было продано 10000 телевизоров и только 16000 - в следующем. Но вот перейден определенный порог, и в 1948 году их число достигает 190000. В последующие годы оно постоянно растет и в 1955 году составляет 32 миллиона. Чем больше покупали телевизоров, тем больше вкладывали денег в создание телепрограмм, а это, в свою очередь, стимулировало продажу телеприемников.

Поначалу и первые проигрыватели аудиокомпакт-дисков продавались не очень хорошо - отчасти потому, что выбор компакт-дисков был небогат. Вдруг, как по волшебству, ассортимент и проигрывателей, и дисков начал расти, и в какой-то момент критический порог был взят. Все больше людей покупали проигрыватели, потому что предлагалось все больше компакт-дисков, а это заставляло компании расширять их ассортимент. Любители музыки оценили новое, высококачественное звучание и удобство компакт-дисков. Так компакт-диски превратились в стандарт de facto и вытеснили грампластинки из музыкальных магазинов.

Один из важнейших уроков, преподанных компьютерной индустрии, заключается в том, что для пользователя ценность компьютера определяется преимущественно качеством и многообразием существующих программ. Мы все, занятые в этой индустрии, усвоили этот урок; кто-то учился на чужих ошибках, а кто-то - на своих.

Летом 1980 года в Microsoft обратились два представителя IBM с предложением обсудить персональный компьютер, который могла бы выпускать эта корпорация. В то время позиции IBM в царстве аппаратных средств были непоколебимы, ей принадлежало более 80% рынка мэйнфреймов. Но ее малые компьютеры имели весьма умеренный успех. IBM привыкла продавать большие дорогостоящие машины крупным заказчикам. Руководители IBM, численность персонала которой достигала 340000 человек, подозревали, что их компания, как и многие другие, не сможет без посторонней помощи торговать маленькими недорогими машинами.

IBM хотела менее чем за год вывести на рынок свой персональный компьютер. Чтобы выдержать этот график, ей пришлось отказаться от давней традиции: разрабатывать все оборудование и программное обеспечение самостоятельно. Так IBM выбрала курс на создание собственного персонального компьютера в основном из готовых компонентов, доступных любому участнику рынка. Это привело к появлению абсолютно открытой платформы, легко копируемой другими.

Хотя IBM обычно сама разрабатывала микропроцессоры для своей продукции, в этом случае компания решила покупать их у Intel и, что для Microsoft гораздо важнее, не создавать свою операционную систему, а лицензировать ее у нас.

Сотрудничая с группой разработчиков из IBM, мы поддержали их планы создания одного из первых персональных компьютеров на базе 16-разрядного микропроцессорного чипа - 8088. Переход с 8- на 16-разрядные микропроцессоры превратил бы персональный компьютер из игрушки в полноценный инструмент. Поколение 16-разрядных компьютеров смогло бы поддерживать до 1 мегабайта памяти - в 256 раз больше, чем 8-разрядные. Поначалу это было лишь теоретической возможностью, поскольку IBM пока не собиралась предлагать более 16 Кб, т.е. всего 1/64 полного объема памяти. Преимущества 16-разрядности, кроме того, резко уменьшались решением использовать чип с 8-разрядным подключением к остальным частям компьютера. Соответственно, чип "думал" гораздо быстрее, чем "общался". Но все "равно, применение 16-разрядного микропроцессора чрезвычайно укрепило позиции IBM на рынке персональных компьютеров, а сами эти компьютеры и по сей день остаются стандартом.

IBM, с ее репутацией и желанием применить открытую архитектуру, которую могли бы копировать другие компании, имела реальный шанс создать новый стандарт персональной вычислительной техники. Мы хотели участвовать в этом процессе и поэтому приняли вызов. Приступая к созданию операционной системы, мы закупили кое-какие разработки у другой компании из Сиэтла и наняли ее ведущего инженера Тима Патерсона (Tim Paterson). После многочисленных модификаций система превратилась в дисковую операционную систему фирмы Microsoft, или MS-DOS. А Тим стал, по сути, ее отцом.

IBM, наш первый лицензиат, назвала систему PC-DOS; аббревиатура PC подразумевала "персональный компьютер". IBM выбросила PC на рынок в августе 1981 года, что привело к настоящему триумфу. Компания умело проводила рыночную политику и популяризировала термин PC. Этот проект задумал Билл Лоу (Bill Lowe), а реализовал Дон Эстридж (Don Estridge). Надо отдать должное квалификации сотрудников IBM, сумевших менее чем за год довести свой персональный компьютер от голой идеи до рыночного продукта.

Теперь уже мало кто помнит, что оригинальный IBM PC изначально комплектовали тремя операционными системами на выбор: нашей PC-DOS, CP/M-86 и UCSD Pascal P-system. Мы понимали, что из трех выживет только одна, - она и станет стандартом. Нам хотелось, чтобы MS-DOS подтолкнули те же силы, которые "работали" на видеокассеты VHS. Перед нами встали три взаимосвязанные задачи. Во-первых, сделать MS-DOS лучшим продуктом. Во-вторых, помочь другим программистским фирмам создать продукты на базе MS-DOS. В-третьих, гарантировать ее низкую стоимость.

Мы заключили с IBM легендарную сделку: за низкую, однократную выплату передали ей права на использование нашей операционной системы на стольких компьютерах, сколько она сумеет реализовать. Таким образом, у IBM появился стимул проталкивать MS-DOS и продавать ее недорого. Наша стратегия сработала. IBM предлагала UCSD Pascal P-system примерно за 450 долларов, CP/M-86 - за 175, а MS-DOS - за 60.

Мы не ставили прямую цель - заработать деньги на IBM, нам было выгоднее другое - лицензировать MS-DOS всем компьютерным компаниям, предлагавшим машины, более или менее совместимые с IBM PC. IBM могла свободно использовать наше программное обеспечение, но у нее не было эксклюзивной лицензии или контроля за будущими улучшениями. Так Microsoft стала передавать индустрии персональных компьютеров лицензии на программную платформу. А IBM в конечном счете отказалась от усовершенствования UCSD Pascal P-system и CP/M-86.

Клиенты довольно активно раскупали IBM PC, и в 1982 году разработчики начали переносить свои программы на эту аппаратную платформу. Каждый новый клиент, каждое новое приложение усиливали потенциал IBM PC как промышленного стандарта de facto. Вскоре большая часть программ (причем лучших, вроде Lotus 1-2-3) создавалась уже именно для этого персонального компьютера. Мич Кейпор (Mitch Kapor) и Джонатан Сачс (Jonathan Sachs) разработали 1-2-3 и революционизировали электронные таблицы. Первые изобретатели электронных таблиц, Дэн Бриклин (Dan Bricklin) и Боб Фрэнкстон (Bob Frankston), заслуживают бесконечного уважения за свой продукт VisiCalc, но 1-2-3 обогнала его по всем параметрам. Кстати, Мич - человек очень интересный, эклектичное прошлое которого (в данном случае как диск-жокея и инструктора по трансцендентальной медитации) типично для лучших разработчиков программ.

Положительная обратная связь начала двигать рынок PC. Появились тысячи прикладных программ, невероятное множество компаний стало выпускать дополнительные платы, расширяющие аппаратные средства PC. Изобилие программ и вспомогательного оборудования для PC стимулировало рост продаж этих персональных компьютеров - они раскупались в масштабах, которые IBM не предвидела. Цикл положительной обратной связи принес IBM миллиарды долларов. В течение нескольких лет более половины всех персональных компьютеров, используемых в бизнесе, выпускала IBM, а большая часть остальных машин была совместима с IBM PC.

Стандарт IBM стал платформой, которую все имитировали. А причиной столь грандиозного успеха был удачный выбор времени и применение 16-разрядного процессора. Планирование и маркетинг играют ключевую роль в принятии технических продуктов. PC оказался хорошей машиной, но ведь и другая компания могла бы установить стандарт, добившись выпуска нужных программ и достаточного числа машин.

Решения, выбранные IBM, были обусловлены ее стремлением поскорее выбросить на рынок персональные компьютеры, но эти решения крайне упростили другим компаниям создание совместимых машин. Архитектура не была секретом. Микропроцессорные чипы от Intel и операционная система Microsoft доступны всем. Такая открытость была мощным стимулом для поставщиков отдельных компонентов, разработчиков программных продуктов и прочих участников компьютерного бизнеса.

В течение трех лет исчезли почти все конкурирующие стандарты персональных компьютеров. Исключение составили только Apple II и Macintosh фирмы Apple. Hewlett Packard, DEC, Texas Instruments, и Xerox, несмотря на общепризнанные достижения в технологиях, репутацию и обширную клиентуру, в начале восьмидесятых годов потерпели на рынке персональных компьютеров полное фиаско, потому что их машины не были совместимы с PC и не предлагали ничего существенного по сравнению с архитектурой IBM. Сонмы инновационных фирм вроде Eagle или NorthStar воображали, что их машины будут раскупать нарасхват только потому, что они чуть-чуть лучше IBM PC. Рано или поздно все эти фирмы либо переориентировались на выпуск IBM-совместимых машин, либо обанкротились. IBM PC превратился в стандарт. К середине восьмидесятых насчитывалось несколько десятков IBM-совместимых компьютеров. И хотя покупатели, быть может, не говорили об этом прямо, но почти все они искали то оборудование, на котором работает большая часть существующих программ и которое уже есть у их знакомых.

Сейчас среди некоторых ревизионистски настроенных историков стал расползаться слух, будто бы IBM допустила ошибку, сотрудничая с Intel и Microsoft при разработке своего PC. Они пытаются доказать, что IBM следовало запатентовать архитектуру PC и что Intel с Microsoft якобы перехитрили IBM. Но они забывают об одной важной вещи. IBM потому и стала основной силой в индустрии персональных компьютеров, что смогла собрать под своей эгидой невероятное множество талантливых разработчиков и организаторов и с их помощью продвинула свою открытую архитектуру. Именно IBM устанавливала стандарты.

В производстве мэйнфреймов балом всегда правила IBM, и конкуренты не могли состязаться с ней в затратах на НИОКР и маркетинг. Если какой-то конкурент пытался взять ту же высоту, IBM, сосредоточив свои активы, останавливала его восхождение. В изменчивом мире персональных компьютеров позиции IBM напоминали позиции лидера в марафоне. Пока лидер бежит с той же скоростью, что и другие, или быстрее, он - впереди, а прочие лишь пытаются догнать его. Но стоит хотя бы на секунду замедлить бег, как лидерство упущено.

К 1983 году я пришел к выводу, что следующим нашим шагом должна стать разработка графической операционной системы. Я был уверен, что мы не удержим передовые позиции в индустрии программных продуктов, если будем цепляться за MS-DOS - операционную систему текстового режима. Работая с ней, пользователю зачастую приходилось набирать весьма туманные команды. Она не давала никаких графических подсказок, упрощающих выбор и запуск приложений. Кстати, способ, которым человек общается с компьютером, называется интерфейсом. Так вот, я полагал, что будущее за графическими интерфейсами и что для Microsoft очень важно выработать новый стандарт, в котором картинки и шрифты стали бы неотъемлемой частью простого в использовании интерфейса. Упростить работу с персональными компьютерами требовали интересы не только их нынешних владельцев, но и новых покупателей, которых часто пугало освоение сложного интерфейса.

Чтобы проиллюстрировать громадную разницу между компьютерной программой с текстовым интерфейсом и графическим, приведу такой пример. Представьте, что Вы играете на компьютере в одну из настольных игр вроде шахмат, шашек, Го или монополии. При наличии системы с текстовым интерфейсом Вы вводите свои ходы, используя символы. Вы пишете: "Передвинуть фигуру с квадрата 11 на квадрат 19" или что-нибудь более зашифрованное: "Пешку на QB3". Но в графической компьютерной системе доска с фигурами сама показывается на экране. Вы просто перемещаете их в нужные позиции.

Сотрудники ныне знаменитого исследовательского центра фирмы Xerox - Palo Alto Research Center - в Калифорнии, рассматривая принципы общения человека с компьютером, сделали любопытное открытие. Они показали, что компьютером легче управлять, если Вы выбираете свои действия, указывая что-то на экране и видя соответствующие картинки. Они использовали устройство, которое назвали "мышью": его можно было перемещать по поверхности стола и тем самым передвигать указатель по экрану. Увы, Xerox так и не сумела воспользоваться коммерческими выгодами, которые сулила эта сногсшибательная идея, потому что ее машины были слишком дороги и в них применялись нестандартные микропроцессоры. Воплотить новые идеи в ходовую продукцию - не каждой компании по силам.

В 1983 году Microsoft объявила, что с помощью продукта под названием Windows собирается реализовать на IBM PC графический интерфейс. Мы поставили себе целью: разработать программное обеспечение, способное расширить MS-DOS, работать с мышью, создавать графические изображения и формировать на экране ряд окон для выполнения в них разных программ. В то время на рынке было всего две модели персональных компьютеров, позволявшие работать с графическими изображениями: Xerox Star и Apple Lisa, - обе очень дорогие, ограниченные по возможностям и построенные на архитектурах собственной разработки. Другие производители аппаратных средств не могли лицензировать их операционные системы; кроме того, большинство программистских фирм эти компьютеры не привлекали, и приложений для них было слишком мало. А Microsoft стремилась создать открытый стандарт и обеспечить графический интерфейс на каждом компьютере, работающем под управлением MS-DOS.

Первая популярная графическая платформа появилась на рынке в 1984 году, когда Apple выпустила свой Macintosh. Собственная (патентованная) операционная система "Макинтоша" была полностью графической и пользовалась огромным успехом. Первые модели этих компьютеров и версии операционной системы были весьма ограниченны, но ярко демонстрировали потенциал графического интерфейса. Этот потенциал раскрылся только тогда, когда усовершенствовали и компьютеры, и их программное обеспечение.

Мы тесно сотрудничали с Apple в процессе создания Macintosh. Группу ее разработчиков возглавлял Стив Джобс (Steve Jobs). Работать с ним было по-настоящему интересно. У Стива удивительное чутье на технику и умение мотивировать труд специалистов мирового уровня.

Разработка графических программ потребовала немалого воображения. Как должна выглядеть такая программа ? Как она должна себя вести? Часть идей мы почерпнули из разработок фирмы Xerox, а часть родилась в головах наших сотрудников. Поначалу интерфейс получился избыточным. Мы использовали чуть ли не все имеющиеся шрифты и значки (icons). Тогда мы "вычистили" все лишнее и изменили систему меню - чтобы она выглядела менее хаотично. Мы создали для Макинтоша текстовый процессор, Microsoft Word, и электронную таблицу, Microsoft Excel, - первые графические продукты Microsoft.

Macintosh была великолепной операционной системой, но Apple (вплоть до 1995 года) никому не разрешала выпускать компьютеры, способные работать с ней. Здесь проявился традиционный подход, свойственный многим производителям оборудования: хочешь это программное обеспечение - купи наши компьютеры. А Microsoft стремилась к тому, чтобы Макинтоши хорошо продавались и стали общепризнанными персональными компьютерами, - и не только потому, что мы много вложили в разработку приложений для него, но и потому, что хотели перевода компьютеров на графический интерфейс.

Такие ошибки, как решение Apple ограничить продажу своей операционной системы рамками исключительно собственных компьютеров, еще не раз будут повторяться. Некоторые телефонные и кабельные компании уже поговаривают о том, что какие-то средства связи смогут работать только под управлением их собственного программного обеспечения.

Сейчас все важнее конкуренция и одновременное сотрудничество, однако до понимания этого многим еще расти и расти.

При создании операционной системы OS/2 камнем преткновения между IBM и Microsoft стало разделение программного обеспечения и оборудования. Впрочем, эта проблема актуальна и сегодня. Хотя, по нынешним стандартам, программные продукты не должны зависеть от конкретных аппаратных платформ, многие компании, пользуясь тем, что выпускаемое ими оборудование тесно взаимосвязано с ими же разработанным программным обеспечением, стремятся обособить свои системы. Какие-то фирмы относятся к созданию оборудования и программного обеспечения как к разным видам бизнеса, а какие-то - нет. Эти диаметрально противоположные подходы непременно отразятся и на информационной магистрали.

На протяжении восьмидесятых IBM по всем меркам капитализма внушала только благоговение. В 1984 году она достигла рекордной прибыли - 6,6 миллиарда долларов. В том же году IBM предложила персональный компьютер второго поколения, высокопроизводительную машину PC AT, построенную на микропроцессоре Intel 80286 (в разговорной речи его называли просто "286 процессором"). Этот компьютер был в 3 раза быстрее, чем оригинальный IBM PC. Машины AT пользовались колоссальным успехом, и через год их доля в объеме продаж всех персональных компьютеров составила более 70%.

Выпуская свой первый PC, IBM никак не ожидала, что этот компьютер бросит вызов ее мэйнфреймам, - тем более что значительную часть покупателей PC составляли ее традиционные клиенты. Менеджеры компании полагали, что такие маломощные машины будут иметь спрос только на нижнем уровне рынка. По мере того как персональные компьютеры становились все мощнее, IBM начала сдерживать их развитие, опасаясь чрезмерной конкуренции своим мэйнфреймам.

В производстве мэйнфреймов IBM всегда контролировала принятие новых стандартов. Она могла ограничить показатель "цена/производительность" новой линии оборудования, чтобы не терять заказчиков существующей, более дорогой продукции; могла стимулировать разработку новых версий своих операционных систем, выпустив оборудование, требующее нового программного обеспечения, и наоборот. Такая стратегия хороша для рынка мэйнфреймов, но ущербна для динамичного рынка персональных компьютеров. IBM еще могла завышать цены, но всем уже было известно, что масса фирм выпускает совместимое оборудование с аналогичными параметрами, и, если IBM не предложит подходящую цену, это сделают за нее другие.

Три инженера из фирмы Texas Instruments, оценив на примере IBM перспективы производства персональных компьютеров, решили основать новую компанию - Compaq Computer. Получив лицензию на MS-DOS, компания занялась выпуском компьютеров, расширяемых теми же платами и работавших с теми же программами, что и IBM PC. Более компактные, эти машины делали все, что делали IBM PC. Compaq стала легендой американского бизнеса - в первый же год она продала компьютеров более чем на 100 миллионов долларов. IBM могла бы собирать "дань" с таких фирм, предоставляя лицензии на свои системы, но на рынок пришли совместимые системы, и оборудование IBM оказалось неконкурентноспособным.

Кроме того, IBM всячески затягивала выпуск персональных компьютеров на более мощном чипе Intel 386, стремясь сохранить объем продаж младших моделей мини-компьютеров, почти не отличавшихся по мощности от ПК на базе 386 микропроцессора. Эти проволочки позволили Compaq в 1986 году выпустить первый компьютер с микропроцессором Intel 386. Тем самым Compaq значительно подняла свой престиж и серьезно потеснила IBM.

Но IBM не собиралась сдавать своих позиций и готовила удар сразу по двум направлениям: в производстве оборудования и в области программного обеспечения. Она хотела разработать такие компьютеры и такие операционные системы, новые возможности которых нельзя было бы реализовать в отрыве друг от друга. Такой шаг отбросил бы конкурентов или заставил их ощутимо раскошелиться на приобретение лицензий. Стратегия состояла в том, чтобы превратить чужие "IBM-совместимые" в абсолютно устаревшие машины.

В этой стратегии было несколько здравых идей, в частности намерение упростить конструкцию PC, заложив в нее все то, что раньше предлагалось только как дополнение. Это могло не только снизить стоимость компонентов, выпускаемых IBM, но и увеличить их долю на рынке. Подобный замысел привел бы также к существенным изменениям в архитектуре аппаратных средств - появлению новых типов разъемов и стандартов на вспомогательные платы, клавиатуры, мыши и даже дисплеи. Чтобы увеличить преимущество, IBM планировала попридержать какие-либо из этих спецификаций вплоть до выпуска первых систем на их основе. Иначе говоря, предполагалось переопределить стандарты совместимости. Прочим производителям персональных компьютеров и периферии пришлось бы начинать все с начала, и IBM вновь вырвалась бы в лидеры.

К 1984 году существенную долю в бизнесе Microsoft составляли лицензии на MS-DOS, передаваемые фирмам - сборщикам IBM-совместимых персональных компьютеров. Наше сотрудничество с IBM началось при разработке операционной системы, которая должна была заменить MS-DOS; впоследствии ее назвали OS/2. По соглашению, Microsoft имела право продавать другим изготовителям компьютеров ту же операционную систему, которую IBM поставляла вместе со своими машинами. И мы, и IBM могли самостоятельно расширять эту операционную систему (т.е. идти дальше совместных разработок). В целом на этот раз ситуация складывалась иначе, чем при работе над MS-DOS. Теперь IBM держала под контролем стандарт, который должен был укрепить ее позиции в производстве оборудования для персональных компьютеров и мзйнфреймов. Она непосредственно участвовала в разработке и реализации OS/2.

В планах IBM, связанных с корпоративным программным обеспечением, OS/2 отводилось центральное место. Она должна была стать первой реализацией архитектуры IBM - Systems Application Architecture, которую компания намеревалась сделать единой платформой прикладных программ для всей линейки компьютеров - от мэйнфреймов и машин среднего класса до персональных. IBM рассчитывала на то, что распространение ее технологий с мэйнфреймов на персональные компьютеры привлечет большинство корпоративных заказчиков, которые все активнее переходили с мэйнфреймов и мини-компьютеров на ПК. Кроме того, предполагалось, что это даст IВМ дополнительное преимущество над конкурентами, не имеющими доступа к технологиям мэйнфреймов. IBM внесла собственные усовершенствования в операционную систему OS/2 (в этом варианте она называлась Extended Edition - расширенное издание), в том числе сервис для коммуникаций и баз данных. Она планировала также создать полный набор офисных приложений - OfficeVision, - которые бы работали на базе расширенного варианта OS/2. Эти приложения, включая текстовый процессор, позволили бы IBM стать лидером на рынке прикладных программ для персональных компьютеров и конкурировать с Lotus и WordPerfect. Но разработка комплекса OfficeVision требовала усилий тысяч и тысяч сотрудников. При этом OS/2 превращалась не просто в операционную систему, а в эдакое знамя "крестового похода" этой корпорации.

Разработки осложнялись тем, что проект должен был отвечать множеству противоречащих друг другу требований, а также планам IBM относительно Extended Edition и OfficeVision. Тем временем Microsoft вырвалась вперед и подготовила ряд приложений для OS/2, но наш интерес к ней постепенно таял. Мы согласились участвовать в этом проекте, уверенные, что IBM позволит сделать OS/2 чем-то достаточно близким к Windows, чтобы программисты, внося минимальные модификации, могли предлагать приложения для обеих платформ. Но IBM настаивала, чтобы приложения были совместимы с ее мэйнфреймами и системами среднего класса. Мы поняли: OS/2 превращается в какого-то монстра, ориентированного скорее на мэйнфреймы, чем на персональные компьютеры.

Деловые отношения с IBM были жизненно важны для нас. В тот год (1986) мы объявили о ликвидности акций, переданных в свое время ряду сотрудников. Именно тогда Стив Балмер и я предложили IBM приобрести 30% собственности Microsoft (по минимальной договорной цене), чтобы она могла разделять наши успехи или - провалы. Мы полагали, что это сблизит наши компании и позволит нам сотрудничать более продуктивно. Но IBM это не заинтересовало.

Мы работали не покладая рук над совместным с IBM проектом, стремясь благополучно завершить его. Я чувствовал, что для наших компаний это билет в будущее... Но, увы, проект только увеличивал пропасть между нами.

Новая операционная система - вещь всегда очень серьезная. На нас работали группы и за пределами Сиэтла, а у IBM были группы в Бока Ратоне (штат Флорида), Херсли Парк (Новая Англия) и Остине (штат Техас). Но географические проблемы - ничто в сравнении с грузом наследства мэйнфреймов IBM. И в прошлых, "софтверных" проектах IBM никогда не удавалось точно предугадать настроение пользователей ПК, потому что все у нее было ориентировано прежде всего на пользователей мэйнфреймов. Например, одна из версий OS/2 "грузилась" больше трех минут, а IBM казалось, что это неплохо, поскольку в мире мэйнфреймов загрузка занимает до пятнадцати минут.

IBM, с численностью персонала свыше 300000 человек, загоняла себя в тупик еще и тем, что постоянно стремилась к консенсусу в рамках всей компании. Каждому подразделению предлагалось внести свои замечания, что на практике сводилось к одному: подгонке операционной системы персональных компьютеров к продуктам, рассчитанным на мэйнфреймы. Получив больше 10000 таких замечаний, можно было годами обсуждать их.

До сих пор помню замечание № 221: "Убрать шрифты. Причина: улучшение конечного продукта". Кому-то в IBM не понравилось, что в операционной системе персональных компьютеров несколько шрифтов только из-за того, что какой-то там принтер от мэйнфрейма не мог ими печатать.

В конце концов стало ясно, что такое сотрудничество совершенно бесплодно. Тогда мы предложили IBM другой выход: мы самостоятельно разрабатываем новую операционную систему, а потом она за небольшую сумму приобретает на нее лицензию. Свою прибыль мы бы получили от продажи этого продукта другим компьютерным фирмам. Но IBM заявила, что ее программисты должны участвовать в разработке любых программных продуктов, имеющих стратегическое значение. А новая операционная система, несомненно, относится к таким продуктам.

IBM была признанной великой компанией. Зачем ей понадобилась эта возня с разработкой программного обеспечения для персональных компьютеров ? Одна из причин - в явной тенденции IBM продвигать своих лучших программистов в администрацию, а менее талантливых - оставлять на месте. И что еще важнее, ей не давали покоя прошлые успехи. Однако столь привычная IBM технология разработки продукции не годилась для динамичного рынка программ, ориентированных на персональные компьютеры.

В апреле 1987 года IBM выпустила в свет интегрированный комплекс оборудования и программного обеспечения, который должен был сразить жалких имитаторов. Этого "убийцу клонов" назвали PS/2, и работал он под управлением новой операционной системы OS/2.

В PS/2 было несколько новаторских решений. Самое известное из них - новая "микроканальная шина" для подключения к системе вспомогательных плат, позволявшая дополнять персональный компьютер такими специфическими возможностями, как обработка звука или коммуникационная связь с мэйнфреймами. Microchannel на PS/2 была весьма элегантной заменой соединительной шине PC AT, но решала те проблемы, с которыми большинство клиентов просто не сталкивалось. Ее скорость потенциально превосходила скорость шины PC AT, но на практике шина в то время не вносила существенного вклада в быстродействие компьютеров, и поэтому клиенты не получали особых выгод от ее применения. Гораздо важнее то, что Microchannel оказалась абсолютно несовместима ни с одной из тысяч вспомогательных плат, прекрасно работавших с компьютерами типа PC AT.

В итоге IBM согласилась за определенные отчисления передавать лицензии на Microchannel производителям плат расширения и персональных компьютеров. Но к тому моменту коалиция производителей уже объявила о новой шине, обладавшей многими возможностями Microchannel и в то же время совместимой с шиной PC AT. Клиенты отказывались от Microchannel, предпочитая старые шины PC AT. Выбор плат расширения для PS/2 нельзя было и сравнивать с тем, что предлагалось для систем, совместимых с PC AT. Это вынудило IBM продолжить выпуск компьютеров, поддерживающих старую шину. Однако настоящая катастрофа для IBM была в другом - она утратила контроль над архитектурой персональных компьютеров. Теперь ей уже никогда не удастся в одиночку повернуть индустрию в новом направлении.

Несмотря на титанические усилия IBM и Microsoft, клиенты все же считали OS/2 слишком громоздкой и сложной системой. Чем хуже выглядела OS/2, тем привлекательнее казалась Windows. Поскольку мы потеряли надежду на совместимость Windows и OS/2 и уже не верили в то, что OS/2 сможет работать на машинах со скромными ресурсами, мы решили продолжить разработку Windows. Она была гораздо компактнее: занимала меньше пространства на жестком диске и требовала меньше памяти - ей нашлось бы место и на машинах, которые никогда не смогли бы работать с OS/2. Мы называли это "семейной" стратегией. Иными словами, OS/2 могла бы стать системой "high-end", а Windows - младшим членом семейства для машин попроще.

IBM от нашей стратегии не была в восторге, вынашивая свои планы. Весной 1988 года совместно с другими изготовителями компьютеров она выступила с инициативой Open Software Foundation с целью способствовать развитию UNIX, операционной системы, изначально созданной в Bell Labs фирмы AT&T в 1969 году, но впоследствии разветвившейся на многочисленные клоны. Некоторые из ее версий разрабатывались в университетах, которые использовали UNIX как лабораторную среду для исследований в теории операционных систем. Другие версии создавали компьютерные фирмы. Каждая фирма совершенствовала UNIX под свои компьютеры, что приводило к ее несовместимости с другими версиями. В результате UNIX стала не единой открытой системой, а набором операционных систем, конкурирующих друг с другом. Эти различия все больше ухудшали совместимость программного обеспечения и задерживали появление мощного рынка независимых разработок для UNIX. Лишь немногие программистские фирмы могли позволить себе создание и тестирование приложений под дюжину разных версий UNIX. Ну а магазины, торгующие программными продуктами, не могли держать на складе всевозможные версии одних и тех же программ.

Open Software Foundation была одной из самых обещающих попыток "унификации" UNIX и создания единой архитектуры для прикладных программ, способной работать на оборудовании, поставляемом разными производителями. Теоретически унифицированная UNIX могла бы войти в цикл положительной обратной связи. Но, несмотря на значительные ассигнования, в рамках Open Software Foundation не удалось добиться сотрудничества с ведущими производителями вычислительной техники, которые отчаянно конкурировали друг с другом и боролись за каждого покупателя. Авторы этой инициативы, включая IBM и DEC, продолжали пропагандировать преимущества именно своих версий UNIX. Но если Вы покупали UNIX-систему у одной фирмы, то созданное Вами программное обеспечение не обязательно работало на UNIX-системе другой фирмы. Таким образом, Вы привязывались к одному поставщику, тогда как в мире персональных компьютеров Ваш выбор не ограничен одним или несколькими поставщиками.

Уязвимость Open Software Foundation и подобных ей инициатив в том, что невозможно навязать какие-то жесткие стандарты быстро развивающейся и постоянно меняющейся отрасли, а все компании, входящие в комитет стандартов, являются конкурентами. Рынок (компьютеров или бытовой электроники - не важно) принимает только те стандарты, на которых настаивают покупатели. Стандарты должны гарантировать взаимозаменяемость аппаратных средств, сводить к минимуму необходимость в переобучении пользователей и, естественно, максимально способствовать развитию мощной индустрии программных продуктов. Новый стандарт не должен обходиться слишком дорого, иначе его не примут. Рынок эффективно отбирает разумные стандарты и сам заменяет их, когда прежние устаревают или начинают "бить по карману".

Операционные системы Microsoft сегодня предлагаются более чем 900 различными фирмами, что дает клиентам широкий выбор. Microsoft сумела обеспечить совместимость и добиться от изготовителей компьютеров согласия не вносить в наше программное обеспечение таких модификаций, которые бы приводили к несовместимости. Значит, сотням тысяч разработчиков приложений нет нужды беспокоиться о том, на каких персональных компьютерах будут работать их программы, а на каких - не будут. И хотя термин "открытый" употребляется в самых разных значениях, для меня он имеет один смысл: возможность выбора аппаратных и программных средств.

Бытовая электроника тоже выигрывает от стандартов, складывающихся на рыночной основе. Сначала фирмы, выпускавшие бытовую электронику, скрывали от конкурентов свою технологию, но теперь почти все они открыты и с готовностью идут на лицензирование своих патентов и торговых секретов. Отчисления подобного рода обычно не превышают 5% стоимости товарной единицы. Аудиокассеты, видеоленты формата VHS, компакт-диски, телевизоры и сотовые телефоны - все это примеры технологий, созданных частными компаниями, которые получают дивиденды от любого, кто производит товары по их лицензиям. А скажем, алгоритмы, разработанные Dolby Laboratories для подавления шумов, стали в этой области стандартом de facto.

В мае 1990 года, в последние недели перед выпуском Windows 3.0 мы предложили IBM лицензировать у нас Windows и устанавливать ее на свои персональные компьютеры. Мы говорили IBM, что, по нашему мнению, у OS/2 большое будущее, но сейчас успех на стороне Windows, тогда как OS/2 еще долго будет отыскивать свою нишу.

В 1992 году IBM и Microsoft прекратили сотрудничество в разработке OS/2, и IBM в одиночку продолжила работы над этой операционной системой. А от амбициозных планов в отношении OfficeVision она в конечном счете отказалась.

Затраты IBM на OS/2, OfficeVision и связанные с ними проекты аналитики оценивают в сумму свыше 2 миллиардов долларов. Если бы IBM и Microsoft удалось договориться, тысячи человеко-лет - лучших лет лучших сотрудников в обеих компаниях - не пропали бы даром. А если OS/2 и Windows были бы совместимы, графический интерфейс стал бы стандартом гораздо раньше.

Принятие графических интерфейсов задержалось еще и потому, что большинство крупных программистских компаний не вкладывало в них деньги. В основном они игнорировали Macintosh и отмахивались от Windows (если не высмеивали ее). Lotus и WordPerfect, лидеры рынка электронных таблиц и текстовых процессоров, лишь к OS/2 проявляли весьма скромный интерес. Теперь в ретроспективе они понимают, что допустили ошибку, и весьма дорогую. Когда Windows в конце концов поднялась на гребне "волны" положительной обратной связи, которую обеспечили небольшие, но многочисленные программистские фирмы, крупные компании оказались сзади, потому что не успели вовремя перейти на Windows.

Windows, как и персональные компьютеры, продолжает развиваться. Microsoft дополняет ее все новыми и новыми возможностями. Любой, не спрашивая Microsoft, может разработать приложение, выполняемое на платформе Windows. Поэтому сегодня для этой платформы предлагаются десятки тысяч коммерческих программных продуктов, в том числе и конкурирующих с большинством приложений, созданных самой Microsoft.

Иногда клиенты выражают мне свою обеспокоенность тем, что Microsoft - едва ли не монополист в операционных системах персональных компьютеров - может поднять цены, снизить темп инноваций или вовсе прекратить их внедрение. Так вот, если мы поступим как-нибудь в этом роде, мы не сможем продавать новые версии своих продуктов. Прежние пользователи не станут их покупать, а уж новых пользователей мы точно не приобретем. В результате наши доходы упадут, а конкуренты займут наше место. Механизм положительной обратной связи помогает всем, а значит, нельзя почивать на лаврах - конкуренты не дремлют.

Если продукт постоянно не совершенствуется, успех его быстротечен. Даже VHS-стандарт будет заменен, когда появятся более эффективные форматы видеокассет по приемлемым ценам. По сути, эпоха VHS уже на закате. В ближайшие несколько лет мы увидим новые цифровые форматы, цифровые видеодиски, которые обеспечат то же качество при просмотре художественных фильмов, какое мы имеем сейчас, слушая музыку на компакт-дисках, а информационная магистраль предоставит затем такие виды услуг, как "видео-по-заказу", и VHS станет вообще не нужным.

Но вернемся к MS-DOS. Сейчас это основная операционная система для персональных компьютеров, но постепенно она заменяется системой с графическим пользовательским интерфейсом. Заменой ей могла бы быть и Macintosh, и OS/2, и UNIX. Но получилось так, что лидером стала Windows. Однако в области высоких технологий перемены не редкость, и даже на ближайшее будущее нет никакой гарантии, что Windows сохранит лидерство.

Мы вынуждены неустанно совершенствовать свои программные продукты, чтобы не отставать от прогресса аппаратных средств. Каждая последующая версия только в том случае получает признание у новых пользователей, если ее принимают постоянные клиенты. Microsoft обязана делать новые версии настолько привлекательными по цене и своим возможностям, чтобы ими захотели заменить старые версии. А это совсем непросто, ведь любые перемены требуют больших затрат как от разработчиков, так и от покупателей. Лишь крупные достижения способны убедить достаточное число людей, что усовершенствованные версии стоят этих затрат. Видимо, новые поколения Windows будут появляться каждые 2-3 года.

По всему миру - в старых гаражах, и в научных институтах - вызревают новые семена конкуренции. Скажем, Internet приобретает такое значение, что Windows только выиграет, если сумеет недвусмысленно доказать, что она - лучший способ доступа к Internet. Все компании, занимающиеся операционными системами, стремятся предложить конкурентноспособную поддержку доступа к Internet. А когда, к примеру, распознавание речи станет подлинно надежным, немедленно последуют очередные крупные изменения в операционных системах.

В нашем бизнесе ситуация меняется слишком быстро, чтобы тратить время на воспоминания. Однако, фокусируя внимание на перспективах, я стараюсь тщательно анализировать наши просчеты. Ведь это очень важно - разобраться в ошибках и извлечь из них уроки. Но не менее важно и другое: чтобы никто из сотрудников не боялся экспериментировать - отдельные ошибки несмертельны.

Та же IBM впоследствии, под руководством Лью Герстнера (Lou Gerstner), стала работать гораздо эффективнее, восстановив и свою прибыль, и свое видение перспективы. И хотя продолжающийся спад в сбыте мэйнфреймов для IBM по-прежнему проблема, она, несомненно, остается одной из крупнейших компаний, которые выпускают продукцию для различных сфер бизнеса и которые будут работать для информационной магистрали.

В последние годы Microsoft пригласила на работу нескольких опытных менеджеров из фирм, испытывавших затруднения. Когда фирма "тонет", невольно приходится проявлять смекалку, копать глубже и думать, думать, думать. Я хочу, чтобы рядом со мной были люди, которые прошли через это. Microsoft не застрахована от провалов, и мне нужны те, кто доказал, что не теряется в самых неординарных обстоятельствах.

Конец для лидера рынка может наступить очень быстро. Когда тебя вдруг выбросит из цикла положительной обратной связи, тогда зачастую уже слишком поздно что-то менять: в игру вступают все прелести отрицательной спирали. Самое трудное поэтому - уловить первые признаки кризиса и начать действовать, когда, казалось бы, дела идут превосходно. По-видимому, этот парадокс придется преодолевать и компаниям, участвующим в строительстве информационной магистрали. Лично я стараюсь всегда быть начеку. Хотя, должен признаться, я и представить не мог, что Microsoft так разрастется, а я, на пороге новой эры, вдруг осознаю себя частью истэблишмента. Сейчас моя цель - доказать, что и процветающая компания способна эффективно обновляться и не уступать лидерства.


Глава 4 - Приложения и устройства

Глава 4
Приложения и устройства

Помню, в детстве каждое воскресенье в восемь вечера по телевизору показывали The Ed Sullivan Show (шоу Эда Салливана). Большинство американцев (у кого был телевизор) старалось не пропустить эту передачу, потому что только в ней и можно было увидеть "Битлз", Элвиса Пресли, "Темптейшнз" или, например, парня, у которого десять собак крутили на носах тарелки. Не дай Бог, если в тот момент Вас не было дома: в понедельник Вы уже не участвовали в горячем обсуждении вчерашнего шоу.

Обычное телевидение позволяет выбирать, что смотреть, но не когда смотреть. Для такого телевидения подходит технический термин "синхронный". Зритель подстраивается (синхронизируется) под сетку вещания. Именно так 30 лет назад я смотрел шоу Эда Салливана, и именно так большинство из нас сегодня вечером будет смотреть новости.

В начале восьмидесятых видеомагнитофоны предоставили нам больше свободы. Если программа Вас настолько интересовала, что Вы были готовы возиться с настройкой таймеров, то, пожалуйста: вставляйте пустую кассету, записывайте передачу и смотрите ее когда угодно. Разговор по телефону - "вещь" тоже синхронная, потому что в нем одновременно участвуют два собеседника. Записывая телепередачу на видеомагнитофон или телефонный звонок на автоответчик, Вы подменяете синхронную связь более удобной ее формой - "асинхронной".

Человечество всегда искало способы заменить синхронную связь асинхронной. 5000 лет назад до изобретения письменности единственной формой общения было устное слово: люди пропускали новость, если отсутствовали при ее оглашении. После появления письменности стало возможным хранить сведения; любой мог читать их тогда, когда ему (или ей) это было удобно. В частности, эти слова я пишу дома в начале 1995 года, но представления не имею, где и когда их прочтете Вы.

Одно из преимуществ, которые сулит информационная магистраль, - свобода выбора. Как только связь становится асинхронной, Вы сами отбираете нужную информацию. Даже те, кто редко записывает телепередачи, берут фильмы напрокат. Всего за несколько долларов видеопрокат предлагает тысячи и тысячи записей на любой вкус. Зритель получает возможность по своему выбору один вечер провести с Элвисом, другой - с "Битлз", а третий - с Гретой Гарбо.

Телевидение существует менее шестидесяти лет, но за этот период практически во всех развитых странах оно превратилось в главный фактор, определяющий общественное мнение. Однако телевидение в каком-то смысле стало всего лишь заменой коммерческому радиовещанию, до этого на протяжении двадцати лет доставлявшему в наши дома новости и развлечения. А с тем, что принесет нам информационная магистраль, не сравнится никакое радио- или телевещание.

Магистраль сделает возможным то, что кажется невероятным, но на самом деле отражает технологию, которая призвана облегчить и улучшить нашу жизнь. Поскольку покупатели уже оценили достоинства кинематографа и привыкли платить за просмотр фильмов, "видео-по-заказу" станет важной областью применения информационной магистрали. Важной, но не основной. Мы уже знаем, что персональные компьютеры соединят друг с другом задолго до того, как то же самое сделают с телевизорами, и что качество фильмов на первых системах вряд ли будет особенно высоким. Зато эти системы подойдут для других, не менее важных сфер употребления: игр, электронной почты, ведения семейного бюджета и т.д. Когда станет возможным передавать по сетям высококачественное видео, посредничество видеомагнитофонов уже не понадобится: Вы будете просто выбирать нужное из длинного списка доступных программ. Прообразы систем "видео-по-заказу" уже устанавливают в некоторых люксах фешенебельных отелей, заменяя или дополняя ими платные видеоканалы. Отели, аэропорты и даже авиалайнеры - отличные лаборатории для развития новых услуг информационной магистрали, которые позже придут и в наши дома.

Телевидение продолжит трансляцию передач так же, как и сегодня, для "синхронного потребления". Однако после выпуска в эфир эта передача, подобно тысячам других видеозаписей, станет доступна любому желающему. Очередную серию Seinfeld Вы посмотрите, когда Вам удобнее: вечером в четверг или утром в воскресенье. А если его своеобразный юмор Вам не по душе, то есть из чего выбрать. Вы запросите конкретную ленту или телепередачу, и ее биты передадут Вам по сети.

Информационная магистраль создаст такое ощущение, словно между человеком и предметом его интересов нет никаких посредников: делаешь заказ и тут же его получаешь.

Видеофильмы, телепрограммы и другие виды цифровой информации будут храниться на серверах, мощных компьютерах с очень емкими дисками. Серверы обеспечат доступность информации в любой точке сети. Если Вы захотите увидеть нашумевший фильм, проверить сомнительный факт или забрать электронную почту, Вы сделаете соответствующий запрос, и его направят серверу или серверам, хранящим эту информацию. И Вы не узнаете, откуда переданы эти материалы: с сервера на соседней улице или с другого края страны; да и какая разница - откуда ?

Затребованные цифровые данные будут считаны с сервера и по определенному маршруту переданы телевизору, персональному компьютеру или телефону - имеющимся у Вас информационным устройствам. Эти цифровые устройства станут необходимы человеку по той же причине, что и их аналоговые предшественники: каждое облегчает какую-то грань быта. Но в отличие от электронных машин - текстовых процессоров, принесших в офисы первые микропроцессоры, - эти информационные устройства предстанут как универсальные, программируемые компьютеры, подключенные к информационной магистрали.

Пользуясь пультом дистанционного управления на инфракрасных лучах, даже прямую трансляцию Вы сможете прерывать, вновь запускать воспроизведение или переходить к любой предыдущей части программы. Если кто-нибудь позвонит, Вы легко приостановите передачу на время телефонного разговора. Все будет под полным Вашим контролем. Единственное, что с прямым эфиром, разумеется, не удастся, - "прокрутить" его вперед.

Доставка фильмов и телепрограмм - вещь, с технической точки зрения, простейшая. Большинство зрителей приветствует почти неограниченный выбор "видео-по-заказу" и готовы безоговорочно принять его. В нем есть потенциал, который для информационной магистрали должен стать тем, что на компьютерном жаргоне называют killer application (убойное или эффектное приложение) - таким привлекательным для клиентов использованием технологии, что одно это создает ей широкий рынок сбыта и она чуть ли не превращается во что-то, без чего жить нельзя, - пусть даже ее создатель об этом и не догадывался.

Простейший пример: Skin-So-Soft - один из многих косметических лосьонов, на который мало кто обращал внимание, пока вдруг не выяснилось, что он обладает свойствами репеллентов. Может быть, и сейчас кто-то пользуется им по прямому назначению (для смягчения кожи), но расходится он в основном благодаря второму, более эффектному своему действию (отпугиванию насекомых).

Хотя оборот "убойное приложение" появился недавно, сама идея не нова. Томас Эдисон был не только великим изобретателем, но и великим бизнесменом. Основав в 1878 году свою Edison General Electric Company, он отлично понимал: чтобы продавать электричество, сначала надо продемонстрировать его ценность покупателям - доказать, что с его помощью простым щелчком выключателя можно залить дом светом в любое время суток. Эдисон разжег воображение публики, пообещав, что электрический свет станет таким дешевым, что только богатые смогут покупать свечи. Он попал в точку: люди с готовностью платили за электроэнергию, желая насладиться эффектным применением электричества - освещением домов.

Электричество пришло в дома как способ освещения, но весьма скоро ему нашли и другое применение. Создали первые электроплиты и электрические машины для уборки квартир (потом их назвали пылесосами). Вскоре появились электрокамины, тостеры, холодильники, стиральные машины, электроутюги, фены, прочие бытовые приборы, и вот - без электричества уже не обойтись.

Эффектное использование технического новшества превращает забавную абстракцию в товары первой необходимости и позволяет таким образом заработать деньги. Без "убойного" приложения изобретение может пропасть - мы все свидетели тому, какой неудачей закончилась попытка внедрить стереоскопическое кино и квадрофонический звук.

В третьей главе я упомянул, что в семидесятые годы необходимость обрабатывать тексты привела к появлению в офисах микропроцессоров. Поначалу использовали специальные машины, предназначенные исключительно для создания документов. Рынок таких машин рос чрезвычайно быстро; на нем действовало более пятидесяти фирм с суммарным объемом ежегодных продаж более чем на миллиард долларов.

Спустя несколько лет появились персональные компьютеры. Их способность выполнять разные приложения была качественно новой. Вот оно "убойное" приложение персонального компьютера ! Пользователь ПК мог закрыть WordStar (в свое время одна из самых популярных программ текстовых процессоров) и запустить другую программу, скажем электронную таблицу VisiCalc или систему управления базами данных (СУБД) dBase. Комплекс таких "убойных" приложений, как WordStar, VisiCalc и dBase, был настолько заманчив для пользователя, что сам по себе служил веским стимулом к покупке персонального компьютера.

Первым "убойным" приложением для оригинального IBM PC была электронная таблица Lotus 1-2-3, подогнанная под вычислительные мощности той машины. Для Apple Macintosh такими приложениями стали Aldus PageMaker (программа верстки), Microsoft Word (текстовый процессор) и Microsoft Excel (электронная таблица). В те годы треть Макинтошей использовали в бизнесе, и многие покупали его для настольного издательства (сам этот термин появился несколько позже).

Информационная магистраль станет реальностью благодаря слиянию технологических достижений в двух областях: связи и компьютеров. Ни одно достижение в одиночку не сумеет продемонстрировать свое "убойное" приложение - эффектное применение. Но все вместе - смогут. Магистраль окажется совершенно необходимой, потому что предложит огромный комплекс услуг - информационные, образовательные услуги, развлечения, покупки на дому, все виды связи. Но сейчас еще нельзя предсказать, когда станут доступны все нужные компоненты. Наибольшая проблема - создание простой в использовании "информационной" аппаратуры. В ближайшие годы очевиден количественный рост цифровых устройств, которые будут воплощаться в разных формах и работать с разными скоростями. Детальнее мы обсудим их позже. Пока же достаточно знать, что некие ПК-подобные устройства, объединенные информационной магистралью, не дадут нам потерять связь ни друг с другом, ни с ценной для нас информацией. В число этих устройств войдут и такие, которые заменят существующую сейчас аналоговую аппаратуру вроде телевизоров или телефонов. А сохранятся только те из них, что окажутся незаменимыми. И хотя мы не знаем, какие формы станут популярны, очевидно, что по своей природе это будут универсальные программируемые компьютеры, объединенные информационной магистралью.

Многие дома уже сегодня подключены к двум специализированным коммуникационным инфраструктурам: телефонным линиям и телевизионным кабелям. И когда эти системы преобразуют в единую цифровую сеть, мы станем свидетелями рождения информационной магистрали.

Телевизор не будет выглядеть как компьютер (клавиатура у него не появится), но дополнительная электроника придаст его внутренней архитектуре заметное сходство с ПК. Телевизор соединят с информационной магистралью через дополнительный блок - приставку, очень похожую на ту, что выдают сегодня своим абонентам многие кабельные телекомпании; только в ней будет не дешифратор, а мощный универсальный компьютер. Саму приставку можно расположить внутри телевизора или рядом с ним, установить где-нибудь в подвале или даже вне дома. Персональный компьютер и эта приставка свяжут Вас с информационной магистралью, и, ведя "диалог" с коммутаторами и серверами сетей, они будут отыскивать нужную информацию и пересылать ее по Вашему запросу.

Но как бы эта приставка ни сближала телевизор и ПК, между ними сохранится существенная разница - хотя бы в том, с какого расстояния Вы смотрите на их экраны. Сегодня не менее чем у трети американцев есть персональные компьютеры (не считая игровых приставок). В конечном счете почти в каждом доме будет минимум один компьютер, подключенный непосредственно к информационной магистрали. Эту аппаратуру Вы будете использовать в тех случаях, когда важны мельчайшие детали изображения или когда нужно что-то напечатать. Расположенный в полуметре от Ваших глаз высококачественный монитор позволяет легко различать мелкие буквы набираемого текста и другие крохотные фрагменты изображения. А телевизор с большим экраном, стоящий в противоположном углу комнаты, для подобных целей совсем непригоден, зато идеален для демонстрации кадров, мелкие детали на которых не столь значимы.

Коммуникационные приставки и другое оборудование будут рассчитаны на то, чтобы связать с информационной магистралью даже устаревшие телевизоры и большинство нынешних персональных компьютеров, но, несомненно, появятся и новые телевизоры, и новые ПК, способные давать более качественную картинку. Изображение на экранах современных телевизоров сильно уступает киноэкранному и журнальным иллюстрациям. Хотя телевизионные сигналы в США обеспечивают 486 строк в кадре, на многих телевизорах не все строки различимы, а бытовые видеомагнитофоны записывают и воспроизводят с разрешением всего лишь около 280 строк. В результате на экране телевизора трудно прочесть даже заключительные титры фильма. К тому же обычные телевизионные экраны отличаются по формату от большинства киноэкранов. Так называемый аспект (aspect ratio) (соотношение ширины и высоты картинки) телеэкрана составляет 4:3, т.е. ширина изображения на треть больше высоты. А художественные фильмы обычно снимаются в формате 2:1 - ширина изображения в два раза превосходит его высоту.

Существующие системы телевидения высокой четкости (high-definition TV, HDTV) обеспечивают разрешение свыше 1000 строк, аспект 16:9 и более качественную цветопередачу; смотреть их - одно удовольствие. Но несмотря на явные усилия правительственных и деловых кругов Японии (именно в этой стране разработаны все системы HDTV), телевидение высокой четкости пока не привилось, потому что требует новой дорогостоящей аппаратуры и для вещания, и для приема. Рекламодатели не жаждут участвовать в финансировании телевидения высокой четкости, поскольку на эффективности рекламы оно практически не сказывается. Однако шансы выжить у этого типа телевидения все же есть, так как информационная магистраль позволит принимать видеоизображение с несколькими разрешениями и аспектами. Понятие регулируемого разрешения хорошо знакомо пользователям персональных компьютеров, которые могут выбирать подходящее разрешение: от обычного, с 480 горизонтальными строками (режим VGA) до повышенного, с 600, 768, 1024 или 1200 строками - в зависимости от параметров мониторов и видеоадаптеров.

Прогресс и телевизоров, и дисплеев персональных компьютеров, несомненно, продолжится: они станут компактнее и качественнее. У большей их части будут плоские экраны. Появится и новый вид экрана: цифровая панель с белым покрытием - большой, встроенный в стену экран, толщиной, по-видимому, в пару сантиметров, - которая заменит современные кинескопы. Эта панель позволит не только просматривать картинки, фильмы и другие видеоматериалы, но и без труда разбирать тексты или какие-то мелкие детали изображения. На них можно будет что-то рисовать или записать текст. Управляющий этой панелью компьютер, распознав рукописный текст, преобразует его в печатный. Поначалу такие устройства появятся в конференц-залах, потом в офисах и даже в частных домах.

Нынешние телефоны подключат к тем же сетям, что соединяют персональные компьютеры и телевизоры. На телефонах появятся небольшие плоские экраны и крошечные видеокамеры. В остальном они более или менее сохранят свой сегодняшний облик, и на кухнях мы по-прежнему будем вешать настенные телефоны, поскольку они экономят место. Зато разговаривая по телефону, Вы увидите своего собеседника или то изображение, которое он (или она) захочет Вам показать. В техническом плане у телефона, висящего над мойкой, будет много общего с коммуникационной телеприставкой, расположенной в гостиной, или с персональным компьютером из рабочего кабинета, но внешне он вряд ли сильно изменится. Кардинально сменится лишь его начинка - как, впрочем, и у всей информационной аппаратуры.

В мобильном обществе возникает потребность эффективно работать даже в дороге. Лет 200 назад путешественники часто брали с собой переносной "письменный стол" - складную доску с прикрепленным к ней ящичком из красного дерева для перьев и чернил. В сложенном виде она была довольно компактна, в раскрытом мало чем отличалась от доски небольшого письменного стола. Между прочим, именно на такой доске в Филадельфии, вдали от своего виргинского дома, Томас Джефферсон и написал Декларацию независимости.

В наше время потребность в переносных "письменных принадлежностях" привела к созданию лэптопов - портативных персональных компьютеров, умещающихся на ладонях. Многие, кто работает и в офисе, и дома (в том числе и я), выбирают основным компьютером лэптоп или даже более компактный ноутбук. Эти миниатюрные компьютеры можно подключать к большому монитору и к корпоративной сети в офисе. Ноутбуки постепенно будут "худеть", пока действительно не сравняются по толщине с блокнотом. Сегодня ноутбуки - самые компактные полноценные компьютеры, но вскоре появятся карманные компьютеры с цветными экранами - размером с обычный фотоснимок. Пройдет совсем немного времени, и, когда Вы достанете его из кармана, уже никто не воскликнет: "Ух ты ! Какой у Вас компьютер !"

Что Вы сейчас обычно носите с собой ? Ну, наверное, как минимум ключи, какие-то документы, деньги и часы. Весьма вероятно, что время от времени Вы берете с собой кредитную карточку, чековую книжку, туристские чеки, записную книжку, календарик, блокнот, что-то почитать, фотоаппарат, карманный диктофон, сотовый телефон, пейджер, билеты на концерт, карту, компас, калькулятор, электронную записную книжку, фотографии и, возможно, даже свисток, чтобы звать на помощь.

Все это (и гораздо большее) Вы сможете объединить в другом "информационном" устройстве, которое мы называем компьютером-бумажником. Он будет примерно того же размера, что и обычное кожаное портмоне, а значит, его можно носить в кармане или сумочке. Он позволит принимать и передавать сообщения, вести расписание, читать и отправлять электронную почту и факсы, узнавать погоду и биржевые сводки, играть в простые и сложные игры. Сидя на совещании, Вы будете вводить в него пометки, намечать деловые встречи, а если Вам до чертиков надоест слушать докладчиков, то можно отвлечься на выпуск новостей или насладиться любыми из тысяч фотографий своих детей.

В новом бумажнике вместо наличности у Вас будут "цифровые" деньги, не поддающиеся подделке. Сегодня, когда Вы кому-то протягиваете купюру, чек, сертификат или другой платежный документ, передача этой бумажки символизирует передачу денежных средств. Но деньги не обязательно должны быть купюрами. Суммы, зафиксированные на кредитных карточках, - эквивалент финансовой информации в цифровой форме. Завтра компьютер-бумажник позволит тратить и получать деньги в цифровом виде. Он подключится к компьютеру, расположенному в магазине, и перечислит нужную сумму, не требуя физического обмена товара на "живые" деньги в кассу. Цифровые расчеты будут использоваться и в сделках между отдельными лицами. Если Вашему сыну понадобятся деньги, Вы "перекинете" пятерку на его компьютер-бумажник со своего.

Когда такие компьютеры получат всеобщее признание, мы избавимся наконец от очередей в аэропортах, театрах и прочих общественных местах, где приходится показывать свои документы или билеты. Скажем, когда Вы будете проходить в зал вылета, Ваш компьютер-бумажник свяжется с компьютерами аэропорта и подтвердит, что за билет уплачено. Отпадет необходимость в ключах или магнитных карточках - компьютер-бумажник пошлет нужный сигнал компьютеру, управляющему замком.

С исчезновением наличности и кредитных карточек мошенники могут переключиться на компьютеры-бумажники, так что придется принять определенные меры, чтобы ими нельзя было воспользоваться так же, как украденной кредитной карточкой. Компьютер-бумажник будет хранить набор "ключей", идентифицирующих своего владельца. При необходимости Вы сможете легко прекратить их действие или заменить новыми. В случае особо важных сделок одного только "ключа" в Вашем компьютере-бумажнике явно недостаточно. Простейшее решение проблемы - требовать ввода пароля в момент совершения сделки. Другой вариант, который, кстати, избавит от обязанности все время помнить пароль, - использовать биометрические параметры. Индивидуальные биометрические параметры гораздо надежнее, и, я уверен, такая защита наверняка появится на некоторых моделях компьютеров-бумажников.

Система биометрической защиты запоминает такие физиологические особенности человека, как отпечаток пальца или спектр голоса. Например, перед совершением сделки с серьезными финансовыми последствиями Ваш компьютер может потребовать от Вас громко прочесть случайное слово, выведенное им на экран, или прижать большой палец к специальному устройству. Потом он сравнит то, что "услышал" или "почувствовал", с цифровой записью отпечатка пальца или голоса.

Компьютер-бумажник с соответствующей начинкой в любой точке Земли сообщит Вам Ваши точные координаты. Спутники системы глобального определения координат (Global Positioning System, GPS), вращающиеся вокруг Земли, передают сигналы, которые позволяют авиалайнерам, океаническим кораблям и крылатым ракетам с приемниками этих сигналов фиксировать свои координаты с точностью до ста метров. Подобные устройства - кстати, весьма компактные - сегодня доступны всего за несколько сот долларов и будут встроены во многие карманные компьютеры.

Компьютер-бумажник соединит Вас с информационной магистралью, когда Вы будете двигаться по обыкновенному шоссе, и подскажет, где Вы находитесь. Встроенный в него динамик поможет Вам выбрать оптимальную дорогу, даст знать, что бесплатный участок трассы заканчивается или что на следующем перекрестке часто бывают аварии. Отслеживая цифровые отчеты по транспортному потоку, он предупредит, что сегодня в аэропорт надо выехать пораньше или предложит альтернативный маршрут. На цветные карты, формируемые карманным компьютером, можно будет накладывать любую информацию: названия дорог, погодные условия, расположение кемпингов, живописных мест, даже пунктов быстрого питания. Если, допустим, Вы спросите: "Где находится ближайший китайский ресторанчик, который еще открыт ?" - запрошенные сведения будут переданы Вашему компьютеру по беспроволочной сети. Вдали от дорог, где-нибудь в лесу этот компьютер послужит компасом, да и вообще будет полезен ничуть не меньше, чем швейцарский армейский нож.

В сущности, карманный компьютер и видится мне новым швейцарским армейским ножом. В детстве у меня был один из таких ножей - не совсем простой, с двумя складными лезвиями, но без целого магазина всяких приспособлений. У него была классическая блестящая красная ручка с белым крестом, набор лезвий и несколько инструментов, в том числе отвертка, маленькие ножницы и даже штопор (хотя в то время я им еще не пользовался).

Некоторые карманные компьютеры, простые и элегантные, предоставят лишь самый минимум возможностей: маленький экран, микрофон, защитное устройство для денежных операций и какие-то базовые звуковые средства. Другие модели, напротив, будут изобиловать всяческими "наворотами" вроде телекамер, сканеров (способных считывать печатный или рукописный текст) и устройств для приема сигналов в системе глобального определения координат. У большинства карманных компьютеров появится "кнопка SOS" - специально для тех случаев, когда Вам понадобится экстренная помощь. В каких-то моделях не исключены встроенные термометры, барометры, высотомеры и измерители пульса.

Соответственно будут колебаться и цены, но в среднем карманный компьютер вряд ли обойдется дороже современной видеокамеры. Если простая смарт-карта ("интеллектуальная" кредитная карточка), предназначенная исключительно для операций с "цифровыми" деньгами, стоит сейчас столько же, сколько рядовая видеокамера, то цена действительно совершенного карманного компьютера может быть близка к стоимости престижной видеокамеры, т.е. от 1000 долларов и выше. А ведь его возможности будут куда шире, чем у самого экзотического компьютера прошлого десятилетия. Смарт-карты со встроенными микропроцессорами (базовая форма карманных компьютеров) внешне похожи на обычные кредитные карточки и очень популярны сейчас в Европе. Смарт-карты будущего смогут идентифицировать своего владельца и хранить электронные деньги, билеты и медицинскую информацию. У них не будет экрана, звуковых средств и прочих атрибутов дорогих карманных компьютеров. Но они пригодятся для туристов и как запасное устройство для денежных операций; а кому-то их хватит на все случаи жизни.

Если у Вас нет с собой компьютера-бумажника, Вы все равно получите доступ к информационной магистрали через киоски - одни платные, другие бесплатные, - которые будут установлены в офисных зданиях, торговых пассажах и аэропортах, как сейчас на каждом шагу встречаешь фонтанчики с питьевой водой, комнаты отдыха и таксофоны. Такие киоски заменят не только таксофоны и банкоматы, ведь, перекрывая по своим возможностям эти аппараты, они предоставят и другие услуги информационной магистрали: от пересылки и приема сообщений до сканирования карт и покупки билетов. Они станут неотъемлемой частью нашей повседневной жизни, их найдешь повсюду. Некоторые киоски украсит реклама, похожая на ту, что сейчас можно увидеть в аэропортах, у телефонных будок системы бронирования номеров в отелях и аренды автомашин: бегущая строка проинформирует Вас обо всех специфических услугах. Как и банкоматы в аэропортах, эти киоски, внешне напоминающие обычные автоматы, тоже будут компьютерами.

Независимо от форм, которые примут персональные компьютеры, пользователи по-прежнему смогут работать с большим числом приложений. Вспомните, как сейчас Вы выбираете телевизионные каналы, пользуясь пультом дистанционного управления. Будущие системы, предоставляя больший выбор, сделают это лучше. Вам не придется по очереди нажимать на все кнопки. Не нужно будет мучительно вспоминать номер канала, чтобы найти интересную передачу. Вместо этого на экране появится графическое меню, и Вы выберете программу, указав на легко узнаваемую картинку.

И необязательно указывать. Со временем мы сможем голосом управлять нашими телевизорами, персональными компьютерами и другой информационной аппаратурой. Поначалу придется ограничиться весьма узким словарем, но в конце концов с ними можно будет чуть ли не разговаривать. Это потребует мощного оборудования и программного обеспечения, потому что речь, которую человек воспринимает без малейших усилий, компьютеру интерпретировать очень трудно. Уже сейчас программы распознавания речи прекрасно работают с небольшим набором предопределенных команд вроде "Позвони моей сестре". А вот расшифровать произвольную фразу компьютеру гораздо сложнее, хотя и это станет возможным в ближайшие 10 лет.

Кому-то покажется удобным от руки писать команды компьютеру, а не проговаривать их в микрофон или вводить с клавиатуры. Многие компании, в том числе и Microsoft, успели по несколько лет поработать над так называемыми "перьевыми компьютерами" (pen-based computers), способными считывать рукописный текст. Надо признаться, я был излишне оптимистичен в отношении сроков разработки программ, позволяющих распознавать рукописный текст, особенно написанный разными почерками. Трудности возникали на каждом шагу. Когда мы сами испытывали систему, она работала отлично, но посторонние пользователи все время сталкивались с проблемами. В результате мы обнаружили, что неосознанно пишем четче и аккуратнее, чем всегда. Получалось, что мы подстраиваемся под машину, а не она - под нас. В другой раз, когда группа решила, что наконец удалось создать работающую программу, сотрудники с гордым видом принесли ее мне на демонстрацию. Все, кто работал над этим проектом, писали только правой рукой, и компьютер, запрограммированный на распознавание отдельных линий письменного текста, не смог интерпретировать мои упражнения в каллиграфии, потому что я левша. В общем, оказалось, что распознавание рукописного текста - задачка, ничуть не легче распознавания речи. Но я уверен, что с появлением более мощных компьютеров и эту задачу удастся решить.

Независимо от того, как Вы подаете команды: голосом, записывая их от руки или указывая в меню, выбор будет пошире элементарного переключения между программами, и, естественно, Вам захочется, чтобы это делалось просто. Вряд ли кому-то понравится слишком запутанное управление, которое заставляет попусту терять время. Программная платформа магистрали должна настолько упростить поиск информации, чтобы ее смог найти даже тот, кто сам не знает, чего ему надо. А информации будет целое море. Ведь магистраль обеспечит доступ ко всему: товарам, услугам, сокровищам сотен библиотек... перечислять можно еще долго.

Опасения, которые вызывает магистраль, чаще всего касаются "перегрузки информацией". Обычно их слышишь от тех, чье чересчур развитое воображение рисует такую картину: по волоконно-оптическим кабелям магистрали, как из рога изобилия, так и сыпятся на бедную голову громадные порции всевозможных сведений.

Перегрузка информацией - явление достаточно распространенное и не должно быть проблемой. Мы уже давно умеем справляться с огромными массивами сведений, опираясь на обширную инфраструктуру, помогающую отбирать только самое нужное, - от библиотечных каталогов и обзоров видеофильмов до "Желтых страниц" и советов знакомых. Если кто-то беспокоится по поводу перегрузки информацией, спросите его, как он подбирает себе книги. Ведь заходя в книжный магазин или библиотеку, никто не собирается читать все подряд. По каталогам, указателям и книжным обозрениям каждый отбирает нужное.

Сплав технологий и искусства аннотирования, заложенный в информационную магистраль, поможет находить материал самыми разными способами. Идеальная система навигации должна быть мощной и в то же время простой в использовании. Базовыми методами выборки требуемых сведений будут запросы (queries), фильтры (filters), пространственная навигация (spatial navigation), гиперсвязи (hyperlinks) и агенты (agents).

Суть различных методов выборки информации легче всего понять через образные сравнения. Представьте, что в некое хранилище помещен набор специфических сведений - перечень каких-то фактов, список фильмов или что-то еще. Запрос приводит к перебору всех элементов в хранилище и проверке каждого из них на соответствие заданному критерию. Фильтр действует иначе: он постоянно проверяет на соответствие заданному критерию новые поступления. Пространственная навигация: Вы бродите по хранилищу и заглядываете на полки только в определенных местах.

Но, по-видимому, самый целесообразный и, пожалуй, самый простой подход по сравнению с остальными - заручиться помощью частного агента, представляющего Вас на информационной магистрали. В действительности агент будет программой, в которую заложена некая личность; тем или иным способом Вы сможете общаться с этой личностью. Похоже на то, как будто вместо себя Вы отправляете на поиски своего помощника.

Вот как работают разные системы. Запрос, по сути, тот же вопрос, на который Вы получаете исчерпывающий ответ. Например, Вы не помните название фильма, но знаете, что в нем сыграли Спенсер Треси (Spencer Тrаcy) и Кэтрин Хепберн (Katharine Hepburn) и что там есть сцена, где он засыпает вопросами дрожащую от холода героиню. Итак, введите запрос на все киноленты, в которых есть "Спенсер Треси", "Кэтрин Хепберн", "холод" и "вопросы". В ответ сервер сообщит о романтической комедии 1957 года Desk Set (Кабинетный гарнитур), в которой Треси в самый разгар зимы на террасе, на крыше небоскреба, допытывается о чем-то у окоченевшей Хепберн. Вы сможете просмотреть эту сцену или весь фильм целиком, прочесть сценарий, изучить реакцию критиков и узнать комментарии, когда-либо прозвучавшие из уст Треси и Хепберн по поводу этой сцены. Если картина продублирована или снабжена субтитрами для зарубежного проката, Вы сможете познакомиться и с такими ее версиями. Хранимые, скорее всего, на серверах в разных странах, они в мгновение ока окажутся в Вашем распоряжении.

Система воспримет не только прямолинейные запросы типа "Покажи все опубликованные в мире статьи о первом младенце из пробирки", "Дай список всех магазинов, которые предлагают не менее двух сортов собачьего корма и которые могут доставить заказ не позднее чем через час" или "Кому из своих родственников я не звонил уже больше трех месяцев ?". Она справится и с более сложными запросами, например: "В каком крупном городе самая высокая доля тех, кто смотрит видеоклипы рок-музыкантов и регулярно интересуется международной торговлей ?" В общем случае подобные вопросы не потребуют длительного ожидания, поскольку многие из них с большой степенью вероятности уже были кем-то заданы и ответы на них подготовлены и хранятся в готовом виде.

Кроме того, Вы сможете также устанавливать "фильтры" - своего рода постоянно действующие запросы. Они будут круглосуточно отслеживать новую информацию, соответствующую Вашим интересам, и отфильтровывать все постороннее. Запрограммированный фильтр станет собирать только определенные сведения, скажем новости о местной спортивной команде или достижения в конкретной области наук. Если для Вас нет ничего важнее прогноза погоды, фильтр вынесет его на первую полосу Вашей "персональной газеты". Некоторые фильтры будут создаваться Вашим компьютером автоматически - просто потому, что ему "известны" Ваше образование, деловые связи, окружение и основной круг интересов. Мне, например, такой фильтр мог бы сообщить о чем-то важном, касающемся моего прошлого: "Метеорит вдребезги разнес Lakeside School". Разумеется, Вы вправе и сами создать фильтры, скажем, постоянно действующий запрос типа "Требуется: Nissan Maxima 1990 года на запчасти", "Сообщить о любом, кто продает сувениры с прошлого Кубка мира по футболу" или "Ищу напарника - велосипедного фаната для воскресных моционов и в дождь, и в жару". Фильтр будет "начеку" до тех пор, пока Вы не прекратите его действие. Однако и это еще не все. Найдя Вам, допустим, напарника для воскресной езды на велосипеде, фильтр автоматически проверит и другие сведения, которые тот мог обнародовать в сети. Фильтр попытается выяснить: "Что он собой представляет ?" - ведь это первое, что бы Вы сами спросили о своем новом друге.

Пространственная навигация будет базироваться на принципе, по которому мы находим информацию сегодня. Желая подыскать что-то на ту или иную тему, Вы идете в соответствующий отдел библиотеки или книжного магазина. Примерно то же самое практикуется и в газетах; в них есть разделы: спорт, недвижимость, бизнес, сообщения о погоде и т.д. Все эти рубрики в большинстве газет изо дня в день появляются строго на своем месте.

Пространственная навигация, которая уже применяется в некоторых программных продуктах, позволяет быстро переходить туда, где находится информация на нужную тему; при этом Вы взаимодействуете с механизмом поиска через визуальную модель реального или придуманного (виртуального) мира. Такую модель можно представить как карту или как иллюстрированное трехмерное оглавление. Пространственная навигация сыграет особенно важную роль при управлении телевизором и крохотным персональным компьютером, у которых вряд ли будет обычная клавиатура.

Чтобы заняться банковскими операциями, Вы перейдете к схеме центральной улицы, а затем - мышью, через пульт дистанционного управления или даже пальцем - укажете здание своего банка. Если Вам любопытно, какие дела слушались в суде и какие судьи вели их, Вы укажете на здание суда. Или выберите автобусную станцию, чтобы выяснить расписание нужного автобуса. Намереваясь остановиться в каком-нибудь отеле, Вы сможете заранее узнать, какие номера свободны, изучить план этажа и если в этом отеле есть видеокамера, подключенная к магистрали, - заглянуть в холл и ресторан.

В любой момент Вы сможете вернуться к карте и "пойти" по улице дальше. Любой участок карты можно увеличивать и уменьшать, а здания рассматривать с разных ракурсов. Но вот, допустим, Вы собрались купить газонокосилку. Если на экране внутренний вид дома, Вы "выходите" через черный ход и отыскиваете гараж. Щелчок картинки гаража - и Вы внутри. Там Вы увидите всякие инструменты, в том числе газонокосилку. Новый щелчок кнопкой мыши - на этот раз газонокосилки, - и на экране появляется список категорий информации, так или иначе связанной с интересующей Вас газонокосилкой, включая рекламу, обзоры, документацию и адреса торговых салонов в киберпространстве. Располагая всеми мыслимыми сведениями, Вы сравниваете разные модели газонокосилок и выбираете наиболее подходящую. Заметьте: когда Вы щелкнете картинку гаража и как бы войдете в него, компьютер незаметно для Вас соберет информацию о расположенных "внутри" гаража объектах с сотен серверов магистрали, отстоящих друг от друга на тысячи километров.

Указывая на экране объект и получая о нем сведения, Вы пользуетесь одной из форм так называемой гиперсвязи. Гиперсвязи позволяют скачками перемещаться между отдельными участками информационного "пространства" подобно тому, как в фантастических романах космические корабли совершают переходы через гиперпространство.

Гиперсвязи информационной магистрали дадут возможность быстро находить ответы на любые возникающие вопросы. Например, в выпуске новостей рядом с британским премьер-министром Вы заметили кого-то незнакомого. С помощью пульта дистанционного управления Вы указываете на эту персону. На экране появляется биография этого человека и перечень репортажей, в которых он фигурировал в последнее время. Указав что-то в списке, Вы читаете или смотрите соответствующий репортаж, произвольно выбирая темы и тем самым собирая видео-, аудио- и текстовую информацию со всего мира. Теперь спутник британского премьера Вам знаком.

Пространственную навигацию можно использовать и для экскурсий. Если Вас заинтересует собрание живописи конкретного музея, Вы сможете "пройти" по галерее виртуальных залов, рассматривая выставленные в них полотна так, словно Вас действительно окружают музейные стены. Чтобы узнать подробности о какой-то картине или скульптуре, Вы воспользуетесь гиперсвязью и без всякой толчеи и спешки расспросите о чем угодно, не боясь показаться полным профаном. Тут Вы можете натолкнуться на весьма интересные экспонаты - как и в подлинных выставочных залах. Конечно, путешествие по виртуальной галерее не совсем то же, что экскурсия по настоящей художественной галерее, но очень близко к реальности. Ведь и балет, и баскетбольный матч - зрелища захватывающие, даже когда их смотришь по телевизору, а не в театре или на стадионе.

Если в тот же "музей" заглянут и другие посетители, при желании Вы сможете увидеться с ними и пообщаться. Так что в виртуальной реальности необязательно быть отшельником. Одни ее участки будут служить именно для встреч и разговоров, в других - Вы никогда никого не встретите. В каких-то участках Вы появитесь в своем истинном обличье, в каких-то - нет. А уж каким Вы предстанете перед другими пользователями, зависит только от Вас и от правил, принятых в конкретной точке киберпространства.

При использовании пространственной навигации можно бродить и по тем местам, которые в реальности не существуют, а созданы Вашим воображением. Вы сможете сами придумывать музеи и не раз возвращаться к ним. Вам будет позволено раздвигать стены, строить новые галереи, перевешивать картины. Захочется, и Вы соберете все натюрморты в одном месте, даже если один из них - фрагмент помпейской фрески, который висел в зале древнеримского искусства, а другой - кисти Пикассо из зала современной живописи. Вы исполните роль хранителя музея или коллекционера знаменитых полотен, собирая их по всему миру и развешивая в собственной "галерее". Допустим, у Вас сохранились приятные впечатления о картине, на которой лев охраняет спящего человека, но Вы не помните ни имени художника, ни где Вы ее видели. Информационная магистраль избавит Вас от долгих поисков этой картины. Вы опишете ее тему, сформулировав тем самым запрос. Компьютер или другая аппаратура просеет сокровищницы информации и выдаст Вам то, что отвечает запросу.

Вы сумеете устроить экскурсию даже своим друзьям - не важно, сидят они рядом с Вами или находятся на другом конце света. "Вот здесь, между Рафаэлем и Модильяни, - скажете Вы, - моя любимая акварель, которую я нарисовал в три года".

Последний и во многих отношениях самый полезный помощник - агент. Это фильтр, в который заложена некая личность и который как бы способен проявлять инициативу. Задача агента сводится к одному - помогать. Помогать в поиске информации при самых разных ситуациях.

Чтобы разобраться в действиях агента, сначала представим, насколько он улучшит нынешний интерфейс пользователя с персональным компьютером. Сейчас этот интерфейс графический, как в Apple Macintosh или Microsoft Windows, что дает возможность отображать на экране и данные, и какие-то зависимости, не описывая их словами. Кроме того, графические интерфейсы позволяют выбирать объекты (в том числе картинки) и перемещать их по экрану.

Но графический пользовательский интерфейс недостаточно прост для будущих систем. Мы столько всего размещаем на экране, что начинаем путаться в программах или функциях, применяемых от случая к случаю. Все эти возможности хороши для людей знающих, а к среднему пользователю машина должна быть дружелюбнее, иначе ему с ней очень неуютно. Эту ситуацию и призваны исправить агенты.

Как Вам помочь, агенты "догадываются" отчасти потому, что компьютер запоминает Ваши прошлые действия. Ради эффективной работы с Вами он сможет подстроиться именно под Вас. Связанная с магистралью информационная аппаратура, подчиняясь магии программ, будет "набираться опыта" от общения с Вами и сама предложит оптимальные способы решения тех или иных задач. Такие программные средства я называю "softer software" (приблизительно это можно перевести как "программы с элементами искусственного интеллекта").

Аппаратными средствами управляют программные, но, как только программа написана, она навсегда остается неизменной. А программа с элементами искусственного интеллекта по мере своей работы постепенно умнеет. Она учится примерно так же, как Ваш помощник, и тоже со временем становится все полезнее, узнавая Ваши привычки и вникая в Ваши задачи. Вы вряд ли попросите нового помощника в первый день его работы оформить документ так, как сами оформили письмо пару недель назад. И не скажете ему ни с того ни с сего: "Разошлите копии всем, кто должен быть в курсе". Но пройдут месяцы, может быть, годы, и он, досконально освоив свои обязанности и Ваш стиль работы, станет более ценным сотрудником, Вашей правой рукой.

Сегодняшний компьютер - как помощник в первый день работы. Его постоянно надо инструктировать, словно он впервые "пришел" к Вам. И сколько бы Вы с ним ни работали, он не станет подстраиваться под Вас - ни на йоту. Поэтому мы бьемся над разработкой программ нового поколения, с элементами искусственного интеллекта - ведь никто не обязан мириться с помощником или с программой, которые ничему не учатся.

Если бы уже сейчас существовал программный агент, способный учиться, я бы с удовольствием переложил на него часть своих обязанностей: контроль за сроками проектов, их изменениями, выделение среди них принципиально важных и несущественных. Чтобы делать такие выводы, нужно руководствоваться несколькими критериями: размер проекта, число связанных с ним проектов, причина задержки и ее срок. При этом агент должен как-то различать, когда двухнедельная задержка ни о чем не говорит, а когда действительно свидетельствует о настоящих осложнениях и требует срочного вмешательства. На достижение этой цели уйдет немало времени хотя бы потому, что - как и с любым помощником - не так-то просто найти верный баланс между инициативой и рутиной. Не хотелось бы перестараться. Если программный агент начнет лезть не в свое дело и оказывать непрошеные услуги, это будет раздражать пользователей, привыкших к недвусмысленному контролю над своими компьютерами.

Через агента Вы сможете "разговаривать" с программой, которая приобретет, таким образом, некоторую одушевленность. Вполне вероятно, что программа, помогая Вам в работе, будет имитировать поведение и характер какой-нибудь знаменитости или героя мультфильма. Так агент, играющий роль той или иной личности, образует "дружеский пользовательский интерфейс" (social user interface). Разработкой агентов с элементами дружеского пользовательского интерфейса занимается сейчас целый ряд компаний, в том числе и Microsoft. Агенты не заменят графического пользовательского интерфейса, скорее дополнят его, предлагая в помощь любой персонаж на выбор. Этот персонаж исчезнет, как только Вы дойдете до хорошо знакомых Вам компонентов программного продукта. Но едва Вы засомневаетесь или прибегнете к справочной системе, как агент тут же объявится и предложит свои услуги. Можете даже считать, что агент - Ваш сотрудник, внедренный в программный продукт. Он запомнит, в чем Вы преуспели, чем занимались раньше, и это поможет ему предвидеть проблемы и предлагать способы их решения. Заметив что-то необычное, он сразу же привлечет к этому Ваше внимание. Если Вы, несколько минут проработав над чем-то, вдруг от этого отказываетесь, он, по-видимому, поинтересуется: уверены ли Вы, что недавнюю работу следует выбросить ? Впрочем, такими качествами уже обладают некоторые программы. Но если Вы трудились над чем-то битых 2 часа, а потом велели удалить все, что сделали, программа с дружеским интерфейсом сочтет Вашу команду необычной (не исключая ошибки с Вашей стороны). В таком случае агент может спросить: "Ты работал над этим целых 2 часа. Ты твердо уверен, что хочешь удалить это ?"

Некоторые люди, слыша о программах с элементами искусственного интеллекта и дружеским интерфейсом, реагируют очень бурно - их просто в дрожь бросает от идеи очеловечить компьютер. Но я уверен, что даже они не прочь поработать с таким компьютером. Люди всегда, с древнейших времен, олицетворяли природу, наделяли ее человеческими качествами. Пример тому - мультфильмы. Тот же Lion King (Король-Лев) мало что общего имеет с реальностью, да и не претендует на это. Все понимают разницу между крошкой Симбой и настоящим детенышем льва. И тем не менее, когда ломается автомобиль или зависает компьютер, мы начинаем осыпать его проклятиями, взывать к его "совести" или горестно спрашиваем, что же он нас так подвел. Конечно, мы все прекрасно понимаем, однако продолжаем воспринимать неживые предметы так, будто они разумны и действуют по своей воле. Ученые в университетах и программистских фирмах стараются сейчас - с учетом нашей склонности к очеловечиванию вещей - сделать компьютерные интерфейсы эффективнее. Программы вроде Microsoft Bob уже продемонстрировали, что люди удивительно тепло принимают программных агентов с заложенными в них личностями. Обнаружено также, что реакция людей сильно зависит от того, какой голос у агента: мужской или женский.

Недавно мы работали над проектом, в котором пользователи, в частности, оценивали свой опыт общения с компьютером. Когда в конце сеанса компьютер просил пользователей оценить эффективность работы с ним, отклики почти всегда были положительными. Но когда работу с первым компьютером просил оценить второй компьютер, пользователи становились гораздо строже. Иначе говоря, нежелание пользователей критиковать первый компьютер "в лицо" означает, что им не хотелось задеть его "чувства" - пусть даже они отлично знали, что это всего лишь машина. Дружеские интерфейсы, конечно, не панацея, они подходят не везде и не всем, но думаю, что будущее именно за ними, - как раз потому, что они очеловечивают компьютер.

Какие виды навигации будут использоваться на магистрали, мы представляем отчетливо. А вот насчет среды, в которой пройдет навигация, ясности куда меньше. Сделаем однако несколько вполне обоснованных предположений. Большинство сфер применения информационной магистрали будет, несомненно, связано с чистыми развлечениями. Ничто не помешает Вам сыграть в бридж или в шахматы со своим другом, даже если он живет в другом городе. Спортивные турниры, транслируемые по телевидению, Вы сможете наблюдать в разных ракурсах. Вы сами будете выбирать момент игры для замедленного повтора и подберете комментатора на свой вкус. Крупнейший в мире магазин звукозаписей - информационная магистраль - в любое время суток предложит любую песню. А может быть, Вы напоете свою мелодию в микрофон и послушаете, как она звучит в исполнении оркестра или рок-группы. Или решите посмотреть фильм Gone With the Wind (Унесенные Beтром), заменив лицо и голос Вивьен Ли (Vivien Leigh) или Кларка Гейбла (Clark Gable) своими. Или захотите проверить, как Вы смотритесь в последних творениях парижских модельеров или в чем-то еще, что Вы мечтаете купить.

Обилие информации просто зачарует тех, кто любопытен. Вам интересно, как устроены механические часы ? "Загляните" внутрь и задайте любые вопросы. Когда-нибудь - с помощью программы, создающей виртуальную реальность, - Вы сможете совершить экскурсию по часовому механизму. Станете на час хирургом, оперирующем на сердце, или ударником на каком-нибудь рок-концерте. И все это благодаря тому, что информационная магистраль через компьютер принесет в Ваш дом виртуальную реальность. Какие-то функции информационной магистрали будут надмножеством существующих в нынешних программах, но качество графики и анимации значительно улучшится.

Другие сферы ее применения окажутся сугубо практическими. Например, когда Вы уедете в отпуск, программа-"экономка" отключит отопление, уведомит почту не приносить пока корреспонденцию на дом, будет периодически зажигать свет в разных комнатах, чтобы казалось, будто Вы дома, и сама оплачивать мелкие счета.

Ну а какие-то области должны быть абсолютно серьезны. Как-то раз в выходные мой отец сломал палец и стал искать ближайший травмпункт. Он оказался в детской больнице Сиэтла. Там отцу отказали в медицинской помощи, потому что он - ну никак ! - не выглядел ребенком. Будь в то время информационная магистраль, сколько бы нервов он сэкономил ! Соответствующая программа сразу бы подсказала, куда следует обратиться.

Если через несколько лет мой отец опять сломает палец, он сможет воспользоваться услугами информационной магистрали не только для того, чтобы найти подходящий госпиталь, но и чтобы оформить нужные бумаги прямо в пути. Госпитальный компьютер сообщит о переломе дежурному травматологу, а тот - опять же через информационную магистраль заранее возьмет с сервера историю болезни своего пациента. Если врач сделает рентгеновский снимок, его сохранят в цифровом виде на сервере, и любой специалист с соответствующими правами доступа сможет исследовать его в любой момент в любой точке мира. Описание рентгеновского снимка будет связано с историей болезни.

Вернувшись домой, пациент при желании сам посмотрит на этот снимок и послушает комментарии специалиста. Или соберет всех членов семьи и скажет: "Только взгляните, какой перелом ! Послушаем, что о нем сказал врач".

Многое из того, о чем здесь говорилось, уже реализуется в приложениях для персональных компьютеров. Интерактивная информация стремительно входит в нашу жизнь и скоро станет обыденностью. Однако, прежде чем это произойдет, придется сложить еще немало кусочков головоломки - компонентов информационной магистрали.


Глава 5 - Путь к информационной магистрали

Глава 5
Путь к информационной магистрали

Чтобы наслаждаться плодами информационной магистрали, о которых шла речь в предыдущей главе, прежде ее еще надо создать ! Возможно, кто-то сильно разочаруется - ведь столько всего было сказано о междугородных телефонных сетях и Internet, который зачастую и называют "информационной супермагистралью". Увы, истина в том, что полноценная магистраль вряд ли придет в наши дома раньше чем через десятилетие.

Персональные компьютеры, мультимедийное программное обеспечение на компакт-дисках, сети кабельного телевидения с высокой пропускной способностью, телефонные линии и Internet - все это важные компоненты, на которых будет строиться информационная магистраль. Каждый из них - символ будущего. Но на роль информационной магистрали не может претендовать ни один.

Создание магистрали - дело непростое. Оно потребует не только подготовки физической инфраструктуры (прокладки волоконно-оптических кабелей, установки высокоскоростных коммутаторов и серверов), но и разработки программных платформ. В третьей главе я рассказывал об эволюции аппаратных и программных платформ, которая привела к появлению персонального компьютера. А завтра в результате развития персональных компьютеров и Internet появится платформа, на которой будут построены и приложения для информационной магистрали - о них мы говорили в четвертой главе. В создании программных компонентов этой платформы уже наблюдается та же конкуренция, что и в компьютерной индустрии восьмидесятых.

Действующие на магистрали программы должны обладать качественным интерфейсом, высокой степенью защиты, средствами поддержки систем электронной почты и электронных досок сообщений, совместимостью с конкурирующими программными компонентами и другими возможностями.

Поставщики программных компонентов магистрали подготовят соответствующие инструментальные средства и стандарты пользовательских интерфейсов, которые помогут разработчикам в создании разнообразных приложений и систем управления базами данных - банками информации, доступной на магистрали. Чтобы приложения взаимодействовали с другими программами, платформе необходим стандарт на так называемые профили пользователей (user profiles); в этом случае информацию о предпочтениях людей, работающих за данным компьютером, можно передать из одного приложения в другое. "Обобществление" подобной информации позволит программам подстраиваться под запросы конкретных пользователей.

Ряд компаний (в том числе и Microsoft), уверенных в выгодности поставок программного обеспечения для магистрали, уже конкурируют в разработке отдельных ее компонентов - фундамента будущих приложений для информационной магистрали. Несомненно, что на рынке таких компонентов преуспеет не одна фирма, и поэтому они (компоненты) должны и обязательно будут бесконфликтно работать друг с другом.

Программная платформа магистрали должна также поддерживать множество разных типов компьютеров, включая серверы и всю информационную аппаратуру. Заказчиками большей части этого программного обеспечения явятся, конечно, не частные лица, а организации, управляющие кабельными системами, телефонные компании и другие поставщики доступа к сетям (сетевые провайдеры), но их успех всецело зависит от конечных потребителей. Сетевые провайдеры всегда тяготеют к той программной платформе, которая предлагает потребителям наилучшие по своим характеристикам приложения и самый широкий доступ к информации. Поэтому на первом этапе компании, занятые созданием компонентов программной платформы, будут биться за сердца и умы разработчиков приложений и провайдеров - ведь именно они определят ценность той или иной платформы.

Появление приложений продемонстрирует потенциальным инвесторам значимость информационной магистрали; этот этап весьма критичен, учитывая, каких средств потребует строительство магистрали. По нынешним оценкам, подключение к магистрали только одного информационного устройства (телевизора или ПК) в США обойдется примерно в 1200 долларов (плюс-минус пару сотен в зависимости от конкретного устройства и его архитектуры). Сюда входит стоимость прокладки волоконно-оптических кабелей к каждому дому, установки серверов, коммутаторов и соответствующей электроники. По грубой прикидке, в США около 100 миллионов домов, а значит, суммарные инвестиции только в этой стране выльются в кругленькую сумму порядка 120 миллиардов долларов.

Никто не станет тратить такие деньги, пока ему не докажут, что технология действительно работает и что потребители готовы оплачивать новые приложения. Абонентная плата за услуги телевидения, включая "видео-по-заказу", не окупит гигантских расходов на строительство магистрали. А инвесторы согласятся его финансировать только при абсолютной уверенности в конечной прибыли, и не меньше той, какую сегодня приносит кабельное телевидение. Если финансовая отдача от магистрали не будет очевидна, на ее строительство никто не даст и гроша ломаного. Здесь все подчиняется своим законам. Думаю, что у инвесторов появится уверенность в отдаче, когда новаторы реализуют свои идеи во что-то вещественное. Как только инвесторы оценят перспективы новых приложений и услуг и убедятся в потенциальной окупаемости инфраструктуры магистрали, особых проблем с привлечением капиталов уже не будет. Эти вложения не превысят затрат на другие инфраструктуры, которые теперь мы воспринимаем как само собой разумеющееся: дороги, водопроводы, канализацию, электросети.

Я - оптимист. Бурное развитие Internet за последние годы лишний раз убеждает в том, что приложения магистрали быстро завоюют популярность и оправдают крупные капиталовложения. Под Internet подразумевается группа компьютеров, соединенных друг с другом по стандартным протоколам (спецификациям) обмена информацией. Он еще очень далек от информационной магистрали, но лучшего на сегодняшний день нет, и в конечном счете он войдет в ее инфраструктуру.

Успех Internet - самое важное достижение в мире вычислительной техники с тех пор, как в 1981 году появился первый IBM PC. Аналогия с этим персональным компьютером уместна по многим причинам. Компьютер типа IBM PC никогда не был верхом совершенства. Многое в его архитектуре или взято с потолка, или просто неудачно. Но, несмотря ни на что, его популярность достигла таких высот, что превратило его в стандарт. И кто бы ни пытался бороться против этого стандарта (зачастую вполне обоснованно), все попытки неизменно заканчивались провалом, потому что остальные фирмы продолжали работать над совершенствованием PC.

Сегодняшний Internet - это хаотичный набор взаимосвязанных коммерческих и некоммерческих компьютерных сетей, включая оперативные информационные службы, услуги которых доступны по подписке. Серверы разбросаны по всему миру и подключены к Internet множеством линий, как скоростных, так и не очень. Большинство пользователей подсоединяется к этой системе с помощью персонального компьютера через телефонную сеть, а ее пропускная способность весьма низка, что не позволяет передавать данные с приемлемой скоростью. Связь персонального компьютера с телефонной линией обеспечивает специальное устройство - модем (модулятор/демодулятор). Преобразуя нули и единицы в разные тона, модемы позволяют компьютерам "общаться" по телефонным линиям. На заре эпохи IBM PC типичный модем работал со скоростью 300 или 1200 бит/с (или "бод", как называют эту единицу в области средств связи). Большая часть данных, передававшихся по телефонным линиям с этой скоростью, представляла собой текст, поскольку пересылка изображений превратилась бы в мучительно долгий процесс. Но вскоре появились более быстрые модемы. Сегодня они могут передавать и принимать данные со скоростью 14400 или 28800 бит/с. Однако для обмена многими видами материалов и этого еще недостаточно. Пересылка страницы текста занимает буквально секунду, цветной полноэкранной фотографии с приличным разрешением, даже в сжатом виде, - уже минуты. А про передачу видеофильмов вообще говорить не приходится - при нынешних скоростях модемов это занятие просто бессмысленно.

Уже сейчас каждый человек может передать по Internet свое сообщение - деловое или так, ради забавы. Больные, прикованные к постели, получили возможность общаться с друзьями, которых иначе они никогда бы и не узнали. Люди стеснительные, ощущающие неловкость при разговоре, в сети раскрепощаются. Правда, информационная магистраль, которая позволит передавать и видеоизображение, с подобной раскованностью (социальной, расовой, половой), свойственной обмену текстовыми посланиями, увы, покончит.

Благодаря Internet и другим информационным службам, использующим телефонные сети, можно представить, как будет функционировать информационная магистраль.

Когда я отправляю Вам какое-то сообщение, оно передается по телефонной линии с моего компьютера сначала на сервер, где находится мой "почтовый ящик", и только потом - прямо или косвенно - пересылается на сервер с Вашим почтовым ящиком. Как только Вы соединитесь со своим сервером по телефонной линии или через корпоративную компьютерную сеть, Вы получите ("скачаете") содержимое почтового ящика, в том числе и мою информацию. Именно так работает электронная почта. Вы составляете послание и отправляете его одному адресату, или двадцати пяти, или всем сразу, пересылая на электронную доску сообщений (electronic bulletin board).

Ее назначение просто, как и обычной доски объявлений: каждый может оставить здесь свое послание для всеобщего прочтения. Кто-то отвечает на них, и завязывается публичная беседа, хотя и своеобразная, так как обмен мнениями протекает асинхронно.

Электронные доски сообщений обычно формируются по интересам отдельных групп, что намного облегчает адресацию конкретного послания. Коммерческие службы предлагают электронные доски сообщений для пилотов, журналистов, учителей и других, более узких категорий специалистов. В Internet, где никем не контролируемые и зачастую весьма нескромные электронные доски сообщений называются "usenet newsgroups", существует тысячи групп, всецело поглощенных какой-то одной, чрезвычайно ограниченной темой: кофеином, галстуками или Рональдом Рейганом. Вы можете скачивать сразу все сообщения по выбранной тематике, только последние из поступивших, вести от определенной персоны, отклики на какое-то другое послание, а также сообщения, в ключевой строке которых присутствует указанное Вами слово, и т.д.

Кроме электронной почты и обмена файлами, Internet поддерживает просмотр "всемирной паутины" - одного из самых популярных приложений этой сети. Под всемирной паутиной имеется в виду сеть World Wide Web, название которой сокращают до Web (паутина) или WWW; это группа серверов, подключенных к Internet и предлагающих страницы информации в графическом виде. Если Вы подсоединились к одному из таких серверов, на экране Вашего компьютера появляется страница с несколькими гиперсвязями. Активизируя гиперсвязь щелчком мыши, Вы переходите на другую страницу с дополнительной информацией и другими гиперсвязями. Эта страница может храниться на том же сервере или на любом другом в пределах Internet.

Основная страница, принадлежащая какой-либо компании или лицу, называется "домашней" страницей (home page). Создавая такую страницу, Вы регистрируете ее электронный адрес, по которому Вас могут найти пользователи Internet. В современной рекламе часто встречаются ссылки на домашнюю страницу; ее адрес входит теперь в реквизиты многих фирм. Программное обеспечение для настройки Web-сервера стоит очень дешево и подходит практически для любых компьютеров. Ну а программы для просмотра "паутины", тоже пригодные для всех машин, обычно предлагаются и вовсе бесплатно. В ближайшей перспективе средства просмотра Internet будут интегрированы в операционные системы.

Легкость, с которой фирмы и частные лица публикуют информацию в Internet, изменяет сам смысл этого глагола. Internet провозгласил себя местом, где публикуют "материалы" (content). У него достаточно пользователей, поэтому и возникает выигрыш от положительной обратной связи: чем больше он привлечет подписчиков, тем больше получит материалов, а чем больше он получит таких материалов, тем больше у него будет подписчиков.

Уникальные позиции Internet основываются на нескольких элементах. Во-первых, на протоколах TCP/IP, которые определяют его транспортный уровень, поддерживают распределенные вычисления и невероятно легко масштабируются. Во-вторых, на протоколах, которые устанавливают способы просмотра "паутины", - очень простых и в то же время позволяющих серверам вполне приемлемо справляться с чрезвычайно интенсивным сетевым трафиком (потоком данных в сетях). Кроме того, в WWW реализовано многое из того, что десятки лет назад предсказывали люди, подобные Теду Нельсону (Ted Nelson), в частности, интерактивные книги и гиперсвязи.

Сегодняшний Internet - это не информационная магистраль, в моем представлении, а лишь ее источник. Аналогией может послужить Oregon Trail ("орегонский путь"). В период между 1841 и началом 1860-х годов из Индепенденса (штат Миссури) более 300000 отчаянных душ отправились на своих повозках в опасное 2000-мильное путешествие. Они устремились на запад, через пустыни к орегонским территориям (Oregon Territories) и на золотые прииски Калифорнии. Свыше 20000 человек погибло от холеры, голода, жары и рук мародеров. Эту дорогу впоследствии окрестили орегонским путем. По размаху и значимости его вполне можно считать отправной точкой современной сети шоссейных дорог. Он пересекал многие границы, и повозки двигались по нему в обоих направлениях. Шоссе Interstate 84 и еще несколько автомобильных дорог сегодня повторяют большую часть маршрута орегонских переселенцев. Однако многие выводы, которые навевает эта аналогия, окажутся ошибочными, если их безоговорочно применить к современной системе дорог. Ведь холера и голод не проблема на шоссе Interstate 84, а пьяные водители и дорожное хулиганство вряд ли были так уж опасны для тех, кто трясся в повозках.

Путь, проложенный Internet, предопределит многие элементы будущей магистрали. Internet - прекрасная, жизненно важная разработка, один из компонентов конечной системы, но в ближайшие годы он существенно изменится. Современному Internet недостает безопасности и системы учета (billing system). И когда-нибудь многое из культуры Internet пользователям информационной магистрали покажется таким же диковинным, как нам сегодня - рассказы о переселенцах и орегонском пути.

Впрочем, и нынешний Internet совсем не тот, что был всего лишь год-два назад. Он эволюционирует с такой скоростью, при которой его описание годовой или даже полугодовой давности может серьезно устареть. У многих это вызывает смятение. Ведь очень трудно быть в курсе последних событий, когда ситуация развивается так динамично. Поэтому большинство компаний, в том числе Microsoft, сотрудничает в определении стандартов на расширение Internet, одновременно стремясь преодолеть свойственные ему ограничения.

Видимо, из-за того, что своим рождением Internet обязан компьютерной науке, он всегда, как магнит, притягивал к себе хакеров - талантливых программистов, которые по разным причинам (кто ради "спортивного интереса", кто в криминальных целях) взламывают чужие компьютерные системы.

Так, 2 ноября 1988 года тысячи компьютеров, объединенных в этой сети, вдруг резко замедлили скорость работы. Многие из них даже ненадолго остановились. Все данные, к счастью, сохранились, но, пока администраторы компьютерных систем пытались восстановить контроль над своими машинами, компьютерное время стоимостью в миллионы долларов было растрачено впустую. Именно в связи с этой историей широкая публика впервые и услышала об Internet. Как потом выяснилось, причиной всему была вредная компьютерная программа, названная "червяком". Она передавалась по сети с одного компьютера на другой и попутно "размножалась", копируя сама себя. ("Червяком", а не вирусом ее назвали потому, что она не инфицировала другие программы.) Она пользовалась незамеченной "щелкой" в системном программном обеспечении и получала прямой доступ к памяти атакуемых ею компьютеров. Там она пряталась и подсовывала неверные данные, что затрудняло ее выявление и уничтожение. Через несколько дней газета The New York Times выявила хакера, автора этой программы. Роберт Моррис-младший, двадцатитрехлетний студент последнего курса Корнелльского университета, написал этого "червяка", а потом выпустил его на свободу, чтобы посмотреть, до скольких компьютеров он сумеет добраться. Однако в программу вкралась ошибка, из-за чего "червяк" стал размножаться гораздо быстрее, чем предполагалось. К Моррису применили Computer Fraud and Abuse Act (Закон о компьютерном мошенничестве и намеренном нанесении вреда) от 1986 года и приговорили к трем годам условного заключения, штрафу в 10000 долларов и 400 часам общественных работ.

И позже в Internet случались разного рода аварии, бывали проблемы в защите, но не так, чтобы уж очень часто. В итоге Internet стал вполне надежным коммуникационным каналом для миллионов людей. Связывая расположенные по всему миру серверы, он обеспечивает обмен электронной почтой, сообщениями для электронных досок и другими данными. В потоке информации чего только нет: от коротеньких сообщений в десяток букв до огромных файлов с фотоснимками и программных пакетов. При этом стоимость услуг сервера, удаленного на тысячи километров, ничуть не выше оплаты услуг того, что находится в каком-нибудь километре от Вас.

Модель ценообразования в Internet уже изменила представление о том, что цена коммуникационных услуг напрямую зависит от времени и расстояния. То же самое произошло и с вычислительной техникой. Раньше, если Вы не могли позволить себе большой компьютер, приходилось арендовать его время с почасовой оплатой. А появление персональных компьютеров от этих хлопот избавило.

Поскольку Internet не требует сколько-нибудь ощутимых платежей, многие считают, что его финансирует правительство. Это не так. Однако, Internet возник в результате правительственного проекта шестидесятых годов - ARPANET; так называлась сеть, которую первоначально использовали исключительно в научно-технических целях. Она была жизненно важным каналом связи между рядом институтов и организаций, но посторонние о ней ничего не знали.

В 1989 году правительство США прекратило финансировать ARPANET и под другим названием - Internet (по имени применявшегося в этой сети коммуникационного протокола) передало его коммерческим организациям. Но даже когда Internet стал работать на коммерческой основе, первыми его клиентами были в основном ученые из университетов и компании, действующие в компьютерной индустрии; они использовали эту сеть для обмена электронной почтой.

Надо сказать, что финансовая модель, обеспечивающая Internet столь подозрительную дешевизну, в самом деле очень интересна. Сегодня, пользуясь телефоном, Вы знаете, что счет за разговор возрастет с увеличением его продолжительности и расстояния, на которое был сделан звонок. Однако предприятия, которым приходится часто связываться с каким-то определенным партнером, могут в значительной мере уйти от этих затрат, арендовав телефонную линию специально для звонков между двумя конкретными участками. Оплата арендованной линии не зависит от интенсивности ее использования - Вы просто вносите за нее ежемесячные взносы.

Основу Internet как раз и составляет "пучок" таких арендованных линий. Соединенные через коммутирующие системы, они управляют "течением" потока данных (так называемые маршрутизаторы). Междугородные связи Internet в Соединенных Штатах обеспечивают 5 компаний, каждая из которых арендует линии у соответствующих владельцев. После разделения компании AT&T ставки за аренду телефонных линий заметно снизились. Поскольку интенсивность трафика в Internet очень велика, а арендная ставка - величина постоянная, эти 5 компаний смогли установить на свои услуги минимальные расценки; иными словами, они обеспечивают колоссальную полосу пропускания при весьма незначительной стоимости.

О термине "полоса пропускания" стоит, пожалуй, сказать подробнее. Как я уже пояснял, он определяет скорость, с которой линия пропускает информацию между соединенными ею устройствами. Полоса пропускания зависит, в частности, от технологии приема и передачи данных. Телефонные сети, например, рассчитаны на двустороннюю связь с низкой полосой пропускания. Телефоны - это аналоговые устройства, "общающиеся" с аппаратурой телефонной компании посредством электрических импульсов, в которые преобразуются звуковые колебания. После оцифровки аналогового сигнала междугородная телефонная станция выдает цифровой сигнал, несущий примерно 64000 бит в секунду.

Коаксиальные кабели, обычно используемые кабельным телевидением, потенциально обладают более широкой полосой пропускания, чем стандартные телефонные провода, поскольку предназначены для передачи высокочастотных видеосигналов. Однако сегодня системы кабельного ТВ не передают биты; свои 30-75 видеоканалов они транслируют по аналоговой технологии. Коаксиальные кабели вполне способны пропускать сотни миллионов и даже миллиард бит в секунду, но для передачи цифровой информации их придется дополнить новыми коммутирующими устройствами. Волоконно-оптический кабель дальней связи, несущий 1,7 миллиарда бит в секунду от одного повторителя (что-то вроде усилителя) до другого, обеспечивает полосу пропускания, достаточную для ведения 25000 телефонных разговоров одновременно. Число таких разговоров можно существенно увеличить за счет сжатия, удаляя избыточную информацию - хотя бы паузы между словами и фразами.

Многие предприятия для подключения к Internet пользуются особым типом телефонной линии - Т-1; она несет 1,5 миллиона бит в секунду и, таким образом, обладает сравнительно высокой пропускной способностью. Подписчики ежемесячно платят местной телефонной компании за эксплуатацию линии Т-1 (по которой их данные передаются на ближайшую "точку входа" в Internet), а также оплачивают услуги компании, обеспечивающей подключение к Internet, по единой ставке - порядка 20000 долларов в год. Эти ежегодные взносы, размер которых вычисляется с учетом пропускной способности линии, полностью покрывают все расходы на Internet, и при этом не важно: постоянно работают подписчики с этой сетью или вообще ей не пользуются, передают данные на несколько километров или на другой край света. Из суммы этих платежей и финансируется вся сеть Internet.

Такой механизм срабатывает, поскольку себестоимость базируется на платежах за пропускную способность линии, а цены просто следуют за себестоимостью. Чтобы контролировать время и дальность связи, владельцам линий понадобилось бы немало усилий и средств. А зачем их тратить, если можно и без этого получить прибыль ? Кроме того, такая модель ценообразования способствует расширению использования Internet: оплатив доступ к Internet, клиент уже не должен доплачивать за интенсивность работы в нем.

Естественно, подавляющее большинство не может позволить себе арендовать линию Т-1. Тогда, чтобы подключиться к Internet, надо связаться с местным провайдером. Это та самая компания, которая ежегодно выплачивает 20000 долларов за соединение с Internet по линии Т-1 или по другому высокоскоростному каналу. Таким образом, частные лица звонят местному провайдеру по обычной телефонной линии, а тот соединяет их с Internet. В этом случае взимается ежемесячная плата, обычно в размере 20 долларов, за которую Вы имеете 20 часов в самое дорогое время.

В ближайшие годы в обеспечении доступа к Internet конкуренция будет только возрастать. К этому бизнесу присоединятся крупные телефонные компании всего мира. Как следствие, заметно упадут цены. Оперативные службы типа CompuServe и America Online включат в подписку и доступ к Internet - как стандартную услугу. В целом через несколько лет Internet значительно усовершенствуется, доступ к нему упростится и войдет в пользовательский интерфейс операционных систем. Навигация по Internet станет легче, и его объединят с другими коммерческими оперативными службами.

Но одна техническая проблема для Internet по-прежнему остается нерешенной: как обрабатывать материалы, передаваемые в режиме реального времени, особенно аудио (включая речь) и видео. Технология, на которой базируется Internet, не гарантирует передачу данных из одной точки в другую с постоянной скоростью. Темп пересылки пакетов зависит от "заторов" в сети. Ряд изощренных приемов, конечно, позволяет эпизодически передавать высококачественные звук и видеоизображения, но полноценная их поддержка требует коренного изменения сети, так что эти возможности вряд ли будут реализованы в ближайшие несколько лет.

Но как только технологический барьер останется позади, Internet вступит в прямую конкуренцию с "голосовыми" сетями телефонных компаний. А поскольку подход к ценообразованию у них прямо противоположный, будет весьма любопытно понаблюдать за их конкурентной борьбой.

В связи с тем, что Internet изменяет принципы оплаты коммуникационной связи, он может изменить и наше общее отношение к платежам за информацию. Кое-кто считает: Internet продемонстрировал, что информация будет бесплатной - по крайней мере, в большинстве случаев. Действительно, значительные объемы информации, от снимков NASA (National Aeronautics and Spасе Administration - Государственное управление по аэронавтике и исследованию космического пространства) до сообщений на электронные доски, передаются пользователями бесплатно, но думаю, что наиболее привлекательную информацию, голливудские кинофильмы или энциклопедические базы данных, по-прежнему будут создавать с расчетом на прибыль.

Особый вид информации - программное обеспечение. Сегодня в Internet масса бесплатных программ, и некоторые из них довольно полезны. Зачастую подобные программы появляются в результате дипломных работ студентов или выходят из институтов, финансируемых правительством. Однако мне кажется, что стремление пользователей к качеству, поддержке и многофункциональности такого важного инструмента, как программа, неизбежно приведет к развитию коммерческого программного обеспечения. Уже сейчас многие студенты и преподаватели университетов, авторы бесплатных программ, заняты составлением бизнес-планов для организуемых ими фирм; они готовы поставлять коммерческие версии своих программ с большими возможностями. Разработчикам - и тем, кто хочет заработать на своем продукте, и тем, кто отдает его бесплатно, - будет гораздо легче распространять программы, чем теперь.

Все это послужит на благо будущей информационной магистрали. Однако, прежде чем она станет реальностью, мы будем использовать ряд переходных технологий, которые вызовут к жизни новые приложения. И хотя они не обеспечат всех возможностей полноценной магистрали, все же это будет шаг вперед по сравнению с тем, что мы имеем сейчас. Затраты на такое эволюционное продвижение будут вполне сопоставимы с ценой современных приложений, которые уже доказали свою необходимость.

Некоторые из переходных технологий будут опираться на телефонные сети. К 1997 году большинство скоростных модемов сможет поддерживать одновременную передачу речи и данных по существующим телефонным линиям. Представим такую картину. Планируя свой летний отдых, Вы обращаетесь в туристическое агентство. Если и у Вас, и в агентстве есть персональные компьютеры, Вам покажут снимки отобранных отелей или небольшую табличку, по которой дома, сидя в кресле, Вы сравните цены в этих отелях. А если не только у Вас, но и у Вашего приятеля (искусного кулинара) есть персональный компьютер, позвоните ему и узнайте, сколько слоев в его пирожном - очень уж оно получается высоким. И пока на кухне готовится тесто, пусть он покажет Вам это пирожное в разрезе !

Технология, которая реализует эти "чудеса", носит аббревиатуру DSVD (Digital Simultaneous Voice Data) - одновременная передача цифровых данных и речи. Она яснее ясного - демонстрирует возможности совместного использования разных видов информации в сети. Думаю, что в ближайшие 3 года она распространится повсеместно и обойдется недорого, так как не потребует сколько-нибудь заметных изменений в существующей телефонной системе. Телефонным компаниям не придется модифицировать свои коммутаторы, следовательно, и абонентная плата за телефон останется прежней. Для DSVD достаточно установить на обоих концах линии соответствующие модемы и программы.

А вот другой промежуточный вариант использования телефонных сетей потребует внедрения специальных телефонных линий и коммутаторов. Эта технология называется ISDN (Integrated Services Digital Network - цифровая сеть комплексных услуг). Она позволяет передавать речь и данные, начиная с 64000 или 128000 бит/с, т.е. делает все, что делает DSVD, только в 5 - 10 раз быстрее. Она великолепно работает там, где достаточно средней пропускной способности. При ее использовании Вы получаете возможность быстрой передачи текста и неподвижных картинок. Видеоизображения тоже можно пересылать, но с посредственным качеством: для рядовых видеоконференций сойдет, но для фильмов не годится. А настоящей магистрали нужно высококачественное видео.

Сотни сотрудников Microsoft каждый день пользуются ISDN, подключая свои домашние компьютеры к нашей корпоративной сети. ISDN была разработана уже более десяти лет назад, но оставалась практически невостребованной, пока в ней не назрела необходимость. Но самое удивительное в том, что телефонные компании, вкладывая огромные средства в коммутаторы для управления ISDN, слабо представляли, как именно будет работать эта технология. Развитие персональных компьютеров привело к взрывному росту потребности в ISDN. И это замечательно. В 1995 году плата расширения для поддержки ISDN стоила 500 долларов, а в ближайшие несколько лет должна упасть примерно до 200 долларов. Тариф за эксплуатацию линий зависит от конкретной местности; в Соединенных Штатах он составляет в среднем около 50 долларов в месяц. Я думаю, что он снизится минимум до 20 долларов и не будет заметно превышать плату за обычную телефонную связь. Microsoft - одна из тех фирм, которые стремятся убедить телефонные компании повсеместно уменьшить эти тарифы и тем самым стимулировать владельцев персональных компьютеров на использование ISDN.

У кабельных компаний свои промежуточные технологии и стратегии. Для местных телефонных услуг они хотят задействовать существующие сети своих коаксиальных кабелей, что непременно приведет к конкуренции с телефонными компаниями. Ведь уже доказано: специальные кабельные модемы позволяют подключать персональные компьютеры к кабельным сетям. Таким образом, кабельные компании способны обеспечить несколько большую полосу пропускания, чем ISDN.

Другим промежуточным шагом для кабельных компаний станет 5- или даже 10-кратное увеличение числа передаваемых ими вещательных каналов. Втиснуть большее число каналов в существующие кабели они смогут за счет применения технологии цифрового сжатия.

Эта так называемая 500-канальная система (в реальности она вряд ли обеспечит более 150 каналов) создаст условия для появления системы, близкой к "видео-по-заказу", - правда, лишь для ограниченного круга телепередач и фильмов. В этом случае Вы выбирали бы не номер какого-то канала, а искали то, что Вас интересует, на экране, в списке вариантов. Популярный фильм или передачу запускали бы сразу по 20 каналам, смещая на каждом канале время его (ее) начала на 5 минут. Это позволило бы Вам подбирать для просмотра фильмов или телепередач наиболее удобное время (в пределах некоего интервала), а уж само переключение на нужный канал осуществлялось бы специальной телевизионной приставкой. Получасовые новости CNN Headline News могли бы выходить не по одному, а по шести каналам со сдвигом: в 18:00, 18:05, 18:10, 18:15, 18:20 и 18:25. Все 500 каналов были бы израсходованы очень быстро.

Кабельные компании вынуждены расширять число каналов еще и потому, что испытывают давление конкуренции. Спутники прямого вещания вроде DIRECTV, принадлежащие Hughes Electronics, уже напрямую транслируют в наши дома сотни каналов. Поэтому, чтобы не потерять клиентов, кабельным компаниям приходится шевелиться. И если бы смысл информационной магистрали сводился к одной только доставке узкого ассортимента видеопродукции, 500-канальная система всех бы вполне устроила.

500-канальная система, оставаясь - по сути своей - в основном синхронной, обеспечит весьма ограниченный выбор и в лучшем случае будет всего лишь обратным каналом связи с низкой пропускной способностью. Под обратным каналом связи (back channel) подразумевается путь, выделенный для передачи команд и других данных от информационных устройств потребителя в сеть. Подобный канал в 500-канальной системе может пригодиться для заказа какой-то продукции или программ, ответа на вопросы, участия в телевизионных викторинах и в некоторых видах игр - все через телевизионную приставку. Однако обратный канал связи с низкой полосой пропускания не обеспечит той гибкости и той степени интерактивности, которые потребуют наиболее интересные приложения информационной магистрали. Он не поможет переслать видеозаписи с Вашими детьми бабушке и дедушке и не даст поиграть в действительно интерактивные игры.

Кабельные и телефонные компании во всем мире развиваются по четырем параллельным направлениям. Во-первых, каждая из них будет стремиться играть на поле противника. Кабельные компании предложат телефонные услуги, а телефонные компании - видеоуслуги, в том числе передачу телевизионных сигналов. Во-вторых, обе системы будут совершенствовать способы подключения персональных компьютеров с помощью либо ISDN-, либо кабельных модемов. В-третьих, перейдут на цифровую технологию, с тем чтобы увеличить число телевизионных каналов и добиться высокого качества сигналов. В-четвертых, поставят целью подключение широкополосных систем к телевизорам и персональным компьютерам.

При этом любая из четырех стратегий побуждает делать капиталовложения в цифровые сети. Между телефонными компаниями и сетями кабельного телевидения развернется жесточайшая конкуренция за право стать основным сетевым провайдером (поставщиком сетевых услуг) в конкретном районе.

В итоге и Internet, и другие переходные технологии создадут основу для настоящей информационной магистрали. В ней объединятся лучшие качества телефонных и кабельных сетей. Как телефонная сеть, она позволит вести разговоры частным лицам, и каждый, пользующийся этой сетью, сможет поступать сообразно своим интересам. Кроме того, в этом качестве она будет обеспечивать полноценную двустороннюю связь, благодаря чему значительно расширятся ее "интерактивные" возможности. А как сеть кабельного телевидения, она будет обладать высокой пропускной способностью, так что в одном доме ее вполне хватит для одновременного подключения нескольких телевизоров и персональных компьютеров к разным источникам видеопрограмм или информации.

Большая часть проводной сети, соединяющей серверы между собой и с их клиентами, будет изготовлена из невероятно прозрачных волоконно-оптических кабелей - "асфальта" информационной магистрали. Все основные междугородные телефонные магистрали в пределах Соединенных Штатов сегодня построены на волоконно-оптических кабелях, но линии, связывающие наши дома с этими информационными артериями, по-прежнему изготавливаются из медных проводов. Телефонные компании заменят в своих сетях медные провода и участки с микроволновой и спутниковой связью волоконно-оптическими кабелями, что сделает полосу пропускания пригодной для передачи высококачественного видео.

Одновременно возрастет и доля волоконно-оптических кабелей в системе коммуникаций, принадлежащей компаниям кабельного телевидения. Параллельно этому телефонные и кабельные компании будут включать в состав своих сетей новые коммутаторы, которые позволят направлять потоки цифровых видеосигналов и другой цифровой информации в любую точку. Затраты на модернизацию существующих сетей (для их интеграции в информационную магистраль) составят менее четверти того, во что обошлась бы прокладка к каждому дому новых линий.

Волоконно-оптические линии можно представить как широкие водопроводные трубы, проложенные под улицами. Непосредственно к домам они не подводятся, для этого предназначены трубы диаметром поменьше, отходящие от магистрального трубопровода. Сначала волоконно-оптические кабели проложат, по-видимому, только до распределительных узлов, оттуда сигналы пойдут в дома либо по коаксиальному кабелю, несущему кабельное телевидение, либо по "витым парам" медных проводов, используемых для доступа к телефонным услугам. Однако в дальнейшем волоконно-оптические кабели будут подводить напрямую к отдельным домам, если Вам понадобятся огромные потоки данных.

В качестве коммутаторов выступят мощные компьютеры, которые будут переводить потоки данных с одного пути на другой, так же как сейчас перегоняют товарные вагоны на сортировочной станции. По крупным сетям потекут миллионы таких потоков, и - независимо от количества промежуточных узлов - все их биты необходимо доставить адресатам, без путаницы и опозданий. Чтобы представить, насколько грандиозные задачи будут решаться в эпоху информационной магистрали, приведу такую параллель. Вообразите миллиарды вагонов, которые нужно транспортировать по железнодорожным путям, переключая бесчисленные стрелки (коммутаторы), и при этом не выбиваться из графика: вагоны должны прибывать в пункты назначения точно по расписанию. Поскольку вагоны сцеплены в составы, работа сортировочной станции парализуется, когда через нее проходит длинный товарный поезд. Поэтому жестко сцеплять вагоны не выгодно, гораздо эффективнее отправлять их в путь поодиночке, так им легче маневрировать между стрелками, а в точке назначения можно вновь сформировать единый состав.

Так и всю информацию, переправляемую по магистрали, будут разбивать на крошечные пакеты, и каждый из них пойдет в сети по независимому маршруту - подобно автомобилям, которые едут в один и тот же пункт разными дорогами. Когда Вы закажете видеофильм, его тоже "разрежут" на миллионы мелких кусочков, и каждый из них отыщет до Вашего телевизора свой путь.

Такая маршрутизация пакетов будет осуществляться по коммуникационному протоколу ATM (Asynchronous Transfer Mode - протокол асинхронного режима передачи), который послужит одним из "кирпичиков" для основания информационной магистрали. Телефонные компании всего мира уже начинают переходить на ATM-технологию, потому что именно она позволяет максимально использовать преимущества высокой пропускной способности волоконно-оптических кабелей. В частности, одно из принципиальных достоинств ATM в том, что она гарантирует доставку информации строго в заданное время. ATM разбивает каждый цифровой поток на одинаковые пакеты по 48 байт транспортируемых данных и добавляет по 5 байт управляющей информации, которые помогают маршрутизаторам очень быстро коммутировать пакеты и направлять их в точки назначения по оптимальному маршруту. А в этих точках пакеты вновь реконструируются в поток.

ATM обеспечивает передачу информационных потоков с очень высокой скоростью - на первых порах вплоть до 155 миллионов бит в секунду; в дальнейшем скорость повысится до 622 миллионов бит в секунду и в конечном счете достигнет величин порядка 2 миллиардов бит в секунду. Эта технология, причем за очень низкую плату, позволит обмениваться видеоизображениями так же просто, как сейчас нас не затрудняет разговор по телефону. Подобно тому, как достижения в технологии производства чипов привели к резкому падению цен на вычислительную технику, так и ATM, помимо всего прочего позволяющая передавать еще и огромное количество старомодных телефонных разговоров, значительно собьет цены на междугородные звонки.

Широкополосные кабельные соединения свяжут с магистралью большинство информационных устройств, а некоторые из них будут действовать на принципах беспроводной связи. Мы уже пользуемся рядом беспроводных коммуникационных устройств: сотовыми телефонами, пейджерами и пультами дистанционного управления. Они посылают радиосигналы, предоставляя нам свободу передвижения, но их пропускная способность весьма ограниченна. Завтрашние беспроводные сети станут работать быстрее, но пока не произойдет крупный технологический рывок, проводные сети будут обладать значительно большей пропускной способностью. Впрочем, мобильные устройства предназначены для приема и передачи сообщений, поэтому осуществлять на них прием видеосигналов не только дорого, но и, по меньшей мере, просто странно.

Беспроводные сети, которые помогут нам поддерживать связь и в дороге, сформируются на базе современных систем сотовой связи и нового, альтернативного вида беспроводной телефонной службы, называемой PCS (Personal Communications Service - служба персональной связи). Когда в пути Вам понадобится какая-то информация с домашнего или офисного компьютера, через портативное информационное устройство Вы подключитесь к беспроводному участку магистрали, затем соответствующий коммутатор соединит его с нужным кабельным участком, а там - с компьютером или сервером в Вашем доме или офисе, и в результате Вы получите запрошенные сведения.

Кроме того, будут действовать и локальные, менее дорогие виды беспроводных сетей, доступные в рамках предприятий и в большинстве домов. Эти сети позволят Вам подсоединяться к магистрали или к Вашей компьютерной системе без дополнительной оплаты услуг (в границах определенной дальности). В локальных беспроводных сетях будет применяться технология, отличная от технологии глобальных беспроводных сетей. Однако портативные информационные устройства сами выберут наиболее дешевую сеть из числа доступных им в данный момент, и пользователь не заметит никаких технологических особенностей. А домашние беспроводные сети позволят заменить пульт дистанционного управления карманным компьютером.

Беспроводная связь вызывает очевидную озабоченность: будет ли она конфиденциальна и безопасна, поскольку радиосигналы можно легко перехватить. Но ведь и проводные сети не исключают такой возможности. Поэтому программное обеспечение магистрали будет шифровать передаваемую информацию, чтобы избежать чужих глаз и ушей.

Правительства всех крупных государств уже давно стремятся обеспечить полную конфиденциальность информации - как по экономическим, так и по военным соображениям. Необходимость в защите (или взломе) персональных, коммерческих, военных или дипломатических сообщений привлекает к этой проблеме уже несколько поколений самых крупных умов. Расшифровка кода всегда доставляет большое удовлетворение. Чарлз Беббидж, который в середине 1800-х годов добился грандиозных успехов в искусстве расшифровки, писал: "Расшифровка, на мой взгляд, одно из самых пленительных искусств, и боюсь, что я потратил на нее больше времени, чем она того заслуживает". Увлекательность этого занятия я почувствовал еще в детстве, когда мы, как и все дети, играли с простыми шифрами. Мы шифровали записки, заменяя одну букву алфавита другой. Если приятель присылал мне код, который начинался как "ULFW NZXX", то нетрудно было догадаться, что это означало "DEAR BILL" и что вместо D подставлена U, вместо E - L и т.д. Располагая семью буквами, остальной текст записки можно прочитать уже очень быстро.

Прошлые войны заканчивались для кого-то победами, для кого-то поражениями отчасти и потому, что у большинства сильных держав не было тех криптологических мощностей, которые сегодня есть у эрудированного школьника с персональным компьютером. А вскоре любой ребенок - в том возрасте, когда он уже способен пользоваться персональным компьютером, - сможет передавать сообщения, зашифрованные так, что ни одно государство не сможет быстро его раскодировать. Это одно из последствий повсеместного распространения фантастической вычислительной мощи.

При отправке по информационной магистрали какого-то сообщения Ваш компьютер или другое информационное устройство "поставит" на нем цифровую подпись, которую применять можете только Вы, и зашифрует сообщение так, чтобы его сумел прочитать только Ваш адресат. В сообщении может содержаться информация любого вида, в том числе речь, видео или цифровые деньги. Получатель будет уверен (почти на 100%), что сообщение исходит именно от Вас, что оно отправлено точно в указанное время, что оно не поддельное и что никто другой не расшифровал его.

Механизм, который позволит это реализовать, базируется на математических принципах, в том числе на так называемых "необратимых функциях" (one-way functions) и "шифровании по общему ключу" (public-key encryption). Это весьма "продвинутые" концепции, так что я обрисую их лишь в самых общих чертах. Главное, запомните: несмотря на техническую сложность этой системы, пользоваться ею будет чрезвычайно просто. От Вас потребуется всего лишь сообщить информационному устройству, что именно Вы хотите сделать, а остальное - дело техники.

Необратимая функция - нечто, что сделать гораздо легче, чем отменить. Например, Вам разбивают оконное стекло; этот процесс тоже описывается необратимой функцией, правда, бесполезной для шифрования. В криптографии же применяется тот вид необратимых функций, который позволяет легко отменить действие, если известна некая дополнительная информация, и в то же время крайне затрудняет отмену при отсутствии подобной информации. В математике существует целый ряд таких необратимых функций. Одна из них связана с простыми числами, которые дети изучают в школе. Простое число нельзя поделить без остатка ни на какое другое число, кроме единицы и самого себя. В первой дюжине следующие простые числа: 2, 3, 5, 7 и 11. Числа 4, 6, 8 и 10 простыми не являются, поскольку всех их можно разделить на 2 без остатка. А число 9 не относится к простым, потому что делится без остатка на 3. Простых чисел существует великое множество, и, когда перемножают два таких числа, получают значение, которое делится без остатка только на эти же простые числа. Например, перемножив 5 и 7, Вы получите 35, и это значение можно разделить без остатка только на 5 и 7. Поиск простых чисел называется в математике "разложением на множители".

Умножить простые числа 11927 на 20903 и получить результат 249310081 совсем нетрудно, куда сложнее восстановить два его множителя - простые числа. Тут-то и проявляется эффект необратимой функции - сложность разложения чисел на множители, что и лежит в основе самой изощренной на сегодняшний день криптографической системы. Даже самые мощные компьютеры тратят немало времени на разложение действительно крупного произведения на составляющие его простые числа. В системе кодирования, основанной на разложении на множители, используются два разных ключа: один для шифровки сообщения, а второй - отличный от первого, но связанный с ним, - для расшифровки. Располагая только ключом шифрования, сообщение легко закодировать, но раскодировать его в пределах разумного времени практически невозможно. Расшифровка требует отдельного ключа, доступного только определенному получателю сообщения - точнее, компьютеру получателя. Ключ шифрования основан на произведении двух огромных простых чисел, а ключ дешифрования - на самих этих простых числах. Компьютер способен формировать новую пару уникальных ключей буквально в мгновение ока, ему ведь ничего не стоит сгенерировать два больших простых числа и перемножить их. Созданный таким образом ключ шифрования можно без особого риска сделать общим, учитывая, насколько сложно даже другому компьютеру разложить его на составные простые числа и тем самым получить ключ дешифрования.

Практически этот вид шифрования встанет в центр системы защиты на информационной магистрали. Весь мир будет во многом полагаться на эту сеть, поэтому значимость должного уровня защиты информации очевидна. Информационную магистраль можно сравнить с сетью почтовых предприятий, где у каждого есть свой бронированный почтовый ящик с неподдающимся взлому замком. В щель почтового ящика любой может опустить письмо, но только у владельца этого ящика есть ключ, который позволит достать оттуда корреспонденцию. (Некоторые правительства, наверное, будут настаивать, чтобы у каждого почтового ящика была вторая, запасная дверца с отдельным ключом, который бы хранился у какой-то правительственной организации, но мы пока не станем обращать внимания на политические соображения, а сосредоточимся на защите, обеспечиваемой программными средствами.)

Каждый пользовательский компьютер (или другое информационное устройство) на основе простых чисел будет генерировать ключ шифрования, сообщаемый всем желающим, и ключ дешифрования, известный только конкретному пользователю. Вот как это будет выглядеть на практике. У меня есть информация, которую я хочу Вам передать. Моя система (на базе информационного устройства или компьютера) отыскивает Ваш общий ключ и с его помощью шифрует сообщение перед посылкой. Никто, кроме Вас, это сообщение прочитать не сможет, несмотря на то что этот ключ давно стал достоянием гласности. Почему ? А потому, что принадлежащий Вам общий ключ не содержит информацию, необходимую для дешифрования. Вы получаете сообщение, и компьютер декодирует его на основе личного ключа, соответствующего общему.

Но вот Вы захотели ответить на послание. Ваш компьютер отыскивает общий ключ и с его помощью кодирует ответ. Никто другой это сообщение не сумеет прочитать, невзирая на то что уж этот ключ - точно общий. И тем не менее только я один узнаю содержание Вашей записки, потому что только у меня есть личный ключ дешифрования. Такая система весьма практична, поскольку никому не придется заблаговременно обмениваться ключами.

Насколько велики должны быть простые числа и их произведения, чтобы необратимая функция работала по-настоящему эффективно ?

Концепция шифрования по общему ключу изобретена Уитфилдом Диффи (Whitfield Diffie) и Мартином Хеллманом (Martin Hellman) в 1977 году. Чуть позже другая группа ученых в области компьютерных наук, Рон Ривест (Ron Rivest), Ади Шамир (Adi Shamir) и Леонард Эдельман (Leonard Adelman), стала использовать разложение произведений простых чисел на множители как часть того, что теперь известно под названием "криптосистема RSA" (где RSA - первые буквы фамилий этих ученых). Они считали: чтобы разложить 13О-разрядное произведение простых чисел на множители, понадобятся миллионы лет - независимо от вычислительных мощностей. Для доказательства они предложили всем скептикам найти 2 множителя в 129-разрядном числе (среди тех, кто имеет отношение к криптографии, его называют RSA 129):

114 381 625 757 888 867 669 235 779 976 146 612 010 218 296 721 242 362 562 561 842 935 706 935 245 733 897 830 597 123 563 958 705 058 989 075 147 599 290 026 879 543 541

Ученые были уверены, что сообщение, зашифрованное ими с помощью этого общего ключа-числа, никогда не удастся прочитать. Но они то ли проигнорировали закон Мура (согласно которому, как я рассказывал во второй главе, вычислительная мощность компьютеров постоянно возрастает), то ли просто не ожидали такого успеха персональных компьютеров (который привел к колоссальному росту компьютерного парка и пользователей во всем мире). Так или иначе, в 1993 году более 600 ученых, не считая энтузиастов со всего мира, начали биться над этим 129-разрядным числом, координируя работу своих компьютеров по Internet. И менее чем за год они разложили это число на множители: одно число оказалось 64-разрядным, а другое - 65-разрядным. Эти простые числа выглядели так:

3 490 529 510 847 650 949 147 849 619 903 898 133 417 764 638 493 387 843 990 820 577

и

32 769 132 993 266 709 549 961 988 190 834 461 413 177 642 967 992 942 539 798 288 533

А зашифрованная фраза гласила: "The magic words are squeamish аnd ossifrage" ("Волшебные слова: разборчивый и скопа").

Первый урок, который следует извлечь из этой истории: 129-разрядный общий ключ маловат для шифрования действительно важной и секретной информации. А второй - не следует слишком уж полагаться на надежность криптографической защиты.

Увеличение ключа всего на несколько разрядов резко усложняет взлом. Сегодня математики пришли к выводу - разложение 250-разрядного произведения двух простых чисел займет несколько миллионов лет, даже с учетом постоянного роста вычислительных мощностей. Но кто за это поручится ? Всегда есть вероятность - пусть и ничтожная, - что кто-то вдруг додумается до простого способа разложения больших чисел на множители. А значит, программную платформу информационной магистрали надо строить так, чтобы при необходимости можно было легко сменить систему шифрования.

Единственное, о чем беспокоиться не следует, - так это о том, что нам не хватит простых чисел или что 2 компьютера ненароком используют под ключи одинаковые числа. Простых чисел гораздо больше, чем атомов во Вселенной, поэтому шанс на случайное дублирование ничтожно мал.

Шифрование по ключу дает нечто большее простой конфиденциальности. Оно обеспечивает и аутентификацию документов, потому что личный ключ позволяет зашифровать сообщение, которое можно декодировать только с помощью общего ключа. Работает это так. Информацию, которую я хочу подписать перед передачей Вам, мой компьютер кодирует моим личным ключом. Теперь Вы сможете прочитать это сообщение только в том случае, если "отомкнете" его моим общим ключом. А он известен и Вам, и всем остальным. Таким образом, становится ясно, что сообщение поступило именно от меня, поскольку такого личного ключа больше ни у кого нет.

Пойдем дальше. Мой компьютер берет это кодовое сообщение и снова шифрует его, на этот раз применяя Ваш общий ключ. Затем по информационной магистрали пересылает Вам уже дважды зашифрованное сообщение.

Ваш компьютер принимает его и расшифровывает с помощью Вашего личного ключа. Тем самым он удаляет второй уровень шифрования, но оставляет первый - тот, который был осуществлен на основе моего личного ключа. Тогда компьютер "достает" мой общий ключ и вновь проводит расшифровку сообщения. Благодаря тому, что оно действительно исходило от меня, сообщение расшифровывается правильно, и Вы теперь твердо знаете, кто его автор (это и есть аутентификация документа). Если хотя бы один бит информации изменился, сообщение уже не удалось бы расшифровать корректно, и Вам стало бы ясно, что оно поддельное или что при связи произошел сбой. Подобная экстраординарная защита позволит заключать финансовые сделки с незнакомыми людьми или с теми, кому Вы не доверяете; при указанных условиях Вы сможете быть уверены, что цифровые деньги не фальшивы, а документы и подписи на них действительно принадлежат людям, с которыми Вы имеете дело.

Степень защиты можно усилить, включив в зашифрованные сообщения временные отметки. Если кому-нибудь вздумается помудрить над датой и временем предположительной отправки или написания документа, это тут же выявится. Тем самым восстанавливается свидетельская ценность фотографий и видеозаписей, которая сейчас поставлена под сомнение из-за той легкости, с которой осуществляется их цифровое ретуширование.

Конечно, технические детали принципов шифрования по общему ключу в моем описании слишком упрощены. Прежде всего надо подчеркнуть, что этот метод работает довольно медленно, и поэтому на магистрали он будет не единственным. Но именно он позволит подписывать и аутентифицировать документы, безопасно распространять ключи к другим видам шифрования.

Революция, связанная с персональными компьютерами, раскрыла перед нами небывалые возможности. В этом ее самое крупное достижение. Однако коммуникационная связь через информационную магистраль, доступная и недорогая, откроет нам куда более фантастические перспективы. В выигрыше окажутся не только "технократы". С подключением все большего числа компьютеров к широкополосной сети и с появлением программной платформы - фундамента грандиозных приложений каждый получит доступ к большей части всемирной информации.


Глава 6 - Революция в содержании документов

Глава 6
Революция в содержании документов

Вот уже более 500 лет бумажные документы хранят знания человечества. Один из таких документов Вы сейчас держите в руках, если только не читаете эту книгу с компакт-диска или по сети (как будущее оперативное издание). И хотя с бумагой мы вряд ли когда-нибудь расстанемся, значимость ее как средства поиска, хранения и распространения информации ослабевает уже в наши дни.

Слово "документ", по-видимому, сразу же вызывает у Вас представление о тексте, напечатанном на листах бумаги, но это определение слишком узкое. Документом может быть любая сумма информации. Статья в газете - документ; здесь все ясно. А в более широком толковании "документ" - это и телешоу, и песня, и интерактивная видеоигра. Поскольку все данные можно отразить в цифровом виде, информационная магистраль позволит легко находить, хранить и пересылать любые документы. Печатные документы пересылать намного труднее, да и возможности их весьма ограниченны, когда речь идет не только о тексте, но и о схемах, рисунках и другой графике. В будущие документы, представленные в цифровой форме, мы сможем включать, кроме отдельных картинок, еще и звукозаписи, мультипликацию, программные инструкции, обеспечивающие интерактивность, или комбинацию этих и других элементов.

На магистрали с электронными документами, содержащими разнообразные виды информации, будут происходить такие вещи, которые попросту немыслимы ни с одним клочком бумаги. Ее мощная технология баз данных послужит гарантией для всесторонней индексации электронных документов и режима интерактивного поиска нужных сведений. Распространение таких документов станет чрезвычайно простым и недорогим. Короче говоря, новый тип документов - цифровой - заменит большинство печатных хотя бы потому, что откроет перед нами новые перспективы.

Но это произойдет не завтра. И дело не только в технологиях. Книга, журнал или газета, изданные на бумаге, по-прежнему имеют массу преимуществ перед своими электронными вариантами. Во-первых, цифровой документ не прочитаешь без информационного устройства - того же персонального компьютера. Во-вторых, книга, компактная, легкая, отпечатанная на хорошей бумаге четким шрифтом, по сравнению с компьютером стоит гроши. По крайней мере, в ближайшее десятилетие читать "увесистый" документ на экране компьютера вряд ли будет удобнее, чем на бумаге. Я уверен, что первыми получат широкое распространение те цифровые документы, которые будут не просто дублировать бумажные, а откроют совершенно новые возможности. Телевизор - если его сопоставить с той же книгой - вещь крупная (даже громоздкая), дорогая, а разрешение у него еще хуже, чем у мониторов, но ведь это не отражается на его популярности. Телевидение принесло в наши дома видеоразвлечения и оказалось настолько привлекательным, что заняло свое место в нашей жизни наряду с книгами и журналами.

Постепенно развитие компьютеров и технологии производства мониторов приведет к созданию почти невесомой, универсальной электронной книги (или "e-book"). Представьте: в коробочке размером и весом примерно с нынешнюю книгу (в твердой или гибкой обложке) будет находиться дисплей, способный показывать текст, картинки и видеоматериалы в высоком разрешении. Вы сможете "перелистывать" страницы... пальцем или отдавать команды голосом и так находить нужные отрывки. С такого устройства Вам будет доступен любой документ в сети.

Однако истинный смысл электронных документов вовсе не в том, что мы сможем читать их на каких-то аппаратах. Переход от бумажных книг к электронным - всего лишь конечный этап того процесса, который уже сейчас развивается весьма бурно. Самое волнующее в цифровых документах другое - изменение самого понятия "документ".

Нам придется вложить иной смысл не только в термин "документ", но и в такие понятия, как "автор", "издатель", "офис", "школьный класс" и "учебник". Это повлечет за собой радикальные последствия.

Сегодня, если две фирмы заключают контракт, первый, черновой его проект составляют обычно на компьютере, потом печатают на бумаге. Далее его передают - чаще всего по факсу - другой стороне; там его редактируют: вносят замечания от руки или набирают измененный документ на другом компьютере с последующей распечаткой. Затем он отсылается по факсу обратно; исправления принимаются или отвергаются; появляется новый бумажный документ, его отправляют по факсу, и процесс редактирования возобновляется. При такой работе над документом зачастую трудно разобраться, кто автор конкретных изменений. Координировать все исправления и передачу бумаг становится весьма проблематично. Электронные документы упрощают этот процесс, допуская обмен проектом контракта со всеми правками, замечаниями и пометками: кто и когда их внес.

В ближайшие несколько лет электронный документ с заверенными цифровыми подписями выйдет на первый план, а бумажный отойдет на второй. Уже сейчас многие организации, отказавшись от бумаги и факс-аппаратов, перешли на обмен редактируемыми документами с компьютера на компьютер по электронной почте. Замечу, кстати, что без электронной почты написать эту книгу было бы куда труднее. Читатели, чье мнение для меня небезразлично, просматривали черновой вариант книги в электронном виде, вносили свои замечания и возвращали мне по электронной почте; при этом я всегда видел не только предлагаемую правку, но и кто и когда работал с текстом.

К концу текущего десятилетия большую часть документов, даже официальных, будет уже невозможно адекватно воспроизвести на бумаге. У них появится определенное сходство с нынешними фильмами или песнями. При желании, конечно, Вы сможете отпечатать двумерное представление их содержимого, но тут Вы уподобитесь человеку, который читает ноты, вместо того чтобы слушать музыку.

Некоторые документы в цифровой форме обладают такими достоинствами, какие в бумажных версиях совершенно нереальны. Компания Boeing, например, создавала свой новый авиалайнер "Боинг 777", храня всю техническую информацию в одном электронном документе гигантских размеров. При разработке предыдущих авиалайнеров для координации конструкторских и производственных групп, а также внешних подрядчиков в компании Boeing поступали традиционно: вычерчивали на синьках чертежи и возводили дорогостоящие макеты самолетов в натуральную величину. Подобные макеты служили для подгонки и контроля деталей, спроектированных разными подразделениями. Приступая к созданию "Боинга 777", компания решила покончить с синьками, отказаться от макетов и с самого начала для трехмерного моделирования всех деталей использовать электронный документ, с помощью которого и проверять их подгонку друг к другу прямо на компьютере. Инженеры за компьютерными терминалами могли просматривать чертежи и изучать детали в разных видах. Они получили возможность наблюдать за продвижением работ в какой угодно области, отыскивать результаты всех испытаний, изменять любые части проекта и делать многое другое, что на бумаге просто исключено. Каждый - в рамках своей компетенции - мог найти нужные данные. Все изменения немедленно отражались на терминалах других сотрудников, и они видели: кем, когда и почему внесены эти изменения. Таким образом, компания Boeing сэкономила на цифровых документах сотни тысяч листов бумаги и многие человеко-годы проектно-конструкторских работ.

Помимо всего прочего, работа с цифровыми документами идет быстрее, чем с бумажными. Вы можете моментально передавать информацию и почти с той же скоростью отыскивать ее. Те, кто пользуется цифровыми документами, уже давно осознали, насколько проще в них поиск и ориентация, ведь структуру их содержимого так легко перестроить !

Книга регистрации заказов в ресторане ведется с учетом даты и времени. Заказ на 21:00 записывается ниже, чем заказ на 20:00. Заказы на вечер следуют за теми, что сделаны на полдень. Благодаря этому метрдотель может быстро узнать, сделан ли кем-то заказ на конкретные день и время. Но если по той или иной причине кому-то вздумается выбрать из книги информацию по другим критериям, простой хронологии уже недостаточно.

Только вообразите, в каком положении окажется метрдотель, если я позвоню ему и скажу:

- Моя фамилия Гейтс. Жена забронировала столик на какое-то время в следующем месяце. Будьте так любезны, проверьте, на какое именно.

- Простите, сэр, а Вам известен конкретный день ? - скорее всего спросит тот.

- Нет, это-то я и хочу выяснить.

- Не могла ли она сделать заказ на выходные ? - поинтересуется метрдотель.

Он уже понял, что ему придется пролистать всю книгу, и пытается хоть как-то упростить себе задачу, сужая круг вероятных дат.

Ресторан еще может использовать дедовскую книгу регистрации, потому что общее число заказов невелико. А вот система бронирования авиабилетов - уже не книга, а база данных с огромными массивами регистрационных сведений, информации о рейсах, ценах, наличии свободных мест, расположении кресел в салонах авиалайнеров, и все это по сотням ежедневно выполняемых рейсов во всем мире. Система бронирования SABRE компании American Airlines хранит на жестких дисках компьютеров информацию объемом в 4,4 триллиона байт, т.е. более 4 триллионов букв. Если эти данные скопировать на бумагу, понадобится не менее 2 миллиардов страниц.

Имея дело с бумажными документами и их подборками, мы отыскивали информацию линейно; альтернативные способы ее поиска обеспечивали указатели, оглавления и разного рода перекрестные ссылки. Профессионально составленные указатели придавали книге большую ценность, так как обогащали ее различными способами поиска информации. В бесчисленных офисах папки подбирали по клиентам, поставщикам или по каким-то еще признакам и расставляли в алфавитном порядке, а чтобы ускорить поиск нужных сведений, копии всех документов подшивали в хронологическом порядке. До компьютеризации библиотечных каталогов новые книги регистрировали на нескольких карточках, разнося их по нескольким каталогам, чтобы читатель мог найти книгу по названию, фамилии автора, соавтора или по тематике. Подобная избыточность облегчала поиск требуемой книги.

В детстве мне очень нравилась стоявшая в комнате родителей World Book Encyclopedia выпуска 1960 года. Ее тяжелые переплеты содержали только текст и картинки. По ним я узнал, как выглядел фонограф Эдисона, но услышать его скрежещущий звук не мог. Фотоснимки энциклопедии запечатлели ворсистую гусеницу и бабочку, в которую она превращается, но не было видеофрагментов, которые бы оживили эту метаморфозу. А как было бы здорово, если бы сама энциклопедия устроила мне контрольный опрос по тому, что я вычитал, или если бы устаревшие сведения можно было постоянно обновлять. Естественно, что эти мысли пришли мне в голову не тогда. Первый том я начал читать лет в восемь, твердо вознамерившись прочесть все тома подряд, от корки до корки. Наверное, я бы усвоил гораздо больше, если бы статьи на определенные темы (скажем, по медицине или истории шестнадцатого века) следовали одна за другой. А вместо этого я сначала читал статью "Garter Snakes" (подвязковые змеи), потом "Gary, Indiana" (город Гэри в штате Индиана), потом "Gas" (газ, бензин). Но все равно я получал большое удовольствие от энциклопедии и читал ее еще лет пять, пока не добрался до буквы Р. Тут я открыл для себя Encyclopedia Britannica (Британская энциклопедия) - гораздо более подробную и рассчитанную на искушенного читателя, - но понял, что мне не хватит терпения осилить все тома. Да и к тому же увлечение компьютерами уже поглощало большую часть моего свободного времени.

Издаваемые сегодня энциклопедии - это обычно две дюжины томов с миллионами слов и тысячами иллюстраций; они стоят сотни, а то и тысячи долларов. Немалые расходы, особенно если учесть, как быстро устаревает информация. Microsoft Encarta, которая продается лучше других мультимедийных и печатных энциклопедий, выходит на тридцатиграммовом CD-ROM-диске (Compact Disk - Read Only Memory, компакт-диск - память только для чтения). В ней 26000 статей с 9 миллионами слов, 8 часами звукового сопровождения, 7000 фотографиями и иллюстрациями, 800 картами, 250 схемами и таблицами, 100 видеоклипами и мультипликационными роликами. А стоит она меньше 100 долларов. Хотите узнать, как звучит египетский "уд" (музыкальный струнно-щипковый инструмент), послушать речь, которую произнес в 1936 году король Великобритании Эдуард VIII при отречении от престола, или увидеть мультфильм, поясняющий устройство какой-нибудь машины ? Все это есть в Microsoft Encarta, и никогда не будет ни в одной из печатных энциклопедий.

В обычной энциклопедии в конце статьи часто приводятся ссылки на другие статьи, близкие по теме. Однако сначала их надо собрать, ведь они могут быть разбросаны по разным томам. В энциклопедии на компакт-диске для этого достаточно щелкнуть соответствующую ссылку. А на информационной магистрали в энциклопедические статьи можно будет включать связи с материалами не только из данной энциклопедии, но и из других источников. Нет предела дополнительным сведениям, которые Вы сможете "откопать" по интересующей Вас тематике. По сути, энциклопедия на информационной магистрали превратится в нечто большее, чем простой справочник - она станет чем-то вроде библиотечного каталога, коридора ко всем знаниям, приобретенным человечеством за многие века.

Сегодня в печатной информации ориентироваться очень трудно. Почти невозможно найти исчерпывающие сведения по конкретной тематике (включая книги, газетные статьи и видеоролики). Слишком много времени отнимает подборка отрывочных сведений, которые можно разыскать в отдельных источниках. Например, если Вы захотите что-то узнать про последних лауреатов Нобелевской премии, на сбор их биографий у Вас уйдет весь день. А электронные документы будут интерактивными (т.е. позволят вести "диалог"): Вы запрашиваете какую-то информацию, и документ предоставляет ее. Вам придет в голову другая идея, и документ вновь соответствующе отреагирует. Как только Вы привыкнете к такой системе, Вы сразу поймете, что возможность просмотра информации разными способами делает ее ценнее. Гибкость вызывает интерес к изучению, а оно всегда вознаграждается открытием.

Аналогичным образом Вы сможете получать и свои ежедневные новости, самостоятельно определяя продолжительность их передачи. Это станет возможным благодаря индивидуальному подходу к трансляциям ТВ. Доставляемые только Вам выпуски новостей будут скомпонованы из съемок и репортажей NBС, ВВС, CNN или Los Angeles Times, сюда же может войти прогноз погоды от местной метеорологической службы или от частного метеоролога, которому Вы доверяете больше. Одни репортажи (самые увлекательные) Вы сможете запрашивать в развернутом виде, а другие - буквально в двух-трех словах, только о самом главном. Если при просмотре новостей Вас заинтересуют какие-то подробности, Вы запросите их у другой службы новостей или из архива.

Литературные произведения, пожалуй, один из немногих видов печатных документов, которые ничего не выиграют от перевода в электронную форму. Почти во всех справочниках есть предметные указатели, но в художественной прозе иx нет, ведь романы читают последовательно, от начала и до конца. И дело тут не в каких-то технологических особенностях - любое повествование неотъемлемо связано с последовательным развитием сюжета. Впрочем, сейчас появились новые формы литературы - интерактивные, использующие все преимущества электронного мира, однако и традиционные ее формы по-прежнему будут популярны.

Магистраль позволит распространять любые формы цифровых документов - легко и дешево. Миллионы частных лиц и компаний смогут создавать такие документы и публиковать их в сети. Какие-то документы будут платные, а какие-то - бесплатные, адресованные всем желающим. Вспомним также, как фантастически подешевели средства хранения цифровой информации. Жесткие диски в персональных компьютерах очень скоро будут продаваться всего центов по 15 за мегабайт (миллион байт). Поскольку 1 мегабайт - это около 700 страниц текста, получается, что хранение одной страницы обойдется примерно в 0,00021 доллара, т.е. одну двухсотую того, что стоит ксерокопия страницы (по среднему тарифу в 5 центов за страницу). А поскольку дисковое пространство можно использовать повторно, для записи других данных, то стоимость хранения информации - это на самом деле стоимость аренды дискового пространства. Если средний срок службы жесткого диска принять равным трем годам, амортизационная стоимость хранения одной страницы составит 0,00007 доллара в год. Но средства хранения информации постоянно дешевеют. В частности, цены на жесткие диски в последние несколько лет ежегодно падали на 50%.

Хранение текста не вызовет трудностей, потому что в цифровом виде он очень компактен. А что касается изображений, вспомните старую пословицу: "Лучше один раз увидеть, чем сто раз услышать". Так вот, если ее перефразировать, то можно сказать, что в цифровом мире любая картинка стоит тысячи слов. И ведь это в буквальном смысле ! Высококачественные фотоизображения требуют для хранения значительно больше места, а видео (в сущности, это последовательность изображений, сменяемых с частотой до 30 кадров в секунду) - еще больше. Тем не менее стоимость распространения даже этих видов данных достаточно низка. Художественный фильм в сжатом цифровом формате занимает около 4 гигабайт (4000 мегабайт), т.е. его хранение на жестком диске обойдется приблизительно в 1600 долларов.

Шестнадцать "сотенных" за хранение одного фильма, на первый взгляд, дороговато. Однако примем во внимание, что самый обыкновенный магазин системы видеопроката приобретает популярный фильм минимум в восьми копиях по 80 долларов за каждую. При этом магазин может предложить этот фильм не более восьми клиентам в день.

А как только диск (с фильмом) и управляющий им компьютер подключаются к магистрали, оказывается, что для просмотра этого фильма всеми желающими достаточно одной копии. Разумеется, наиболее популярные документы будут копировать на несколько серверов, чтобы избежать задержек при обращении к ним необычно большого числа пользователей. Требуя лишь разового вложения капитала, по грубым прикидкам равного той сумме, которую сегодня отдельный магазин выкладывает за популярную видеозапись, сервер сможет обслуживать тысячи клиентов одновременно. При этом каждый пользователь понесет дополнительные расходы, складывающиеся из стоимости кратковременной "аренды" дискового пространства сервера и тарифов на связь. А эти цены постоянно падают, так что сумма дополнительных расходов для отдельного пользователя скоро приблизится к нулю.

Это, конечно, не означает, что информация станет бесплатной, но затраты на ее распространение будут очень низки. При издании книг главные расходы связаны с ее выпуском и распространением, а не с выплатой гонорара автору. Деревья надо срубить, древесину измельчить до однородной массы и из нее изготовить бумагу. Книгу надо напечатать, сброшюровать и одеть в переплет. Большинство издателей основной капитал вкладывают в первый тираж, определяемый максимальным количеством экземпляров, которое, по их мнению, может тут же разойтись. Ведь издание книги только тогда приносит прибыль, когда она выпускается сразу значительным тиражом. Но здесь издатели идут на финансовый риск: не исключено, что им не удастся распродать все экземпляры или что на их реализацию уйдет какое-то время. Попутно издатель должен держать книги на складе, отгружать их оптовикам и книжным магазинам, торгующим в розницу. Торговцы тоже вкладывают в этот бизнес свой капитал и, естественно, хотят получить определенную прибыль.

К тому времени, когда покупатель берет в магазине эту книгу и кассовый аппарат, позвякивая, выдает ему чек, авторский гонорар уже составляет ничтожную долю по сравнению с той суммой, которая уходит на доставку информации по переработанной древесной массе. Я предпочитаю называть этот эффект "трением" дистрибуции, потому что он, как и трение, приводит к растрате ресурсов, отнимая деньги у автора в пользу других.

Информационная магистраль во многом будет свободна от этого трения, о чем я расскажу подробнее в восьмой главе. Отсутствие трения в распространении информации - вещь невероятно важная. Оно увеличит ряды авторов, поскольку лишь малая часть покупательского доллара пойдет на оплату дистрибуции.

Печатный пресс Гутенберга вызвал первый реальный сдвиг в этой проблеме - он позволил быстро и сравнительно дешево распространять информацию на любую тему. Снизив "коэффициент трения", печатный пресс породил современные масс-медиа. Количественный рост книг способствовал развитию в обществе интереса к чтению и письму; как только человек становился грамотным, он обнаруживал, что письменное слово дает целый ряд преимуществ. Купцы стали вести учет своих товаров и составлять договоры, влюбленные - обмениваться амурными записками, ну а другие - просто записывать что-то на память, вести дневники. Но сами по себе эти "приложения" не были настолько привлекательными, чтобы избавить людей от лени и заставить их обучаться грамоте. Пока не появилась достаточная прослойка образованных людей, письменное слово как способ хранения информации не приносило особой пользы. И поскольку именно книги способствовали возникновению "критической массы" образованных людей, вполне справедливо сказать, что печатный пресс научил нас читать.

Печатный пресс упростил изготовление множества копий того или иного документа. Ну а как насчет тех трудов, которые были предназначены лишь узкому кругу избранных ? Новая технология требовалась и в малотиражном издательстве. Копирка - вещь, конечно, прекрасная, если Вас устраивают 2 - 3 копии. Мимеографы (устаревшее название ротапринтов) и другие громоздкие машины позволяли размножать документы уже в десятках экземпляров, но использование этих агрегатов Вы должны были предусмотреть еще при работе над оригиналом.

В 1930-х годах Честер Карлсон (Chester Carlson), раздраженный чрезмерной сложностью подготовки патентных заявок (приходилось вручную копировать текст и чертежи), стал искать более совершенный способ малотиражного размножения документов. И вот в 1940 году он запатентовал изобретенный им процесс - ксерографию. В 1959 году компания (впоследствии известная как Xerox), которую он сумел заинтересовать своим изобретением, выпустила его первый копировальный аппарат. Модель 914, позволившая легко и недорого размножать документы умеренным числом копий, привела к настоящему взрыву в объемах и видах информации, предназначенной малочисленным группам потребителей. Маркетинговые исследования предсказывали, что Xerox сумеет продать максимум 3000 своих копировальных аппаратов первой модели. А на самом деле они разошлись в количестве 200000 штук. Год спустя после выпуска копировального аппарата с его помощью каждый месяц делали уже по 50 миллионов копий различных документов. К 1986 году это число превысило 200 миллиардов и растет до сих пор. Большая часть копий никогда бы не появилась на свет, не будь этой технологии - такой простой и дешевой.

Фотокопировальный аппарат и его дальний родственник, настольный лазерный принтер, вкупе с программным обеспечением персональных компьютеров для настольного издательства содействовали появлению многочисленных информационных бюллетеней, меморандумов, программок, рекламных листовок и других документов, ориентированных на сравнительно узкую аудиторию.

Карлсон тоже внес вклад в уменьшение "коэффициента трения" распространения информации. И бешеный успех его копировального аппарата - наглядный пример тому, какие удивительные вещи случаются, стоит лишь снизить этот коэффициент.

Конечно, изготовить копии гораздо легче, чем написать оригинал так, чтобы его захотелось читать. В наше время можно издавать неограниченное количество книг. В обычном книжном магазине Вы найдете порядка 10000 наименований, а в некоторых - до 100000. И лишь малая доля этих фолиантов, менее 10%, принесла прибыль их издателям, хотя некоторые книги пользовались таким успехом, который никому и не снился.

Недавний пример, которым я не перестаю восхищаться, - книга A Brief History of Time (Краткая история времени) Стефена У. Хокинга (Stephen W. Hawking), блестящего ученого, из-за атрофического латерального склероза (болезни Лью Герига) прикованного к инвалидному креслу и разговаривающего лишь с большим трудом. Имела бы эта монография о происхождении Вселенной хоть какие-нибудь шансы на публикацию, если бы издателей была малая горстка и каждый из них мог выпускать только несколько книг в год ? А что если бы у издателя в "портфеле" оставалась всего одна вакансия и ему бы пришлось выбирать между книгой Хокинга и "Сексом" Мадонны ? Смело ставьте на Мадонну, поскольку именно ее книгу, без всяких сомнений, раскупят миллионным тиражом. Таким тиражом ее и раскупили. Но книга Хокинга разошлась тиражом в 5,5 миллионов экземпляров и по-прежнему продается.

Неожиданные бестселлеры нет-нет да и появляются, удивляя всех вокруг (кроме автора). Очень любопытная книга The Bridges of Madison Country (Мосты в округе Медисон) - первый роман, вышедший из-под пера преподавателя искусства общения, который работает в одной из школ бизнеса. Издатель не планировал, чтобы эта книга стала бестселлером, хотя на самом деле никто и не может знать, что привлечет внимание публики. Впрочем, подобные занятия, как и централизованное планирование, при котором пытаются перехитрить рынок, - дело заведомо проигрышное. Почти всегда в списке бестселлеров, публикуемом в The New York Times, есть пара книг совершенно неизвестных авторов. И все это потому, что по сравнению с другими средствами информации издание книг обходится сравнительно недорого - можно рискнуть и поставить на "темную лошадку".

На телевидении или в киноиндустрии ставки намного выше - там рисковать гораздо опаснее. На заре телевидения в каждом географическом районе было всего по несколько станций и большинство передач адресовали максимально широкой аудитории.

Кабельное телевидение существенно обогатило выбор программ, хотя внедряли его вовсе не с этой целью. Его начали создавать в конце сороковых годов, стремясь улучшить качество приема телесигналов в удаленных районах. Коллективные антенны, принимающие сигналы и подающие их в местную кабельную систему, устанавливались там, где прием на индивидуальные антенны блокировали возвышенности. Никому тогда и в голову не приходило, что за кабельное телевидение станут платить и те, у кого прием телесигналов идеален, - просто чтобы смотреть бесконечный поток музыкальных видеоклипов или 24 часа в сутки следить за лавиной новостей или прогнозов погоды.

Когда число передающих станций выросло с 3 - 5 до 24 или даже до 36, динамика программ начала меняться. Если, например, Вы отвечали за программу тридцатого канала, то не могли собрать аудиторию, всего-навсего копируя сетку вещания каналов с 1 по 29. Каналы кабельного телевидения были вынуждены выбирать определенную специализацию. Подобно журналам или информационным бюллетеням, новые каналы концентрировались на интересах и увлечениях сравнительно небольших слоев энтузиастов. Такой подход - полная противоположность работе обычного телевидения, которое стремится передавать то, что может быть интересно почти всем. Однако в любом случае высокая стоимость и недостаточное число каналов по-прежнему ограничивают количество выпускаемых телепрограмм.

Хотя стоимость издания книг гораздо ниже стоимости подготовки и трансляции телепередач, она все равно превышает затраты на публикацию в электронном виде. Чтобы подготовить книгу к печати, издателю приходится идти на предоплату всех издержек, связанных с производством, распространением и маркетингом. А информационная магистраль создаст среду с более низким входным барьером, чем мы видели до сих пор. Именно поэтому Internet представляет собой грандиозную систему "самиздата". Его электронные доски сообщений демонстрируют некоторые из ожидающих нас перемен, когда все получат доступ к системе дистрибуции с низким "коэффициентом трения" и каждый сможет распространять свое творчество - послания, рисунки, программы и т.д.

Надо сказать, что электронные доски сообщений внесли колоссальный вклад в развитие популярности Internet. Для публикации на них только и требуется, что выразить свои мысли и отправить их по нужному адресу. Конечно, это приводит к замусориванию Internet всякой чепухой, но иногда попадаются настоящие жемчужины. Обычно сообщение умещается на одной или двух страницах. Единственное сообщение, отправленное на популярную электронную доску или в список рассылки, может попасть к миллионам людей и стать притчей во языцех. Но может остаться незамеченным и "проваляться" там без толку хоть целую вечность. На этот риск идут потому, что трение дистрибуции очень низкое. Полоса пропускания сети настолько велика, а прочие факторы, влияющие на суммарные затраты, настолько малозначимы, что никто не задумывается о расходах на отправку сообщений. В худшем случае Вас лишь слегка обескуражит тот факт, что сообщение никого не заинтересовало. С другой стороны, если Ваше сообщение окажется любопытным, с ним познакомится целая армия народу, потому что многие пересылают по электронной почте такие сообщения друзьям, дополняя их своими комментариями.

Соединение с электронными досками сообщений проходит удивительно быстро и стоит очень дешево. Почтовая или телефонная связь оправдывает себя при разговорах "один на один", но при обращении к группе людей ее стоимость вырастает весьма значительно. Напечатать и отправить письмо по почте стоит примерно доллар и в среднем во столько же обходится междугородный звонок. Чтобы сделать такой звонок, Вы, естественно, должны знать номер телефона своего абонента и время, когда его можно застать на месте. Таким образом, чтобы собрать даже небольшую группу, Вам придется приложить немало усилий и потратить уйму времени. А что касается электронной доски сообщений, Вам нужно лишь единожды составить свое послание, и оно будет доступно любому.

Электронные доски в Internet охватывают широкий круг тем. Часть корреспонденции просто шуточная. Если одно из таких сообщений кажется кому-то забавным, он передает его дальше по электронной почте. В конце 1994 года такое случилось с фальшивым пресс-релизом о покупке фирмой Microsoft Вселенской церкви (Catholic Church). Тысячи его копий по нашей системе электронной почты распространялись и в Microsoft. Я сам получил больше двадцати экземпляров от своих знакомых и коллег.

Но есть и много других, гораздо более серьезных примеров использования сети для мобилизации людей, обеспокоенных общей проблемой или связанных общими интересами. Во время недавнего политического конфликта в России обе стороны могли апеллировать к мировой общественности, отправляя свои сообщения на электронные доски. Так что сети позволяют контактировать совершенно незнакомым людям, встревоженным одинаковыми проблемами.

Информация, публикуемая в электронном виде, группируется по тематике. Каждая электронная доска сообщений или группа новостей (news-group) имеет свое имя, и любой желающий может присоединиться к ним. Интересную для Вас группу новостей легко выбрать из списка или ориентируясь на наиболее обещающие имена. Если Вам хочется поговорить о паранормальных явлениях, обращайтесь к группе новостей alt.paranormal. Если Вас тянет обсудить их с теми, кто не верит в подобные явления, присоединяйтесь к sci.skeptic. Или подключитесь к copernicus.bbn.com и загляните в National School Network Testbed, где Вы получите подборку планов занятий, используемых и воспитателями детских садов, и учителями выпускных классов. Практически по любой теме, которая только может прийти в голову, в сети есть своя группа.

Мы уже убедились, что изобретение Гутенберга заложило основы массового книгоиздания, но грамотность, которую оно в конечном счете породило, привела к небывалому до тех пор размаху переписки между отдельными лицами. Электронная связь развивалась с точностью до наоборот. Все началось с электронной почты, которая позволила связываться с небольшими группами лиц. А теперь миллионы людей пользуются преимуществами сетей для широкомасштабной дистрибуции (с низким "коэффициентом трения") своих материалов.

У Internet колоссальный потенциал, но важно не подорвать к нему доверие, слишком высоко задрав планку ожиданий. Общее число пользователей Internet и коммерческих оперативных служб типа Prodigy, CompuServe или America Online по-прежнему составляет лишь малую долю населения. Опросы показывают: почти 50% всех пользователей персональных компьютеров в США имеют модем, но из них менее 10% являются подписчиками оперативных служб, а из-за высоких расценок многие отказываются от продления подписки, не выдержав и года.

Понадобятся значительные вложения, чтобы оперативные службы смогли предлагать такие материалы, которые бы привлекали пользователей персональных компьютеров и тем самым увеличили число подписчиков оперативных служб с 10 до 50%, а то и до 90% (в будущем, я уверен, так и будет). Одна из причин, почему сейчас подобные вложения не делаются, в том, что простые (для авторов и издателей) механизмы взимания платы с пользователей пока еще только вырабатываются.

Коммерческие оперативные службы получают определенные доходы, но поставщикам информации отчисляют всего 10 - 30% того, что им платят клиенты. И хотя поставщик, вероятно, знает клиентуру и рынок лучше, ценообразование (как и сколько платит клиент) и маркетинг контролирует оперативная служба. Получаемых доходов попросту не хватает на то, чтобы стимулировать поставщиков предоставлять по-настоящему интересную оперативную информацию.

В последующие годы развитие оперативных служб позволит решить эти проблемы. Оплата станет более гибкой, появятся помесячная подписка, почасовые ставки, тарифы на определенные сведения, доходы от рекламы - все это даст возможность больше платить поставщикам информации. И как только желаемое превратится в действительное, мы станем свидетелями рождения нового вида "масс-медиа". Такой переход может занять несколько лет и потребовать нового поколения сетевой технологии (ISDN или кабельных модемов); так или иначе, но это будет реализовано и откроет огромные возможности авторам, издателям, режиссерам - всем творцам интеллектуальной собственности.

Когда создается новая информационная среда, предлагаемые в ней материалы заимствуются у других средств информации. Но чтобы воспользоваться уникальными преимуществами электронной среды, уже при подготовке материалов нужно учитывать ее специфику. Пока же в "он-лайновом" (оперативном) режиме предлагают в основном то же, что легко найти в других источниках. Издатели просто берут текст со страниц своих журналов или газет (напечатанный бумажный вариант) и "запихивают" его в сеть, зачастую убирая из материалов все картинки, диаграммы и прочую графику. Чисто текстовые электронные доски и электронная почта - штуки, конечно, интересные, но они не могут серьезно конкурировать с другими, более выразительными видами информации. Оперативные материалы должны быть насыщены графикой, фотоизображениями и связями-ссылками на близкую по тематике информацию. По мере того как коммуникационная связь станет быстрее, а коммерческие перспективы четче, в этих материалах будут все чаще встречаться звуковые вставки и видеофрагменты.

Разработка CD-ROM-дисков - мультимедийных версий аудиокомпактдисков - преподнесла кое-какие уроки, которые желательно учесть при подготовке оперативных материалов. Мультимедийные продукты на базе CD-ROM-дисков объединяют в одном документе множество различных видов информации: текст, графику, фотоизображения, анимацию, музыку и видеофрагменты. Сегодня основная ценность этих продуктов - в "мульти", а не в "медиа", и именно они в наибольшей степени приближаются к богатству выразительных средств документов будущего.

Музыка и аудиофрагменты на CD-ROM-дисках звучат чисто, без искажений, но редко когда достигают качества музыкальных компакт-дисков. На CD-ROM-диске можно хранить звук с таким же качеством записи, как и на компакт-диске, но на это уходит слишком много места, а графика и прочие данные могут просто не поместиться.

Нуждаются в усовершенствовании и принципы видеозаписи на CD-ROM-дисках. Разве можно сравнить качество видео, которое сегодня показывают "персоналки" в окне размером с почтовую марку, и то, что мы имели всего несколько лет назад ? Прогресс - ошеломляющий ! - налицо. Пользователи со стажем были чуть ли не сражены, впервые узнав о возможности просмотра видео на своих компьютерах. С другой стороны, дергающееся зернистое изображение явно не многим лучше телевизионной картинки образца пятидесятых годов. Размер изображений увеличится, а качество улучшится с появлением более быстрых процессоров и усовершенствованием методов сжатия; в конечном счете качество видео на ПК далеко обойдет качество картинки на современных телевизорах.

Технология на базе CD-ROM-дисков привела к возникновению новой категории приложений. Магазинные каталоги, музейные путеводители и учебники переиздают сейчас в этой новой, очень привлекательной форме. Охватываются все области знаний. Конкуренция и развитие этой технологии стремительно повышают качество мультимедийных продуктов. CD-ROM-диски заменят новые диски с высокой емкостью. Внешне похожие на нынешние компакт-диски, они будут хранить в 10 раз больше данных. Увеличенная емкость позволит размещать на этих компакт-дисках цифровые видеозаписи продолжительностью более двух часов, а это значит, что на них уместится целый фильм. Качество изображения и звука будет намного выше, чем у лучшего телевизионного сигнала, который можно принять на домашний телевизор, а новые поколения графических чипов позволят включать в мультимедийные продукты спецэффекты голливудского класса - и не только включать, но и держать их под интерактивным контролем самого пользователя.

Мультимедийные CD-ROM-диски популярны сегодня потому, что обеспечивают интерактивное взаимодействие с пользователем, а не потому, что имитируют ТВ. Коммерческая привлекательность интерактивного взаимодействия уже продемонстрирована на примере CD-ROM-версий таких игр, как Myst фирмы Broderbund и Seventh Guest фирмы Virgin Interactive Entertainment - детективных фильмов, в которых повествовательный сюжет перемешан с сериями загадок. Игрок, расследуя тайны и подбирая ключи к решению головоломок, сам определяет порядок своих действий.

Успех этих игр вдохновил авторов на создание интерактивных романов и фильмов, где они только намечают общий сюжет и вводят определенный круг героев, а уж концовка зависит от шагов, сделанных читателем-игроком. Разумеется, никто не призывает к тому, чтобы читатель или зритель вмешивался в развитие интриги всех книг или фильмов и тем самым влиял на ее развязку. Увлекательный сюжет, который заставляет Вас, затаив дыхание, неподвижно сидеть несколько часов перед экраном, - подарит Вам прекрасный отдых. И честно говоря, нет никакого желания подбирать финал для The Great Gatsby (Великий Гэтсби) или La Dolce Vita (Сладкая жизнь) - Фрэнсис Скотт Фицджеральд и Федерико Феллини уже гениально сделали это. Тонкая нить доверия, обязательного для восприятия великого произведения, может легко оборваться под тяжестью неуклюжего применения интерактивности. Нельзя управлять фабулой и в то же время как бы жить в ней. У интерактивного произведения столько же общего с его старыми формами, сколько у поэзии - с драмой.

Интерактивные рассказы и игры будут доступны и в сети. Материалы, используемые такими приложениями, Вы сможете распределять между сетью и CD-ROM-дисками, но, по крайней мере на первых порах, эти программы придется настраивать очень тщательно, чтобы CD-ROM-диски работали в сети не слишком медленно. А связано это, как я уже говорил, с тем, что полоса пропускания (или скорость передачи битов) между компьютером и CD-ROM-диском намного превышает пропускную способность существующей телефонной сети. Со временем сети достигнут, а потом и превзойдут скоростные характеристики CD-ROM дисков. Когда это случится, для обеих форм (и сети, CD-ROM-дисков) будут создаваться продукты, одинаковые по богатству используемых в них выразительных средств. Но на это уйдут годы, потому что технология CD-ROM-дисков тоже не стоит на месте. Так что пока эти две формы, столь явно отличаясь по скорости передачи битов, остаются разными технологиями.

За последние годы технологии, лежащие в основе CD-ROM-дисков и оперативных служб, коренным образом улучшились, однако до сих пор лишь немногие пользователи компьютеров создают мультимедийные документы. Для этого все еще нужны слишком большие усилия. У миллионов людей есть видеокамеры, и они снимают любительские фильмы про своих детей или проведенный отпуск. А вот чтобы редактировать видеофильмы, Вы должны быть профессионалом и иметь дорогостоящее оборудование. Такая ситуация обязательно изменится. Достижения в разработке текстовых процессоров и программ настольного издательства для персональных компьютеров уже предоставили сравнительно недорогие инструменты профессионального класса. С их помощью миллионы людей создают простые бумажные документы. Настольные издательские системы достигли такого совершенства, что многие журналы и газеты выпускаются на тех же ПК и с поддержкой тех же программных пакетов, которые каждый может купить в рядовом компьютерном магазине и использовать для печати оригинальных приглашений на день рождения своей дочери. Программы, которые позволят редактировать фильмы и создавать спецэффекты на персональных компьютерах, в будущем станут такими же обыденными вещами, как и системы настольного издательства. И тогда уже профессионала от дилетанта по инструментарию не отличишь - разницу между ними будет определять только талант !

В 1899 году Жорж Мельес (Georges Melies) создал один из первых спецэффектов: в фильме The Conjurer (Фокусник) он превратил женщину в перья. С тех пор кинематографические трюки стали использовать очень часто. В последнее время технология спецэффектов качественно улучшилась за счет цифровой обработки изображений. При этом фотография преобразуется в двоичную информацию, с которой, как мы уже видели, легко оперируют программы. Затем цифровые данные изменяются нужным образом и вновь преобразуются в фотографию - отдельный кинокадр. Профессионально отредактированные кадры кажутся почти натуральными, а результаты могут быть весьма эффектны. Компьютерные программы вдохнули жизнь в динозавров из фильма Jurassic Park (Парк юрского периода), заставили мчаться грозным топотом стадо гну из мультфильма The Lion King (Король-Лев) и привели к потрясающим мультэффектам в фильме The Mask (Маска). По мере того как закон Мура неотвратимо увеличивает быстродействие аппаратных средств, а программное обеспечение становится все изощреннее, уже не остается практически никаких барьеров на пути фантазии. Мощным движителем этого процесса является Голливуд, рождающий все новые и новые эффекты - один удивительнее другого.

В будущем компьютерная программа сможет создавать такие же реалистичные сцены, как и снятые кинокамерой. Те, кто видел фильм Forrest Gump (Форрест Гамп), конечно, заметили, что сцены с участием президентов Кеннеди, Джонсона и Никсона не настоящие. Тем более, актера Тома Хэнкса (Tom Hanks) там просто быть не могло. Гораздо труднее обнаружить подлог в тех кадрах этого фильма, где Гари Синизу (Gary Sinise) методом цифровой обработки "ампутировали" обе ноги - для роли безногого инвалида. Кроме того, синтезированные изображения и цифровое редактирование помогают обезопасить выполнение кинотрюков. Вскоре Вы будете добиваться подобных эффектов и на своем персональном компьютере. Легкость, с которой ПК и программы редактирования фотоизображений уже сейчас обрабатывают сложные картинки, сулит кучу возможностей для любых подделок фотодокументов - таких, что никто и не отличит. А с удешевлением синтеза изображений этот метод будет применяться все шире и шире; если мы возвращаем к жизни тиранозавров, почему бы не оживить и Элвиса ?

Даже те, кого не вдохновляет перспектива стать еще одним С.Б. Де Миллем (C.В. De Mille) или Линой Вертмюллер (Lina Wertmuller), будут включать в свои повседневные документы мультимедийные компоненты. Кто-то, быть может, начнет с того, что наберет на клавиатуре, или напишет от руки, или надиктует в микрофон сообщение для электронной почты: "Ленч в парке сегодня не самая лучшая идея. Посмотрите прогноз погоды". А чтобы усилить информативность, он укажет курсором на значок, связанный с записью прогноза погоды на местной телестудии, и перетащит его по экрану в свой документ. Когда его друзья получат это сообщение по электронной почте, прямо на экранах своих компьютеров они увидят и эту запись - чем не общение на профессиональном уровне ?

В школах дети будут составлять разнообразные альбомы, снимать фильмы и по информационной магистрали показывать их своим друзьям и родителям. В свободное время я и сам люблю делать поздравительные открытки и приглашения с "изюминкой"; например, на открытки, которыми я поздравляю сестру с днем рождения, я иногда вставляю картинки, напоминающие ей о забавных событиях прошлого года. В будущем я смогу включать в электронные открытки даже видеоклипы, потратив всего несколько минут на их подгонку под соответствующий повод. Мы все с удовольствием займемся созданием "альбомов" фотографий, видеозаписей или разговоров. Деловые документы станут немыслимы без мультимедиа. Влюбленные смогут сочинять милые "валентинки", с помощью особых эффектов накладывая на фрагмент из старого фильма любимую песню и строчки собственного сочинения.

С улучшением качества визуальных и звуковых элементов удастся точнее моделировать реальность во всех ее проявлениях. Виртуальная реальность (ВР) позволит нам "бывать" там, где иначе мы никогда бы не побывали, и "делать" то, что иначе мы никогда бы не сделали.

Всевозможные аппаратные имитаторы самолетов, гоночных машин и космических кораблей уже дали нам попробовать "кусочек" виртуальной реальности. Смоделированные полеты и путешествия пользуются в Диснейленде колоссальным успехом. Программные имитаторы (симуляторы - на жаргоне) вроде Microsoft Flight Simulator относятся к числу самых популярных игр, когда-либо созданных для персональных компьютеров, но пока они в большей мере опираются на воображение самого игрока. Аппаратные имитаторы полетов (стоимостью в миллионы долларов) в таких компаниях, как Boeing, дают гораздо большую степень реальности. Снаружи эти механизмы выглядят так, словно пришли к нам из фильма Star Wars (Звездные войны). Внутри - ряд видеодисплеев, обеспечивающих панорамный обзор, как из настоящей кабины. Все приборы управления связаны с компьютером, который моделирует полетные режимы (включая внештатные ситуации) с точностью, по мнению пилотов, просто изумительной.

Несколько лет назад я и двое моих приятелей "полетали" на имитаторе "Боинга 747". Садишься за пульт управления, идентичный тому, что установлен в кабине настоящего самолета. За окнами показываются генерируемые компьютером цветные видеоизображения. "Взлетая", видишь знакомую панораму аэропорта и его окрестностей. Например, при имитации Boeing Field (аэродром компании) на взлетно-посадочной полосе можно увидеть топливозаправщик, а в отдалении вулкан Рейнир (Mount Rainier). И вот, наконец, слышишь свист воздуха, обтекающего крылья, которых на самом деле нет, и глухой металлический звук, с которым убираются несуществующие шасси. Шесть гидравлических систем под днищем имитатора раскачивают и трясут кабину. Весьма впечатляюще !

Основное назначение подобных имитаторов - выработать опыт управления самолетом в экстремальных ситуациях. Другого шанса у пилота может и не быть. Когда я "летал" на таком имитаторе, мои приятели решили подбросить мне сюрприз, попросив смоделировать внезапное появление небольшого самолета. Только вообразите: сижу я на месте пилота, как вдруг перед самым носом выныривает "Сессна" - ну совсем как настоящая ! Неподготовленный к такой "внештатной ситуации", я, конечно, врезался в этот самолетик.

Ряд компаний - от гигантов индустрии развлечений до небольших начинающих фирм - мечтает установить подобные имитаторы (разумеется, не столь масштабные, как у Boeing) в крупных пассажах и центральных городских районах. С удешевлением технологии развлекательные имитаторы будут удивлять нас не более чем сегодня - кинотеатры. А пройдет не так уж много времени, и один из таких высококачественных имитаторов Вы сможете поставить у себя в гостиной.

Хотите обследовать поверхность Марса ? Гораздо безопаснее сделать это через виртуальную реальность. А как насчет мест, не доступных ни одному человеку ? Кардиолог сможет плавно "пройти" по сердцу пациента и обследовать его так скрупулезно, как не позволит ни один медицинский прибор. Хирург - прежде чем взять в руки настоящий скальпель - сможет попрактиковаться в сложнейших операциях, моделируя самое экстраординарное ее течение. И наконец, виртуальная реальность даст шанс просто побродить по миру собственных фантазий.

Чтобы реализовать ВР, необходимы две группы технологий: программное обеспечение, моделирующее какую-либо сцену и заставляющее ее "реагировать" на новую информацию, и устройства, которые позволят компьютеру передавать информацию нашим органам чувств. Программы должны описывать искусственный мир, его краски и звуки вплоть до мельчайших деталей. На первый взгляд, подобная задача кажется чрезмерно сложной, но это-то как раз проще всего. Такие программы мы могли бы написать и сегодня, но, чтобы виртуальная реальность выглядела действительно правдоподобно, нужны компьютеры, вычислительная мощь которых намного превосходит современные. Впрочем, при современном темпе развития технологии такие компьютеры появятся уже очень скоро. Куда серьезнее другая проблема: как "убедить" органы чувств человека в реальности - простите за каламбур ! - виртуальной реальности ?

Органы слуха обмануть несложно; достаточно надеть наушники. В повседневной жизни оба наших уха воспринимают звуки чуть-чуть по-разному - хотя бы потому, что они "смотрят" в противоположные стороны. Благодаря этому мы подсознательно определяем, откуда идет звук. Программа может воссоздавать эту картину, вычислив, как каждое ухо должно слышать конкретный звук. Такой прием работает безотказно. Вы надеваете наушники, подключенные к компьютеру, и... слева от Вас приглушенный шепот, а где-то сзади - звуки шагов.

Глаза обмануть труднее, тем не менее и зрение моделируется сравнительно легко. В комплект оборудования для создания ВР почти всегда включается специальный шлем с линзами, которые фокусируют каждый глаз на своем крошечном компьютерном дисплее. Датчик, отслеживающий поворот головы, позволяет компьютеру просчитывать, в каком направлении Вы смотрите, затем синтезировать то, что при таком повороте Вы должны увидеть. Повернете голову направо - вид на дисплеях шлема сдвинется правее. Поднимете голову - шлем покажет потолок или небо. Но, увы, нынешние шлемы виртуальной реальности слишком тяжелы, слишком дороги и не дают приемлемого разрешения. К тому же компьютерные системы, управляющие ими, пока что слишком медленны. Если быстро повернуть голову, обзор изменится с ощутимой задержкой. Это сразу же нарушает ориентацию и через короткое время у большинства людей вызывает головные боли. Но есть и обнадеживающий момент. Габариты, скорость, вес и стоимость - как раз те вещи, которые технология, подчиняющаяся закону Мура, исправит уже очень скоро.

Ввести в заблуждение остальные органы чувств куда сложнее, поскольку нет подходящих способов подключить компьютер к носу, языку или поверхности кожи. Что касается осязания, то тут превалирует вполне осуществимая идея: изготовить специальный облегающий костюм с "подкладкой" из миниатюрных датчиков. Они обеспечат обратную связь с устройствами, которые могли бы контактировать со всей поверхностью кожи. Не думаю, что подобные костюмы войдут в моду, но альтернативы им пока нет.

На одном дюйме экрана типичного компьютерного монитора размещается от 72 до 120 мельчайших цветных точек - пикселов (pixels); общее их число колеблется между 300000 и 1 миллионом. По-видимому, изнанка упомянутого костюма будет "соткана" из целого "вороха" сенсорных точек - назовем их "тактилами" (tactels), - каждая из которых сможет надавливать на определенный участок кожи.

При достаточном количестве таких тактилов и тщательном их контроле удастся продублировать практически любое осязательное ощущение. Если множество тактилов будут в унисон надавливать на абсолютно одинаковую глубину, то имитируемая в результате "поверхность" покажется гладкой - как будто Вы прикоснулись к отшлифованной металлической поверхности. Если же они будут надавливать на разную глубину, значения которой распределятся в некоторых пределах случайным образом, Вы почувствуете какую-то шершавую поверхность.

Скорее всего для костюма виртуальной реальности понадобится от 1 до 10 миллионов тактилов (в зависимости от того, сколько уровней глубин требуется отслеживать). Изучение человеческой кожи показывает, что для полноценного костюма виртуальной реальности нужна плотность порядка 100 тактилов на дюйм, а на кончиках пальцев, губах и других чувствительных участках - несколько больше. Но основная часть кожной поверхности на самом деле малочувствительна. Рискну предположить, что 256 тактилов на дюйм хватит даже для самой высококачественной имитации. Кстати, именно столько же цветов каждого пиксела обычно используют на мониторах компьютеров.

Общий объем данных, который придется просчитывать компьютеру, чтобы, скажем так, подавать ощущения в "тактильный костюм", будет в 1 - 10 раз больше того объема, которым манипулируют видеоадаптеры на современных ПК. Это вовсе не много. Уверен, когда появится первый тактильный костюм, персональные компьютеры смогут без проблем управлять им. Вы думаете, это фантастика ? Действительно, лучше всего виртуальная реальность описана в так называемой киберпанковой научной фантастике - вроде той, что вышла из-под пера Уильяма Гибсона (William Gibson). Некоторые его персонажи, вместо того чтобы надевать прилегающий к телу костюм, "подключали" кабель от компьютера прямо к центральной нервной системе. Как это сделать "в жизни", ученым еще предстоит решить, но решение это придет гораздо позже, чем информационная магистраль. Кого-то подобные перспективы ужасают, кого-то интригуют. Однако в любом случае вначале такие системы будут оказывать помощь людям с физическими недостатками.

Тема виртуальной реальности (и готовности принять желаемое за действительное) всегда вызывала массу спекуляций, и большая их часть крутится, конечно же, вокруг виртуального секса. Ведь секс стар, как, впрочем, и сама информация. Это недолго - приспособить новую технологию к древнейшему желанию. Вавилонцы оставили нам эротические поэмы на глиняных табличках (клинопись любовных отношений), а тиражирование порнографии было в числе первых применений печатного пресса. Как только видеомагнитофоны превратились в заурядные бытовые приборы, резко увеличился спрос на видеозаписи, отнесенные к разряду X, а сегодня популярны порнографические CD-ROM-диски. Именно услуги сексуальной ориентации привлекают немалую долю подписчиков Internet или таких систем, как French Minitel. И если тут допустимы исторические параллели, проведу ее: на первых порах наибольшим спросом будут пользоваться как раз те документы, которые имеют отношение к виртуальному сексу. Но, как опять же показывает исторический опыт, с развитием рынка для технологии ВР влияние этого фактора ослабеет.

Воображение сохранит ключевую роль во всех новых приложениях. Только воссоздать окружающий мир - этого недостаточно. Великие киноленты потому и стали великими, что не просто отобразили реальные события, но поднялись до уровня их художественного обобщения. Однако пройдет целое десятилетие, пока новаторы масштаба Д.У. Гриффита (D. W. Griffith) и Сергея Эйзенштейна освоят витаскоп и синематограф братьев Люмьер, потом поймут, что движущиеся картинки позволяют делать нечто большее, чем записывать на пленку эпизод из жизни отдельного человека или театральную постановку. Кинематограф был неизведанной, динамичной формой искусства и по сравнению с театром привлекал зрителей совершенно особыми своими качествами. Первопроходцы уловили это и изобрели кино - такое, каким мы знаем его сегодня.

Принесет ли следующее десятилетие Гриффитов и Эйзенштейнов от мультимедиа ? Есть все основания полагать, что такие люди уже присматриваются к современной технологии, пытаясь угадать, что она способна делать и что они способны сделать с ней.

Думаю, что эксперименты с мультимедиа на том не закончатся и будут продолжаться еще не одно десятилетие. Поначалу мультимедийные компоненты, которые появятся в документах на информационной магистрали, образуют сплав существующих выразительных средств - и это разумный путь. Но со временем мы начнем создавать новые формы и форматы, которые далеко опередят те, что нам известны сейчас. Экспоненциальный рост вычислительной мощности компьютеров по-прежнему будет содействовать развитию инструментов и открывать все новые возможности, которые и в ту эпоху покажутся весьма туманными и заумными, как и некоторое из того, о чем я здесь рассуждал, представляется нам сегодня. Талант и творчество всегда перекраивают достижения науки и техники самым непредсказуемым образом.

У многих ли есть талант, чтобы стать еще одним Стивеном Спилбергом (Steven Spielberg), Альбертом Эйнштейном или новой Джейн Остин (Jane Austen) ? Мы знаем, что, по крайней мере, один такой человек жил на свете, и, может быть, других таких нам уже не встретить. Как это ни печально, но я уверен, что отсутствие денег и инструментов загубило талант и потенциал многих людей. Новые технологии предоставят людям новые средства для самовыражения. Информационная магистраль откроет перед грядущими поколениями гениев невиданные условия для творчества.


Глава 7 - Последствия для бизнеса

Глава 7
Последствия для бизнеса

Появление в документах изрядного объема мультимедийных элементов и освобождение их от бумажных пут существенно обогатит способы общения людей и скажется практически на всех сферах их деятельности - бизнесе, образовании и досуге. Информационная магистраль революционизирует связь даже в больших масштабах, чем вычислительную технику. И в бизнесе этот процесс уже заметен.

Чтобы получить преимущество над конкурентами, компании должны работать эффективнее - отсюда стимул к применению самых производительных технологий. Поэтому электронные документы и сети позволяют улучшить управление информацией и наладить более тесное сотрудничество как между своими подразделениями, так и между внешними партнерами. Персональные компьютеры уже оказали на бизнес колоссальное влияние. Но это влияние проявится гораздо сильнее, когда персональные компьютеры будут объединены и внутри, и за пределами компании.

Пройдет десятилетие, и характер ведения бизнеса повсеместно трансформируется. Программы станут дружественнее, а "нервную систему" организаций будут представлять сети, которые протянутся к каждому работнику и дальше - к поставщикам, консультантам и клиентам. В результате компании станут мобильнее и компактнее. В отдаленной перспективе, когда информационная магистраль ослабит зависимость предприятий от городских структур, многие фирмы децентрализуются, рассредоточат рабочие места, и тогда города (как и компании), быть может, уменьшатся в размерах.

В ближайшие 5 лет пропускная способность коммуникационных линий в деловых районах городов возрастет на два порядка - вследствие конкуренции сетевых провайдеров за крупных заказчиков, сконцентрированных в таких районах. Бизнес будет в числе первых пользователей высокоскоростных сетей. Ведь любая новая компьютерная технология сначала внедряется в бизнесе, потому что именно в нем преимущества более совершенных информационных систем проявляются сразу и очень наглядно.

У менеджеров крупных и малых компаний дух захватывает от перспектив, которые открывает информационная технология. Но прежде чем вкладывать деньги, им все-таки следует вспомнить, что компьютер - это только инструмент, помогающий решать уже выявленные проблемы, а вовсе не магическая панацея от всех бед, как считают некоторые. Когда владелец компании говорит: "Фирма теряет деньги, пожалуй, пора обзавестись компьютером", я сразу же предлагаю ему переосмыслить свою стратегию. Новая техника в лучшем случае лишь оттянет агонию устаревших форм. Первое правило для применения любой техники или технологии в бизнесе: автоматизация эффективной операции умножает ее эффективность. А второе: автоматизация неэффективной операции умножает ее неэффективность.

Вместо того чтобы сломя голову закупать новейшее и мощнейшее оборудование для каждого сотрудника, менеджерам компаний всех калибров сначала надо призадуматься: а каким бы они хотели видеть свой бизнес ? Какие процессы в нем существенны, какие базы данных играют ключевую роль ? В идеале - продумать информационные потоки.

Например, когда Вам звонит заказчик, вся ли связанная с ним информация (состояние счетов, любые жалобы, список сотрудников, занимавшихся этим клиентом) немедленно выводится на экран ? Подобная технология хорошо известна, и клиенты, естественно, ожидают соответствующего уровня сервиса. Если Ваши системы не справляются с моментальным отображением деловой информации или прайс-листов, Вы рискуете проиграть конкуренту, который лучше использует преимущества этой технологии. Скажем, некоторые автомобильные компании собирают и централизованно хранят сервисную информацию, чтобы любой дилер мог быстро проверить данные по конкретной машине или проанализировать закономерность систематических неполадок.

Фирма должна также досконально изучить свою внутреннюю жизнь (проверка сотрудников, планирование, анализ продаж, разработка продукции и др.) и определить, насколько сети и другие информационные инструменты облегчают решение самых разных задач.

В нашем отношении к компьютерам и их использованию произошел заметный сдвиг. В детстве компьютеры представлялись мне чем-то огромным и очень мощным. Их устанавливали у себя банки и авиакомпании. Они были инструментами крупных организаций, частью большого бизнеса, который и этой чертой (среди прочих) отличался от мелких фирм с их пишущими машинками.

Но сегодня персональный компьютер (недаром его так назвали !) - инструмент индивида, даже в крупной компании. И теперь мы относимся к компьютеру как к личной вещи, которая помогает в работе лично нам.

Кто работает в одиночку - создает документы, проверяет новые идеи, с помощью персонального компьютера может делать это гораздо лучше. Один из луддитов (участники движения конца восемнадцатого века, выступавшие против внедрения машин) вполне мог спросить: "Разве улучшился бы почерк у Черчилля, пользуйся он текстовым процессором ? Или Цицерон стал бы от этого красноречивее, выступая в римском Сенате ?" Критики подобного толка почему-то считают: раз гении прошлых эпох обходились без современных инструментов, значит, еще неизвестно, усилят ли творческий потенциал человека более качественные инструменты. Конечно, насколько персональные компьютеры помогают художнику, вопрос пока спорный, но то, что они повышают эффективность деловых процессов, совершенно очевидно. Возьмем обычного репортера. История знает многих талантливых журналистов, но проверять факты и передавать материалы в редакцию сегодня гораздо легче, чем раньше; кроме того, появилась возможность поддерживать электронную связь с источниками новостей, редакторами и даже читателями. Плюс ко всему стало проще включать в материалы высококачественные схемы и рисунки. Вы только взгляните как подаются теперь научные темы. Лет двадцать или тридцать назад научные иллюстрации высшего качества можно было встретить только в солидных научных изданиях или на глянцевых страницах специализированных журналов типа Scientific American. А сегодня научные статьи прекрасно оформлены даже в газетах - отчасти потому, что программное обеспечение для персональных компьютеров легко справляется с самыми замысловатыми чертежами и иллюстрациями.

Не все предприятия получают одинаковый выигрыш от применения персональных компьютеров. В наибольшей степени выиграли малые предприятия, потому что недорогие аппаратные и программные средства помогли им успешно конкурировать с транснациональными корпорациями. В крупных организациях наблюдается тенденция к специализации: одно подразделение пишет документацию, другое - занимается счетами, третье - обслуживанием клиентов и т.д. Обращаясь в крупную фирму, чтобы обсудить, например, финансовую проблему, Вы ждете, что соответствующий специалист быстро ответит на Ваши вопросы.

В то же время уровень ожиданий при обращении к небольшой фирме совсем иной, поскольку понятно, что она не может нанимать большой штат специалистов. Когда свое дело или, скажем, магазин открывает какой-то индивид, он взваливает на свои плечи все: документацию, счета, клиентов. Иногда просто диву даешься, с каким количеством самых разных дел приходится управляться владельцу малого предприятия. А ведь он может приобрести один персональный компьютер и несколько программных пакетов и получить тем самым электронную поддержку всех своих занятий. И в результате малое предприятие действует эффективнее "тяжелой артиллерии".

Однако крупные компании выигрывают в другом. Применение персональных компьютеров улучшает доступ к всевозможной информации. Персональные компьютеры покончили с громадными издержками, которые плодили всяческие совещания по координации работы подразделений, выработке единой политики и прочим внутренним проблемам. Именно поэтому от внедрения электронной почты крупные предприятия получили гораздо больше, чем малые.

Использование информационных инструментов внутри Microsoft началось с перехода на компьютерные распечатки отчетов. Во многих компаниях, заходя в кабинет менеджера высшего звена, видишь на полках переплетенные в книги компьютерные распечатки с ежемесячной финансовой отчетностью, правда, покрытые толстым слоем пыли. В Microsoft подобные материалы доступны только на экранах компьютеров. Если кому-то нужны подробности, он (или она) изучает нужные цифры за определенный период, по определенному региону или отбирает их по иному критерию. Когда мы впервые ввели оперативную систему финансовой отчетности, сотрудники начали видеть цифры в новом ракурсе. Они, например, стали задумываться над тем, почему наша доля рынка в одном регионе отличается от нее где-то в другом регионе. Начав сообща работать с информацией, мы обнаружили кое-какие ошибки. Сотрудники группы обработки данных потом долго каялись, но... "Очень сожалеем об этих ошибках, - говорили они, - однако мы собираем и выдаем эти цифры каждый месяц вот уже целых 5 лет. Проблемы были там с самого начала, и никто ни разу не упомянул о них". А все потому, что печатную информацию не воспринимали в той мере, которая позволила бы отловить ошибки.

Гибкость, достигаемую за счет перевода информации в электронную форму, трудно описать тому, кто не работал с компьютерами. Но лично я теперь больше не смотрю финансовую отчетность на бумаге - только в электронном виде.

Появление в 1978 году первых электронных таблиц стало большим достижением. Они позволили вставлять в ячейки таблиц любые формулы. Элементы формул могут ссылаться на другие ячейки. Поэтому изменение одного значения приводит к немедленному пересчету и всех связанных с ним значений. Тем самым, благодаря электронным таблицам, Вы можете проигрывать сценарии типа "а что если", моментально выявляя эффект от любого изменения.

Некоторые современные электронные таблицы предусматривают множество разных способов для отображения табличных данных. Простые команды осуществляют фильтрацию и сортировку данных. Наиболее знакомое мне приложение этого типа, Microsoft Excel, включает функцию создания сводных таблиц (pivot table feature). Эта функция обеспечивает просмотр итоговой информации самыми разными способами и существенно облегчает восприятие числовых данных. Критерий выборки информации для сводной таблицы изменяется простым щелчком выделенных ячеек или перемещением мышью заголовка столбца с одной стороны таблицы на другую. Тем самым табличные данные можно представить и обобщенной сводкой, и развернутым анализом по любой категории данных, и подробным отчетом.

В Microsoft такие сводные электронные таблицы ежемесячно рассылаются всем менеджерам; они содержат данные по сбыту: отдельно по подразделениям и конкретным продуктам, а также по текущему и прошлому бюджетному году. Далее каждый менеджер быстро выстраивает эту информацию в нужном ему (или ей) виде. Менеджеры по сбыту могут сравнить объем продаж в своем регионе с тем, что планировалось, или с цифрами предыдущего года. А менеджеры, отвечающие за сбыт определенных продуктов, могут проанализировать объем их реализации по странам и т.д. В общем, электронные таблицы дают тысячи возможностей - только щелкни кнопкой мыши.

Рост быстродействия вскоре позволит персональным компьютерам выводить трехмерную графику очень высокого качества, что, в свою очередь, позволит отображать данные эффективнее и нагляднее, чем это возможно в нынешних двумерных презентациях. Прочие достижения еще больше упростят анализ баз данных, Вы даже сможете вслух спрашивать: "Какой продукт идет лучше всех ?"

Такие инновации сначала проявятся в пакетах офисных приложений - комплексах текстовых процессоров, электронных таблиц, систем подготовки презентаций, систем управления базами данных и электронной почты. Некоторые заявляют, что эти инструменты уже настолько напичканы всяческими "наворотами", что нет никакой необходимости в новых версиях. Но и 5, и 10 лет назад им подобные говорили то же самое. Думаю, через несколько лет, когда в ядро приложений будут включаться механизмы распознавания речи, поддержки дружеских интерфейсов и средств подключения к информационной магистрали, у программ появятся совершенно новые возможности, чрезвычайно привлекательные как для фирм, так и для отдельных пользователей.

Самый большой скачок в производительности и самые большие перемены в стиле работы готовит нам переход на широкомасштабное использование сетей. Изначально персональные компьютеры лишь упрощали обработку документов, которые затем распечатывали и рассылали в конвертах. Первые сети, объединявшие не более двадцати ПК, позволяли использовать один принтер для нескольких компьютеров и хранить файлы на центральных серверах. В дальнейшем сети стали расширять, соединяя их друг с другом и с Internet, расширяя таким образом круг пользователей, которые могли связываться между собой. Сегодня такая связь ограничивается в основном передачей коротких текстовых файлов, но со временем появится реальная возможность обмена и теми документами, о которых я рассказывал в шестой главе. Компании, стремящиеся к тому, чтобы каждый сотрудник выиграл от преимуществ совместного использования документов, устанавливают обширные сети, невзирая на их высокую стоимость. Например, подразделение Microsoft в Греции, оплачивая подключение к нашей глобальной сети, расходует больше средств, чем на зарплату сотрудников.

Сегодня электронная почта становится основным способом обмена сообщениями. В ней даже приняты своего рода соглашения по употреблению определенных сочетаний символов. Чтобы подчеркнуть ироничность фразы, введите подряд три символа: двоеточие, дефис и закрывающую круглую скобку. Получившийся значок :-), если смотреть на него сбоку, немного напоминает улыбающуюся рожицу. Например, Вы написали: "Не уверен, что это хорошая мысль :-)", и тогда "улыбка" в конце предложения сказала бы Вашему адресату, что Вы произносите эти слова добродушно, по-дружески. Замена последнего символа на открывающую круглую скобку превращает смеющееся лицо в хмурое :-(, подчеркивая Ваше разочарование. Такие "значки эмоций" (emoticons), дальние родственники восклицательного знака, вероятно, исчезнут с переводом электронной почты в среду, способную нести звук и видеоизображения.

Обмен информацией внутри предприятий традиционно строился на рассылке всевозможных бумаг, телефонных переговорах и/или совещаниях. При этом на выработку продуманных решений уходила масса времени и денег. Неэффективность такого ведения дел очевидна. Компании, действующие по старинке, рискуют проиграть конкурентам, принимающим решения быстрее, с меньшими затратами и, вероятно, с меньшим числом звеньев в цепочке управления.

В Microsoft (как в фирме, работающей в области технологий) электронные коммуникации используются давно. Первую систему электронной почты мы установили еще в начале восьмидесятых. Даже когда у нас было всего 12 сотрудников, она давала заметный эффект и быстро превратилась в главную форму внутриофисной связи. Электронная почта заменила служебные и докладные записки, семинары, отчеты о командировках и телефонные переговоры. Она сказалась на продуктивности труда нашей, тогда еще небольшой компании, ну а сегодня, когда у нас тысячи сотрудников, без нее просто как без рук !

Электронной почтой пользоваться очень легко. Чтобы написать и отправить электронное сообщение, я "нажимаю" большую кнопку с меткой "Compose" (Сообщение). На экране появляется простая форма. Сначала я вписываю туда имя лица (или лиц), которому предназначено мое сообщение, или выбираю его (их) из электронной адресной книги. Я могу даже указать, что хочу отправить сообщение сразу целой группе корреспондентов. Например, я часто пересылаю информацию ведущим сотрудникам, занятым проектом Microsoft Office, и поэтому в моем адресном списке есть и такой адресат - "Offiсе". Если я его выберу, информация дойдет до всех, кого она касается. При передаче сообщения в поле "From" (От кого) автоматически появляется мое имя. Затем я ввожу в сообщение его краткий заголовок. Теперь получатель сразу поймет, о чем оно и от кого. После этого я набираю текст сообщения.

Электронное сообщение - обычно одно-два предложения без всяких любезностей и шуточек. Мне постоянно приходится отправлять трем или четырем лицам электронные сообщения вроде: "Предлагаю отменить встречу в понедельник в 11 утра и использовать это время на подготовку к презентации во вторник. Возражения ?" Ответ может быть предельно краток, скажем такой: "Идет".

Если подобный обмен мнениями Вам кажется слишком лаконичным, не забывайте, что каждый сотрудник Microsoft ежедневно получает в среднем десятки электронных записок. Сообщение электронной почты подобно реплике или вопросу к докладчику - мгновенная реакция на обстановку, одна мысль в процессе непрерывного общения. Разумеется, Microsoft установила систему электронной почты для дела, но, как и офисный телефон, она весьма популярна среди любителей поговорить на личные темы или просто поболтать. Ни для кого не секрет, что заядлые туристы, члены Microsoft Hiking Club (Туристический клуб Microsoft), таким способом сколачивают группы для похода в горы. Кроме того, электронная почта определенно содействовала развитию парочки романов в Microsoft. Да я сам, когда еще только начинал ухаживать за своей будущей женой Мелиндой, назначал ей свидания по электронной почте. Надо сказать, по какой-то причине люди чувствуют себя более раскованно, общаясь по электронной почте, чем по телефону или лицом к лицу. Это может быть и преимуществом, и проблемой - в зависимости от ситуации.

Я провожу несколько часов в день, "разбирая" электронную корреспонденцию от сотрудников, клиентов и партнеров со всего света. Любой работающий в компании может послать мне сообщение по электронной почте, и поскольку я - единственный, кто прочтет его, никому не надо беспокоиться о соблюдении протокола или субординации.

По-видимому, я не тратил бы столько времени, если бы мой электронный адрес не был известен чуть ли не всей публике. Есть такая книга - E-Mail Addresses of the Rich & Famous, - в которую, наряду с электронными адресами таких знаменитостей, как Раш Лимбаф (Rush Limbaugh) и сенатор Тед Кеннеди (Ted Kennedy), включен и мой. Готовя обо мне статью в журнале The New Yorker, Джон Сибрук (John Seabrook) интервьюировал меня в основном по электронной почте. Такой способ диалога оказался очень эффективен, да и статья его мне понравилась, но в ней был упомянут мой адрес в системе электронной почты. В результате меня завалила лавина почты ! Чего там только не было: и послания от студентов, в которых они просили меня, по сути, выполнить за них домашние задания, и просьбы дать денег, и сообщения от группы, выступающей в защиту китов и почему-то включившей меня в свой список рассылки. Мой адрес служит постоянной мишенью и грубых выпадов, и дружеских откликов незнакомцев, а иногда и просто провокационных заявлений прессы (вроде "Если Вы до завтра не ответите на мой вопрос, я опубликую ту историю о Вас и полуголой официантке !").

В Microsoft (в системе электронной почты) есть особые адреса, предназначенные для деловых предложений, обратной связи с покупателями программных продуктов и других легитимных видов общения. Но все равно многое из той почты приходит на мой адрес, и я вынужден переадресовывать ее соответствующим отделам. Кроме того, в электронной почте попадаются три эквивалента писем типа "прочел - передай другому", которые обходят чуть ли не весь город. Одни грозят абстрактными несчастьями, если Вы не переправите их кому-нибудь еще. Другие в этом случае конкретизируют неприятности: чаще всего предрекают разлад в интимных отношениях. А третьи - они встречаются мне уже лет шесть - содержат рецепт домашних булочек и историю о том, как некая компания потребовала у одной женщины слишком много денег за этот рецепт, и поэтому она хочет поделиться им с Вами бесплатно. В разных вариантах писем эта зловредная фирма фигурирует под разными названиями. Очевидно, что это всего лишь попытка какого-то больного человека свести счеты с той или иной корпорацией. Вся эта околесица перемешивается с действительно серьезной и важной для меня почтой. К счастью, программное обеспечение постоянно совершенствуется, и теперь в нем есть функция, позволяющая мне устанавливать приоритет в приеме почты от определенных отправителей.

В поездках я всегда по вечерам подключаю свой портативный компьютер к системе электронной почты в Microsoft, чтобы принять корреспонденцию и отослать ту, что накопилась у меня за день. При этом большинство получателей даже не замечает, что я не в офисе. Подключившись к нашей корпоративной сети с удаленного участка, я могу также узнать, щелкнув единственный значок, как идет сбыт, проверить ситуацию с проектами или обратиться к любым другим базам данных. Когда меня отделяют от офиса тысячи миль и 12 часовых поясов, я прежде всего заглядываю в свой электронный почтовый ящик: именно по электронной почте почти всегда приходят плохие новости. И если их там нет, я спокоен.

Теперь мы используем электронную почту для самых непредвиденных целей. Например, с началом ежегодной кампании по сбору средств на благотворительные нужды (Microsoft Giving Campaign) наши сотрудники получают по электронной почте специальные приглашения. Кроме призыва принять в ней участие, в таких сообщениях содержится программа, управляющая специальной карточкой. Щелчок значка этой программы выводит на экран саму карточку, через которую сотрудник обязуется передать в дар некоторую денежную сумму - наличными или как вычет из зарплаты. В последнем случае данные автоматически заносятся в базу данных Microsoft, по которой составляется ведомость на выплату зарплаты. Карточка позволяет сотруднику направить свой дар непосредственно в местное отделение благотворительной организации United Way или какой-то другой некоммерческой структуры. При желании любой сотрудник может указать, на какой именно вид (или виды) благотворительности должны пойти его деньги в United Way. Он может даже обратиться к соответствующему серверу, чтобы получить сведения о подобных организациях и узнать, как обстоит дело с благотворительностью в их округе. И все это мероприятие с самого начала и до конца проходит только в электронной форме. Поэтому я как руководитель фирмы, ежедневно анализируя поступающие сводки, могу решать, активно ли мы участвуем в благотворительной кампании или надо еще раз воззвать к сознательности.

Сегодня, помимо устанавливаемых в организациях текстовых систем электронной почты - вроде той, что действует в рамках Microsoft, - существуют и коммерческие службы электронной почты, например MCI Mail или В.Т. Gold (ею управляет корпорация British Telecom). Аналогичные услуги предлагаются также всеми коммерческими оперативными службами типа CompuServe, Prodigy и The Microsoft Network. Они выполняют некоторые из тех функций, что раньше выполняли системы передачи телеграмм и - чуть позже - телексов. Пользователи, подключенные к ним, могут отправлять сообщения практически любому, у кого есть стандартный почтовый адрес Internet. Как частные, так и коммерческие системы электронной почты работают через "шлюзы", позволяющие передавать сообщение из одной почтовой системы в другую. Вы можете направить информацию любому пользователю, у которого есть персональный компьютер и модем; правда, некоторые коммуникационные линии не гарантируют конфиденциальности: связь по Internet в этом плане не слишком надежна. А отдельные коммерческие службы, например MCI, могут доставить сообщение и по факсу, и по телексу, и по обычной почте, если у получателя нет доступа к электронному почтовому ящику.

Будущие достижения в области электронной почты, несомненно, значительно увеличат ее эффективность. Задумайтесь, к примеру, как Вы оплачиваете свои счета. Чаще всего соответствующая компания распечатывает счет на клочке бумаги, заклеивает его в конверт, который затем доставляют Вам на дом. Вы открываете конверт, берете счет, сверяете его со своими записями, выписываете чек и спешите с ним на почту, чтобы не опоздать с оплатой. Мы так привыкли к этой процедуре, что даже не замечаем, сколько времени пропадает зря. А допустим, сумма, проставленная в счете, вызывает у Вас сомнения. Значит, придется звонить в эту компанию и разыскивать нужного человека, которого, между прочим, может не оказаться на месте. Тогда придется ждать, когда он перезвонит.

Но пройдет совсем немного времени, и всю корреспонденцию, включая счета, Вы будете просматривать на одном из своих информационных устройств - ПК, компьютере-бумажнике или телевизионной приставке. Когда поступит счет, одно из этих устройств выведет Вам всю хронологию платежей. Если Вы захотите уточнить его, то сделаете это в удобное время асинхронно, - отправив по электронной почте что-нибудь вроде: "Эй, с чего это вы так задрали тарифы ?"

Десятки тысяч предприятий в Соединенных Штатах уже сейчас обмениваются информацией через электронную систему Electronic Document Interchange, или EDI. Она позволяет компаниям, связанным контрактными отношениями, проводить определенные деловые операции автоматически. Но из-за высокой степени структуризации этих операций (повторение заказов на продукцию, проверка прохождения поставок и др.) обычная система EDI не всегда подходит, поэтому сейчас работают над тем, чтобы объединить положительные стороны EDI и электронной почты в единой системе.

Асинхронность электронной почты и EDI - их безусловное преимущество, но и для синхронной связи всегда найдется местечко. Ведь иногда так хочется позвонить близкому человеку, выговориться, найти немедленный сочувственный отклик.

Через несколько лет появятся гибридные системы, которые объединят элементы синхронной и асинхронной связи. Для передачи речевых и прочих данных - задолго до со создания полноценной информационной магистрали - эти системы будут использовать телефонные линии DSVD (а впоследствии и ISDN).

Представим эту цепочку. Отправляя по Internet информацию о своих товарах, фирмы одновременно отправят клиентам инструкции о порядке синхронного соединения с торговым представителем, который ответит на все вопросы по речевой связи. Например, если Вы покупаете бутсы через домашнюю страницу Эдди Бауэра (Eddie Bauer) - электронный каталог - и хотите выяснить, годятся ли они для болотистых равнин Флориды или горных ледников, то, щелкнув кнопку, вызовете торгового агента на линию и поговорите с ним. Тот сразу же поймет, к какому товару Вы приглядываетесь, и получит о Вас любые сведения, которые Вы сочли возможным обнародовать: не только размер одежды и обуви, манера одеваться, любимый цвет, но и спортивные интересы, покупки в других фирмах и даже толщина кошелька. Хотя многие, конечно, предпочтут не сообщать о себе никаких подробностей. Компьютер Эдди Бауэра может направить Ваш запрос тому же сотруднику, который так любезно разговаривал с Вами в прошлый раз, или эксперту по товару, демонстрируемому на экране Вашего компьютера, - в данном случае по бутсам. Без всяких предисловий Вы спросите: "Выдержат ли эти бутсы поход по болотам ?" - или поинтересуетесь чем-нибудь еще. Торговый представитель может сидеть в офисе, а может находиться где угодно, лишь бы у него был персональный компьютер, подключенный к сети. Если он говорит на одном с Вами языке и знает товар, то всегда готов помочь.

Другой пример. Вы решили изменить завещание, звоните своему адвокату. Тот, возможно, предложит: "Давайте займемся этим прямо сейчас". Он выведет Ваше завещание на экран своего ПК, одновременно оно появится и на экране Вашего компьютера - благодаря DSVD, ISDN или аналогичной технологии. Вместе просматривая документ, Вы обсудите с адвокатом любые спорные вопросы. Затем, если адвокат - человек искушенный, Вы увидите, как он вносит в документ изменения. Впрочем, если роль стороннего наблюдателя Вас не устроит, Вы сможете поработать вдвоем. При этом вы будете не только разговаривать друг с другом, но и видеть одинаковое изображение на экранах своих компьютеров.

И не обязательно, чтобы на ваших компьютерах выполнялась одна и та же программа. Текстовый процессор нужен только на одном конце линии - в данном случае у адвоката. Вам хватит соответствующего модема и программного обеспечения DSVD.

Другое важное применение связи типа "речь-данные" - улучшение качества поддержки программных продуктов. У Microsoft тысячи сотрудников только и делают, что отвечают на вопросы покупателей. По сути, численность сотрудников, занятых поддержкой наших программ, сравнялась с количеством их разработчиков. Все это чудесно, потому что обратная связь помогает нам совершенствовать свои продукты. Часть вопросов направляется по электронной почте, но большинство покупателей по-прежнему звонит по телефону. Беседы по телефону очень неэффективны. Покупатель сообщает, что такой-то его компьютер имеет такую-то конфигурацию, а программа выдает такое-то сообщение об ошибке. Специалист по сопровождению продукта высказывает какие-то предположения, на проверку которых у клиента уходит минимум несколько минут. После этого беседа возобновляется. Каждый звонок в среднем занимает 15 минут, а бывает, и около часа. Но когда все перейдут на DSVD, специалист по сопровождению программного продукта сможет наблюдать за тем, что происходит на экране компьютера нашего клиента (при условии, разумеется, что тот разрешит это), и таким образом напрямую изучать ситуацию, а не полагаться на его пересказы. (Здесь надо принять максимум мер предосторожности, чтобы не нарушить чьих-нибудь секретов.) Это сократит продолжительность звонков в среднем на 30 - 40%, снизит наши "телефонные" затраты, что в итоге уменьшит стоимость программных продуктов - клиенты останутся довольны.

При телефонной DSVD- или ISDN-связи один или оба собеседника смогут передавать не только изображение какого-то документа, но и свои портреты. Скажем, звоня куда-то, чтобы сделать покупку, Вы, без сомнения, увидите улыбающееся лицо представителя фирмы. Но как клиент Вы, вероятно, предпочтете передавать только свой голос. Однако при желании совсем не трудно подобрать для показа те снимки, на которых Вы одеты должным образом (поэтому не имеет значения, что Вы носите на самом деле). А может быть, Вы решите заготовить несколько портретов на все случаи жизни: на одном портрете Вы улыбаетесь, на другом - смеетесь, на третьем задумчивы, на четвертом - сердитесь. Ну а в ходе беседы Вы сможете менять выражение лица, подставляя собеседнику свои портреты, отражающие Ваше настроение в данный момент.

Электронная почта и общие экраны (shared screens) исключат проведение многих мероприятий. Широкие презентации новых товаров или услуг заменят на деловые сообщения электронной почты, к которым будут "приложены" электронные таблицы и другие материалы. Даже совещания, организуемые по старинке, станут гораздо эффективнее, потому что его участники заранее успеют обменяться предварительной информацией по электронной почте.

Упростится и планирование встреч, поскольку этим займется соответствующее программное обеспечение. Например, Вам необходимо встретиться со своим адвокатом. Программы-планировщики (Ваша и его) свяжутся между собой по сети - даже телефонной - и подберут тот день и время, когда вы оба свободны. После этого дата встречи будет отражена в ваших электронных календарях. Так же эффективно можно бронировать места в ресторане или в театре.

Хотя тут возникает одно "но". Предположим, в ресторане не слишком много посетителей, или билеты на спектакль расходятся вяло, или адвокат хочет скрыть, что Вы - его единственный клиент. Такие компании или отдельные лица могут проинструктировать свои программы-планировщики отвечать только на просьбы о встрече. В этом случае Ваша программа не сумеет добиться от программы адвоката списка всех его свободных "окон". Но, запросив аудиенцию на конкретное время, она получит ответ: "Да, мы можем принять Вас во вторник в одиннадцать утра".

Любой клиент вправе ожидать от своего адвоката, дантиста, бухгалтера и других специалистов общения в электронной форме (запись на прием, обмен документами). Скажем, в аптеке у Вас может возникнуть вопрос к своему врачу: годится ли предлагаемый заменитель выписанного лекарства ? Хотя, конечно, врача - в отличие от других специалистов - отрывать от дел нежелательно.

Вскоре мы станем свидетелями конкурентной борьбы внутри различных профессиональных групп: кто быстрее и с большей отдачей внедрит у себя эти средства связи. В своей рекламе фирмы будут особо подчеркивать, насколько далеко они продвинулись в использовании коммуникационных систем на базе ПК.

Когда появится информационная магистраль, способная передавать и высококачественное видео, люди уже не будут ограничены одним лишь звуком и неподвижными картинками. Встречи и совещания будут все чаще проводиться именно в электронной форме, по принципу видеоконференций. Каждый участник подобной встречи - независимо от того, где он находится, - сможет наблюдать за ходом событий на экране своего видеопроектора, телевизора или ПК, но все они будут показывать в основном совпадающее изображение. Одну часть экрана может занимать какой-то документ, в другой Вы увидите чье-то лицо. Если кто-то внесет в документ изменения, они немедленно отразятся на экранах всех участников совещания. Расстояния - больше не помеха для плодотворного сотрудничества партнеров. Это и есть совместное использование информации в синхронном режиме (или в режиме реального времени) через общие экраны.

Если на "электронную встречу" собирается группа по подготовке пресс-релиза, ее участники смогут редактировать текст, вставлять фотографии или видео, пользуясь своим персональным компьютером или ноутбуком. При этом вклад каждого в совместную работу тут же отразится на экранах всех членов группы.

Мы уже привыкли к видеоконференциям. По этому принципу строится, например, телепередача новостей Nightline, где комментируют события аналитики из разных городов. Ведущего и гостей студии могут разделять целые континенты, а они обмениваются мнениями так, будто находятся в одном помещении - зрителю даже кажется, что так оно и есть.

Сегодня видеоконференции должны проходить в специально оборудованном помещении со специальными телефонными линиями. Каждое представительство Microsoft во всех странах мира имеет как минимум одно такое помещение. Поэтому видеоконференции - явление довольно частое, но обставляются они весьма официально. Видеоконференции сокращают число поездок. Сотрудники заграничных филиалов "сидят" на собраниях персонала в нашем центральном офисе в окрестностях Сиэтла, а клиенты и поставщики "заходят" туда, не тратя сил на дорогу. Такие собрания и визиты станут очень популярны (так как экономят время и деньги) и наверняка гораздо продуктивнее селекторных совещаний или очных встреч (многие делаются собраннее, зная, что их снимает камера).

Я заметил, однако, что к этому надо еще привыкнуть. Присутствующему на экране человеку всегда уделяется значительно больше внимания, чем остальным участникам видеоконференции. Впервые я осознал это, когда вместе с несколькими сотрудниками проводил видеоконференцию со Стивом Балмером, который в то время находился в Европе. Мы все тогда словно прилипли к экрану, неотрывно наблюдая за шоу Стива Балмера. Если бы Стив снял ботинки, мы бы стали оглядываться на реакцию друг друга. Когда совещание закончилось, я мог детально описать новую стрижку Стива, но вряд ли бы назвал тех, кто был вместе со мной. Думаю, что со временем, когда видеоконференции станут чем-то обыденным, этот побочный эффект пройдет.

Оборудование для видеоконференций обходится пока совсем недешево - минимум в 40000 долларов. Однако на подходе настольные системы, подключаемые к персональным компьютерам; с их появлением стоимость - и степень официальности ! - видеоконференций существенно снизится. Наше оборудование в основном подключено к ISDN-линиям с пропускной способностью 384000 бит в секунду, что обеспечивает приемлемое качество картинки и звука при тарифе от 20 до 35 долларов в час в пределах Соединенных Штатов и от 250 до 300 долларов в час при международных соединениях.

Снижение стоимости видеоконференций, как и других услуг, базирующихся на компьютерных технологиях, напрямую связано с падением цен на вычислительную технику и средства связи. Компактные устройства (их видеокамеры прикрепляются к мониторам персональных компьютеров или к телевизорам) через информационную магистраль без всяких проблем позволят проводить видеоконференции с более высоким качеством изображения и звука при меньшей стоимости. Когда персональные компьютеры повсеместно подключат к ISDN-линиям, видеоконференции станут в бизнесе такой же стандартной процедурой, как сейчас размножение документов на "ксероксах".

Кто-то беспокоится, что видеоконференции и общие экраны превратят корпоративные собрания в некое подобие телевизионного просмотра слушаний в Конгрессе. Как люди смогут перешептываться, закатывать глаза от скучного докладчика или передавать записки ? В действительности на видеоконференции такое неформальное поведение (украдкой) станет даже проще, потому что сеть, помимо всего прочего, облегчает индивидуальное общение. Однако на собраниях всегда действовали свои неписаные правила, и проведение собраний через сети потребует узаконить некоторые из этих правил. Насколько допустимо как-то показать, что человеку неинтересно ? В какой мере он может скрывать свое видеоизображение или речь от других ? Допустимы ли "побочные" связи между персональными компьютерами участников видеоконференции, т.е. как относиться к "перешептыванию в зале" ? Уверен, со временем все это утрясется и появится новый этикет собраний.

Домашние видеоконференции, естественно, будут несколько иными. Если в них всего два участника, это напомнит разговор по видеофону. Ведь как здорово поприветствовать своих детей, когда тебя нет в городе, или показать ветеринару пораненную лапу твоей собаки или кошки. Но в большинстве случаев, находясь дома, Вы наверняка будете отключать видеокамеру, особенно если позвонит незнакомый человек. Может быть, в такой ситуации Вы предпочтете транслировать неподвижную заставку: свой портрет, или семейный снимок, или какое-то другое изображение, которое, на Ваш взгляд, точно передает Вашу индивидуальность, но защищает "визуальную неприкосновенность". Это очень похоже на подбор вежливых, но обезличенных фраз для автоответчика. А "живое" видео Вы включите лишь тогда, когда позвонит близкий друг или когда того потребует дело.

Все синхронные и асинхронные изображения, о которых я говорил до сих пор - фотографии, видео или документы, - отражали какой-то фрагмент реальной действительности. А когда компьютеры станут мощнее, стандартный ПК сможет синтезировать реалистичные изображения. Ваш телефон или компьютер сформирует, например, цифровое изображение Вашего лица, показывая, как Вы слушаете или даже говорите. Вы и впрямь будете разговаривать по телефону - ведь для этого Вы и выскочили мокрым из душа. Но телефон представит Вас в лучшем выходном костюме. При этом выражение Вашего лица будет соответствовать словам (не забывайте, что маленькие компьютеры скоро станут очень мощными). Так же легко телефон передаст Ваши слова, синтезируя облик другого человека или некий идеализированный образ. В разговоре с совершенно незнакомым человеком - чтобы тот не заметил у Вас бородавку или двойной подбородок, - можно прибегнуть к помощи компьютера, и незнакомец никогда не узнает, что на самом деле Вы вовсе не такой красавец, как Кэри Грант (Cary Grant) или Мег Райан (Meg Ryan).

Все эти электронные инновации - электронная почта, общие экраны, видеоконференции и видеофон - способы преодоления разделяющего собеседников пространства. Их повсеместное распространение не только повлияет на методы нашей работы с другими людьми, но и снивелирует нынешние различия между рабочим и не-рабочим местом.

В 1994 году в Соединенных Штатах уже более 7 миллионов человек не ходили ежедневно в офисы, а работали дома и поддерживали связь с внешним миром через факсы, телефоны и электронную почту. (Их иногда называют "telecommuters" - те, кто общается по телекоммуникациям.) Некоторые писатели, инженеры, адвокаты и представители других профессий, чья деятельность сравнительно автономна, уже проводят дома часть рабочего времени. А возьмите коммивояжеров или торговых агентов. Об их работе судят прежде всего по результатам, и, пока они обнадеживающие, никого особо не волнует, где именно трудится человек: в офисе, дома или в дороге. Большинству нравится этот свободный образ жизни, но некоторые считают, что так недалеко и до клаустрофобии - все время проводить дома. Ну а кому-то просто не хватает самодисциплины для эффективной работы вне офиса. В будущем, однако, ряды telecommuter'ов пополнят миллионы людей, которые через информационную магистраль будут работать дома (по крайней мере, часть своего времени).

Те, кто работает в основном "на телефоне", тоже верные кандидаты в telecommuter'ы, потому что все звонки легко переадресовать им домой. Представители сервисных служб, диспетчеры, специалисты по технической поддержке продукции получат дома доступ к той же информации, что и в офисе. Спустя десятилетие во многих объявлениях о найме среди прочих условий появятся упоминания о количестве часов в неделю, которые надо провести в офисе (если это вообще понадобится). Некоторые вакансии потребуют от работника наличия персонального компьютера для работы исключительно на дому. Кроме того, организации, связанные с обслуживанием клиентов, смогут нанимать дополнительных сотрудников на неполный рабочий день.

Физическое отделение работника и работодателя потребует от администрации соответствующей перестройки управления, а от сотрудников - продуктивной работы при полной самостоятельности. Понадобятся также новые механизмы обратной связи, чтобы и работник и наниматель могли адекватно оценивать качество выполненной работы.

Предполагается, что в офисе сотрудник непрерывно занят весь рабочий день; тот же сотрудник, работая дома, получает зарплату (возможно, по другой ставке) только за время, действительно отданное службе. Допустим, если вдруг заплачет малыш, папа или мама щелкнет какую-нибудь кнопку вроде "занят" и отправится успокаивать ребенка, - эти минуты уже не зачтут в рабочий день. Вернувшись к компьютеру, он (или она) подаст сигнал о готовности, и сеть вновь начнет передавать рабочие материалы, требующие его (или ее) внимания. Так что работа по неполному графику и совместительство приобретут новый смысл.

Все эти процессы, вероятно, резко сократят число офисов, необходимых компаниям. Единственный офис могли бы обслуживать несколько человек, распределив между собой "присутственные" часы. Такие крупные аудиторские фирмы, как Arthur Andersen и Ernst & Young, уже сейчас заменили множество дорогостоящих персональных кабинетов небольшим количеством общих кабинетов, где сидят те аудиторы, чьи дела требуют присутствия в офисе. Завтра компьютеры, телефоны и цифровые видеопанели в таком общем кабинете будут подстраиваться непосредственно под того, кто его занимает в данное время. Например, в первой половине дня видеопанели покажут календарь, семейную фотографию и любимые комиксы одного сотрудника, а во второй половине дня - картины, к которым неравнодушен сотрудник, его сменивший. Подобная "трансформация" кабинета будет происходить всякий раз, как только очередной сотрудник зарегистрируется на рабочем месте, а возможной она станет после появления цифровых видеопанелей и информационной магистрали.

Но наибольшее влияние на характер труда окажет, безусловно, информационная технология. Она потребует пересмотреть саму природу почти всех занимающихся бизнесом организаций, в том числе их структуру и соотношение численности постоянного персонала, внешних консультантов и фирм.

Перестройка корпораций начнется с той логической посылки, что любая компания может быть организована лучше. На сегодняшний день основное внимание уделяется внедрению новых способов внутриофисного обмена информацией. Следующим шагом станет переопределение границ между компанией, ее клиентами и поставщиками. Придется по-новому ответить на ключевые вопросы: как клиенты узнают о Вашей продукции ? Как они ее заказывают ? Насколько расширится круг Ваших конкурентов, когда географические расстояния не будут иметь значения ? Как лучше наладить сервис, чтобы клиенты были довольны и после покупки Ваших товаров ?

Реконструкция коснется и самих структур крупных компаний. Электронная почта - мощный фактор сокращения управленческих иерархий любой корпорации. Если коммуникационные системы достаточно хороши, много уровней управления и не требуется. Среднее звено управления, передающее информацию вверх-вниз по командной цепочке, сегодня уже не играет той роли, что раньше. Microsoft родилась как компания информационного века, и ее структура всегда была сравнительно простой. Мы стремимся к тому, чтобы между мной и любым сотрудником было не более шести уровней управления. Но благодаря электронной почте между нами в определенном смысле вообще нет никаких уровней управления.

Когда технология будет помогать бизнесу в поиске внешних экспертов, когда она упростит сотрудничество с ними, перед консультантами откроется огромный, конкурентоспособный рынок. Если Вам понадобится специалист для подготовки рекламных материалов, Вы запросите - через программы, действующие на информационной магистрали, - список консультантов определенной квалификации, свободных в такое-то время и согласных на такой-то тариф. Таким образом программное обеспечение отфильтрует все не подходящие Вам предложения. Вы сможете даже поинтересоваться: "Есть ли в числе этих кандидатов кто-нибудь, кто уже работал на нас и получил разряд выше восьмого ?" Услуги подобной системы станут настолько дешевы, что впоследствии Вы поручите ей подбирать к ребенку приходящих нянь или нанимать людей для стрижки Ваших газонов. Если Вы ищете работу по найму или по договору, система позволит связаться с потенциальными работодателями и одним щелчком кнопки переслать им в электронной форме Ваши резюме.

Компании займутся переоценкой и таких кадровых проблем, как оптимальная численность сотрудников юридических и финансовых отделов, взвешивая все "за" и "против" их работы непосредственно в штате. В периоды особо активной деятельности компании смогут без труда обращаться за помощью к нужным специалистам, обходясь без расширения штатов и офисов. Предприятия, научившиеся успешнее привлекать доступные по сети ресурсы, будут работать эффективнее, вынуждая и остальных следовать их примеру.

Многие фирмы станут значительно компактнее, потому что информационная магистраль позволит легко находить внешние ресурсы и активно работать с ними. В бизнесе большое не значит хорошее. Например, у голливудских студий постоянный штат на удивление мал, а все потому, что они нанимают основных работников, включая актеров, и зачастую арендуют оборудование под конкретные фильмы. Аналогичной модели придерживаются и некоторые программистские фирмы, нанимая программистов только по мере надобности. Конечно, выполнение многих функций компании по-прежнему возлагают только на постоянных сотрудников. Не всегда разумно зависеть от свободного времени в расписании какого-нибудь специалиста, особенно когда работа срочная. Но отдельные должностные обязанности, безусловно, можно рассредоточить как в организационном, так и в географическом смысле.

Географический фактор важнее структуры корпораций. Многие из крупных социальных проблем современности обусловлены непрерывным ростом городского населения. Недостатки жизни в городах очевидны: тут и уличные пробки, и высокая стоимость жизни, и преступность, и загрязнение воздуха, не говоря уже о других проблемах. Но есть и много преимуществ: разнообразие рабочих мест, сервис, развитая сеть образования, развлечений, друзья. За последнюю сотню лет большая часть населения индустриально развитых стран, сознательно или подсознательно взвесив все "плюсы" и "минусы", предпочла жить в городах.

Информационная магистраль изменит этот баланс. Она существенно уменьшит недостатки проживания вдали от больших городов - тем, у кого будет с ней связь. Как консультант или работник сферы технического сервиса, Вы сможете сотрудничать практически с любой фирмой, где бы она ни находилась. Как потребитель, Вы сможете, не покидая дома, получить любые услуги - финансовые, юридические и даже некоторые медицинские. Вам не придется всякий раз куда-то ехать, чтобы повидаться с друзьями или с семьей. Через информационную магистраль можно приобщаться и к новинкам культурной жизни, хотя, как мне кажется, бродвейский или уэст-эндский мюзикл в гостиной - не совсем то же, что в нью-йоркском или лондонском театре. Однако увеличение размеров и разрешения экранов улучшит и в домашней обстановке восприятие всех типов видеоизображений, включая фильмы. Резко возрастет число образовательных программ. Все это развяжет руки тем, кто давно мечтал поменять городской дом на сельский.

Создание системы шоссейных дорог, связавших штаты, непосредственно сказалось на том, где именно предпочитают жить американцы. Она сделала доступными новые пригороды и внесла свой вклад в развитие автомобильной культуры. Возможно, и открытие информационной магистрали подтолкнет людей к переселению из городских центров. Для архитекторов, строителей и других муниципальных служб это будет иметь серьезные последствия. Если к тому же произойдет географическое распределение талантливых людей, компании будут искать более творческие подходы к совместной работе с консультантами и сотрудниками, проживающими вдали от сфер действия этих фирм. А это вызовет новый цикл положительной обратной связи, поощряя людей к жизни в сельской местности.

Уменьшение численности населения городов хотя бы на 10% приведет к значительному снижению стоимости земельных участков, затрат на амортизацию в транспортных и других городских системах. Если бы средний клерк в крупном городе хотя бы один или два дня в неделю оставался дома, это значительно бы сократило расход бензина, загрязнение атмосферы и количество уличных пробок. Но точно предугадать все последствия сейчас еще трудно. Если в числе "переселенцев" будут преобладать работники умственного труда высшей квалификации, налоговая база городов может оскудеть, что усилит внутригородские проблемы и подтолкнет к переезду остальных работников этой категории. В то же время уменьшится нагрузка на городские инфраструктуры, упадет квартирная плата, что создаст условия для повышения уровня жизни оставшихся горожан.

Однако все эти перемены растянутся на десятилетия, потому что большинству удобнее жить так, как они привыкли с детства, не меняя своих привычек. Однако новые поколения легко усваивают идеи работы с информационными инструментами, не скованными пространствами. Эти инструменты будут для них так же естественны, как для нас - телефон или шариковая ручка. Но технология не станет ждать, когда к ней будут готовы люди. В ближайшие 10 лет произойдут существенные подвижки в том, где, как и на какие компании мы работаем, где и с кем мы предпочитаем жить. Мой Вам совет - постарайтесь узнать о технологии, которая непременно коснется и Вас, как можно больше. Чем больше Вы о ней будете знать, тем меньше она Вас будет страшить. Роль технологии состоит в том, чтобы обеспечивать рост гибкости и эффективности. Перед менеджерами, умеющими смотреть в будущее, открывается великое множество перспектив.


Глава 8 - Капитализм без трений

Глава 8
Капитализм без трений

Представляя концепцию рынка, Адам Смит в своем труде The Wealth of Nations (Исследования о природе и причинах богатства народов, 1776 год) писал: если бы каждый покупатель знал о ценах каждого продавца, а каждый продавец знал, сколько готов заплатить каждый покупатель, тогда все принимали бы на "рынке" абсолютно взвешенные решения и ресурсы общества распределялись бы эффективнее. Но до сих пор идеал Смита не достигнут, потому что претенденты на роль покупателей и продавцов не располагают полной информацией друг о друге.

Редкий покупатель в поисках стереомагнитолы для своей автомашины имеет время и терпение, чтобы обойти всех торговцев, а значит, он действует на основе неполной и неточной информации. Вот и получается: купив такой аппарат за 500 долларов, спустя неделю или две Вы увидите рекламу, предлагающую то же самое за 300. Но это еще что ! Хуже, если Вы вообще выбросите деньги на ветер, купив не то, что надо, - просто из-за отсутствия нужных сведений.

Лишь очень немногие рынки приблизились к идеалу Адама Смита. Инвесторы, покупающие и продающие валюту и некоторые другие ценности, имеют дело с эффективными электронными рынками, которые обеспечивают их исчерпывающей информацией о предложении, спросе и ценах в любой точке мира. Каждый из них поставлен практически в равные условия, потому что сведения обо всех предложениях, заявках на торги и сделках одновременно поступают во все конторы. Однако большинство других рынков работает крайне неэффективно. Например, если Вы попытаетесь найти врача, адвоката, аудитора, какого-то другого специалиста или захотите купить дом, то сразу же столкнетесь с ограниченностью информации на этот счет и увидите, что сравнивать предложения весьма трудно.

Информационная магистраль расширит электронный рынок, сделает его связующим звеном, универсальным посредником. И зачастую единственными участниками сделки будут выступать только истинный покупатель и продавец. Все товары, выставленные на продажу по всему миру, Вы сможете проверить, сравнить и даже попросить подогнать или дооборудовать в соответствии со своими требованиями. Решив что-то приобрести, Вы поручите своему компьютеру найти этот товар по лучшей цене из любого приемлемого источника или попросите его "поторговаться" с компьютерами продавцов.

Информация о продавцах, их товарах и услугах будет доступна любому компьютеру, подключенному к магистрали. Распределенные по всему миру серверы будут реализовывать заявки (на покупку) и предложения (о продаже) в конечные сделки, проводить аутентификацию, обеспечивать безопасность, в том числе переводов денежных средств, одним словом, поддерживать жизнедеятельность рынка. Воцарится рай для покупателей - новый мир капитализма с низким "коэффициентом трения", в котором рыночная информация в изобилии, а издержки на заключение сделок минимальны.

Любой рынок, от толкучки до магистрали, способствует формированию конкурентоспособных цен и эффективной передаче товаров - от продавца к покупателю с умеренным "коэффициентом трения". В этом немалая заслуга посредников, ведь именно они сводят покупателей и продавцов. Однако постепенно информационная магистраль возьмет на себя функции посредников, заставив последних, чтобы заработать комиссионные, расширить свое участие при заключении сделок. Например, магазины и сервисные фирмы, которые до сих пор извлекали доходы только потому, что расположены на бойком месте, в выгодной географической точке, наверняка потеряют это преимущество. Но те из них, кто внесет реальную добавленную стоимость, не просто выживут - преуспеют, так как магистраль даст им возможность предлагать свои услуги потребителям по всему миру.

Уверен, переход коммерции на магистраль вызовет в розничной торговле самые серьезные изменения. Такие перспективы не всем придутся по вкусу, ведь большинству всегда кажется, что новое, неизведанное таит в себе какую-то опасность или угрозу. Впрочем, привыкнув к переменам, мы, по своему обыкновению, еще будем удивляться, как это обходились без них раньше. Потребитель не только выиграет за счет ценовой конкуренции, но и получит гораздо больший ассортимент товаров и услуг. Сеть магазинов, вероятно, уменьшится, их число определит спрос, если людям вообще не разонравится совершать променад за покупками. Упрощая и стандартизуя "шоппинг", информационная магистраль сбережет Ваше время. Покупая подарок любимому человеку, Вы будете иметь куда больший выбор товаров и, конечно, сможете найти что-нибудь весьма необычное. Время, сэкономленное на покупке, Вы потратите на то, чтобы придумать забавный рисунок на упаковку или смешной текст на поздравительную открытку, но еще лучше - провести его с любимым.

Мы все ценим совет компетентного продавца, приобретая одежду, ювелирные изделия, ценные бумаги, видеокамеру, бытовые приборы или дом. Мы все также знаем, что мнение такого человека не всегда объективно, ведь он (или она) стремится продать товар из определенного каталога.

На информационной магистрали основные сведения о товарах будут поступать непосредственно от их производителей. Как и сегодня, торговые фирмы, чтобы привлечь нас, будут изобретать все новые ухищрения и трюки. Реклама превратится в некий симбиоз того, что сейчас передают по телевизору, печатают в журналах и торговых каталогах. Если реклама какого-то товара заинтересует Вас, гиперсвязи позволят просмотреть не только дополнительные сведения об этом товаре, но и любую другую информацию, например руководства по эксплуатации, включающие, кроме текста, видео- и звукозаписи. Поставщики, естественно, постараются, чтобы вся эта информация была легко доступна.

Мы в Microsoft будем использовать магистраль для распространения информации о наших продуктах. Сегодня мы печатаем миллионы страниц всевозможных рекламных брошюр, спецификаций и рассылаем их по почте всем, кто их запрашивает. Но никто точно не знает, какой именно объем сведений нужен в спецификациях на программные продукты: ведь их читают и случайные люди, и просто любопытные, и те, кто по-настоящему стремится разобраться во всех тонкостях. Кроме того, из-за быстрого изменения ситуации на нашем рынке только что отпечатанные десятки тысяч экземпляров какой-то брошюры зачастую приходится выбрасывать: в ней речь шла о той версии продукта, которую мы уже заменяем новой. Поэтому в дальнейшем наша информация будет распространяться в основном в электронной форме, тем более - мы обслуживаем пользователей компьютеров. Мы уже не печатаем эти миллионы страниц на бумаге, вместо них ежеквартально рассылая компакт-диски, а к самым требовательным своим клиентам, профессиональным программистам, обращаемся через оперативные службы по сетям.

Но Вы вовсе не обязаны полагаться только на то, что говорим мы или любой другой производитель. Обратитесь к более объективным источникам информации - обзорам тех или иных товаров. Познакомившись с рекламой, обзорами и мультимедийными руководствами, запросите соответствующие правительственные постановления. А потом проверьте, обслуживает ли поставщик свою продукцию. После этого копните и поглубже - в ту область, которая Вас интересует больше всего (например, срок службы данного товара). Или прибегните к помощи торговых консультантов. Они будут публиковать специализированные обзоры по всем типам товаров: от насадок для дрелей до балетных тапочек. Ну и конечно, Вы по-прежнему будете узнавать мнение своих знакомых, но сделаете это гораздо эффективнее - по электронной почте.

Если Вы подумываете о совместном бизнесе с какой-нибудь фирмой или о покупке какой-то вещи, то сможете выяснить, как о них отзываются другие. Собираясь приобрести, скажем, холодильник, Вы заглянете на электронные доски сообщений с официальными и неофициальными обзорами холодильников, а также на электронные доски соответствующих фирм-производителей и торговцев. И вообще, у многих появится привычка перед крупной покупкой просматривать такие электронные доски. Если Вам захочется выразить свое впечатление о каком-то враче, клубе или даже о компьютерном чипе, Вы легко найдете в сети место, где обсуждают соответствующую компанию или продукт, и внесете в это дело свою лепту. В результате компании, плохо обслуживающие своих клиентов, увидят, что их репутация и объем продаж начинают падать, тогда как у хорошо работающих фирм, напротив, число верных им клиентов растет.

Однако все отзывы - и одобрительные, и особенно отрицательные необходимо проверять весьма тщательно. Ведь они могут исходить от ярых фанатиков, а не от людей, которые просто решили поделиться своими соображениями.

Предположим, фирма торгует кондиционерами, которыми 99,9% покупателей очень довольны. А один сердитый покупатель (из числа оставшихся 0,1%) завалил электронную доску "письмами", изливая свою желчь по поводу и этой марки кондиционеров, и компании, которая их выпускает, и ее обслуживающего персонала. Эффект сравним с тем, как если бы Вы сидели на собрании, где каждый может регулировать усиление своего микрофона от 0 до 1000 (при нормальном уровне, скажем, 3), и несколько человек, поставив громкость на всю 1000, начали истошно орать. В общем, если я тоже соберусь купить кондиционер и загляну на подобную электронную доску сообщений, "визит" окажется пустой тратой времени: все, что я застану здесь, - несколько горлопанов. А это будет нечестно и по отношению ко мне, и по отношению к фирме, торгующей кондиционерами.

К счастью, уже сейчас начинает складываться своеобразный сетевой этикет, "сетикет" ("netiquette") - правила поведения в сети. Превращая информационную магистраль в своего рода городскую площадь перед ратушей, мы вправе ожидать, что она будет отвечать уровню нашей культуры. Но в мире бездна разных культур, и поэтому магистраль разделится на части; одни выделят специфическим традициям и нравам, другие отдадут для всеобщего пользования. А пока превалируют пограничные умонастроения, участники электронных форумов частенько поступают не самым лучшим образом, а иногда просто незаконно. Свободно распространяются нелегальные копии защищенной авторскими правами интеллектуальной собственности, в том числе статьи, книги и программы. То тут, то там всплывают всякие мошеннические пособия на тему "как быстро разбогатеть". Процветает порнография, легко доступная детям. Некоторые почти маниакально злословят о программах, товарах, фирмах и людях, которых они почему-либо недолюбливают. На головы участников форумов, стоит им что-то прокомментировать, тут же обрушиваются потоки грязных ругательств. Легкость, с которой индивид - любой индивид ! - может поделиться своим мнением с членами огромного электронного сообщества, просто беспрецедентна. И те, кто любит вопить громче всех, могут свободно раскидывать свои злобные послания хоть на 20 электронных досок. Я сам видел, во что превращались некоторые электронные доски, когда там объявлялись любители "поорать". Остальные участники дискуссии обычно терялись, не зная, что делать. Кто-то начинал отвечать в том же духе, кто-то пытался высказывать здравые вещи. Но поток желчных посланий не ослабевал и очень быстро разрушал чувство общности людей.

Internet, верный традициям академического сообщества, всегда полагался на саморегуляцию - через баланс давления и противодавления. Например, если кто-нибудь из дискуссионной группы присылал сообщение на отвлеченную тему или, хуже того, пытался продать что-то на электронном форуме, который остальными расценивался как весьма далекий от коммерции, то этот претендент на роль отступника или лавочника мог просто захлебнуться в лавине обрушивавшихся на него упреков. Так что до сих пор за соблюдением нравственных норм следили в основном самозваные цензоры, немедленно отправлявшие "на костер" всякого, кто, по их мнению, переступал рамки приличий и демонстрировал антиобщественное поведение.

Коммерческие оперативные службы нанимают добровольцев и профессиональных сотрудников, которые должны следить за порядком на их электронных досках сообщений. Форумы под таким наблюдением отфильтровывают часть антиобщественных элементов, отказывая в приеме на серверы неприличных сообщений или пиратской информации. Однако на большинстве форумов Internet такой опеки нет. Там творится все что угодно, и никто ни за что не отвечает, потому что все действуют анонимно. Надо выработать какие-то процедуры, чтобы спорить, не доходя до "рукоприкладства", чтобы потом не апеллировать к отделу защиты прав потребителей при главном прокуроре штата. Надо найти какие-то способы заставлять людей "снизить тон", чтобы магистраль не стала рупором клеветы и оскорблений или местом, где можно выплеснуть свое раздражение.

Многие провайдеры стараются сейчас сузить доступ к форумам с явно выраженной сексуальной ориентацией, а недавно начались атаки на незаконное распространение материалов, защищенных авторскими правами. В ряде университетов студентов и преподавателей заставляют удалять нежелательную корреспонденцию. Некоторым это как кость в горле, потому что киберпространство кажется им местом, где можно все. У коммерческих служб аналогичные проблемы. На них сыпятся жалобы из-за ограничений на свободу общения. Беснуются родители, у которых аннулируют учетную запись из-за того, что их одиннадцатилетнее чадо нагрубило наблюдателю. Все это вынудит компании создавать в Internet особые сообщества и устанавливать в них такие правила, которые избавят от этих проблем.

Политики уже ломают головы над тем, в каких случаях оперативные службы следует считать общественными носителями связи, а в каких - издателями. например, телефонные компании по закону рассматриваются общественными носителями связи. Они всего лишь передают сообщения, не отвечая за их содержание. Если кто-то досаждает Вам непристойными звонками, телефонная компания может скооперироваться с полицией, но никому и в голову не придет обвинять ее в том, что какой-то подонок звонит Вам и говорит всякие гадости. С другой стороны, журналы и газеты являются издателями. Они отвечают перед законом за содержание публикуемых ими материалов и могут быть привлечены к ответственности за клевету. Кроме того, они заинтересованы в поддержании своей репутации и издательской ориентации - это важная часть их бизнеса. Любая солидная газета всегда тщательно проверяет публикуемые материалы - и не только потому, что стремится избежать обвинений в клевете, но и потому, что искажение фактов просто подорвет ее позиции.

А оперативные службы одновременно выступают и как общественные носители связи, и как издатели - именно здесь корень всех проблем. Когда они действуют как издатели и предлагают материалы, которые сами заказали, подготовили, или отредактировали, тогда, действительно, на них должны распространяться законы об издательской деятельности. Но когда они доставляют нам электронную почту, выступая общественными носителями связи, которые не вникают в содержание корреспонденции, всякая ответственность за нее должна быть снята. Электронная почта, "гостиные", электронные доски и форумы, позволяющие общаться без всякого надсмотра, являются новыми средствами связи, и их следует отличать от материалов, публикуемых оперативной службой. Однако совсем недавно нью-йоркский судья дал ход судебному процессу по обвинению в клевете, постановив, что вовлеченная в тяжбу оперативная служба является издателем информации, а не просто ее дистрибутором. Возможно, к тому времени, когда Вы будете читать мою книгу, ситуация прояснится. Слишком высоки здесь ставки. Ведь если сетевых провайдеров всецело рассматривать как издателей, значит, им придется следить за содержанием всей передаваемой ими информации. По сути, это будет означать введение цензуры и может крайне неблагоприятно сказаться на свободе обмена мнениями, такой важной в электронном мире.

В идеале нужно выработать ряд стандартов, которые позволят при входе на электронные доски сообщений или при обращении к их материалам как-то помечать, стоит ли за ними какой-либо "издатель". Вопрос в том, какие это должны быть стандарты и кто будет осуществлять надзор за их соблюдением. Электронная доска для лесбиянок не должна принимать сообщений антилесбиянской направленности, а электронную доску, посвященную обсуждению какого-то продукта, не должны переполнять сообщения от конкурентов. Весьма неразумно запрещать детям выходить на какие бы то ни было электронные доски, но в то же время нереально - и, наверное, это было бы нарушением свободы слова - подвергать все электронные доски цензуре со стороны кого-то, кто желает взять на себя ответственность за их содержимое. Думаю, скорее всего мы придем к тому, что введем набор категорий (вроде разрядов, присваиваемых фильмам); они будут показывать, контролируют ли в данном месте чересчур громкие голоса, удаляет ли "редактор" те сообщения, которые, на его взгляд, выходят за рамки политики, проводимой данной группой, и т.п.

Электронные доски, о которых я говорил, - бесплатные, общественные. Однако в сети найдутся места, где за плату Вам предложат профессиональную информацию и профессиональные консультации. Вы удивлены ? Зачем нужен эксперт, когда вокруг полно всякой информации ? Да по той же причине, что и сейчас. Например, Consumer Reports предлагает обзоры, объективно оценивающие множество потребительских товаров, но все они ориентируются на широкую аудиторию, поэтому не всегда детализируют те сведения, которые интересуют именно Вас. Не докопавшись до нужных рекомендаций, Вы сможете нанять - на 5 минут или на весь день - компетентного торгового консультанта и устроить с ним на магистрали видеоконференцию. Он поможет подобрать товары, которые Ваш компьютер потом купит для Вас по самой низкой цене из надежного источника.

Я предполагаю, что традиционная связка торговли и услуг консультантов потеряет актуальность. Сейчас цена подобных услуг (а покупатель считает их бесплатными) включается магазинами в общую стоимость товара (действует система наценок). В дальнейшем магазины, где работают консультанты, неизбежно столкнутся с конкуренцией со стороны торговцев, предлагающих на информационной магистрали более низкие цены. Конечно, умеренные колебания цен в разных торговых точках по-прежнему сохранятся. Они будут отражать отличия в их обороте, поставках и предлагаемом ими сервисе.

Некоторые торговцы заложат стоимость "консультации" в счет за товар, но при крупных покупках Вы скорее всего предпочтете обратиться к действительно независимому эксперту. Стоимость услуг такого эксперта не превысит разницы между минимальной ценой товара и той его ценой, к которой Вас подведет магазинный консультант. Допустим, Вы узнали у какой-либо службы на магистрали, где купить престижный автомобиль по наилучшей цене, - и в конце концов купили его. Такой сервис - а служба выступала посредником в сделке - Вы оплатите согласно почасовому тарифу или как небольшой процент от стоимости покупки. Все зависит от уникальности конкретной службы, от того, есть ли у нее в сети реальные конкуренты.

Со временем консультационные услуги будут во все большей степени перекладываться на программные средства, способные анализировать Ваши запросы и выдвигать соответствующие предложения. В ряде крупных банков уже сейчас разработаны "экспертные" компьютерные системы, весьма успешно анализирующие рутинные операции, связанные с займами и кредитами. Когда программные агенты распространятся повсеместно, а программное обеспечение систем распознавания и синтеза речи существенно улучшится, Вы сможете разговаривать с мультимедийным документом, в который заложена некая личность, как с живым экспертом. Вы будете его перебивать, переспрашивать, требовать больше подробностей. В конце концов, какое это имеет значение - с кем именно Вы говорите: с человеком или с его очень хорошей имитацией. Ведь главное - получить ответы на свои вопросы.

Шаг вперед к дисконтной электронной торговле на магистрали - нынешние системы покупок на дому через телевизионные каналы. В 1994 году с их помощью продали товаров почти на 3 миллиарда долларов, несмотря на то что эти системы действуют в синхронном режиме, т.е. Вам приходится сидеть перед телевизором и ждать, когда появится на экране интересующий Вас товар. А информационная магистраль позволит любому покупателю самому "бродить" среди товаров и услуг со всего мира. Если Вы ищете свитеры, сначала Вы опишете их фасон, а потом выберете любую расцветку - во всех ценовых диапазонах. Может быть, прежде чем заплатить деньги, Вы предпочтете "побывать" на демонстрации мод или сделать что-то еще. Так или иначе, но интерактивность позволит совмещать полезное с приятным.

Сегодня фирменные товары часто становятся "персонажами" художественных фильмов и телевизионных программ. Герой, который когда-то заказал бы просто пиво, теперь заказывает Budweiser. В кинофильме Demolition Man (Разрушитель, 1993 год) создается впечатление, что на планете из всей сети быстрого питания уцелели исключительно рестораны Тасо Bell. За эту привилегию заплатила корпорация PepsiCo, в которую входят рестораны Тасо Bell. Ну а Microsoft заплатила за то, чтобы в кинофильме True Lies (Правдивая ложь) Арнольд Шварценеггер (Arnold Schwarzenegger) обнаружил на экране компьютера арабскую версию Windows. В будущем компании, вероятно, станут платить не только за то, чтобы их продукция появлялась в фильмах, но и за то, чтобы она была доступна для покупки любому зрителю. У Вас будет возможность выяснять подробности о каждом увиденном изображении. Вот так магистраль позволит реализовать еще один - ненавязчивый - вид сервиса. Если во время фильма Top Gun (Топ Ган) Вы решили, что солнцезащитные очки пилота, роль которого играет Том Круз (Tom Cruise), действительно здорово смотрятся, Вы сможете приостановить фильм, выспросить все про эти очки и тут же их купить. Правда, если ленту снабдили коммерческой информацией. А может быть, Вы просто пометите нужную сцену, чтобы вернуться к ней позже. Если в фильме есть сцена, снятая в каком-то отеле на экзотическом курорте, Вы легко разузнаете, где он находится, какие в нем расценки, и забронируете себе номер. Если Вам приглянулась удобная кожаная сумочка, с которой не расстается снявшаяся в фильме звезда, то магистраль позволит Вам просмотреть всю гамму кожаных изделий данной фирмы и либо заказать одну из них, либо выяснить адрес магазина, где они есть в продаже.

Поскольку информационная магистраль сможет нести видео, в большинстве случаев Вы заранее в деталях разглядите то, что собираетесь заказать. Тогда не попадете впросак, как однажды это произошло с моей бабушкой. Я отдыхал в летнем лагере, и она решила прислать мне сладости. Заказав сотню лимонных леденцов, она полагала, что я быстро справлюсь с сотней конфет. Каково же было мое изумление, когда я получил 100 пакетиков с леденцами ! Я раздавал их направо и налево и пользовался большим успехом у своих сверстников, пока однажды у нас не разболелись десны. Так вот, на магистрали, прежде чем бронировать места в каком-нибудь отеле, Вы совершите по нему видеоэкскурсию. Вам не придется переживать, действительно ли цветы, заказанные для матери по телефону, так хороши, как обещает каталог. Вы увидите, как цветочница составляет букет, а если пожелаете, она на Ваших глазах заменит увядшие розы свежими анемонами. Покупая одежду, Вы рассмотрите ее на экране в полный рост, даже сможете оценить, как она сочетается с другими вещами из Вашего гардероба или с теми, которые Вы только собираетесь купить.

Точно зная, что Вам нужно, Вы сможете без проблем заполучить это. Компьютеры позволят подгонять серийные товары под запросы конкретного потребителя. Такая подгонка станет для производителя важным способом внесения добавленной стоимости. Все чаще товары - от ботинок до кресел, от газет и журналов до музыкальных альбомов - будут создавать прямо на месте, чтобы они точно соответствовали пожеланиям того или иного заказчика. И главное, такая вещь не всегда обойдется дороже серийной. Вот тогда поточное производство (mass production) многих категорий товаров сменится серийным производством с подгонкой (mass customization) - так же, как несколько поколений назад поточное производство вытеснило изготовление на заказ (made-to-order).

До массового выпуска товаров каждую вещь создавали по отдельности, используя трудоемкие методы, которые не позволяли добиться высокой производительности и приличного уровня жизни. Пока не изобрели швейную машину, все рубашки шили вручную, управляясь одними лишь нитками и иголкой. У человека среднего достатка в то время рубашек было немного - стоили они дорого. В 1860-х годах, когда в изготовлении одежды начали применять методы поточного производства, фабрики стали выпускать большие партии одинаковых рубашек. Цены на них упали, и даже рабочие могли позволить себе несколько штук.

Скоро появятся компьютеризованные швейные машины, способные при пошиве каждой рубашки следовать разным наборам команд. Заказывая одежду, Вы сообщите свои размеры, выберете ткань, фасон, покрой воротничка и прочие переменные параметры. Все эти сведения через информационную магистраль попадут на завод, который тут же выполнит заказ и передаст его службе быстрой доставки. Доставка товаров, заказанных через магистраль, превратится в крупный бизнес. Здесь неизбежна жестокая конкуренция, и, когда люди начнут покупать товары в основном на магистрали, подобная услуга станет очень быстрой и дешевой.

Корпорация Levi Strauss & Co. уже экспериментирует с изготовлением на заказ женских джинсов. В растущей сети их торговых точек покупательницы доплачивают всего 10 долларов за точную подгонку джинсов по своей фигуре (рост и объем бедер и талии) и выбирают любую из 8448 комбинаций фасонов. Эти сведения магазинный компьютер передает на завод корпорации в штате Теннесси, где машины под управлением заводских компьютеров раскраивают джинсовую ткань, наклеивают на нее ярлык со штрих-кодами, а потом стирают и сшивают. Готовые джинсы пересылаются в магазин, откуда поступил заказ, или прямо клиенту.

Вполне вероятно, что в ближайшие несколько лет размеры одежды всех клиентов будут регистрироваться в электронном виде, благодаря чему Вы легко проверите, подойдет ли Вам готовая одежда или ее лучше сделать на заказ. Если Вы откроете эти сведения своим друзьям и родственникам, им будет куда проще купить для Вас не только красивую, но и подходящую вещь.

Подобного рода информация значительно расширит возможности магистрали по оказанию консультационных услуг. Люди, добившиеся успеха в тех или иных областях, смогут публиковать свои соображения, рекомендации и обзоры примерно так же, как преуспевающие инвесторы издают информационные бюллетени. Арнольд Палмер (Arnold Palmer) и Нэнси Лопез (Nancy Lopez) могли бы назвать любителям гольфа полезные, на их взгляд, материалы. Редактор, сегодня работающий в The Economist, мог бы открыть свою службу и распространять дайджесты новостей, связанные с текстом и видео во множестве источников. Пользователи его службы, вместо того чтобы тратить по 60 центов за газету, платили бы по несколько центов в день за услуги эксперта-посредника, подбирающего новости, и еще какую-то (совсем небольшую) сумму - источникам каждого сообщения. При этом клиент определял бы, сколько статей он хочет прочитать и сколько денег он готов заплатить за это. Чтобы получать свою ежедневную дозу новостей, Вы могли бы подписаться на услуги сразу нескольких таких служб, а уж окончательную компоновку собственной "газеты" Вы доверили бы программному агенту или специальному человеку.

Эти службы, людские или электронные, будут собирать информацию, отвечающую определенной философии или определенному кругу интересов, и в конкурентной борьбе им поможет только талант и репутация. Аналогичную роль сегодня выполняют журналы. Многие из них посвящены очень узкой тематике и направлены к ограниченной аудитории. Например, читатель, интересующийся политикой, отлично знает: то, что он (или она) читает в National Review, вовсе не "новости". Это бюллетень из мира консервативной политики, который старается не бросать вызов убеждениям читателей. А на другом конце политической шкалы The Nation - журнал, ориентированный на публику с либеральными взглядами.

Поставщики информации - примерно так же, как киностудии, стремясь продать свои новые фильмы, устраивают в кинотеатрах предварительные просмотры, печатают афиши и предпринимают массу других усилий - будут пользоваться всеми мыслимыми и немыслимыми способами, лишь бы убедить Вас принять их продукцию. В потоке информации Вы найдете немало сведений местного характера, поступающих из ближайших больниц, школ, торговых предприятий и даже от разносчиков пиццы, потому что подключение фирмы к магистрали не вызовет значительных затрат. А как только подобная инфраструктура будет создана и ее примет некая критическая масса пользователей, буквально все бизнесмены захотят "приходить" к своим клиентам по магистрали.

Впрочем, некоторые беспокоятся, что покупка товаров или новостей через информационную магистраль начисто лишит их возможности неожиданных открытий - самому выкопать в газетах сенсацию или наткнуться на необычное блюдо в закусочной где-нибудь на парковой аллее. Конечно, такие "сюрпризы" - штука очень редкая. В частности, газеты издают редакторы, которые по опыту знают запросы своих читателей. Хотя время от времени та же The New York Times публикует на первой полосе не совсем обычные для нее статьи, например о достижениях в математике. Сугубо специализированные материалы подаются под таким углом, который делает их интересными широкому кругу читателей, включая тех, кому математика просто до лампочки. Примерно так же поступают и владельцы магазинов, выискивая что-то новое, что может заинтриговать покупателей. В витрины они всегда выставляют те товары, которые, как они надеются, остановят взгляд прохожего и заманят его в магазин.

Так что и на магистрали хватит места заранее просчитанным сюрпризам. Нет-нет да и соблазнит Вас программный агент каким-нибудь вопросником, который поможет уточнить Ваши вкусы, выявить подсознательные реакции на те или иные вещи. Агент превратит анкетирование в своеобразную игру, даст Вам сравнить Вашу реакцию с нормой. Построив на основе полученной таким образом информации профиль Ваших наклонностей, агент сможет в дальнейшем руководствоваться им. Он будет изучать, как Вы пользуетесь системой для чтения новостей или "шоппинга", и в этот момент также займется пополнением профиля Ваших вкусов. Он запомнит, к чему Вы проявляете интерес, на какие статьи реагируете так, словно они для Вас сюрприз, и постарается в будущем устраивать Вам побольше подобных "сюрпризов". Как только Вам захочется чего-нибудь эдакого, пожалуйста - получите ! Наверное, нет смысла говорить, сколько еще предстоит споров и пересудов насчет того, кому будет разрешен доступ к содержащейся в этих профилях информации. Но главное - чтобы Вы имели доступ к своему профилю.

Спрашивается: зачем каждому человеку создавать такой профиль ? Лично мне вовсе не хочется открывать о себе всю подноготную, но, с другой стороны, знай агент, что мне, например, любопытно посмотреть на систему безопасности в новой модели Lexus'а, он бы мне ее показал. Или, скажем, обратил мое внимание на выход новой книги Филипа Рота (Philip Roth), Джона Ирвинга (John Irving), Эрнста Дж. Гейнза (Ernest J. Gaines), Дональда Кнута (Donald Knuth), Дэвида Халберстэма (David Halberstam) или другого давно любимого моего писателя. Я был бы не прочь, если бы агент сигнализировал о появлении новых книг по интересующей меня тематике: экономике и технике, теории обучения, биотехнологии, Франклине Делано Рузвельте наконец. Меня очень увлекла книга The Language Instinct, написанная Стивеном Пинкером (Steven Pinker), профессором из MIT (Массачусетсского технологического института), и я бы хотел быть в курсе новых книг или статей, развивающих его идеи.

С сюрпризами Вы встретитесь и тогда, когда будете "путешествовать" по гиперсвязям, установленным другими людьми. Сегодня пользователям нравится бродить по всемирной паутине в Internet, "пролистывая" страницы компаний, связанные с другими страницами - этой же или других компаний. Подобные связи обозначаются "горячими точками" (картинками, кнопками или выделенными словами), щелчком которых на экран вызываются связанные с ними страницы.

Некоторые частные лица создают свои домашние страницы. Частные домашние страницы - штука, о которой можно рассуждать очень долго. Какими сведениями или мыслями Вы хотели бы поделиться со всем миром ? Будут ли на Вашей странице гиперсвязи, и если будут, то с чем ? Кому взбредет в голову заглянуть на Вашу страницу ?

Электронный мир позволит фирмам-производителям продавать свои товары непосредственно потребителям. Чтобы облегчить доступ к информации о выпускаемой ими продукции, все они, несомненно, обзаведутся в сети своими страницами. В то же время любой фирме, выработавшей успешную стратегию дистрибуции (в нашем случае - создавшей сеть розничных торговцев программными продуктами), придется решать, как именно пользоваться этими страницами. Ведь публиковать свежую информацию, включая списки дистрибуторов, - дело совсем нетрудное, но важно поддерживать и розничных торговцев. Поэтому даже такая компания, как Rolls-Royce, с ее исключительно закрытой системой дистрибуции, по-видимому, тоже создаст домашнюю страницу, на которой будет сообщать о своих последних моделях и о том, где их приобрести.

Розничные торговцы хорошо поработали на Microsoft, и нам приятно, что покупатели, заходя в магазины, видят там большинство наших продуктов, а продавцы способны дать им толковый совет. Microsoft и в дальнейшем намерена продавать свою продукцию через розничную торговлю, но часть торговых точек станет электронной.

А возьмите страховую компанию, которая эффективно работает через агентов. Захочет ли такая компания обслуживать клиентов прямо из центрального офиса ? Доверит ли она агентам, которые сейчас ведут дела исключительно в своем районе, действовать через сеть в масштабах государства ? Решить это вот так сразу очень и очень непросто. Здесь придется учитывать все факторы и на их основе принимать те или иные решения. Ну а конкуренция покажет, чей подход лучше.

Домашние страницы - электронная форма рекламы. Программная платформа информационной магистрали предоставит фирмам полный контроль над способами подачи информации. На магистрали реклама должна быть оригинальнее, изобретательнее, чтобы она притягивала внимание избалованных пользователей, которые к тому времени привыкнут смотреть только то, что им хочется, и тогда, когда это им удобно.

Сегодня реклама субсидирует почти все телевизионные программы и периодические издания. Рекламодатели размещают свои ролики в самых популярных программах и публикациях, которые привлекают наибольшую аудиторию. Они тратят колоссальные средства, пытаясь убедиться в эффективности своей рекламной стратегии. И на магистрали рекламодатели тоже потребуют каких-то гарантий: действительно ли их реклама достигла тех, кому она адресована. Но реклама не окупит себя, если каждый начнет ее пропускать. Магистраль предложит здесь определенные альтернативы. Одна из них - такое программное обеспечение, которое позволит быстро прокручивать все, кроме рекламы, воспроизводимой с нормальной скоростью. Не исключено, что на магистрали организуют просмотр рекламных объявлений блоками. Например, когда во Франции начали группировать рекламные объявления, их пятиминутные блоки стали самыми популярными отрезками эфирного времени.

Сейчас реклама адресуется телезрителям по кустовому принципу. Рекламодателям известно, что телевыпуск новостей привлекает один тип зрителей, а соревнования по борьбе - другой. При этом учитывается размер аудитории и ее демографический состав. Реклама, обращенная к детям, субсидирует детские передачи; та, что адресуется домохозяйкам, финансирует мыльные оперы, транслируемые в дневное время; производители автомобилей и пива являются спонсорами спортивных соревнований. Однако в распоряжении рекламодателей, размещающих рекламу на телевидении, по-прежнему находится лишь самая общая информация о зрительской аудитории той или иной передачи, полученная по статистической выборке. Поэтому телевизионная реклама часто обращается не к тем, кого упомянутая в ней продукция может заинтересовать.

Журналы, напротив, благодаря своей ориентации на людей с определенными интересами позволяют адресовать рекламу более прицельно - автолюбителям, музыкантам, модницам и даже таким узким группам, как любителям плюшевых медвежат. Тот, кто покупает журнал, посвященный плюшевым мишкам, естественно, хочет видеть рекламу о предмете своей страсти и обо всем, что с ним связано. Кстати, многие покупают специализированные журналы зачастую не только из-за репортажей и статей, но и из-за соответствующей рекламы. Журналы мод, например, если они процветают, минимум наполовину заполнены рекламой. Они предлагают читателям как бы рассматривать витрины, не выходя из дома. Рекламодатель в этом случае не знает запросов конкретных читателей журнала, но ему кое-что известно об этой читательской аудитории в целом.

Информационная магистраль позволит расслоить потребителей по их интересам и каждой группе адресовать свой поток рекламы. От этого выиграют все: зрители (реклама станет целенаправленной, а потому более интересной), продюсеры и оперативные издания (они смогут отдавать на откуп рекламодателям четко выраженные группы зрителей и читателей). Рекламодатели получат большую отдачу от каждого потраченного на рекламу доллара. Кроме того, информацию о предпочтениях той или иной аудитории легко собирать и распространять без вмешательства в чью бы то ни было личную жизнь - в интерактивной сети маршрутизацию рекламы легко осуществлять на основе сведений о потребителях, не открывая, кто именно является ее получателем. Например, владельцы сети ресторанов должны твердо знать только одно: их рекламу получит определенный круг семей со средним достатком и маленькими детьми - вот и все.

В начале телепередачи Home Improvement служащая средних лет и ее муж увидели бы, скажем, рекламу домика, в котором они могли бы уединиться, выйдя на пенсию, а юная парочка по соседству в начале той же передачи - где провести отпуск всей семьей. И все это происходило бы независимо от того, смотрели они передачу в одно время или в разное. Прицельная реклама гораздо выгоднее рекламодателю, да и зритель проводил бы вечера у телевизора, не раздражаясь чрезмерным обилием рекламных сюжетов.

Некоторые рекламодатели, например Coca-Cola, стремятся, как говорят, достучаться до каждого. Но даже Coca-Cola могла бы адресовать рекламу своего диетического напитка только тем, кто в ней заинтересован. Ford Motor Company показывала бы рекламу "Линкольн-континенталь" состоятельным людям, "Форд-эскорт" - молодежи, грузовика с автопогрузчиком - сельским жителям, а всем остальным - "Таурас". Или, скажем, можно было бы рекламировать один и тот же продукт с участием разных актеров, отличающихся полом, расой или возрастом. Все эти варианты рассылались бы соответствующим группам потребителей. Чтобы сделать рекламу максимально эффективной, понадобятся программы со сложными алгоритмами, способные выделять в передачах место для адресной рекламы. В этом случае расходы, конечно, вырастут, но, поскольку рекламные объявления станут эффективнее, затраты окупят себя.

Даже бакалейная лавка на ближайшем углу и местная химчистка смогут рекламировать свои услуги так, как они никогда не делали этого раньше. Адресные потоки рекламы будут постоянно течь по сети, поэтому рекламные видеоролики станут доступны даже самым мелким предпринимателям. Реклама какого-нибудь магазинчика может транслироваться исключительно на несколько соседних кварталов и обращаться к жителям с определенными доходами или интересами.

Сегодня самый действенный способ адресации к узкой аудитории - сборник рекламных объявлений. Каждая категория объявлений отражает интересы небольших групп, например, тех, кто хочет купить или продать ковер. Завтра такая реклама уже не будет привязана к бумаге или ограничена одним только текстом. Если Вы ищете подержанный автомобиль, Вы отправите запрос, где укажете ценовой диапазон, модель и другие важные для Вас параметры, и вскоре получите список соответствующих предложений. Или, допустим, скажете программному агенту, чтобы он известил Вас, когда на рынке появится подходящая машина. В рекламе торговцев автомобилями обязательно будут гиперсвязи с фотографиями или видеороликами автомашин и даже с их техпаспортами - Вы сможете составить вполне отчетливое впечатление о состоянии, в котором находится приобретаемый автомобиль. Аналогичным образом Вы проверите пройденный километраж, не заменялся ли мотор и есть ли в машине подушки безопасности. Возможно, Вы захотите просмотреть и открытые полицейские записи, чтобы выяснить, не попадала ли эта машина в аварии.

Продавая свой дом, Вы сможете подробно описать его и включить в текст фотографии, видеозаписи, планы этажей, налоговую документацию, счета за коммунальные услуги, ремонт и даже музыку - для настроения. Шансы на то, что потенциальный покупатель увидит Вашу рекламу, повышаются, так как информационная магистраль продемонстрирует ее любому, кто заглянет в эту рекламу. В результате - когда покупатели получат прямой доступ к такому изобилию информации - может измениться вся система операций с недвижимостью.

Конечно, оперативные рекламные объявления не сразу привлекут внимание, потому что на первых порах ими будут пользоваться лишь очень немногие. Но постепенно слухи о довольных клиентах сделают свое дело, и люди станут все чаще прибегать к этой услуге. По мере того как все большее число продавцов будет находить покупателей именно таким образом, начнет проявляться эффект положительной обратной связи. Когда количество обращений в службу рекламных объявлений достигнет некой критической массы (может быть, это случится всего через год-два после ее создания), чистое любопытство сменится отношением к ней как к основному способу контактов продавцов и покупателей.

Однако более крупные изменения произойдут в практике рассылки рекламы. Сегодня немалая доля такой рекламы попадает прямиком в мусор. Мы вырубаем деревья, делаем из древесины бумагу, чтобы пустить ее под рекламные материалы, а их зачастую выбрасывают не читая. На информационной магистрали "посыльная" реклама перейдет в электронную форму - превратится в интерактивные мультимедийные документы. И хотя в этом случае природные ресурсы уже не будут растрачиваться впустую, понадобятся определенные меры, чтобы не получать каждый день по тысяче таких рекламных "буклетов".

Но не волнуйтесь, Вас не накроет лавиной несущественной информации, потому что программные средства будут фильтровать поступающую рекламу и корреспонденцию от незнакомых лиц, - свое драгоценное время Вы потратите на просмотр только той почты, которая Вам интересна. А большинство вообще заблокирует рассылаемую по электронной почте рекламу, кроме той, что касается определенной продукции. Поэтому рекламодатели начнут пускаться на всякие трюки, лишь бы привлечь Ваше внимание; например, предлагать за просмотр рекламы небольшое вознаграждение (пятачок или, может быть, доллар). Эта сумма поступит с электронного счета рекламодателя на Ваш электронный счет, как только Вы просмотрите такую рекламу. В сущности, часть из тех миллиардов долларов, которые сейчас ежегодно тратятся на рекламу в средствах массовой информации, а также на ее печать и рассылку по почте, будет попросту поделена между потребителями, согласными "переваривать" всю присылаемую им рекламу.

Реклама, рассылаемая клиентам и предлагающая им вознаграждение за ее чтение, может оказаться чрезвычайно эффективной, потому что рекламодатели будут направлять ее только потенциальным покупателям. Такие фирмы, как Ferrari или Porsche, могут разослать "долларовые" объявления автолюбителям в надежде, что те заинтересуются, увидев классную новинку и услышав призывный рокот ее мотора. Затраты компании на рекламу окупятся уже в том случае, если хотя бы один из тысячи купит новую машину. Размер вознаграждения за чтение рекламы может варьироваться в зависимости от профиля потенциального клиента. Такая реклама с вознаграждением будет доступна всем, кто не числится у рекламодателя в списке A. Но если, например, шестнадцатилетний подросток (без ума от машин !) захочет почувствовать себя за рулем "Феррари", он тоже получит подобное рекламное объявление, но уже без вознаграждения за его чтение.

Все это может показаться несколько странным, однако тут всего лишь проявляется рыночный механизм, свойственный капитализму без трений. Рекламодатель решает, сколько он готов платить за Ваше время, а Вы решаете, за какую сумму готовы этим временем поступиться.

Рекламные сообщения, как и прочая корреспонденция, будут храниться в различных папках. Вы проинструктируете свой компьютер, как их нужно сортировать. Непрочитанная почта от друзей и членов семьи - в одной папке, сообщения и документы (личные или деловые) - в другой. А реклама и сообщения от незнакомых людей могут быть отсортированы по сугубо меркантильному признаку: какая сумма предлагается за их чтение. Скажем, компьютер составит группы одноцентовых сообщений, десятицентовых и т.д. При отсутствии "гонорара" такое сообщение отвергается. Вы будете просматривать отсортированные сообщения и выбрасывать все, что Вам неинтересно. В отдельные дни, возможно, Вы вообще не станете заглядывать в папки с рекламными объявлениями. Но если кто-то пришлет Вам десятидолларовое объявление, Вы, вероятно, взглянете на него - даже не из-за денег, а из чистого любопытства: кто это решил, что контакт с Вами стоит целых 10 долларов ?

Конечно, Вы не обязаны брать деньги, принимая подобное сообщение, Вы можете отказаться от "гонорара". Поэтому предлагаемое вознаграждение - на деле всего лишь та сумма, которой кто-то готов рискнуть, только бы привлечь Ваше внимание. При этом платежеспособность отправителя будет заблаговременно проверяться. Допустим, кто-то передаст Вам стодолларовое сообщение, из которого следует, что отправитель - Ваш давно потерянный брат. Тогда - если он действительно окажется Вашим братом - Вы наверняка откажетесь от его денег. С другой стороны, если он просто пытался таким оригинальным способом что-то продать, Вы скорее всего возьмете предлагаемые деньги, подумав про себя: "Спасибо тебе большое".

В Соединенных Штатах рекламодатели сейчас ежемесячно тратят на каждую американскую семью более 20 долларов, финансируя бесплатное вещание и кабельное телевидение. Основная масса рекламы настолько знакома нам, что, в сущности, даже не раздражает, когда мы видим ее по телевизору или слышим по радио. Мы понимаем, что эти программы потому и "бесплатны", что за них платят рекламодатели. Зрители и слушатели платят за них косвенно, так как расходы на рекламу входят в цены кукурузных хлопьев, шампуней и бриллиантов. Но мы прямо оплачиваем другие развлечения и информацию (например, книгу, билет в кино или видеокассету). Средняя американская семья ежемесячно тратит около 100 долларов на билеты в кино, газеты и журналы, покупку книг, оплату кабельного телевидения, приобретение компакт-дисков и кассет, прокат видеозаписей и тому подобные вещи.

Когда Вы платите за кассету или диск, Ваши права на их повторное использование или перепродажу существенно ограничены. Так, приобретая альбом "Битлз" Abbey Road (Монастырская дорога), на самом деле Вы приобретаете конкретный диск (или кассету) и лицензию на воспроизведение записанной на нем музыки неограниченное число раз в некоммерческих целях. Если же Вы купили книгу в мягкой обложке, это значит, что в действительности Вы купили бумагу, краску и право читать самому (и другим давать) текст, отпечатанный на данной бумаге данной краской. Этот текст Вам не принадлежит, и Вы не имеете права его перепечатывать, разве что в отдельных, строго оговоренных обстоятельствах. Когда Вы смотрите телепередачу, Вы также не владеете ею. И между прочим, чтобы в Америке зрители могли легально записывать телепередачи в личное пользование, понадобилось специальное постановление Верховного Суда.

Информационная магистраль принесет ряд инноваций в то, как будет лицензироваться интеллектуальная собственность, в частности музыка и программное обеспечение. Звукозаписывающие компании и даже отдельные артисты смогут продавать музыку по-новому. Вам, потребителю, не понадобятся компакт-диски, кассеты или какая-либо аппаратура. Музыка будет храниться на серверах магистрали в виде битов информации. "Покупка" песни или альбома, по сути, будет означать покупку прав на доступ к соответствующим битам. Вы сможете слушать музыку дома, на работе или в дороге, не таская с собой ни диски, ни кассеты. В любом месте, где есть звуковые колонки, подключенные к магистрали, Вы просто "предъявите" свои права на доступ. Конечно, Вам никто не разрешит арендовать концертный зал и наслаждаться в нем приобретенными музыкальными произведениями или создавать рекламу с их использованием. Но в некоммерческих целях Вы вправе проигрывать купленные песни в любом месте без дополнительной платы держателям авторских прав. Аналогичным образом информационная магистраль поможет следить за тем, купили ли Вы права на чтение конкретной книги или на просмотр видеофильма. И если Вы действительно купили их, то сможете обращаться к ним в любое время, в любом месте, с любого информационного устройства.

Такой пожизненный выкуп прав подобен тому, что мы делаем сегодня, покупая музыкальный диск, кассету или книгу - с единственным отличием, что в этом процессе не участвует физический носитель. Однако есть и много других способов продажи музыки и прочей информации.

Например, песни могли бы быть доступны по принципу оплаты за каждое прослушивание. При этом с Вашего счета каждый раз снималась бы некоторая, крайне незначительная сумма, скажем 5 центов. При таком тарифе прослушивание "альбома" с двенадцатью песнями обошлось бы в 60 центов. Проиграв весь альбом 25 раз, Вы потратили бы 15 долларов, т.е. примерно столько же, сколько сейчас стоит компакт-диск. Если в альбоме Вам нравится всего одна песня, за те же 15 долларов Вы сможете прослушать ее целых 300 раз. Кроме того, поскольку цифровая информация - вещь очень гибкая, с улучшением качества звука Вам не придется снова платить за ту же музыку, как это происходит сейчас из-за замены грампластинок в личных фонотеках компакт-дисками.

Несомненно, что в коммерции опробуют все модели ценообразования. Возможно, мы встретим такие варианты, при которых "цифровые развлечения" разрешат приобретать на определенный срок или на определенное число прослушиваний, после чего их придется покупать заново. Или, скажем, Вам дадут прослушать какую-нибудь песню или поиграть в захватывающую игру 10 раз бесплатно и только потом поинтересуются, не хотите ли Вы приобрести ее. Не исключено, что подобное "демо"-воспроизведение частично заменит функции, сейчас выполняемые радиостанциями. Автор может разрешить Вам переслать его новую песню Вашей приятельнице, но она сумеет прослушать ее бесплатно лишь несколько раз. Музыкальные группы для желающих приобрести сразу все их альбомы могли бы устанавливать специальные цены, которые были бы куда ниже, чем если бы эти альбомы покупались отдельно.

Даже сегодня система оплаты развлекательной информации не без нюансов. Ограниченный период популярности этой информации сказывается на том, как ее реализуют издательства и киностудии. Первые, например, часто поступают так: печатают книгу двумя тиражами (разнося их по времени) - сначала в твердой обложке, потом в мягкой. Если покупателю нужна эта книга и он может заплатить за нее 25 - 30 долларов, - пожалуйста, нет проблем ! А если он подождет (от полугода до 2 лет), то сможет купить ту же книгу значительно дешевле, за 5 - 10 долларов, но уже в не столь долговечном переплете.

Популярные фильмы сначала всегда показываются в кинотеатрах первого класса, затем второго класса, далее в отелях, по ТВ-системе, где за просмотр каждого фильма надо платить отдельно, и в авиалайнерах. После этого они появляются в видеопрокате, на премьерных телеканалах вроде HBO и, наконец, передаются по остальной телевизионной сети. Еще позже Вы увидите их по местному телевидению или по основным кабельным каналам. Вот так фильм постепенно продвигается к разным аудиториям, чтобы его могли посмотреть все, кто - случайно или намеренно - пропустил предыдущие сеансы его показа.

Поэтому я почти уверен, что и на информационной магистрали все материалы будут появляться аналогичным образом - отдельными выпусками, разнесенными по времени. В момент выхода популярного фильма, мультимедийного произведения или электронной книги, возможно, их цена будет выше номинала. Наверняка ведь найдутся желающие заплатить подороже (допустим, 30 долларов), лишь бы побывать на премьере фильма. Спустя неделю, месяц или сезон его цена упадет до 3 - 4 долларов (столько мы платим сегодня за разовый просмотр фильма). В принципе, специалисты по маркетингу могут опробовать весьма необычные идеи. Скажем, только что вышедший фильм в первый месяц его проката Вы сможете посмотреть, если войдете в первую тысячу тех, кто предложит на торгах (через информационную магистраль) наивысшую цену. С другой стороны, если есть записи, подтверждающие, что Вы покупали афиши и сувениры ко всем фильмам, которые Вы смотрели, тогда, возможно, какие-то ленты Вы получите почти бесплатно, за символическую цену. Распродажа видеокассет с мультфильмами The Little Mermaid (Русалочка) и Aladdin (Аладдин) вместе с сопутствующими товарами может подвигнуть компанию Disney на подарок детям всего мира - показать что-нибудь разок бесплатно.

При ценообразовании нужно учесть и другую крупную проблему - легкость передачи информации. Магистраль позволит передавать права на интеллектуальную собственность от одного лица к другому со скоростью света. Музыка, литературные произведения и другая интеллектуальная собственность, содержащаяся на дисках или в книгах, большую часть времени остается невостребованной. Когда Ваш экземпляр Thriller или Bonfire of the Vanities просто стоит на полке, Вы не пользуетесь им и скорее всего другие - тоже. Издатели это учитывают. Если бы средний покупатель часто одалживал знакомым свои альбомы и книги, объем их продаж упал, а цены поднялись. Если, допустим, альбом в среднем используется в течение 0,1% времени владения, его передача знакомым "со скоростью света" может привести к падению объема продаж в 1000 раз. Так что право одалживать знакомым купленную интеллектуальную собственность, по-видимому, будет ограничено, чтобы ту же книгу нельзя было давать почитать чаще, чем, скажем, раз 10 в году.

Общественные библиотеки станут тем местом, куда каждый сможет прийти и, воспользовавшись высококачественным оборудованием, получить доступ к ресурсам информационной магистрали. Руководство библиотек сможет пустить выделяемые им фонды, которые сегодня идут на покупку книг, альбомов, фильмов и подписных изданий, на выплату отчислений за пользование образовательными электронными материалами. Не исключено, что авторы разрешат читать свои произведения в библиотеках бесплатно или за меньшие отчисления.

Понадобятся также новые законы по охране авторских прав, которые прояснят права покупателей в различных - совершенно новых - ситуациях. И магистраль непременно вынудит нас к этому.

Видеофильмы, которые обычно смотрят не более одного раза, по-прежнему будут предлагаться в прокат, но, вероятно, не через магазины. Скорее всего потребители закажут видеофильмы и другие программы через информационную магистраль. Поэтому магазины видеопроката и музыкальные магазины постепенно уйдут с рынка. А вот книжные магазины еще очень долго будут торговать печатной продукцией, хотя, по-видимому, техническую и особенно справочную литературу переведут в электронную форму.

Однако появление эффективных электронных рынков скажется не только на развлечениях. Горячее дыхание "электронной" конкуренции почувствуют практически все, кто сейчас так или иначе выступает в роли посредников.

Адвоката из небольшого городка ждут новые испытания, ведь жители могут отказаться от его услуг и привлечь более именитых адвокатов через сетевые видеоконференции. Человек, покупающий какую-то недвижимость, захочет обратиться за консультацией к специалисту именно в этой области права, а не к местному адвокату по общим делам. Однако ресурсы магистрали дадут шанс и местному адвокату сдвинуть с мертвой точки свою карьеру: расширить свои знания и клиентуру, стать экспертом в любой области права и успешно конкурировать в ней с другими адвокатами, время которых гораздо дороже. Клиенты только выиграют от этого. Расценки на такие рутинные процедуры, как составление завещаний, будут снижаться благодаря эффективности и специализации адвокатских услуг на электронном рынке. Информационная магистраль возьмет на себя и роль посредника при обращении клиентов за сложными медицинскими, финансовыми и прочими консультациями. Такой сервис будет очень популярен. Кроме того, согласитесь, что, договорившись о встрече, проводить ее по телевизору или через компьютер гораздо удобнее, чем ехать куда-то, искать место для парковки, ждать в приемной, а потом, усталому, возвращаться домой или в офис.

Видеоконференции всех видов - альтернатива командировкам на какие бы то ни было совещания или деловые встречи. А если Вы все же поедете на подобную встречу, то только потому, что на ней необходимо Ваше личное присутствие. Со временем деловые поездки вообще не понадобятся, но мобильность общества повысится, поскольку работать можно будет в любом месте, не теряя связи со своим офисом и домом благодаря информационной магистрали.

Индустрия туризма изменится, хотя общее количество туристических поездок может остаться прежним. Турагентам, как и всем специалистам, услуги которых базировались на использовании информации, не доступной остальным, придется существенно перестроиться. Как только эта информация (базы данных и всевозможные справочные материалы) через магистраль придет в наши дома, многие путешественники отправятся в поиск за нужными сведениями самостоятельно, не прибегая к услугам турагентов.

Умные, опытные, умеющие творчески подходить к делу турагенты будут процветать, но для этого им придется специализироваться в каких-то областях, предлагать клиентам нечто большее простого перечисления маршрутов и бронирования билетов и номеров в отелях. Допустим, Вы хотите побывать в Африке. Самые дешевые билеты в Кению Вы прекрасно найдете и сами, значит, турагентству, чтобы не потерять Вас как клиента, надо предложить что-то еще. Например, агентство занимается исключительно поездками в Восточную Африку и, следовательно, подскажет Вам, что больше всего нравится в тех местах европейцам или американцам; предупредит, что в заповеднике Tsavo National Park слишком много туристов или что, если Вы хотите увидеть стада зебр, лучше посетить Танзанию. Какие-то другие туристические агентства будут специализироваться на продаже туров в своем городе. Агент в Чикаго предложит по сети услуги всем желающим посетить его родной город, а не чикагцам, собирающимся в другие места. В этом случае клиенты могут не знать турагента, зато, и это гораздо важнее, он хорошо знает Чикаго.

Хотя газеты будут существовать еще очень и очень долго, этот бизнес - после того как потребитель получит доступ к информационной магистрали - изменится коренным образом. В Соединенных Штатах доходы ежедневных газет сильно зависят от рекламы. В 1950 году, когда телевизоры еще были в новинку, четверть всей общенациональной рекламы приходилась на газеты. К 199З году их доля в этой рекламе сократилась до 12%, по большей части из-за конкуренции со стороны телевидения. В результате количество ежедневных газет в Соединенных Штатах катастрофически упало, а основное бремя по финансированию оставшихся легло на плечи местных рекламодателей - розничных торговцев и частных лиц, размещающих свои рекламные объявления. (Этот вид рекламы практически не срабатывает на радио и телевидении.) И если в 1950 году доля рекламных объявлений в общих доходах ежедневных газет от рекламы составляла всего лишь 18%, то к 1993 году она выросла до 35%, а это миллиарды долларов.

Информационная магистраль обеспечит альтернативные, более эффективные способы "знакомства" продавцов и покупателей. А как только подавляющее большинство потребителей на рынке начнет делать покупки в электронной форме, необходимость в рекламных объявлениях отпадет, и немалая часть рекламной базы газет окажется под угрозой.

Но это не означает, что газеты тут же исчезнут или перестанут играть значимую роль в доставке новостей и рекламы. Как и всем компаниям, которые выступали посредниками или брокерами, им придется приспосабливаться к новым реалиям электронного мира.

Перемены не обойдут и банковское дело. В Соединенных Штатах около 14000 банков, обслуживающих частных лиц. Большинство людей вкладывает деньги в филиалы банков, расположенные недалеко от их дома или от работы. И несмотря на некоторые отличия в процентных ставках и наборе услуг, редко кто меняет свой банк на более выгодный, если до его филиала надо ехать куда-то в сторону. Да и перевод счета из банка в банк сегодня отнимает слишком много времени.

Но когда информационная магистраль уменьшит значимость географического фактора, мы станем свидетелями рождения электронных оперативных банков, у которых нет никаких филиалов. Для их строительства не понадобится ни кирпичей, ни цемента. Благодаря минимуму накладных расходов, электронные банки окажутся весьма конкурентоспособными, а все операции будут осуществляться через компьютерные системы. Потребность в наличных сократится, потому что большую часть покупок будут совершать через компьютеры-бумажники или электронные "смарт-карты", которые объединят в себе функции кредитных карточек, чековых книжек и некоторых других банковских документов. Этот процесс уже начинается на фоне консолидации американской банковской системы и ее все более эффективной работы.

Исчезнут и значительные различия в процентных ставках по крупным и мелким вкладам. С появлением информационной магистрали возникнет новый тип посредников, способных эффективно аккумулировать средства мелких вкладчиков и предлагать им процентные ставки, близкие к тем, что предлагаются крупным вкладчикам. Финансовые институты станут более специализированными: какой-то банк предпочтет заняться ссудами в автомобильной промышленности, а другой сосредоточится на ссудах в кораблестроении. За все эти услуги банки по-прежнему будут брать комиссионные, но их уровень определится в острой и действенной конкуренции.

Еще совсем недавно мелкий вкладчик не мог вложить свои деньги во что-то более серьезное, чем банковский сберегательный счет. Мир акций, взаимосберегательных фондов, облигаций, ценных бумаг, долговых обязательств и других не менее таинственных инструментов капитала оказывался просто недосягаем тому, кто был посторонним на Уолл-Стрит.

Но все это ушло в прошлое, как только компьютеры начали менять нашу жизнь. Сегодня списки "дисконтных" биржевых брокеров можно найти на "Желтых страницах" (Yellow Pages), и многие вкладчики приобретают акции через местные филиалы банков или по телефону. С появлением информационной магистрали выбор для инвесторов значительно расширится. Биржевые брокеры, как и другие посредники, чья работа - способствовать заключению сделок, вероятно, должны предлагать что-то по-настоящему ценное, например свои знания. Компании, предоставляющие финансовые услуги, по-прежнему будут процветать. Базовые принципы экономики промышленности изменятся, а объем сделок стремительно увеличится, когда информационная магистраль даст среднему потребителю прямой доступ к финансовым ранкам. Вкладчики, располагающие сравнительно небольшими суммами, смогут получать прибыль от всех видов инвестиционной деятельности, сегодня доступных только финансовым институтам.

Когда я делаю прогнозы относительно будущих изменений в промышленности, многие начинают интересоваться, а не собирается ли и Microsoft играть на том же поле. Так вот, сфера деятельности Microsoft - создание крупных программных продуктов и обеспечение связанных с ними информационных услуг. Мы не станем ни банком, ни магазином.

Как-то раз, когда я отозвался о банковских внутренних базах данных как о "динозаврах", один репортер написал статью, в которой сообщил, что я считаю сами банки динозаврами и что мы хотим конкурировать с ними. С тех пор вот уже больше года я разъезжаю по всему миру и объясняю руководителям банков, что меня неправильно процитировали. Microsoft и без того хватает дел в своем бизнесе - будь то поддержка предприятий, выпуск компьютерных программ и программного обеспечения для серверов Internet или что-то еще.

Наш успех в мире персональных компьютеров был бы невозможен без тесного сотрудничества с такими великими компаниями, как Intel, Compaq, Hewlett Packard, DEC, NEC и десятками других. Мы много и плодотворно работали даже с IBM и Apple, с которыми Microsoft время от времени вступала в конкурентные схватки. Мы создали компанию, которая зависит от партнеров. Мы поставили на то, что наши партнеры многое делают лучше нас - лучше создают процессоры, лучше собирают компьютеры и успешнее занимаются дистрибуцией и системной интеграцией. Мы отрезали от рынка тоненькую дольку и сосредоточились лишь на ней. В новом мире мы хотим и готовы сотрудничать с компаниями любых отраслей промышленности, чтобы воспользоваться (и им, и нам) всеми преимуществами, которые сулит информационная революция.

Перемены коснутся всех отраслей индустрии. Некоторые компании, что сейчас занимаются обработкой информации или дистрибуцией, вдруг обнаружат, что уже не в состоянии вносить добавленную стоимость. Они сменят область своих деловых интересов, а их коллеги сумеют ответить на вызов новых конкурентов. Но трагедии в этом нет. Ведь вокруг такой непочатый край работы, особенно в сфере обслуживания, образования, городского управления, не говоря уже о том поле деятельности, которое откроет сама магистраль. Все это создаст новые рабочие места и новые возможности. Магистраль, которая позволит всем ощутить колоссальные объемы информации на кончиках пальцев, станет бесценным инструментом обучения. Тот, кто решит сменить карьеру и стать компьютерным консультантом, сможет воспользоваться лучшими лекциями лучших профессоров, моментально узнает о требованиях к тем или иным курсам, выяснит все об экзаменах и условиях аккредитации. Конечно, не каждому удастся избежать неурядиц в своей жизни. Но в целом общество только выиграет от этих перемен.

Капитализм - несомненно, величайшая из построенных экономических систем - в прошлое десятилетие наглядно доказал свои преимущества над другими системами. Информационная магистраль умножит эти преимущества. Она позволит тем, кто производит товары, намного зорче видеть, что хотят покупатели, а потенциальным клиентам намного выгоднее покупать эти товары. Адам Смит, наверное, порадовался бы за нас. Но потребители порадуются точно - и это гораздо важнее.


Глава 9 - Образование - лучшее вложение денег

Глава 9
Образование - лучшее вложение денег

Великие педагоги всегда говорили, что обучение - это не только занятия в классах или работа под присмотром учителей. Но все время перед теми, кто хотел удовлетворить свое любопытство или самостоятельно разобраться в каком-то вопросе, неизменно вставала одна проблема: где найти нужную информацию ? Магистраль, по-видимому, откроет перед нами бескрайнее море информации - доступной в любое время и в любом месте, когда и где мы пожелаем ею воспользоваться. Удивительные перспективы просто кружат голову, потому что эта технология, улучшая образовательный процесс, неизбежно преобразит и все сферы жизни общества.

Некоторые опасаются, что информационная технология приведет к дегуманизации образования. Но кто видел, как дружно возятся с компьютером дети - примерно как я со своими друзьями в 1968 году, - какой восторг охватывает студентов, которые обмениваются дружескими посланиями через океаны, тот знает: технология, напротив, способна гуманизировать среду образования. Вынуждая постоянно учиться, она превратит этот процесс в удовольствие и сразу же даст почувствовать практические результаты. В предвидении возможностей, которые сулит информационная технология, будут перестраиваться не только корпорации - изменения коснутся и школьных классов, и студенческих аудиторий.

Говард Гарднер (Howard Gardner), профессор из Harvard Graduate School of Education, доказывает, что разных детей и учить надо по-разному, потому что каждый по-своему воспринимает мир. Массовое образование не учитывает эту особенность. Гарднер считает, что в школах надо "ввести обучение профессиям, ближе знакомить с новыми технологиями, расширить внеклассную работу", чтобы каждый ученик занимался делом по душе. Уверен, в будущем общество опробует все подходы к образовательному процессу, так как информационная магистраль значительно упростит и их проверку, и их сравнение.

Информационная технология - подобно тому как сейчас она помогает корпорации Levi Strauss & Со. выпускать джинсы серийно и одновременно подгонять их по размеру, - принесет оптимальное сочетание методов коллективного и индивидуального обучения. Мультимедийные документы и простые в использовании авторские инструментальные средства позволят учителям корректировать учебные планы исходя из интересов конкретных учеников. В образовании, как и в изготовлении синих джинсов, станет возможным "массовое производство с подгонкой": компьютеры будут тонко настраивать продукцию - в данном случае учебные пособия, - чтобы обучение соответствовало способностям учащихся. Это касается не только школьников или студентов. И рабочие могут на тех же принципах повышать свою квалификацию, чтобы не отстать от достижений технологии.

Все члены общества, в том числе дети, будут располагать такими объемами информации, которыми сегодня не владеет никто. Мне кажется, одно это во многих пробудит любопытство и фантазию. Степень образованности будет зависеть только от желания каждого ее повысить.

Бытуют опасения, что техника вытеснит учителей. На это я могу недвусмысленно заявить: НИЧЕГО ПОДОБНОГО. Информационная магистраль не заменит и не обесценит таланта преподавателей, творческих способностей администраторов, внимания родителей, да и усердия самих учащихся наконец. Однако технология будет играть решающую роль в образовательном процессе.

Магистраль объединит труды лучших педагогов и авторов. Учителя будут опираться на эти материалы в своей работе, а студенты изучать их в интерактивном режиме. Со временем элитарное образование станет доступным даже тем, кому не выпало счастье обучаться в лучших учебных заведениях или родиться в состоятельной семье. Таким образом, каждый ребенок получит шанс максимально раскрыть свои природные дарования.

Однако мы никогда не придем к подобным достижениям, если нам не удастся изменить нынешнюю ситуацию с компьютерами в школах. Увы, вокруг них было поднято слишком много шумихи, а возлагавшиеся надежды не оправдались. Сегодня у большей части школьных персональных компьютеров не хватает мощности, чтобы они были просты в работе, недостаточна дисковая емкость, отсутствует связь с сетями - все это не позволяет детям "покопаться" в интересной для них информации. Поэтому компьютеры пока мало повлияли на образование.

Медленное внедрение новых технологий в школах в какой-то мере связано с консерватизмом педагогического истэблишмента, а также с дискомфортом и даже страхом, которые вызывают компьютеры у иных преподавателей и администраторов (их возраст в среднем старше, чем в других профессиональных группах). Здесь же сказывается и нехватка средств, выделяемых из бюджета на покупку вычислительной техники.

По использованию новой информационной технологии общеобразовательные школы в Соединенных Штатах значительно отстают от американского бизнеса. Дошкольники, знакомые с сотовыми телефонами, пейджерами и персональными компьютерами, попадая в начальные школы, видят только доски, мел и проекторы.

Рид Хандт (Reed Hundt), председатель Федеральной комиссии связи (U.S. Federal Communications Commission), так прокомментировал эту ситуацию: "В нашей стране еще тысячи зданий и миллионы людей, у которых нет ни телефонов, ни кабельного телевидения, ни особых надежд на подключение к широкополосным линиям связи. Я имею в виду школы".

Несмотря на слабую оснащенность, перемены в школах - и весьма значительные - все же произойдут. Но случится это не в одночасье. Внешне образовательный процесс останется прежним. Школьники так же будут ходить в классы, слушать учителей, задавать вопросы, выполнять домашние задания, участвовать во всех видах работ (в том числе лабораторных или экспериментальных).

Похоже, что никто во всем мире уже не возражает против установки в школах большего числа компьютеров, но темпы их поставок в разных странах разные. Лишь в нескольких государствах (например, в Нидерландах) компьютеры есть практически в каждой школе. Во Франции и во многих других странах компьютеров в школах пока не хватает, но правительства обещают исправить это положение. Англия, Япония и Китай вводят изучение информационной технологии в государственные образовательные программы, особое внимание уделяя профессиональной подготовке. Уверен, большинство государств увеличит объем инвестиций в образование, и в конце концов число компьютеров в школах сравняется с их количеством в домах и офисах. Со временем - в менее развитых странах ждать придется дольше - компьютеры действительно придут в каждый школьный класс.

Компьютерное оборудование дешевеет чуть ли не ежемесячно, а стоимость программ, ориентированных на систему образования, при оптовой закупке вполне доступна любой школе. Многие кабельные и телефонные компании в Соединенных Штатах уже пообещали бесплатное (или по льготному тарифу) подключение школ и библиотек к сетям в зоне своего действия. Например, Pacific Bell объявила о своих намерениях предоставить всем школам в Калифорнии бесплатные услуги в ISDN-сети сроком на 1 год, а TCI и Viacom предлагают во всех обслуживаемых ими районах бесплатный доступ школ к кабельной сети.

Хотя школьный класс так и останется школьным классом, новая технология многое изменит в нем. На уроках будут практиковать мультимедийные презентации, домашние задания, помимо чтения учебников, включать просмотр электронных документов, а может быть, и что-то большее. Школьников станут поощрять к углубленному изучению наиболее интересных для них предметов, и определиться в своем выборе будет совсем несложно. Часть дня они проведут за персональным компьютером, исследуя информацию самостоятельно или группой. Накопившиеся мысли и вопросы они выскажут своему учителю, а тот решит, какие из них заслуживают внимания всего класса. Пока школьники сидят за компьютерами, учитель может спокойно поработать с отдельными учениками или с небольшими группами и вместо общей лекции сосредоточиться на решении конкретных проблем и задач.

Педагоги, как и многие специалисты, кроме всего прочего, в современной экономике выступают посредниками - посредниками между знаниями и учащимися. А значит, им тоже придется не раз приспосабливаться к изменяющимся условиям. Однако, в отличие от людей некоторых других профессий, они могут смотреть в будущее с безусловным оптимизмом. Когда очередное новшество повышает уровень жизни общества, обязательно возрастает спрос на учителей. И педагоги, способные принести в школьные классы творческий дух и энергию, всегда будут преуспевать. То же самое можно смело сказать и о преподавателях, умеющих находить общий язык с детьми и разговаривать с ними на равных, как со взрослыми, - дети ценят это.

Всех нас учили и хорошие, и плохие педагоги. В средней школе у меня был изумительный учитель химии, преподававший свой предмет невероятно интересно. Химия увлекала меня куда больше биологии. На уроках биологии мы препарировали лягушек - по сути, просто кромсали их на куски, - и учитель не объяснял нам, зачем мы это делаем. В то же время преподаватель химии очень прочувственно рассказывал о своем предмете и обещал, что знание химии поможет нам понять этот мир. Когда мне перевалило за двадцать, я прочел монографию Джеймса Д. Уотсона (James D. Watson) Molecular Biology of the Gene (Молекулярная биология гена) и только тогда осознал, насколько меня подвел школьный опыт изучения биологии. Изучение жизни - великая наука. Открытия в области биологии являются важнейшими для людей, и через несколько десятилетий они революционизируют медицину. Ведь человеческая ДНК подобна компьютерной программе, только бесконечно совершеннее. И теперь мне кажется просто удивительным, что благодаря одному, хорошему учителю я восхищался химией, а из-за другого, плохого - изнывал от тоски на уроках биологии.

Когда преподаватели великолепно знают свое дело, готовят прекрасные материалы, от их усилий ежегодно выигрывают лишь несколько десятков их собственных студентов. Учителям, работающим в разных местах, сейчас очень трудно опираться на труды своих коллег. Сеть позволит совместно использовать учебные материалы и таким образом распространять достижения лучших педагогов. Чаще всего смотреть лекции в видеозаписях не так интересно, как слушать их из уст самого преподавателя. Но иногда возможность просмотра видеозаписи лекций конкретного преподавателя, иным образом не доступного, перевешивает потерю живого диалога. Например, несколько лет назад, будучи в отпуске, я и один мой знакомый обнаружили в Вашингтонском университете каталог видеозаписей с циклом лекций выдающегося физика Ричарда Фейнмана (Richard Feynman). Мы смогли посмотреть те лекции, которые Фейнман читал в Корнелле (Cornell) 10 лет назад. Конечно, мы получили бы от них гораздо больше, если бы присутствовали в той аудитории или могли задавать Фейнману вопросы, как на видеоконференции. Но четкость его мышления помогла нам разобраться во многих концепциях физики куда лучше, чем любая книга или любой другой преподаватель, с которыми я когда-либо имел дело. Он просто оживил свой предмет. И мне кажется, что эти лекции должен прослушать каждый, кто изучает физику. С появлением информационной магистрали эти и другие уникальные материалы станут доступными всем преподавателям и студентам.

Скажем, если какой-нибудь учитель из городка Провиденс (штат Род-Айленд) умеет особенно удачно объяснять суть и принципы фотосинтеза, текст его лекций и мультимедийные материалы могли бы получить преподаватели всего мира. Кто-то использовал бы эти материалы без изменений, а кто-то адаптировал бы их под свои условия, прибегнув к простым в обращении авторским программным средствам. Обратная связь с другими заинтересованными преподавателями позволила бы легко обновлять учебную информацию и совершенствовать ее подачу. Спустя непродолжительное время обновленными материалами пользовались бы уже тысячи учителей по всему миру. Наиболее популярные материалы выявить очень легко, потому что сеть позволит подсчитывать число обращений к ним или проводить опросы учителей в электронной форме. Корпорации, желающие помочь системе образования, смогут устанавливать денежные призы тем преподавателям, чьи материалы признаны лучшими.

Учителю непросто подготовить урок, который был бы интересен 25 ученикам 6 часов в день и 180 дней в году - тем более, что они постоянно смотрят телевидение и уже пресыщены всяческими зрелищами. Могу представить, как лет через десять учитель средней школы будет работать над лекцией о Солнце, пытаясь донести не только теорию, но и рассказать об истории открытий, которые сделали возможным создание самой этой теории. Когда он захочет выбрать какую-нибудь иллюстрацию - будь то слайд или видеозапись, снимок или портрет великого ученого, - информационная магистраль предоставит ему внушительный каталог разнообразных изображений. В его распоряжении окажутся фрагменты видеозаписей и озвученные анимации из бесчисленных источников. Понадобится всего лишь несколько минут, чтобы отобрать и составить из них иллюстративный ролик, - работа, на которую раньше уходили целые дни. Читая лекцию о Солнце, учитель продемонстрирует подходящие картины и схемы. Если какой-то ученик заинтересуется источником солнечной энергии, преподаватель проиллюстрирует свой ответ мультфильмом с изображением атомов водорода и гелия, покажет солнечные вспышки, пятна на Солнце; может быть, даже вызовет на видеопанель короткий видеоролик, поясняющий, как в результате слияния ядер выделяется энергия. Одним словом, наглядное обучение действительно оправдает свое название. Но для этого учителю придется сначала организовать нужные связи с серверами информационной магистрали. Список таких связей он раздаст своим ученикам, чтобы они, занимаясь дома или в библиотеке, изучили эти материалы внимательнее и под теми ракурсами, которые им более интересны.

А представим учителя живописи в старших классах, который воспользовался видеопанелью для демонстрации высококачественной цифровой репродукции картины Сера (Seurat) Bathers at Asnieres (Купание в Асньере). На этой картине изображены юноши, отдыхающие на берегу Сены в 1880-е годы, - на фоне парусных шлюпок и дымовых труб. Видеопанель проговорила бы название картины на чистом французском - Une Baignade а l'Asnieres - и развернула бы карту пригородов Парижа, выделив городок Асньер. Учитель мог бы проиллюстрировать этой картиной (написанной в стиле пуантилизма) закат импрессионизма. Или выйти через нее на более общие темы, например, рассказать о жизни французов в конце девятнадцатого столетия или о промышленной революции во Франции, а то и пояснить, как глаз воспринимает дополнительные цвета (complementary colors).

Показав на оранжевато-красную шляпу (фигура в правой части композиции), он скажет: "Взгляните, кажется, что шляпа дрожит на ветру. Здесь Сера воспользовался оптической иллюзией. Шляпа красная, но на ней есть крошечные точки оранжевого и синего цвета. Синий цвет Вы заметите, если только присмотритесь очень внимательно". Произнося эти слова, преподаватель так увеличит изображение шляпы, чтобы ученики смогли разглядеть фактуру холста. При таком масштабе станут заметны синие пятнышки, и учитель объяснит, что синий цвет дополняет оранжевый. Затем на видеопанели появится изображение круга с разноцветными сегментами (color wheel), и либо учитель, либо сам мультимедийный документ пояснит: "Каждый цвет на этой окружности расположен напротив того цвета, который его дополняет: красный - напротив зеленого, желтый - напротив фиолетового, а синий - напротив оранжевого. Такова особенность наших глаз: смешение дополнительных цветов усиливает их интенсивность. Сера знал об этом и, чтобы красные и оранжевые тона шляпы казались ярче, добавил вкрапления синего цвета, обманув этим наше зрение".

Компьютеры, подключенные к информационной магистрали, помогут преподавателям отслеживать и оценивать успехи учащихся, а при необходимости и корректировать их обучение. В домашние задания, которые, конечно, никуда не денутся, очень скоро войдут гипертекстовые ссылки на электронные источники. Студенты и школьники станут создавать собственные гиперсвязи и использовать мультимедийные элементы в своих домашних работах, передавая их руководителю в электронной форме на дискете или через информационную магистраль. Преподаватели будут накапливать своеобразное досье студенческих работ, просматривать их в любой момент или делиться ими с другими преподавателями.

Специальные программы помогут обобщать информацию об успехах, уровне знаний, интересах и ожиданиях учащихся. Свободные от бумажной рутины учителя, опираясь на собранные сведения, смогут уделять каждому ребенку больше внимания. Эта информация позволит также безошибочно подгонять учебные пособия, классные и домашние задания под конкретного школьника. И она же поддержит преподавателя в разговоре с родителями ученика о его успеваемости. В результате такого заинтересованного общения (включая постоянные видеоконференции) удастся наладить самый тесный контакт между учителями и родителями. Последние будут успешнее помогать своим детям, может быть, привлекая репетиторов или объединяя усилия с другими родителями.

Родители должны познакомить своих детей с теми программами, которые они применяют на работе. Некоторые преподаватели уже сейчас используют популярные деловые программы для организации своей работы и для того, чтобы привить студентам навыки обращения с современными рабочими инструментами. Многие студенты колледжей и старшеклассники теперь готовят доклады не на пишущих машинках (тем более не от руки), а на персональных компьютерах в текстовых процессорах. Уже стало обычным делом, излагая математические и экономические теории, применять электронные таблицы и приложения для построения разных типов диаграмм, а на большинстве финансово-бухгалтерских курсов - и вообще стандартом. Кстати, студенты и профессорско-преподавательский состав сегодня пополнили ряды пользователей наиболее распространенных деловых приложений. Например, среди студентов, изучающих иностранные языки, очень популярны текстовые процессоры, способные работать с несколькими языками. Такие программы включают дополнительные средства для проверки орфографии и подбора синонимов в многоязычных документах.

В некоторых семьях, напротив, именно дети знакомят своих родителей с вычислительной техникой. Ребятишки отлично ладят с компьютерами отчасти потому, что у них еще не выработались стереотипы выполнения тех или иных задач. Кроме того, дети очень любят проверять ответные реакции на свои действия, и компьютеры в этом смысле просто идеальны. Родители иногда изумляются, насколько их юные чада увлечены компьютерами, но в этом нет ничего удивительного, просто детям нравится интерактивность, - играют они с Вами в прятки, возятся с пультом дистанционного управления, переключая телевизионные каналы, или нажимают на клавиши компьютера.

Я всегда с удовольствием наблюдаю, как моя трехлетняя племянница играет в Just Grandma and Me, - CD-ROM-версию одной детской книги, выпущенную фирмой Broderbund. Она запоминает диалоги в этом мультфильме и разговаривает с персонажами примерно так же, как это делает, когда сказку ей читает мама. Если моя племянница берет мышку компьютера и щелкает почтовый ящик, тот открывается и из него выпрыгивает лягушка, а иногда высовывается рука, которая снова захлопывает дверцу ящика. Возможность влиять на поступки экранных героев, выяснять: "Что получится, если я щелкну здесь ?" - сильно разжигает ее любопытство. Интерактивность в сочетании с хорошим, интересным сюжетом удерживает внимание маленького ребенка.

Я всегда считал, что большинство людей гораздо умнее и любопытнее, чем это может показаться при их работе с современными информационными инструментами, которые не раскрывают этих человеческих достоинств. Многим знакомо чувство удовлетворения, когда, заинтересовавшись какой-то темой, удается обнаружить превосходные материалы и досконально ее изучить. Но согласитесь, если поиск информации заводит в тупик, руки опускаются, тут же начинаешь думать, что уже никогда не разберешься в данном предмете. И когда подобная ситуация повторяется все чаще, в особенности с ребенком, желание попробовать еще раз постепенно тает.

Мне посчастливилось вырасти в семье, где детей поощряли задавать вопросы. Повезло мне и в том, что в детстве я дружил с Полом Алленом. Как-то раз, сразу после нашего знакомства, я спросил его, откуда берется бензин. Я очень хотел узнать, что это значит - "очищать" бензин и как на нем работают машины. Я раздобыл книгу о горючих жидкостях, но ничего в ней не понял. А Пол (он здорово разбирался не только в бензине, но и во многих других вещах) сумел доходчиво и занятно все мне объяснить. Считайте, что пламя нашей дружбы разгорелось из моего интереса к бензину.

У Пола всегда были ответы на мучившие меня вопросы (и огромная коллекция научной фантастики). А я был сильнее Пола в математике и программировании (среди знакомых Пола в этом мне вообще не было равных). Так что мы стали друг для друга интерактивными источниками знаний: спрашивали, отвечали, рисовали схемы или рассказывали, где найти нужные сведения. Нам нравилось бросать вызов друг другу и проверять свои знания. Именно так и будут взаимодействовать пользователи с информационной магистралью. Допустим, еще один подросток заинтересуется бензином - не в 1970, а где-нибудь в 2000 году. Ему не повезло, и у него нет такого друга, как Пол Аллен, но если в его школе или библиотеке есть компьютер, связанный с богатыми "залежами" мультимедийной информации, он сможет зарыться в свою тему так глубоко, как только пожелает. Он увидит фотографии, видеозаписи и мультролики, поясняющие, как выкачивают, перевозят и очищают нефть. Он узнает, в чем разница между автомобильным и авиационным топливом. А чтобы выяснить, чем отличается двигатель внутреннего сгорания от газотурбинного, ему надо лишь спросить об этом.

Он сможет исследовать сложную молекулярную структуру бензина, который представляет собой смесь сотен различных углеводородов, и попутно разобраться в самих углеводородах. При стольких-то связях с источниками знаний - кто знает, на какие просторы выведет его это исследование ?..

Поначалу новая информационная технология сделает небольшой шажок вперед по сравнению с нынешними инструментами. Вмонтированные в стену видеопанели заменят неровные строчки и кривые схемы на школьных досках четкими шрифтами и красочной графикой - миллионами учебных иллюстраций, фотографий, мультфильмов и видеозаписей. Мультимедийные документы частично возьмут на себя функции учебников и учебных пособий. Кроме того, связанные с серверами на информационной магистрали, мультимедийные документы будут постоянно и автоматически обновляться.

Существующие сегодня CD-ROM-диски позволяют представить, что такое интерактивность. Программное обеспечение реагирует на команды, выводя информацию в виде текста, звука и видеоизображений. CD-ROM-диски уже используются детьми в школах и дома, но эти диски имеют ряд ограничений, которых не будет у магистрали. Сейчас на них предлагается либо понемногу обо всем (как в энциклопедиях), либо все по одной теме (скажем, о динозаврах), но общий объем единовременно доступной информации строго определяется емкостью диска. Ну и, разумеется, Вы можете работать только с теми дисками, которые у Вас есть. Тем не менее это крупное достижение, если сравнить с текстами, отпечатанными на бумаге.

Мультимедийные энциклопедии дают не только знания, но и возможность вставлять из них материалы в домашние документы, кроме того, энциклопедии содержат инструкции для учителей: как лучше ими пользоваться в школе на уроках, а как - при выполнении домашних заданий. Я был глубоко взволнован, услышав от преподавателей, студентов и школьников о том, как они работают с нашими программными продуктами, - многое мы просто и не предвидели.

CD-ROM-диск - один из предшественников информационной магистрали. "Всемирная паутина" в Internet - другой. Она обеспечивает доступ к интересной образовательной информации, правда, основная ее часть - простой текст. Преподаватели с творческой жилкой уже обращаются к этим материалам, придумывая новые, более захватывающие формы лекций.

Ученики четвертого класса в Калифорнии занимались поиском в сетях газет, сообщавших что-либо о проблемах, с которыми сталкиваются выходцы из Азии. В Бостонском университете создали интерактивную программу для старшеклассников, которая детально и наглядно моделирует такие химические явления, как растворение в воде молекул солей.

А например, средняя школа имени Христофора Колумба (Christopher Columbus Middle School) в Юнион-сити (штат Нью-Джерси), благодаря применению новой информационной технологии, смогла выйти из жесточайшего кризиса. В конце восьмидесятых средние экзаменационные баллы в этой школе были такими низкими, а процент прогулов и отчислений среди детей - таким высоким, что ее администрацию решили сменить. Но управление по делам образования, учителя и родители (свыше 90% которых - выходцы из испаноязычных стран, плохо владеющие английским) предложили план по спасению этой и аналогичных школ, рассчитанный на 5 лет.

Bell Atlantic (местная телефонная компания) согласилась им помочь. Была создана специальная сетевая мультимедийная система на базе персональных компьютеров, соединившая дома учащихся со школьными классами, преподавателями и администрацией. Изначально корпорация предоставила 140 мультимедийных ПК, что позволило оборудовать дома семиклассников, дома их учителей и установить минимум по четыре компьютера в школьных классах. Компьютеры были оснащены сетевыми платами и подключены к высокоскоростным линиям, связанным с Internet. Корпорация взяла на себя и еще одну обязанность: обучить преподавателей работе на персональных компьютерах. Затем преподаватели по выходным дням устраивали курсы для родителей (явка последних была свыше 50%) и поощряли учащихся активно пользоваться электронной почтой и Internet.

Спустя 2 года родители уже помогали своим детям работать с домашними ПК и поддерживали тесные контакты с преподавателями и администрацией школы. Результаты не замедлили сказаться: процент прогулов и отчислений свелся к нулю, а на экзаменах эти школьники показывали результаты почти в 3 раза выше, чем в среднем по городским школам штата Нью-Джерси. И тогда эту программу распространили на все средние школы штата.

Реймонд У. Смит (Raymond W. Smith), председатель правления Bell Atlantic, так отозвался об этих событиях: "Я считаю, что готовность школьной системы к коренным изменениям, включая сами методы обучения, заинтересованное и активное участие родителей, а также продуманное внедрение новой технологии... позволили создать настоящее педагогическое сообщество, в котором дом и школа дополняют и поддерживают друг друга".

В средней школе Lester В. Pearson School (Канада), расположенной в районе, где проживает множество этнических групп, компьютеры - неотъемлемая часть повседневного учебного процесса. На 1200 школьников приходится более 300 персональных компьютеров, при этом они используют свыше 100 различных программ. Если верить администрации школы, у них самый низкий процент отчисления учащихся - всего 4% (в среднем по Канаде этот показатель равен 30%). Ежегодно в эту школу приезжает до 3500 человек, чтобы воочию убедиться в том, как "новые технологии преобразуют все стороны школьной жизни".

Когда информационная магистраль вступит в строй, каждый получит доступ к сокровищам миллионов книг. Читатель сможет задавать вопросы, распечатывать текст, читать его прямо с экрана или даже прослушивать, выбирая диктора на свой вкус. Информационная магистраль станет его наставником, домашним учителем.

Компьютеры с дружескими интерфейсами сами установят, в какой именно форме лучше подавать информацию тому или иному пользователю. Во многие образовательные программные средства заложат целый ряд совершенно разных личностей, и тогда школьник и компьютер смогут приятельски болтать друг с другом. Школьник спросит (может быть, вслух): "Отчего разгорелась Гражданская война в Америке ?" И компьютер ответит: "Это была битва за новую экономику, за права человека". Продолжительность и глубина ответа будут зависеть от конкретных обстоятельств и уровня подготовки данного ребенка. Он сможет в любой момент перебить компьютер, попросить рассказать что-то подробнее, а что-то покороче или изложить материал по-другому. А компьютеру будет известно, насколько силен его "подопечный", что он читал или смотрел на эту тему, и поэтому машина сама внесет коррективы в форму подачи материалов. Если компьютер знает, что тот любит исторические романы, военные рассказы, фолк-музыку или спорт, попробует преподнести запрошенную информацию именно в такой "упаковке". Но машина, как и хороший педагог, не пойдет на поводу у ребенка с односторонними интересами. Напротив, она воспользуется его пристрастиями, чтобы расширить его кругозор, увлечь новыми идеями.

Интенсивность обучения определят природные способности учеников - компьютеры будут заниматься с каждым столько, сколько нужно. И конечно, особое внимание будет приковано к детям, отстающим в учебе. Таким образом, все школьники будут получать образование по индивидуальному плану.

Еще одним преимуществом компьютеризованного обучения станет совсем другое отношение школьников к экзаменам. Не секрет, что сегодня они оказываются для детей тяжелым испытанием, нередко вызывая панический ужас: "Я опять провалил этот предмет !", "Мне не хватило времени..." или "Я начисто забыл этот материал". Через какое-то время у многих неудачников, среди которых есть дети просто медлительные или неорганизованные, опускаются руки, они уже не стараются, делают вид, что экзамены - чепуха. В итоге развивается негативное отношение к учебе вообще.

Интерактивная сеть позволит учащимся экзаменовать самих себя постоянно и в спокойной обстановке. Самоконтроль сродни самоанализу, он чем-то похож на те проверки, которые Пол Аллен и я устраивали друг другу. Только так можно изменить отношение к экзаменам. Ошибка не повлечет за собой наказания; напротив, она заставит систему помочь учащемуся восполнить пробел в какой-то теме. Если же кто-то зайдет в окончательный тупик, система предложит обсудить проблему с преподавателем. Систематически контролируя себя, учащийся будет чувствовать степень своей подготовки, и тогда официальные экзамены перестанут навевать столько опасений и приносить столько сюрпризов.

Многие фирмы, выпускающие образовательные программные средства и пособия, уже поставляют интерактивные программные продукты для изучения основ языкознания, математики, экономики, биологии. Например, компания Academic Systems из Пало-Альто (штат Калифорния) работает над интерактивной мультимедийной системой для колледжей, которая помогает в изучении базовых курсов английского языка и математики. Принятую концепцию назвали "опосредованное обучение" (mediated learning); она сочетает методы традиционной педагогики с компьютеризованным обучением. Каждый студент начинает с пробного экзамена, чтобы выяснить, какие темы он знает, а какие - нет. После этого система составляет подробный план занятий для данного студента. Его успехи постоянно проверяются, и, по мере освоения им учебных материалов, в персональный план занятий вносятся соответствующие коррективы. В случае затруднений программа сообщает о них преподавателю, и тогда тот индивидуально занимается со студентом. Сейчас эта программа только "обкатывается", но одно уже очевидно: студенты довольны новыми учебными материалами, хотя максимальных успехов добиваются те группы, которым преподаватель уделял больше времени. Эти результаты подчеркивают тот факт, что новая технология сама по себе не улучшит образование.

Некоторые родители воспринимают компьютеры в штыки, считая, что машина не может уследить, чем занимается их ребенок. Они радуются, когда дети, не отрываясь, читают захватывающую книгу, но испытывают куда меньший энтузиазм, когда они часами просиживают за компьютером. Видимо, все дело здесь в видеоиграх. Ребенок, проводящий много времени за видеоигрой, мало чему учится. До сих пор основные средства идут на разработку развлекательных, а не образовательных компьютерных программ. Ведь создать увлекательную игру куда проще, чем познакомить ребенка с миром информации, сделав это просто и интересно.

Как только в городских и семейных бюджетах изменится приоритет трат - в сторону выпуска и покупки интерактивных учебных пособий, непременно появятся тысячи новых программистских фирм, которые создадут в сотрудничестве с педагогами занимательные интерактивные пособия. Например, Lightspan Partnership совместно с Голливудом уже сейчас работает над серией познавательных программ, где мультипликация будет чередоваться с игрой настоящих актеров. Lightspan надеется, что их программы, построенные на основе прогрессивных технологий, захватят внимание юных зрителей (от пяти до одиннадцати лет) и пробудят в них интерес к знаниям. Живые персонажи сопровождают ребенка на всех занятиях (для объяснения базовых понятий) и во всех играх (для закрепления пройденного материала). Уроки сгруппированы в циклы, которые дополняют элементарные школьные курсы по математике, чтению и языку. Программы, выпускаемые этой фирмой, будут доступны в домах (благодаря интерактивному телевидению), общественных центрах и школах. Но пока интерактивное телевидение еще не получило широкого распространения, этот вид программного обеспечения будет предлагаться владельцам персональных компьютеров на CD-RОМ-дисках или через Internet.

Однако только информация, только новая технология не смогут решить всего комплекса серьезных проблем, стоящих сегодня перед многими общественными школами: нехватка бюджетных средств, насилие, наркотики, высокий процент исключений, криминогенная обстановка и незавидное положение учителей, больше озабоченных собственным выживанием, чем учебным процессом. Все общество должно обратить внимание на эти фундаментальные проблемы.

И все же именно общественные школы, несмотря на трудности, - наша величайшая надежда. Представьте ситуацию, когда большинство детей в городских общественных школах живут на пособие, едва-едва умеют говорить на государственном языке, мало что знают, и их ждет весьма неопределенное будущее. Такова была Америка в 1900-е годы, когда страну наводнили иммигранты и десятки миллионов их детей переполнили школы, парализовав систему социальной помощи в наших городах.

И все же то поколение (и следующее за ним) сумело добиться высокого уровня жизни, равного которому в мире нет. Проблемы американских школ не являются чем-то непреодолимым, они просто сложны. Даже сегодня на каждую общественную школу, пребывающую в бедственном состоянии, приходятся десятки хороших школ, о которых в газетах, к сожалению, ничего не пишут. Я уже приводил несколько примеров. В этой книге я не собираюсь слишком углубляться в данный предмет, скажу одно: общество может отвоевать и уже отвоевывает свои улицы и школы. Но такая борьба всегда требует напряжения сил и идет постепенно - улица за улицей, школа за школой. Да и сами родители должны прикладывать усилия к тому, чтобы дети приходили в школы с желанием учиться. Если относиться ко всему по принципу "Пусть этим занимается школа (или правительство)", ничего хорошего не выйдет - это точно.

Как только в стране сложится хотя бы умеренно позитивное отношение к образованию, информационная магистраль непременно поднимет уровень знаний молодых поколений. Магистраль позволит ввести новые методики преподавания и предоставит гораздо больший выбор. За счет государственных субсидий можно разработать качественные учебные программы и сделать их бесплатными. Появятся и частные поставщики, которые будут конкурировать с государственными в своем стремлении улучшить бесплатные пособия. В их роли выступят и сторонние общественные школы, и преподаватели, работающие в школе или ушедшие в бизнес, и даже некие педагогические службы, предлагающие свои услуги через магистраль. В итоге информационная магистраль станет для школ способом привлечения и отбора новых преподавателей или использования их услуг на расстоянии.

Магистраль упростит и домашние занятия. Она позволит родителям выбирать подходящие классы из множества разнообразных вариантов и легко контролировать успеваемость своих детей.

Обучение с помощью компьютера явится плацдармом, с которого дети шагнут в огромный мир знаний, чтобы продолжить учебу в других формах. Любой ребенок должен все потрогать своими руками - будь то игрушка или инструмент. Наблюдение за химической реакцией на экране компьютера - хорошее дополнение к лабораторным занятиям по химии, но оно не заменит практического опыта. Дети нуждаются в общении друг с другом и со взрослыми, иначе они не научатся работать в коллективе, не овладеют социальными нормами поведения.

Хороший учитель будет делать гораздо больше, чем просто подсказывать детям, где найти ту или иную информацию на магистрали. Ведь им по-прежнему нужно учиться письму, искусству общения и многим-многим другим вещам, в том числе использованию техники как инструмента в своей деятельности. Добьются успеха те учителя, которые возьмут на себя роль наставников и партнеров, подтолкнут детей к творчеству, перекинут для них мостик в большую взрослую жизнь.

Компьютеры на информационной магистрали смогут моделировать мир, равно как и объяснять его. Несколько лет назад один учитель из Sunnyside High School в Тусоне (штат Аризона) организовал школьный клуб, где занимаются компьютерным моделированием реальной жизни и ее событий. Школьники даже создали математическую модель банды и убедились, какими последствиями чревато участие в ней. Успех этого клуба заставил полностью пересмотреть учебные программы по математике. Основная идея реорганизации сводилась к тому, что образование - это не раздача "правильных" ответов на все случаи жизни, а обучение детей методам, позволяющим самостоятельно найти "правильный" ответ.

Особенно полезно моделирование при изучении наук. Теперь дети учатся тригонометрии, не выполняя какие-то абстрактные упражнения, а измеряя высоту реальных гор, проводя тригонометрическую съемку из двух точек. Уже появился ряд компьютерных моделей, обучающих биологии. Например, популярная программа SimLife моделирует процесс эволюции, чтобы дети своими глазами увидели его. И вовсе не обязательно быть ребенком, чтобы получить удовольствие от этой программы, которая позволяет "создавать" растения и животных, а затем наблюдать, как они взаимодействуют друг с другом и участвуют в экосистеме, тоже сконструированной Вами. Фирма Maxis Software, издатель программы SimLife, выпускает и другую программу, SimCity, которая дает возможность построить город со всеми его взаимосвязанными системами, такими, как дороги и общественный транспорт. Вы становитесь мэром или архитектором виртуального общества, стремясь реализовать Вами же поставленные цели. Вы строите фермы, заводы, дома, школы, университеты, библиотеки, музеи, зоопарки, больницы, тюрьмы, порты, скоростные шоссе, мосты и даже подземки. Вы сталкиваетесь с проблемами роста города или природными катаклизмами, в том числе с пожарами. Вы преобразуете и сам ландшафт. Вы вносите какие-то коррективы в модель города (например, строите аэропорт или увеличиваете налоги), а они тут же - вполне предсказуемо или неожиданно для Вас - сказываются на жизнедеятельности всего смоделированного общества. Это потрясающе увлекательная игра и в то же время очень быстрый метод познания того, как устроен мир.

Моделирование помогает исследовать и то, что лежит за пределами Земли. Дети, играя с космическими имитаторами, путешествуют по солнечной системе или галактике на космическом корабле. Многие из тех, кому кажется, что их не интересует ни биология, ни устройство городов, ни космос, поэкспериментировав с компьютерными моделями, уже больше так не думают. Когда научные понятия и теории подаются в наглядной и занимательной форме, они способны увлечь даже самых равнодушных и ленивых.

В будущем учащиеся всех возрастов и способностей смогут визуально представлять любую информацию и взаимодействовать с ней в интерактивном режиме. Студенты, например, изучая погоду, будут просматривать спутниковые снимки, полученные на основе модели гипотетических метеорологических условий. Такая модель позволит задавать вопросы типа "а что если ?", скажем: "Как изменится завтрашняя погода, если скорость ветра возрастет на 25 км/ч ?" Компьютер просчитает все параметры по этой модели и покажет на экране погодные условия такими, какими они выглядели бы из космоса. Игровые имитаторы, несомненно, станут гораздо совершеннее, но даже сейчас лучшие из них просто зачаровывают и несут в себе огромный учебный потенциал.

Когда смоделированные ситуации приблизятся к жизненным, наступит царство виртуальной реальности. Уверен, что на каком-то этапе в школах появится оборудование для создания виртуальной реальности, может быть, даже целые классы - есть же музыкальные залы и театры в некоторых наших школах ! Это поможет учащимся исследовать любую область и любой объект в занимательной интерактивной форме.

Однако технология не приведет к изоляции школьников друг от друга. Ведь одна из важнейших целей образования - научить детей работать и жить в коллективе. В некоторых самых передовых школах мира компьютеры и коммуникационные сети уже влияют на традиционные отношения учащихся между собой и с учителями, способствуя развитию навыков коллективной работы.

Преподаватели школы Ralph Bunche (P.S. 125) в Гарлеме организовали компьютеризованный обучающий узел, где нью-йоркские школьники узнают, как пользоваться Internet для научных исследований, как познакомиться с ровесниками из всех стран мира и как обращаться к добровольным наставникам из расположенного неподалеку Колумбийского университета. Ralph Bunche была одной из первых начальных школ в стране, которая завела во "всемирной паутине" свою домашнюю страницу. На этой странице есть связи с такими школьными реалиями, как стенная газета, художественные работы детей и даже - урок по испанскому алфавиту с иллюстрациями.

Internet, упрощая сотрудничество с отдаленными институтами, оказывает значительную помощь в проведении учебных экспериментов - особенно на уровне колледжа. Университеты всегда были на острие всевозможных компьютерных новшеств. Несколько университетов являются настоящими исследовательскими центрами, которые изучают новые компьютерные технологии, а ряд других имеет крупные компьютерные лаборатории, где работают студенты. Кроме того, сегодня самые интересные страницы во "всемирной паутине" создаются именно университетами.

Некоторые университеты используют сети не столь глобально. Например, в Вашингтонском университете во "всемирную паутину" помещают планы занятий и задания по некоторым курсам. Там же часто публикуют конспекты лекций, и любой желающий может бесплатно ими воспользоваться - мне бы такое в мои студенческие годы ! А где-нибудь в другом учебном заведении учитель английского настаивает на участии всех студентов во внеаудиторных дискуссиях - через систему электронной почты. Таким образом, оценка выставляется не только по результатам аудиторных занятий и домашних заданий, но и по вкладу в дискуссии, проводимые в электронной форме.

Студенты колледжей уже почувствовали вкус к электронной почте, которую они применяют не только в учебных целях, но и - за весьма умеренную плату - для общения с семьей и друзьями, в том числе с теми, кто учится в других университетах. Да и родители студентов все активнее вливаются в ряды постоянных пользователей электронной почты, потому что сегодня это лучший способ контакта со своими детьми. Даже в некоторых начальных школах учащимся постарше разрешают открывать собственную учетную запись в Internet. В Лейксайде, школе моего детства, внутренняя сеть теперь подключена к Internet, что позволяет детям просматривать оперативную информацию и общаться по электронной почте со сверстниками из США и из других стран. Почти все учащиеся открыли учетные записи в системе электронной почты и за 12 недель получили целых 259587 сообщений - в среднем по 30 сообщений в неделю на каждого. Из них 49000 сообщений пришло через Internet, а сами они отправили порядка 7200 сообщений.

В Лейксайде точно не знают, сколько сообщений отправляет каждый школьник и что они в них пишут. Конечно, некоторые посвящены школьным делам, но большая часть, в том числе отправляемая по Internet, несомненно, касается сугубо личных интересов школьников. Администрация Лейксайда относится к этому достаточно спокойно - не как к злоупотреблению электронной почтой, а как к дополнительному виду учебы.

Многие учащиеся средних школ (вроде нью-йоркской P.S. 125) с удовольствием общаются со сверстниками из других стран, с иной культурой, и участвуют в сетевых дискуссиях по всему миру. Целые классы (из разных штатов и государств) уже связываются между собой по сети, образуя то, что сейчас называют "учебными кружками" ("learning circles"). Большинство учебных кружков помогает школьникам усвоить определенные темы, выслушав точку зрения своих единомышленников или оппонентов. В 1989 году, когда рухнула Берлинская стена, западногерманские школьники смогли обсудить это событие со сверстниками из разных стран. А например, другой учебный кружок изучал китобойный промысел совместно со школьниками из Alaskan Inuit - эскимосы по-прежнему питаются в основном китовым мясом. Ребята так заинтересовались их бытом, что пригласили к себе старейшину племени.

Вице-президент Эл Гор выступил с инициативой - широкомасштабным проектом GLOBE (Global Learning and Observations to Benefit the Environment - глобальное изучение и наблюдение окружающей среды). Он рассчитан на школьников, пользующихся компьютерными сетями. Есть надежда, что этот проект согласятся финансировать и правительства, и частные лица. Проект предполагает, что старшеклассники по всему миру будут собирать научную информацию о Земле. Дети займутся рутинным сбором статистических сведений (температура, количество атмосферных осадков и т.д.) и передачей их через Internet и спутниковую связь в центральную базу данных управления National Oceanic and Atmospheric Administration, расположенного в Мэриленде, где на основе этой информации будут формировать карты, отражающие состояние планеты. Затем эти карты перешлют обратно школьникам, а также передадут ученым и познакомят с ними широкую общественность. Никто пока не знает, какова окажется научная ценность подобных данных - особенно если сбором займутся совсем юные участники проекта, - но эта работа, безусловно, станет грандиозным вкладом в глобальное сотрудничество огромного числа детей разных наций и приобщит их к экологическим проблемам.

Образовательные возможности магистрали будут доступны не только школьникам и студентам, но и всем желающим "подучиться". Каждый человек, где бы он ни был, сможет пользоваться лучшими курсами лучших преподавателей. Через магистраль многие взрослые повысят уровень своего образования, профессиональную квалификацию.

Специалисты различных профилей, общественно-политические лидеры и родители примут участие в образовательном процессе, пусть даже эпизодически. Это пойдет на пользу всем и вряд ли будет стоить дорого. Думаю, что присутствие таких гостей на занятиях (через видеоконференции прямо из их домов или офисов) станет обычной практикой.

Когда студенты и школьники будут напрямую связаны с безграничной информацией и друг с другом, перед учебными заведениями и обществом в целом неизбежно встанут новые вопросы и проблемы. (Некоторые из них - касающиеся Internet - я уже рассматривал в этой книге.) Разрешать ли учащимся приносить в классы свои портативные компьютеры ? Разрешать ли кому-то заниматься индивидуальным поиском в сети на общих занятиях ? Если - да, то какую степень свободы можно дать учащимся ? Могут ли они обращаться к той информации, которую их родители считают неприемлемой с моральной, общественной или политической стороны ? Разрешать ли выполнение домашних заданий, рассчитанных на другие классы ? Разрешать ли во время уроков обмен электронными "записочками" ? Надо ли учителю постоянно следить за тем, что происходит на экране компьютера у каждого школьника, или вести запись для последующей выборочной проверки ?

Какие бы проблемы ни вызвал прямой доступ к неограниченной информации, выгоды, которые он сулит, с лихвой компенсируют эти проблемы. Мне нравилось учиться в школе, но большую долю своего любопытства я утолял за ее стенами. Насколько бы изменилась моя школьная жизнь, будь в то время подобный доступ к информации, - теперь остается только гадать ! Информационная магистраль сместит "фокус" в образовании с аудиторий на личность. Целью образования станет не диплом, а наслаждение непрерывной учебой - на протяжении всей жизни.


Глава 10 - Информационная магистраль и дом

Глава 10
Информационная магистраль и дом

Одно из многих опасений, высказываемых по поводу информационной магистрали, - не получится ли так, что мы будем меньше времени проводить в обществе себе подобных ? Некоторые боятся, как бы дома не превратились в этакие уютные центры досуга, которые никому не захочется покидать, и как бы люди, укрывшись в этих убежищах, не оказались в изоляции друг от друга. Но я так не думаю и попытаюсь доказать это на примере своего дома.

Этот дом, который я строю, как мне уже кажется, чуть ли не всю жизнь (а читаю об этом даже дольше), оборудуется по последнему слову техники; в нем есть, например, небольшой кинотеатр и система "видео-по-заказу". Жить в нем очень интересно, но я определенно не собираюсь проводить там все время. Ведь покупая теле-, радио- и другую "развлекательную" аппаратуру, Вы не перестаете ходить в театры, парки, музеи и магазины, потому что мы, как говорят ученые, существа общественные. Но мы сможем чаще оставаться дома, ведь магистраль создаст великолепные условия для отдыха, общения (дружеского и делового) и работы. И хотя характер, да и само соотношение многих видов деятельности, несомненно, изменятся, думаю, что большую часть времени люди будут проводить вне дома.

В первой главе я упомянул, что новое всегда вызывает опасения. В пятидесятые годы боялись, например, что телевидение, изобретение тех лет, вытеснит кинотеатры, и все будут сидеть по домам и смотреть только телевизор. Впоследствии платное ТВ, а затем и система видеопроката спровоцировали те же страхи. Разве станет кто-то тратиться на парковку, нанимать няню к ребенку, покупать напитки и шоколадные батончики с жуткой наценкой только ради того, чтобы посидеть в темноте с незнакомыми людьми ? Но кинотеатры по-прежнему полны. Лично я очень люблю кинематограф и предпочитаю смотреть фильмы в кинотеатрах. Я хожу в кино почти каждую неделю и не думаю, что информационная магистраль что-нибудь здесь изменит.

Новые коммуникационные возможности позволят куда проще, нежели сегодня, поддерживать контакт с друзьями и родными, живущими за тридевять земель. Наверное, каждый человек хоть раз в жизни потерял друга только из-за того, что тот переехал на новое место. В свое время я "встречался" с женщиной, которая жила в другом городе. Мы проводили много времени друг с другом - по электронной почте. И придумали способ, как нам вместе ходить в кино. Найдя фильм, который шел в кинотеатрах наших городов примерно в одно время, мы бы отправлялись в кино, болтая по сотовому телефону. А посмотрев фильм, по дороге домой обсуждали бы его все тем же способом. В перспективе подобные "виртуальные свидания" станет устраивать легче, потому что просмотр фильма можно сочетать с видеоконференцией.

Я уже играю в бридж через оперативную систему. В этой системе есть своего рода приемная, которая позволяет игрокам видеть, кто еще хочет к ним присоединиться. Играющие могут самым примитивным образом выбирать для себя обличье, в котором они хотят предстать перед партнерами: пол, прическа, телосложение и т.д. В первый раз подключаясь к этой системе, я очень спешил к назначенному времени и совсем не позаботился о своей электронной внешности. Когда мы начали игру, мои друзья стали присылать мне сообщения, что на их экранах я выгляжу лысым и голым (показывается только часть тела от пояса и выше). Конечно, данная система не идет ни в какое сравнение с будущими, которые обеспечат полноценную видео- и речевую связь, но сама возможность обмениваться друг с другом "записочками" в процессе игры - штука все-таки замечательная.

Магистраль не только упростит контакты с друзьями из далеких краев, она познакомит Вас с новыми. Дружба, родившаяся в сети, в конце концов приведет к личной встрече. Сегодня способы знакомства с теми людьми, которым мы симпатизируем, весьма ограниченны, но сеть это изменит. Разнообразие впечатлений сделает жизнь гораздо интереснее. Допустим, Вы хотите поиграть в бридж. Информационная магистраль поможет подобрать партнера с соответствующим (Вашему) уровнем мастерства - хоть по соседству, хоть в другой стране. Идея интерактивных игр с удаленными участниками вряд ли нова. Любители шахмат издревле проводили турниры по почте: одно письмо - один ход. Вся разница в том, что исполняемые в сети приложения упростят поиск партнеров с одинаковыми увлечениями и позволят играть в том же темпе, как если бы это происходило "вживую".

Еще одно отличие заключается в том, что в процессе игры (в бридж или Starfighter) Вы сможете беседовать со всеми ее участниками. Используя новые DSVD-модемы, о которых я уже рассказывал, Вы будете разговаривать с игроками по обычным телефонным линиям, в то время как на экране Вашего компьютера развернутся перипетии самой игры.

Игра в дружеской "электронной" компании, как и за традиционным карточным столом, сближает людей, порождает среди них дух здорового соперничества. А за беседой играть гораздо интереснее. Поэтому ряд фирм выводят сейчас на новый уровень концепцию игр с несколькими участниками. В скором времени Вы сможете сражаться не только в одиночку или с друзьями, но - с тысячами людей, а в какой-то перспективе получите возможность увидеть своих партнеров, если они, конечно, согласятся предстать перед Вами. Не составит никакого труда найти эксперта в какой-то игре и понаблюдать за тем, как он делает ходы, или взять у него пару уроков. Магистраль позволит Вам не только "собирать" своих друзей за одним игровым столом, но и "встречаться" где-нибудь в воображаемом или реальном месте, скажем в Кенсигтон Гарденс (Kensington Gardens). Несомненно, изобретут и новые виды компьютерных игр, в которых исследование каких-то виртуальных миров станет частью сюжета.

Уоррен Баффет (Warren Buffett), известный своей смекалкой в финансовых делах, - один из моих добрых друзей. Не один год я ломал голову над тем, как заставить его пользоваться персональным компьютером. Я был готов даже прилететь к нему и научить этому делу. Но мне никак не удавалось его заинтересовать, пока вдруг он сам не обнаружил, что с помощью компьютера (и оперативной службы) можно играть в бридж с друзьями по всей стране. После этого в течение первых шести месяцев каждый день, приходя домой с работы, он часами играл на компьютере. Вот так - несмотря на то что он всячески избегал вычислительной техники и вложений в нее, - однажды все-таки сел за компьютер и тут же попался ему на крючок. В общем, теперь Уоррен пользуется услугами оперативных служб даже активнее, чем я.

Нынешние системы не заставляют играющих описывать свою истинную внешность, вводить имя, возраст или пол. А судя по всему, подобные системы наиболее популярны среди детей и пенсионеров. Поэтому следовало бы добавить функцию, позволяющую родителям ограничивать время (и деньги), которое их дети тратят на такие забавы.

Думаю, что сетевые компьютерные игры войдут в моду и станут еще увлекательнее. У нас появится богатый выбор игр, включая все классические настольные и карточные, а также приключенческие и ролевые. Специально для новой сетевой среды изобретут и новые виды игр. Лучшие из них, возможно, будут отбирать на конкурсной основе с вручением призов. Время от времени всякие знаменитости и игроки-виртуозы будут проводить показательные игры, и любой сможет понаблюдать за ходом баталии, а то и рискнуть выступить против них.

Когда удастся организовать обратную связь со зрителями, игровые викторины на телевидении поднимутся на качественно новый уровень. Зрители отдадут свои голоса в чью-то пользу и тут же увидят результаты - так в старых шоу (вроде Queen for а Day) замеряли громкость аплодисментов в студии. Тем же способом можно присуждать призы участникам викторин. Некоторые фирмы, например Answer TV, уже разработали и опробовали системы для интерактивных телеигр, но, поскольку они (системы) узкоспециализированны, их создателям пока не удалось вызвать тот интерес, который дает заработать деньги. На информационной магистрали, чтобы принять участие в телепередаче, не придется покупать ни особого оборудования, ни особых программ. Вообразите, как в будущем, сидя дома, зрители станут активными участниками шоу вроде Password или Jeopardy! и будут выигрывать наличные деньги или какие-то другие призы. Такие передачи смогут даже вести учет своих постоянных участников и награждать их специальными призами или просто упоминать их имена, если они присоединятся к игре.

Магистраль создаст условия и для азартных игр. Это крупный бизнес в Лас-Вегасе, Рено и Атлантик-сити, а Монако вообще живет только за счет доходов от этой индустрии. Прибыль, которую приносят казино, просто баснословна. Страстные игроки по-прежнему верят - несмотря на то что все шансы против, - будто они все-таки сорвут банк ! Когда я учился в колледже, мне нравилось играть в покер. Успех в этой игре, с моей точки зрения, в основном зависит от искусства игрока. И хотя, бывая в Лас-Вегасе, я иногда играл в рулетку, азартные игры, в которых удача зависит только от случая, меня особо не привлекают. Может быть, потому, что я больше стеснен во времени, чем в деньгах. Если бы ставки шли не на деньги, а на дополнительное время в сутках, вот тогда я, наверное, втянулся бы в азартные игры.

Достижения технологии всегда влияли на этот бизнес. Телеграфный аппарат - чуть ли не сразу после изобретения - использовали на бегах, чтобы быстрее узнавать результаты скачек. Игровые автоматы постоянно шли в ногу с прогрессом вычислительной техники. Несомненно, что и информационная магистраль заметно скажется на азартных играх - и легальных, и нелегальных. Мы определенно увидим, как пари будут заключать на серверах, а ставки делать по электронной почте. При этом все выплаты тоже будут проходить в электронной форме.

Азартные игры - бизнес строго регулируемый, поэтому трудно заранее сказать, какие их формы разрешат на магистрали. Может быть, авиапассажирам, от скуки не знающим чем заняться, позволят играть на деньги - не знаю. Но технология даст людям возможность ставить деньги на что им вздумается, и, если это законно, обязательно найдется кто-то, кто организует соответствующий сервис. Магистраль будет напрямую транслировать скачки, собачьи бега и прочие подобные соревнования, так что сопровождающий их ажиотаж азартные игроки почувствуют и дома - необязательно на стадионе. Многие правительства расширят лотерейный бизнес, и не исключено, что в будущем появятся различные электронные лотереи. Но очевидно и другое: магистраль существенно усложнит контроль за азартными играми.

Уверен, все мы воспользуемся уникальностью магистрали, чтобы найти людей с близкими нам интересами. Сегодня Вы, может быть, член местного лыжного клуба, где встречаетесь с другими любителями лыж. Может быть, Вы также выписываете журнал Recreational Skier и поэтому в курсе всех последних событий, связанных с лыжами. А завтра Вы сможете присоединиться к огромному сообществу лыжников через информационную магистраль, чтобы мгновенно получать самый свежий прогноз погоды и постоянно поддерживать контакт с энтузиастами лыжного спорта со всего мира.

Чем больше людей войдет в это электронное сообщество - пусть даже эпизодически, - тем ценнее оно станет для каждого его члена. Со временем вся информация о лыжах и лыжном спорте будет доступна в электронной форме. И если Вы присоединитесь к электронному сообществу, Вы узнаете о лучших трассах в окрестностях Мюнхена, о самых низких ценах на конкретные лыжные палки, познакомитесь с рекламой лыжных аксессуаров, одним словом, будете в курсе всех "окололыжных" новостей. Если кому-то удалось сфотографировать или заснять на видеопленку лыжные гонки или поход, он поделится этими материалами с другими. Опытные мастера лыжного спорта будут рецензировать все книги об этом виде спорта. В сети организуют дискуссии о законах и правилах безопасности на лыжне. Возникло сомнение - Вы моментально получите видеозаписи с соответствующими инструкциями. Эти и другие мультимедийные документы будут распространяться бесплатно или за определенную плату, и ими смогут пользоваться хоть несколько человек, хоть тысячи. Такое сообщество станет на информационной магистрали тем местом, куда Вы обратитесь за помощью, "заболев" лыжами.

Если Вам - прежде чем съехать с крутого склона - надо улучшить свою спортивную форму, то, наверное, лучше сделать это в тесном электронном контакте с несколькими десятками таких же, как Вы. Ведь в хорошей компании можно расслабиться, меньше себя контролировать. Ну а если Вы все-таки чувствуете неловкость - отключите видеокамеру. Члены этой "группы здоровья" могли бы подбадривать друг друга и даже заниматься в одно время.

Сообщество лыжников довольно велико и определить его несложно. Но на информационной магистрали будут работать программы, которые помогут находить людей, чьи интересы более специфичны, или сведения, более узкие и нестандартные. Если Вы подумываете посетить Берлин, магистраль предоставит Вам море всякой информации о нем - исторической, туристической, социологической. Но будут еще и программы, способные подыскать Вам в этом (или другом) городе собратьев по какому-то увлечению и предложить им встретиться с Вами. Если Вы коллекционируете пресс-папье из венецианского стекла, то, вероятно, мечтаете стать членом одного или нескольких мировых сообществ людей, поглощенных той же страстью. Некоторые из них наверняка живут в Берлине и с удовольствием покажут Вам свои коллекции. Если Вы берете в Берлин десятилетнюю дочь, Вы поинтересуетесь, нет ли в этом городе кого-то, кто знает Ваш язык, у кого тоже десятилетняя дочь и кто бы хотел провести время вместе с Вами. Найдя двух-трех подходящих людей, Вы тем самым создали бы небольшое - и, вероятно, временное - сообщество лиц с одинаковыми интересами.

Недавно я путешествовал по Африке и сделал много снимков шимпанзе. Действуй сейчас информационная магистраль, я бы отправил сообщение, в котором предложил всем, кто когда-либо участвовал в сафари, обменяться фотографиями. Их можно поместить на ту же электронную доску, где находятся и мои снимки шимпанзе. А доступ к этой электронной доске получили бы только "коллеги" по сафари.

Уже сегодня тысячи групп новостей в Internet и бесчисленные форумы в коммерческих оперативных службах стали местом обмена информацией для небольших сообществ. Например, в Internet есть группы, живо обсуждающие (в текстовом виде, конечно) самые разные темы, что видно хотя бы по их названиям: alt.agriculture.fruit, alt.animals.raccoons, alt.asian-movies, alt.coffee, bionet.biology.cardiovascular, soc.religion.islam или talk.philosophy.misc. Но темы этих дискуссий еще не так узки и специализированны, как некоторые предметы, которым, на мой взгляд, посвятят себя будущие электронные сообщества. Какие-то из них будут заниматься исключительно местными проблемами, а какие-то - глобальными. Круг выбора подобных сообществ вряд ли превысит тот, который сегодня открывает перед Вами телефонная система. Сначала Вы подберете группу, отвечающую Вашим устремлениям в целом, а уже в ней найдете тот маленький сектор, к которому и присоединитесь. Можно представить, что в центр внимания какого-то электронного сообщества попадут, например, администрации всех муниципалитетов.

Скажем, иногда меня раздражает, как работают светофоры возле моего офиса: красный свет горит дольше, на мой взгляд, чем должен. С одной стороны, я бы мог написать письмо в городскую администрацию и сообщить, что светофоры запрограммированы не оптимально, но администрация расценила бы его лишь как очередной навет какого-то кляузника. С другой стороны, будь у меня возможность сколотить "сообщество" тех, кто ездит по тому же маршруту, мы обратились бы к администрации уже с более веской жалобой. Найти таких людей несложно: разослать сообщения тем, кто живет поблизости, или поместить объявление на электронную доску, связанную с делами местного муниципалитета. Достаточно изобразить схему злополучного перекрестка и дать такой текст: "В утренние часы-пик на этом перекрестке почти никто не сворачивает налево. Кто считает, что цикл переключения светофора надо сократить ?" Все, кто согласен, присоединились бы к моему сообщению. И тогда бороться с городской администрацией было бы легче.

По мере того как сетевые сообщества будут набирать вес, к ним станет обращаться все большее число людей, для кого небезразлично мнение общественности. Ведь человеку всегда любопытно, что думают другие, какие фильмы смотрят, какие новости считают интересными. Например, собираясь на встречу с какой-то группой людей, я не откажусь заранее прочитать ту же "газетную передовицу", что и они, - будет о чем поговорить. Таким же образом Вы сможете узнавать, в какие уголки сети заглядывают чаще. Короче говоря, появятся "горячие списки" самых интересных мест.

Электронные сообщества и вся та информация, которой они располагают, создадут, помимо положительных аспектов, и определенные проблемы. Когда эти сообщества наберут силу, некоторым институтам придется серьезно перестроиться. Например, медики уже сейчас вынуждены бороться с пациентами, которые начитались медицинской литературы в электронной форме и наслушались впечатлений от своих собратьев по недугу. Слухи о каких-то неортодоксальных или непроверенных методах лечения быстро распространяются в этих сообществах. Особо дотошные пациенты, которые участвуют в испытаниях лекарственных препаратов, умудряются, пообщавшись с другими "экспериментальными" больными, выяснить, что им дают плацебо, а не настоящее лекарство. Подобные открытия приводят к тому, что некоторые отказываются продолжать испытания или начинают искать какие-то альтернативные лекарственные средства. Конечно, это наносит урон медицинским исследованиям, но разве можно винить людей, пытающихся спасти свою жизнь ?

Не только врачи ощутят на себе последствия свободного доступа к такой обширной информации. Новые проблемы встанут и перед родителями, которым придется контролировать детей, ведь они смогут узнавать почти все, что их интересует, прямо с домашнего информационного устройства. Уже сейчас создаются специальные системы, помогающие родителям проводить ревизию того, что смотрят их дети. Все это может вылиться в крупную политическую проблему, если издатели информации всерьез не займутся этим.

Но игра стоит свеч ! Ведь чем доступнее информация, тем шире у нас выбор. Сегодня фанаты всяческих сериалов вынуждены подстраиваться под программу телепередач, но как только "видео-по-заказу" даст нам возможность смотреть то, что мы хотим, и тогда, когда мы хотим, ситуация изменится. Мы будем планировать свой досуг не по сетке вещания, а исходя из семейных, производственных или общественных дел. До появления телефона люди каждодневно общались только со своими соседями. Жизнь проходила с теми, кто обитал неподалеку. Телефон и автомобиль позволили нам вырваться из этого узкого круга. Правда, личных визитов мы наносим теперь меньше, чем лет сто назад (всегда можно снять трубку !), но ведь это не значит, что мы стали вести более замкнутый образ жизни. Напротив, нам стало гораздо проще разговаривать друг с другом и поддерживать контакты. Настолько проще, что иногда хочется обратного.

Пройдет лет десять, и кто-то, быть может, недоверчиво покачает головой, услышав, что было такое время, когда незнакомец, ошибочно набрав Ваш номер, мог потревожить Вас своим звонком. Сотовые телефоны, пейджеры и факс-аппараты уже подталкивают бизнесменов к явным решениям там, где раньше они обходились неопределенными. Десятилетие назад такой проблемы - принимать звонки в машине или факсы дома - просто не существовало. Дома или в машине было легко уединиться. При современном уровне техники приходится решать, где и когда с нами удобнее связаться. А когда появится возможность работать в любом месте, связываться с кем и где угодно, Вы уже будете определять, кто и по какому поводу имеет право Вас беспокоить. Так что вполне однозначно устанавливая круг "доверенных" лиц, Вы снова превратите свой дом в свою крепость.

Информационная магистраль позволит предварительно отсортировывать поступающую корреспонденцию - будь то прямые телефонные звонки, мультимедийные документы, электронная почта, реклама или даже сводки новостей. Любой, кому Вы разрешили контактировать с собой, сделает это через Ваш электронный почтовый ящик или по телефону. В то же время Вы сможете указывать, что такой-то имеет право присылать почту, но не имеет права звонить по телефону. Или задать, что одни могут звонить в любое время, а другие - только когда Вы свободны. Вам вряд ли понравится ежедневно принимать тысячи рекламных объявлений, но, вознамерившись попасть на концерт, билеты на который давно проданы, Вы дадите нужную команду и немедленно получите все предложения на этот счет. Входная корреспонденция будет содержать краткую аннотацию - откуда поступила и что собой представляет, например: реклама, поздравление, опросник, публикация, счет или связанные с работой документы. У Вас появится возможность проводить определенную политику в отношении присылаемой почты. Вам решать, кто вправе звонить во время обеда, связываться с Вами в машине (или когда Вы в отпуске) и какие звонки или сообщения стоят того, чтобы поднять Вас с постели посреди ночи. Число таких разграничений может быть совершенно произвольным, а заданные Вами критерии - изменены в любой момент. Вместо того чтобы раздавать едва знакомым людям номер своего телефона (который, бывает, передают по цепочке от одного другому), Вы просто внесете имена нужных людей в постоянно обновляемый список и пометите, насколько Вы заинтересованы в контакте с каждым из них. Если с Вами захочет связаться человек, имени которого нет ни в одном из Ваших списков, ему придется выходить на Вас через кого-то, кто в таких списках присутствует. При этом "ранг" любого включенного в список легко повысить или понизить, а то и вообще выкинуть его из всех списков. В последнем случае такому человеку, чтобы связаться с Вами, придется присылать сообщение с "премиальными", как я уже рассказывал в восьмой главе.

Достижения в технологии обязательно отразятся и на архитектуре. Когда-то менялась внутренняя обстановка наших жилищ, теперь изменятся и сами дома. В их стены начнут встраивать управляемые компьютерами дисплеи всевозможных размеров. О проводке, соединяющей различные компоненты, позаботятся еще при строительстве домов, при этом будут учитывать размещение экранов относительно окон, чтобы свести к минимуму отражения и блики. Когда информационные устройства подключат к магистрали, отпадет надобность во многих предметах: справочниках, стереоприемниках, компакт-дисках, факс-аппаратах, шкафчиках для папок и различных записей. Многие вещи, загромождающие сейчас комнаты, перейдут в иное состояние - в форму цифровой электронной информации, которая будет извлекаться только при необходимости. Даже старые фотографии мы сможем хранить в цифровом виде и вызывать на экран (вместо того чтобы вставлять в рамочки и развешивать по комнатам).

Я много думал об этих вещах, потому что сейчас строю дом, в котором пытаюсь предвосхитить будущее. Когда я делюсь своими проектами, которые чуть-чуть опережают время, на меня иногда смотрят так, словно допытываются: "А ты уверен, что действительно хочешь этого ?"

Как и все, кто строит для себя дом, я стремлюсь к тому, чтобы он гармонировал с окружающей природой и отвечал запросам людей, которые будут в нем жить. Я хочу, чтобы его архитектура была интересна и красива. Но еще больше хочу, чтобы в нем было уютно. Ведь именно здесь будет жить моя семья и я сам. Дом - это близкий спутник, или, как говорил великий архитектор двадцатого столетия Ле Корбюзье (Le Corbusier), "машина, в которой ты живешь".

Мой дом строится из дерева, стекла, бетона и камня. Он расположен на склоне холма и большая часть его окон смотрит на запад (через озеро Вашингтон на Сиэтл), чтобы любоваться закатами солнца и видом горы Олимпик.

Мой дом полон "кремния" и программ. Кремниевые микропроцессоры с микросхемами памяти, оживляемые программами, придадут этому дому некоторые функции, которые через несколько лет информационная магистраль принесет в миллионы домов. Используемые технологии пока являются экспериментальными, но со временем многое из того, что я делаю сейчас, распространится повсеместно и уже не будет стоить так дорого. Система, предназначенная для досуга, довольно близко моделирует работу аналогичной аппаратуры будущего - я получу представление о жизни в среде новейших технологий.

Сегодня, конечно, не удастся смоделировать области применения магистрали, так как для этого к ней надо подключить много людей. Ну а владеть личной информационной магистралью - в чем-то сродни ситуации, когда телефон есть только у одного человека. По-настоящему интересные возможности магистрали раскроются лишь при участии десятков или сотен миллионов людей, которые будут не только потреблять развлекательную и иную информацию, но и создавать ее. Никакая магистраль не реализуется до тех пор, пока миллионы людей не начнут общаться друг с другом, отыскивая точки соприкосновения и творя разнообразные мультимедийные документы.

Передовая технология, на которой строится мой дом, охватывает не только сферу развлечений. Она принесет тепло, свет, комфорт и безопасность, она заменит все, что устарело с моральной и технологической стороны, но к чему мы привыкли и воспринимаем как само собой разумеющееся. А ведь еще совсем недавно публику удивляли дома с электрическим освещением, канализацией, телефонами и кондиционерами. Моя цель - построить дом, который располагает к приятному отдыху и активному творчеству, создает легкую, спокойную и добросердечную атмосферу. И эти мои желания не так уж сильно отличаются от желаний тех, кто и в прошлом мог позволить себе какое-то необычное жилище. Я экспериментирую, пытаясь понять, что лучше, но этим же занимались и многие до меня.

В 1925 году, когда Уильям Рандольф Херст (William Randolph Hearst), газетный магнат, переехал в свой калифорнийский замок Сан-Симеон (San Simeon), он стремился выжать из современной технологии максимум возможного. В то время поймать на радиоприемнике нужную станцию было довольно тяжело, поэтому он установил в подвале сразу несколько приемников, настроив каждый на определенную станцию. Провода от всех приемников тянулись на третий этаж в личный кабинет Херста и подключались к динамику, встроенному в дубовый шкафчик пятнадцатого века. Нажатием одной кнопки Херст выбирал нужную станцию. В те дни такое чудо вызывало бурный восторг, а сегодня - есть в любом автомобильном радиоприемнике.

Я ни в коем случае не сравниваю свой дом с замком Сан-Симеон, одним из памятников "эпохи излишества" на Западном побережье. Единственное, что нас объединяет, - неукротимый дух технических новшеств. Он хотел новостей и развлечений - одним касанием пальца. Того же хочу и я.

О строительстве нового дома я начал подумывать в конце восьмидесятых. Мне хотелось чего-то эдакого, но без излишеств. Мне нужен был дом, способный вбирать в себя изощренные и постоянно меняющиеся технологии, но делать это ненавязчиво, чтобы техника служила человеку, а не он ей. Я вовсе не желал, чтобы мой дом считали неким технологическим монстром. Изначально он проектировался как прибежище холостяка, но, когда мы с Мелиндой поженились, проект пришлось изменить, например улучшить кухню. Однако кухонная "утварь" там не более совершенна, чем в любой другой хорошо оборудованной кухне современного человека. Мелинда обратила также внимание (и, естественно, исправила несправедливость), что у меня просторный кабинет, а для ее работы место не предусмотрено.

Я подыскал земельный участок на берегу озера Вашингтон, сравнительно недалеко от Microsoft. В 1990 году началось строительство гостевого коттеджа, а в 1992 году подготовили фундамент для основной резиденции. Это была грандиозная работа; потребовалось огромное количество бетона, потому что Сиэтл находится в сейсмоопасной зоне, ничуть не менее рискованной, чем Калифорния.

Объем жилых помещений - примерно такой же, как в обычном крупном доме; семейная гостиная - около пяти на девять метров, включая пару удобных кресел для просмотра телевидения и прослушивания музыки. Будет и зал для приемов, который позволит свободно устраивать обед на 100 персон. Мне нравится организовывать вечеринки для новых сотрудников Microsoft и тех, кого мы нанимаем на лето. В доме будет также небольшой кинотеатр, бассейн и гимнастический зал. Теннисный корт мы разместим среди деревьев у самой кромки воды, около залива для катания на водных лыжах (это один из моих любимых видов спорта). Мы собираемся также соорудить что-то вроде небольшого устья, которое будут подпитывать грунтовые воды с холма, расположенного за домом. В этом устье я хочу разводить лососей Кларка (cutthroat trouts), и, говорят, что в таком месте почти наверняка заведутся выдры.

Если Вы захотите приехать ко мне в гости, Вы подъедете к дому по плавному изгибу аллеи, и перед Вами внезапно встанет лес из кленов, ольхи и редких пихт. Несколько лет назад при вырубке леса сняли перегнившую лесную подстилку и положили ее по дальней границе нашего земельного участка. Теперь чего там только не растет ! Пройдет несколько десятков лет, и лес поднимется снова, только на участке вырубки будет преобладать пихта - как это было много лет назад, на пороге двадцатого века, пока здесь тоже не вырубили часть леса.

Остановив машину на полукруглом развороте, Вы окажетесь перед парадной дверью, но отсюда видна лишь макушка дома, его верхний этаж. Войдя внутрь, Вы сразу же получите электронный значок, который нацепите на свою одежду. Он подключит Вас к электронным службам дома. После этого Вы спуститесь вниз либо на лифте, либо по лестнице, ступеньки которой сбегают к воде под наклонным стеклянным потолком - его держат стойки из пихты. (В доме очень много незаделанных горизонтальных и вертикальных балок.) Затем перед Вами откроется великолепный вид на озеро. Надеюсь, что при спуске на первый этаж Вас больше заинтересует именно этот вид и прекрасные пихты, а не электронный значок. Основная часть древесины поступила к нам с лесопильного завода Weyerhaeuser на реке Колумбия; ему стукнуло уже лет восемьдесят, и сейчас его сносят. Древесина - а ее возраст около ста лет - получена из деревьев высотой под 100 метров с диаметром стволов от 2,5 до 5 метров. Пихта - одно из самых крепких (при сравнительно небольшом весе) деревьев на свете. К сожалению, молодые деревья (семидесятилетние) при распилке на стойки часто расщепляются, потому что их волокна еще не так прочны, как у пятисотлетних. А таких старых пихт почти не осталось, те же, что есть, следует сохранить. Но мне повезло: на лесопильном заводе я нашел старые бревна, которые можно повторно пустить в дело.

Стойки из пихтового дерева поддерживают два этажа жилых помещений, мимо которых Вы спускаетесь к воде. Личный покой для меня очень важен. Я хочу, чтобы здесь было такое место, где чувствуешь себя по-домашнему уютно и уединенно, даже когда в других частях дома шумят и веселятся гости.

Если, дойдя до подножья лестницы, Вы повернете направо, то попадете в кинотеатр, а налево - в приемный зал. Шагнув в приемный зал, по правую сторону Вы увидите серию раздвижных стеклянных дверей, через которые можно выйти на террасу, ведущую к озеру. В восточную стену приемного зала будет встроено 24 видеомонитора (каждый с 40-дюймовой трубкой), - четыре в высоту и шесть в ширину. Эти мониторы смогут работать как единое целое, создавая крупные изображения для развлекательных и деловых целей. Мне бы хотелось, чтобы мониторы, когда они не используются, буквально сливались с фактурой деревянной стены. Для этого они должны показывать картинку, имитирующую эту фактуру и совпадающую с остальными частями стены. К сожалению, современная техника ничего убедительного на этот счет предложить не может, поскольку любой монитор всегда испускает свет, тогда как дерево его отражает. В общем, пришлось удовлетвориться тем, что мониторы просто закрываются деревянными панелями.

Электронный значок на Вашей одежде сообщит дому, кто Вы и где находитесь, а тот, на основе этой информации, попытается отвечать на Ваши просьбы и даже предугадывать их - как можно деликатнее. Когда-нибудь вместо значков будет применяться система видеокамер, способная распознавать визуальные образы, но при современном уровне техники это невозможно. Когда за окнами стемнеет, по всему дому Вас будет сопровождать движущаяся вместе с Вами световая волна. Пустые комнаты освещаться не будут. Идя по коридору, Вы, может быть, даже и не заметите, что светильники впереди Вас постепенно становятся все ярче и ярче, а сзади - тускнеют. Однако сопровождать Вас будет не только свет, но и музыка. Вам покажется, что она везде и всюду, хотя на самом деле другие люди услышат иную музыку или просто тишину. А захотите - за Вами будет следовать трансляция фильма или новостей. Если же кто-то свяжется с Вами по телефону, зазвонит лишь ближайший от Вас аппарат.

Вся эта техника не станет бесцеремонно навязываться Вам, но будет в абсолютной готовности и легко доступна. Карманный пульт дистанционного управления предоставит полный контроль над окружающей обстановкой и системой досуга в этом доме. Пульт дополнит функции электронного значка. Он позволит дому не только идентифицировать и находить Вас, но и отдавать ему команды. Через пульт Вы потребуете, чтобы мониторы в комнате стали видимы, и сами выберете, что на них показывать. А выбор будет большой - тысячи картин, видеозаписей, фильмов и телепрограмм.

В каждой комнате мы установим по управляющей консоли - аналогу клавиатуры, которая даст возможность вводить более специфические команды. Я хочу, чтобы эти консоли были заметны тем, кто их ищет, но не слишком бросались в глаза тем, кто в них не нуждается. У консолей будет какая-нибудь своя, легко узнаваемая особенность, по которой, если понадобится, Вы быстро найдете одну из них. Заметьте, с телефоном уже произошло нечто подобное. Он не привлекает к себе особого внимания; многим даже нравится, когда на приставном столике (к дивану или кровати) стоит телефонный аппарат неопределенной формы.

Все компьютеризованные системы должны быть настолько просты и естественны, чтобы люди могли ими пользоваться играючи, свободно. Но простота - штука сложная. Тем не менее с каждым годом компьютеры становятся в работе все проще, и методом проб и ошибок на примере своего дома мы выясним, как создать по-настоящему доступную систему. Вы сможете отдавать дому даже непрямые команды. Совсем не обязательно, например, сообщать точное название песни. Вы "скажете" дому: "Проиграй последние хиты, или песни в исполнении какого-то певца, или те, что звучали на знаменитом фестивале в Вудстоке, или венскую музыку восемнадцатого века, или вещи, в названии которых встречается слово "желтая". Можно заказать песни, рассортированные по какому-то признаку, или те из них, которые еще не "ставили" в прошлый приезд конкретного гостя. А для себя я запрограммирую систему так, чтобы фоном звучала негромкая классическая музыка (под нее лучше думается), которая сменялась бы чем-то современным и энергичным, когда я буду заниматься, скажем, гимнастикой. Если Вам захочется посмотреть фильм, получивший в 1957 году приз Академии искусств за лучшую картину, так и попросите его - Вы увидите The Bridge on the River Kwai (Мост через реку Квай). Этот фильм можно найти и иначе: закажите тот, в котором играет Алек Гиннесс (Alec Guinness) или Уильям Холден (William Holden), или тот, в котором рассказывается о тюремных лагерях.

Если Вы планируете посетить Гонконг, можно заранее полюбоваться его видами на экранах. Вам покажется, что снимки этого города чуть ли не всюду, хотя на самом деле они материализуются на стенах комнат за мгновение до того, как Вы переступаете порог, и тут же исчезают с Вашим уходом. Если у нас с Вами разные вкусы и я вхожу в комнату, где уже сидите Вы, дом - "решая", что делать, - последует заранее установленным правилам. Например, продолжит транслировать образы и музыку для того, кто первый попал в эту комнату, или попробует подыскать что-нибудь, что устроило бы нас обоих.

Концепция дома, который сам заботится о своих обитателях, исходит из двух традиций. Первая - сервис должен быть ненавязчивым, вторая - некие предметы, которые мы носим с собой, вызывают, если так можно выразиться, должное отношение со стороны определенных вещей. Вы уже привыкли к мысли, что какой-то предмет (билет, ключ, пропуск и т.д.) словно говорит людям или машинам, что у Вас есть право на то-то и то-то: открыть запертую дверь, сесть в самолет, купить какой-то товар. Ключи, электронные карточки, водительские права, паспорта, бирки с именами, кредитные карточки и билеты - все это разные предметы, так или иначе удостоверяющие Вашу личность. Если я отдам Вам ключ от своей машины, та позволит Вам сесть в нее, завести мотор и уехать. Можно сказать, что машина доверяет Вам, потому что у Вас есть от нее ключи. А если на стоянке я дам служащему какой-то ключ, который подходит к замку зажигания, но не подходит к багажнику, то этот служащий сможет завести машину, а вот открыть багажник - нет. В моем доме все точно так же: доступ к его прелестям зависит от конкретного электронного ключа.

Но в действительности дело обстоит не столь радикально. Некоторые считают, что в ближайшее десятилетие вокруг нас будут сновать сплошные роботы и помогать нам по хозяйству. Я думаю, что пройдет еще не одно десятилетие, прежде чем роботам найдут более или менее практическое применение. Единственное, что, на мой взгляд, вскоре широко распространится, - это интеллектуальные игрушки. Дети смогут программировать их поведение в различных ситуациях, а те будут отвечать, иногда - голосами популярных персонажей. Эти игрушки удастся программировать лишь в некоторых, весьма узких пределах. У них будет ограниченное поле зрения, они будут определять расстояние до стены в каждом направлении, знать время, различать степень освещенности и воспринимать конкретный набор речевых команд. Мне кажется, было бы здорово иметь игрушечный автомобиль, который бы подчинялся речевым командам и позволял программировать действия в некоторых ситуациях. Кроме игрушек, я вижу еще одно основное применение роботам - военное. Сильно сомневаюсь, что в обозримом будущем интеллектуальные роботы принесут хоть какую-нибудь пользу в домашнем хозяйстве; приготовление еды или смена пеленок потребует от робота обработки колоссальных объемов визуальной информации и очень большой сноровки. С чисткой бассейна, стрижкой газонов и, вероятно, даже с пылесосом справятся и сравнительно "тупые" системы, но стоит лишь чуть усложнить задачу (отойти от простого перемещения предметов), как сразу же возникнет масса непреодолимых пока проблем - ведь машина должна "разумно" реагировать на все неизбежные случайности.

Системы, которые я устанавливаю, служат одной цели - благоустройству дома. Однако по-настоящему я смогу проверить, приятно ли жить в таком доме, только переехав в него. Сейчас я постоянно экспериментирую и учусь на своих ошибках. Как полигон для обкатки оборудования будущего дома команда разработчиков использует уже построенный гостевой коттедж. Поскольку разным людям нравится разная комнатная температура, программное обеспечение, управляющее коттеджем, регулирует ее в зависимости от времени и суток и от того, кто именно находится там. Коттедж "знает", что холодным утром комнату надо прогреть - перед тем как гость встанет с постели. Вечером, когда включен телевизор, освещение в коттедже приглушается. Если кто-то находится в коттедже днем, его освещенность выравнивается с яркостью уличного света. Но, конечно, постоялец всегда может взять управление на себя и все сделать по-своему.

Подобное оборудование существенно экономит электроэнергию. Некоторые коммунальные службы уже сейчас испытывают специальную сеть, которая будет следить за расходом электроэнергии в индивидуальных домах. Это позволит покончить с дорогостоящей практикой, когда контролер раз в один-два месяца обходит каждый дом и записывает показания счетчиков. Но гораздо важнее то, что компьютеры, установленные в домах и соответствующих коммунальных предприятиях, смогут эффективнее и точнее распределять подачу электроэнергии в любое время суток. А это поможет сэкономить кучу денег и во многом избавиться от пиковых перегрузок.

Не все эксперименты в гостевом коттедже были удачны. Например, я заказал звуковые колонки, которые при необходимости опускались бы с потолка. Их корпуса должны были висеть подальше от стен - в оптимальном для качества акустики положении. Но, опробовав эту систему в коттедже, я понял, что она сильно смахивает на всю эту белиберду в стиле Джеймса Бонда, и поэтому для главной резиденции мы избрали вариант со скрытыми колонками.

Дом, который пытается предупредить желания своих обитателей, должен достаточно часто угадывать их правильно, чтобы его просчеты не раздражали. Как-то раз я побывал на вечеринке у знакомых, которые установили компьютеризованную систему управления домом. По программе, освещение выключалось в 10:30 - в это время владелец обычно ложился спать. Так вот, в 10:3О, когда вечеринка была в самом разгаре, освещение, будьте уверены, отключилось, и хозяин потом в полном мраке долго искал, где его включить. Другой пример. В некоторых офисных зданиях применяются детекторы движения. Они управляют освещением в каждой комнате. Если в каком-то помещении активная деятельность стихает хотя бы на несколько минут, лампы гаснут. Те, кому приходится почти неподвижно сидеть за своим столом, боролись с этой системой так: периодически размахивали руками.

Свет не так уж трудно включать и выключать самому. Выключатели очень надежны и просты в обращении, поэтому Вы сильно рискуете, заменяя их каким-нибудь устройством, которым управляет компьютер. Вы должны установить систему, работающую чуть ли не круглые сутки, а выигрыш в удобствах может сойти на "нет" из-за недостаточной ее надежности или чувствительности. Я надеюсь, что системы в моем доме смогут автоматически регулировать освещение и делать это правильно. Но на всякий случай в каждой комнате будет по настенному выключателю, чтобы быстро изменить решение, выбранное компьютером.

Если Вы регулярно просите зажечь яркий свет или, наоборот, создать полумрак, дом предположит, что именно так Вам больше нравится. В сущности, дом будет постоянно запоминать все, что узнает о Ваших предпочтениях. Если раньше Вы просили показывать картины Анри Матисса (Henri Matisse) или фотографии Криса Джонса (Chris Johns) из National Geographic, то в следующий приезд, войдя в комнату, Вы увидите на стенах другие их работы. Если в прошлый раз Вы слушали концерт для рожка Моцарта, то по возвращении, возможно, вновь услышите что-нибудь в этом духе. Если Вы не отвечаете на звонки во время обеда, телефон больше не зазвонит в этот период (если вызов адресован Вам). Мы сможем также "говорить" дому, что нравится конкретному гостю. Например, Пол Аллен - фанат Джими Хендрикса (Jimi Hendrix), и когда бы Пол к нам ни приехал, его будет приветствовать оглушительное соло на электрогитаре.

Аппаратура, устанавливаемая в доме, позволит копить статистические данные по операциям всех систем, и мы сможем, анализируя эту информацию, настраивать их работу.

В будущем для регистрации и анализа всех действий и событий на информационной магистрали станут использовать аналогичную аппаратуру, а отчеты будут доступны всем желающим. С подобным подведением итогов мы встречаемся уже сегодня. Так, в Internet распространяется информация о локальном трафике, которая помогает при выборе альтернативных коммуникационных маршрутов. В телевыпусках новостей часто показывают уличное движение, снимаемое с камер, установленных на вертолетах, и дают оценки средней скорости езды по скоростным шоссе в часы-пик.

Еще один пример - тривиальный, но очень забавный. Студенты-программисты из нескольких колледжей переделали автомат по продаже безалкогольных напитков. Они подключили кое-какое оборудование к индикатору, сигнализирующему, не опустел ли автомат, и теперь он постоянно сообщает эту информацию по Internet. Казалось бы - шутка будущих инженеров, но сотни людей во всем мире еженедельно следят за тем, есть ли в автомате университета Карнеги Меллон (Carnegie Mellon University) хоть капля 7UP или диетической колы.

Однако информационная магистраль предоставит Вам не только сводки по торговым автоматам, но и передаст прямые видеорепортажи из многих общественных мест, немедленно сообщит о результатах розыгрыша любых лотерей, о ставках у букмекеров, о текущих процентах по закладным или о наличии товара в различных магазинах. Полагаю, что у нас появится возможность вызывать на экран прямые видеопанорамы сдающихся в аренду городских поместий и запрашивать списки цен и условия аренды. В нашем распоряжении будут сводки преступлений и любые другие виды общественной (или потенциально общественной) информации.

В своем доме я стану первым пользователем самых необычных электронных средств. У меня есть база данных, включающая более миллиона статичных изображений, в том числе фотографии и репродукции картин. Если Вы будете у меня в гостях, то на экранах, установленных по всему дому, Вы сможете посмотреть портреты президентов и фотографии самолетов, полюбоваться закатом солнца и горнолыжниками в Андах, увидеть редкие французские марки, снимки "Битлз" 1965 года и репродукции картин эпохи позднего Ренессанса.

Несколько лет назад я организовал небольшую фирму (теперь она называется Corbis), чтобы создать уникальный и внушительный цифровой архив изображений. Corbis занимается сбором всех изобразительных материалов - по истории, науке, технике, мировым культурам, изящным искусствам. Эти материалы с помощью высококачественных сканеров преобразуются в цифровую форму. Полученные изображения с высоким разрешением отправляют в базу данных, новейшая технология индексации которой позволяет легко отыскать нужную картинку. Эти цифровые изображения будут предлагаться на коммерческой основе таким пользователям, как редакции журналов и книжные издательства, а также частным лицам. При этом некоторая доля прибыли отчисляется держателям авторских прав на эти изображения. Corbis сотрудничает с музеями, библиотеками, индивидуальными фотографами, агентствами и архивами.

Уверен, что на информационной магистрали качественные картинки будут в цене. И при хорошем интерфейсе ими заинтересуется масса людей. Тот, кто сам не знает, что он ищет, сможет просматривать базу данных наугад, и та будет показывать картинки до тех пор, пока какая-нибудь из них не заинтересует пользователя. Затем можно досконально исследовать все изображения, которые так или иначе связаны с этой картинкой. В ближайшей перспективе навигация по этой базе данных упростится до предела - достаточно запросить что-нибудь вроде "шлюпки", "вулканы" или "знаменитые ученые".

Хотя часть изображений будет посвящена искусству, это не значит, что я недооцениваю оригинальные произведения. Настоящую картину нельзя сравнить ни с одной репродукцией. Но я уверен, что простые в обращении базы картинок способствуют приобщению людей как к изобразительному, так и к фотографическому искусству.

В частых деловых поездках, мне иногда удавалось выкроить время, чтобы посмотреть в музеях оригиналы некоторых великих полотен. Самый интересный "экспонат", который у меня есть, - научные дневники Леонардо да Винчи - начала 1500-x годов. Я восхищаюсь Леонардо еще с юношеских лет, потому что он - гений во многих областях и далеко опередил свое время. Так вот, несмотря на то что мне принадлежит не картина великого художника, а "просто" дневник с записями и чертежами, ни одна репродукция не сможет в полной мере передать его.

Искусство (как и все вокруг) доставляет неподдельную радость, когда ты что-то знаешь о нем. Можно часами бродить по Лувру, восхищаясь картинами, которые ты в лучшем случае смутно помнишь, но, когда рядом с тобой знающий человек, экскурсия сразу становится увлекательнее. Роль экскурсовода - на дому или в музее - способен взять на себя мультимедийный документ. Он даст послушать фрагмент лекции, посвященной работам какого-то художника или картинам определенного периода, позволит рассмотреть (как бы под лупой) отдельные участки картин или скульптур. Если мультимедийные репродукции сделают искусство доступнее, люди, которые разглядывают эти репродукции, наверняка захотят увидеть оригиналы. Знакомство с репродукциями усилит (а не ослабит) тягу к настоящему искусству и приведет в музеи и художественные галереи новые тысячи людей.

Лет через десять эти базы данных с миллионами изображений и прочие возможности интересного досуга, о которых я уже рассказывал, станут реальностью во многих домах и наверняка окажутся куда более впечатляющими, чем те, что будут у меня, когда я перееду в свой новый дом в конце 1996 года. Просто кое-что из этих вещей в моем доме появится чуть раньше, чем у остальных.

Я люблю экспериментировать и готов к тому, что какие-то из концепций моего дома окажутся удачными, а какие-то нет. Может быть, я приду к мысли, что мониторы надо прятать за обычной настенной декорацией, или выброшу электронные значки на помойку. А может быть, я постепенно привыкну ко всем системам в доме, или они настолько понравятся мне, что я буду удивляться, как это раньше обходился без них. Поживем - увидим.


Глава 11 - Золотая лихорадка

Глава 11
Золотая лихорадка

Кажется, чуть ли не каждую неделю какая-нибудь компания или консорциум сообщают, что им удалось вырваться вперед в строительстве информационной магистрали. Постоянная шумиха о грандиозных слияниях компаний и рискованных инвестициях создают атмосферу "золотой лихорадки" - все рвутся не упустить свой шанс, надеясь в этой гонке пересечь финишную ленточку или застолбить участок. Инвесторов, похоже заинтересовали акции, так или иначе связанные с информационной магистралью. Средства массовой информации подогревают ажиотаж, уделяя ей беспрецедентное внимание, особенно если учесть, что ни саму технологию, ни спрос на нее еще никто не исследовал. Эта ситуация принципиально отличается от той, что была на заре индустрии персональных компьютеров. Сегодняшнее безумие может оказаться заразительным, и прежде всего для тех, кто рассчитывает поучаствовать в гонке, но истина в том, что мы только-только выходим на старт.

Когда гонка, наконец, завершится, в ней будет много победителей, в том числе неожиданных. Одним из последствий золотой лихорадки в Калифорнии стало быстрое развитие экономики Запада. В 1848 году в Калифорнию переехало всего 400 переселенцев. Большинство из них занималось сельским хозяйством. А золотая лихорадка только за один год привлекла 25000 переселенцев. Спустя десятилетие промышленность уже доминировала в экономике Калифорнии (даже над добычей золота), а доход на душу населения в этом штате был самым высоким по стране.

Со временем, при правильной инвестиционной политике, магистраль действительно может вывести на большие деньги. Но сейчас множество фирм только гарцует на стартовой позиции. И это-то их гарцевание и выдается за самые важные новости. Поэтому в этой главе я хочу поразмыслить над тем, что же происходит на самом деле.

Несмотря на лихорадочные усилия, ни один из строителей магистрали пока не наткнулся ни на какое золото, и понадобится еще очень много вложений, чтобы это случилось. Приток капиталов обеспечит вера в необъятность рынка. Но ни полномасштабная магистраль, ни рынок, связанный с ней, не станут реальностью до тех пор, пока в большинство домов и предприятий не придут широкополосные сети. А до этого придется разработать и развернуть необходимые программные платформы, приложения, сети, серверы и информационную аппаратуру - все то, что и образует основу магистрали. Многие участки этой магистрали будут бесприбыльны, пока она не привлечет десятки миллионов пользователей. А это потребует упорной работы, денег и применения всех достижений техники. В этом смысле сегодняшнее всеобщее помешательство даже полезно, потому что оно способствует инвестициям и экспериментам.

Никто пока точно не знает, что хочет получить общество от информационной магистрали. Не знает этого и само общество, поскольку оно еще не имело дела с приложениями и интерактивными сетями, способными оперировать с полноскоростным видео. Эксперименты в этом направлении проводились, но их было немного: в некоторых сетях пользователям предлагали посмотреть фильм, заказать кое-какие покупки и опробовать массу всяческих новшеств, которые быстро всем надоедали. В общем, сейчас мы убеждены только в одном: интерактивные системы с ограниченными возможностями дают ограниченные результаты. Потенциал информационной магистрали раскроется во всей его полноте лишь тогда, когда появятся десятки новых приложений. Но как оправдать работы по созданию приложений, не будучи уверенным в рынке ? Хотя бы одно испытание должно подтвердить, что отдача перекроет себестоимость системы ! До тех пор любые заявления, что та или иная компания готова затратить миллиарды на прокладку информационной магистрали, - чистое позерство. С моей точки зрения, создание магистрали - процесс не революционный, а эволюционный; полноценная система будет строиться на основе постепенного развития Internet, персональных компьютеров и программного обеспечения.

Подобное позерство создает бум и атмосферу необоснованных ожиданий вокруг информационной магистрали. Уйма людей рассуждает о путях развития этой технологии. В некоторых из этих рассуждений напрочь игнорируется то отношение, которое уже продемонстрировано обществом, или даются совершенно нереалистичные прогнозы относительно сроков, когда разрозненные фрагменты соединятся в единое целое. Разумеется, теоретизировать вправе каждый, но заблуждаются те "мыслители", которые предрекают, что еще до конца века полноценная информационная магистраль начнет оказывать определяющее влияние на потребителей.

Компании, вкладывающие сегодня средства в информационную магистраль, руководствуются в лучшем случае обоснованными догадками. Скептики приводят веские аргументы насчет того, что возможности магистрали проявятся не так скоро или не в таком объеме, как думается мне. Но я верю в этот бизнес. Microsoft ежегодно тратит по 100 миллионов долларов на исследования, связанные с информационной магистралью. Чтобы НИОКР окупили себя, почти наверняка потребуется не меньше 5 лет, так что мы сделали ставку в 500 миллионов долларов. И вполне можем проиграть эти деньги. Наши акционеры благословили такой риск, учитывая предыдущие наши достижения, но в данном случае никакой гарантии нет. Естественно, мы рассчитываем на победу и, подобно другим участникам гонки, имеем на то свои причины. Мы убеждены, что наши успехи в создании программного обеспечения и наше участие в развитии персональных компьютеров позволят нам окупить все затраты.

В 1996 году в Северной Америке, Европе и Азии должны начаться масштабные испытания по подключению широкополосных сетей к персональным компьютерам и телевизорам. Их финансируют компании, которые решили рискнуть, чтобы оказаться первыми на старте. Некоторые из испытаний будут строиться по принципу "делай, как я" и демонстрировать, что конкретный сетевой оператор может создать широкополосную сеть и управлять ею. Основная цель эксперимента - предоставить платформу разработчикам программных средств для создания и тестирования новых приложений, а также для проверки их практической и финансовой перспективы.

Впервые увидев снимок "Альтаира", мы с Полом Алленом могли только догадываться, какое огромное количество приложений вызовет он к жизни. Мы знали, что программы обязательно появятся, но не знали - какие. Некоторые из них были вполне предсказуемы, например программы, позволяющие использовать персональный компьютер как терминал мэйнфрейма, но появление таких важных приложений, как электронная таблица VisiCalc, предугадать было невозможно.

Будущие испытания помогут найти такие же эффектные и неожиданные приложения, как электронные таблицы, разглядеть услуги, способные завладеть вниманием потребителя; тем самым удастся выработать финансово-экономическое обоснование для развертывания информационной магистрали. Трудно предвидеть, какие приложения привлекут общество. У каждого потребителя свои запросы и свои желания. Лично я, например, надеюсь, что магистраль введет меня в курс медицинских достижений. Я рассчитываю узнавать о заболеваниях, риск которых в моей возрастной группе наиболее высок, и о том, как их избежать. Поэтому меня интересуют компетентные медицинские приложения, а также программы, которые позволят заниматься самообразованием в других областях. Но это касается только меня. Нужны ли медицинские советы другим пользователям ? Что их интересует ? Новые игры ? Новые способы знакомства с людьми ? "Шоппинг" на дому ? Или просто нескончаемый поток сериалов ?

Испытания покажут, какие приложения и какой сервис пользуются наибольшим успехом. В их число, вероятно, войдут расширенные варианты уже существующих коммуникационных услуг вроде "видео-по-заказу" и высокоскоростной связи между персональными компьютерами. Уверен, возникнут и совершенно неизвестные услуги, которые завоюют всеобщее признание и вдохновят новаторов, инвесторов и предпринимателей расширить свою деятельность. Именно этого я и жду от испытаний. Если первый опыт не вызовет у потребителей восторга, строительство полноценной информационной магистрали придется отложить, чтобы пробовать еще и еще раз. Тем временем Internet, компьютерные сети и программы будут совершенствоваться, готовя более прочный фундамент для магистрали, а цены на оборудование и программы упадут еще ниже.

Интересно наблюдать за реакцией крупных компаний на такие перспективы. Никто не хочет выказать свою неуверенность. Телефонные и кабельные компании, телестудии и телекомпании, производители компьютерного оборудования и программных средств, газеты, журналы, киностудии и даже отдельные авторы - все формулируют свою стратегию. С виду их планы кажутся почти одинаковыми, но на самом деле они существенно расходятся в деталях. Это напоминает мне старую притчу о слоне и слепцах: каждый, потрогав слона лишь со своей стороны, чересчур поспешил с выводами о том, как выглядит это животное. Вот и мы, вкладывая миллиарды долларов, опираемся на весьма смутные ощущения об истинных контурах рынка, вместо того чтобы попытаться представить его в целом.

Потребителей все это забавляет, но инвесторам не до смеха, особенно когда они вкладывают деньги в несуществующий продукт. Нет сейчас такого бизнеса - "информационная магистраль". Он еще не принес ни единого доллара прибыли. Строительство магистрали обещает стать поучительным процессом, но кто-то на этом вылетит в трубу. То, что вчера казалось прибыльной нишей, сегодня может обернуться высококонкурентным рынком с низкой маржей или вообще оказаться ненужным. Золотая лихорадка часто подталкивает к непродуманным вложениям, из которых лишь считанные единицы окупят себя. И, когда безумие схлынет, мы бросим взор на обломки рухнувших начинаний и с удивлением спросим: "Кто дал этим компаниям деньги ? О чем они думали ? Какой манией были одержимы ?"

Как и в компьютерном бизнесе, предприимчивость сыграет основную роль в "прокладке" информационной магистрали. Лишь очень немногим компаниям удалось перейти с производства программ для мэйнфреймов на создание приложений для персональных компьютеров. Причем большая часть успехов была достигнута начинающими фирмами, которыми руководили люди, открытые всему новому. То же мы увидим и на информационной магистрали. На каждую существующую крупную компанию, которая приспособится к новым условиям, придется десяток преуспевающих новичков и еще полсотни таких, которые, вспыхнув, подобно метеору, тут же исчезнут во мраке.

Признак развивающегося рынка - стремительное зарождение новшеств во многих его сегментах. Правда, большинство нововведений лопается как мыльные пузыри, независимо от того, какой компанией предпринята попытка, крупной или малой. Крупные компании обычно рискуют меньше, но, когда они взрываются и сгорают дотла, задействованные ими ресурсы оставляют в земле глубокую воронку. А крах начинающей компании такого шума не поднимает. К счастью, люди учатся и на успехах, и на ошибках, что в результате приводит к быстрому прогрессу.

Предоставив рынку самому решать, какие компании и подходы победят, а какие - нет, можно проложить сразу несколько тропинок. Именно на новом рынке преимущества решений, диктуемых конкурентной борьбой, наиболее наглядны. Когда сотни компаний в попытках выяснить спрос пробуют разные (рискованные) подходы, общество приходит к правильному выводу значительно раньше, чем при любой форме централизованного планирования. Информационная магистраль - пока уравнение со многими неизвестными, но рынок все расставит на свои места.

Правительства должны поддерживать на рынке высокий уровень конкуренции и в то же время быть готовы (без излишней поспешности) помочь рынку, если в каких-то областях он потерпит поражение. Когда испытания дадут нужную информацию, мы выработаем "правила дорожного движения" - основные принципы, в рамках которых компании могут соревноваться. Но они не должны определять природу информационной магистрали или диктовать рынку свои условия, потому что правительствам не под силу перехитрить рыночные законы конкуренции, особенно когда запросы потребителей и уровень развития технологии еще неясны.

Правительство США глубоко увязло в выработке правил игры для коммуникационных компаний. Сейчас федеральные законы запрещают кабельным и телефонным компаниям создавать универсальные сети, которые бы вынудили их конкурировать друг с другом. Поэтому, чтобы быстрее пустить магистраль, первым делом надо снять излишние ограничения в области коммуникационной связи.

Олицетворением старого подхода в большинстве стран остаются монополии в области телекоммуникаций. Теоретическое обоснование этому строилось на том, что без стимула стать монополистом ни одна компания не будет вкладывать огромных средств, необходимых для прокладки телефонных кабелей к каждому дому. А свод постановлений, выработанных правительством, заставляет монополистов действовать в интересах общества, получая ограниченную, но гарантированную прибыль. В результате сложилась очень надежная система, предлагающая множество услуг, но невосприимчивая к новшествам. Впоследствии эти правила распространили на кабельное телевидение и локальные телефонные сети. Федеральные и местные власти поддержали монополистов и не допустили конкуренции ради сохранения своего контроля.

Информационную магистраль, предоставляющую видео- и телефонные услуги, создать в Соединенных Штатах при нынешних законах вообще невозможно. Экономисты и историки могут рассуждать обо всех "за" и "против" введения в 1934 году законов о регулируемых монополиях, однако сейчас, по общему убеждению, правила нужно менять. Но как и когда - об этом политики не смогли договориться и к середине 1995 года, потому что в хитросплетениях законодательства немудрено запутаться, а на карту поставлены миллиарды долларов. Проблема в том, как перейти от старой системы к новой, не ущемив интересы многочисленных участников рынка. Из-за этой-то дилеммы реформа в области средств телекоммуникаций вот уже многие годы лежит без движения. Почти все лето 1995 года в Конгрессе кипели страсти: как снять ограничения с индустрии телекоммуникаций ? Надеюсь, когда Вы будете читать мою книгу, создание информационной магистрали в Соединенных Штатах уже станет делом законным.

За пределами Соединенных Штатов ситуация усложняется тем, что во многих странах регулируемые монополии принадлежали самому правительству. Они управляли почтой, телефоном и телеграфом. В некоторых государствах эти службы на вполне законных основаниях могут участвовать в создании информационной магистрали, но, когда в дело вовлечены правительственные структуры, оно обычно продвигается весьма медленно. Думаю, что в ближайшее десятилетие темпы инвестиций и снятия законодательных препон возрастут во всем мире, так как политики начинают понимать, насколько это важно для сохранения конкурентоспособности их стран. В период избирательных кампаний кандидаты будут все чаще включать в свои предвыборные платформы меры, которые позволят их государствам лидировать в строительстве магистрали. Политики поставят эти вопросы в центр внимания общества, что в итоге поможет убрать последние заграждения на международных участках магистрали.

Страны, подобные Соединенным Штатам и Канаде, где во многих домах уже есть кабельное телевидение, находятся в привилегированном положении, поскольку темпы вложений в инфраструктуру магистрали здесь будут постоянно возрастать - благодаря конкуренции между кабельными и телефонными компаниями. Однако в использовании единой сети для услуг телевизионных и кабельных компаний сейчас впереди Великобритания. В 1990 году кабельным компаниям в этой стране разрешили предоставлять услуги телефонной связи. В британскую инфраструктуру волоконно-оптических линий вкладывали крупные средства и иностранные компании, в основном американские (кабельные и телефонные). Теперь жители туманного Альбиона при желании могут пользоваться телефонными услугами своей кабельной телевизионной компании. Конкуренция заставила British Telecom улучшить качество предоставляемых услуг и снизить тарифы.

Оглянувшись назад лет через десять, думаю, мы заметим четкую зависимость между масштабом реформ в области средств телекоммуникаций в каждой стране и состоянием ее "информационной" экономики. Немногие инвесторы захотят вкладывать деньги в государства с неразвитой инфраструктурой связи. В разработку нового законодательства вовлечено столько политиков и лоббистов, что, несомненно, будет испытан целый спектр разных законодательных схем. "Правильные" решения в каждом государстве будут свои.

Но одно совершенно очевидно: правительства не должны вмешиваться в чисто технические вопросы. Кое-кто предлагал, чтобы стандарты сетей устанавливало правительство, дескать, только так можно обеспечить их совместимость. В 1994 году в подкомитет Палаты представителей США поступил законопроект, который предлагал, чтобы все телевизионные приставки были совместимы друг с другом. Авторам законопроекта это предложение казалось гениальным. Оно, по их мнению, гарантировало тетушке Бесси, потратившейся на приставку, что аппарат будет работать даже в том случае, если она переедет в другой конец страны.

Совместимость - вещь очень важная. Благодаря ей процветают компании, которые производят бытовую электронику и персональные компьютеры. На заре индустрии персональных компьютеров появлялось и исчезало много машин. Компьютер Apple I затмил собой Altair 8800. Потом пришел Apple II, первый IBM PC, Apple Macintosh, IBM PC AT, компьютеры 386, 486, Power Macintosh и, наконец, Pentium. Каждая из этих машин в какой-то мере была совместима с остальными. Например, все они могли использовать одни и те же простые текстовые файлы. Но, поскольку каждое следующее поколение компьютеров создавалось в результате очередных прорывов в науке и технике, во многих отношениях они были несовместимы со своими предшественниками.

Совместимость с прежними системами в некоторых случаях очень важна. Компьютеры PC и Apple Macintosh, каждый в рамках своего семейства, обладают преемственной совместимостью, но несовместимы друг с другом. В то же время первый PC был несовместим с прежними машинами IBM, а "Мак" - с прежними компьютерами Apple. В компьютерном мире технология развивается так динамично, что любая компания должна быть готова в любой момент предложить новый продукт, а судить о его достоинствах - дело рынка. Телевизионная приставка, с какой стороны ни посмотри, является компьютером. Исходя из этого нетрудно предположить, что ее ждет тот же путь стремительных изменений, по которому прошла компьютерная индустрия. А ведь рынок для этой приставки будет значительно неопределеннее, чем для персональных компьютеров, и поэтому ее развитием, тем более, призван управлять сам рынок. Со стороны правительства было бы весьма неразумно диктовать здесь какие-то ограничения.

Тогда, в 1994 году, попытка провести через Конгресс США законопроект о телевизионных приставках в конце концов провалилась, но подобные вопросы поднимались и в 1995 году. Думаю, и в других странах кто-то предпримет аналогичные попытки. На первый взгляд, кажется разумным законодательно оформить определенные ограничения, - но стоит ослабить бдительность, и они задушат рынок.

В разных обществах и странах информационная магистраль будет строиться в разном темпе. Когда я бываю за границей, иностранные журналисты часто спрашивают меня, на сколько лет отстает их страна от Соединенных Штатов. Трудный вопрос. Преимущества Соединенных Штатов в размерах рынка, в насыщенности домов американцев персональными компьютерами и в том, как конкурируют между собой телефонные и кабельные компании за нынешние и будущие прибыли. Американские компании лидируют практически во всех технологиях, на основе которых будет строиться магистраль - в микропроцессорах, программном обеспечении, развлекательных системах, персональных компьютерах, телевизионных приставках и сетевом оборудовании. Единственные серьезные исключения - производство мониторов и микросхем памяти.

У других стран свои преимущества. Сингапур, с его плотностью населения и тем политическим вниманием, которое уделяется информационной инфраструктуре, определенно выйдет на лидирующие позиции. Решения правительства кое-что значат в этой уникальной стране, где уже создается инфраструктура информационной магистрали. В скором времени каждой строительной компании придется в обязательном порядке подводить в новые дома и квартиры широкополосные кабели - так же, как сегодня они проводят воду, газ, электричество и телефон. Когда я встретился с Ли Куаном Ю (Lee Kuan Yew), семидесятидвухлетним главой кабинета, который был политическим лидером Сингапура с 1959 по 1990 год, на меня произвело сильное впечатление его понимание перспективы и вера в то, что основным приоритетом государства должен стать быстрый прогресс. Он считает крайне необходимым, чтобы его маленькая страна оставалась в Азии главным сосредоточием высокооплачиваемых рабочих мест. Я осмелился спросить господина Ли, понимает ли он, что правительству Сингапура надо будет отказаться от жесткого контроля над информацией. По его словам, Сингапур осознает, что в будущем придется опираться на иные, нежели цензура, методы, чтобы сохранить свою самобытную культуру и чувство общности народа, принося в жертву ради этого некоторые западные ценности.

А у правительства Китая иной подход - оно, по-видимому, надеется преуспеть и в том, и в другом. Как-то раз на брифинге министр почты и телекоммуникаций У Жичуань (Wu Jichuan) сказал репортерам: "Подключаясь к Internet, мы не подразумеваем полной свободы информации. Я думаю, что общество осознает это. Проходя через таможню, Вы обязаны показать паспорт. То же относится и к информации". У Жичуань заявил, что Пекин предпримет некие "руководящие меры" для того, чтобы контролировать приток данных по всем телекоммуникационным службам - по мере их развития в Китае. "Формирование инфраструктуры средств телекоммуникаций совершенно не противоречит идее государственного суверенитета. Ведь и International Telecommunications Union (Международный союз по телекоммуникациям) утверждает, что управление средствами связи - суверенное дело каждого государства". Видимо, господин министр не понимает, что реализация цензорского надзора при полном доступе к Internet потребует присмотра за каждым пользователем.

Во Франции первая оперативная служба Minitel привела к созданию сообщества издателей информации и познакомила широкую общественность с оперативными системами. Несмотря на ограниченные возможности, Minitel добилась крупных успехов, которые позволили внедрить множество новшеств и извлечь весьма поучительные уроки. Сейчас France Telecom вкладывает деньги в сеть с коммутацией пакетов (packet switch data network).

В Германии компания Deutsche Telekom в 1995 году значительно снизила расценки на услуги своих ISDN-сетей, что существенно повлияло на рост числа пользователей компьютерных сетей. Снижение расценок на ISDN оказалось мудрым шагом, поскольку стимулировало разработку приложений, которые ускорят внедрение систем с высокой пропускной способностью.

Уровень насыщенности бизнеса персональными компьютерами в странах Северной Европы даже выше, чем в Соединенных Штатах. В этих государствах хорошо понимают, какую выгоду получат квалифицированные специалисты от высокоскоростной связи с внешним миром.

Предсказать судьбу информационной магистрали в Японии очень трудно, хотя заинтересованность в высокотехнологичных системах связи там проявляется, пожалуй, как нигде в мире. Персональные компьютеры в бизнесе, школах и домах в Японии распространены намного меньше, если сравнить с другими развитыми странами. Отчасти это связано с трудностью ввода иероглифов с клавиатуры, но сказывается и тот фактор, что в Японии по-прежнему существует мощный рынок специализированных электронных машин - текстовых процессоров.

Однако по объему инвестиций в создание компонентов информационной магистрали Япония уступает только Соединенным Штатам. Многие крупные японские компании располагают прекрасной технологией и традициями долговременного подхода к своим инвестициям. Корпорация Sony владеет компаниями Sony Music и Sony Pictures, в которые входят Columbia Records и Columbia Studios. Toshiba вложила крупные деньги в Time Warner. Политику корпорации NEC прекрасно отражает ее лозунг "Компьютеры и связь", выдвинутый еще в 1984 году и как бы предвосхитивший идею создания информационной магистрали.

До недавнего времени индустрию кабельной связи в Японии связывали излишние ограничения, но темп перемен впечатляет. Масштабы японской телефонной компании NTT выделяют ее среди аналогичных компаний в мире, и она, безусловно, сыграет ведущую роль на всех направлениях строительства информационной магистрали.

В Южной Корее - хотя число компьютеров на душу населения меньше, чем в Соединенных Штатах, - четверть машин установлена в жилых домах. Эта статистика наглядно демонстрирует, что страны с крепкими семейными узами, где заботятся об образовании детей, станут плодородной почвой для расцвета образовательных продуктов. Мощная поддержка правительства позволит создать стимулы для недорогих подключений школ к сетям и провести магистраль в сельские районы и районы с низкими доходами населения.

Австралия и Новая Зеландия тоже заинтересованы в магистрали, отчасти из-за огромной географической удаленности друг от друга и от остальных развитых стран. Телефонные компании в Австралии сейчас приватизируются, что открывает рынок для конкурентной борьбы и реализации перспективных планов. Рынок телекоммуникаций в Новой Зеландии - самый открытый в мире, а местная телефонная компания, недавно приватизированная, - пример того, насколько эффективна может быть приватизация.

Сомневаюсь, что какая-нибудь из развитых стран, включая Западную Европу, Северную Америку, Австралию, Новую Зеландию и Японию, сильно вырвется вперед или отстанет в течение года, если, конечно, этому не поспособствуют неудачные политические решения. В рамках каждого государства по экономическим и демографическим причинам одни группы населения получат доступ к магистрали раньше других. Вначале компьютерные сети проникнут в богатые кварталы, так как именно их обитателей дополнительные расходы не слишком обременят. Не исключено, что местные законодатели будут даже соревноваться друг с другом в создании таких условий, чтобы развертывание информационной магистрали начиналось именно с их территории. В индустриальных странах, где законы благоприятствуют конкуренции, строительство магистрали не потребует денег налогоплательщиков. Темп подключения отдельных домов к магистрали в значительной мере зависит от валового национального продукта (ВНП) на душу населения. Несмотря на это, даже в развивающихся странах связь предприятий и школ с информационной магистралью даст огромный эффект и уменьшит ту пропасть в доходах, которая существует между ними и развитыми государствами. Такие регионы, как Бангалор в Индии или Шанхай и Гуанчжоу в Китае, прежде всего будут подключать предприятия, способные предложить мировому рынку услуги своих высокообразованных работников.

Сегодня во многих странах политические руководители самого высокого ранга всячески содействуют инвестициям в информационную магистраль. Соревнование между государствами, которые пытаются либо вырваться в лидеры, либо просто не отстать от остальных, рождает удивительно плодотворную атмосферу. Поскольку у разных государств разные подходы, мы сможем узнать, какой из них лучше. Некоторые правительства могут прийти к следующему умозаключению: если стране необходимо обзавестись сетью, а частные компании не жаждут создавать ее на свой страх и риск, придется участвовать в строительстве информационной магистрали или финансировать отдельные ее участки. Правительственная поддержка, конечно, поможет ускорить строительство, но следует учесть весьма вероятные негативные последствия. Ведь такая страна может в конце концов получить не информационную магистраль, а что-то вроде "белого слона" - сущую обузу, плод инженеров, оторванных от реальных темпов технического прогресса.

Нечто подобное случилось в Японии с проектом телевидения высокой четкости Hi-Vision. Могущественное министерство международной торговли и промышленности и государственная телекомпания NHK объединили усилия японских производителей бытовой электроники для создания новой аналоговой системы телевидения высокой четкости. NHK обязалась несколько часов в день вести передачи в новом формате. К сожалению, система устарела (стали очевидны преимущества цифровой технологии), даже не успев толком поработать. Многие японские компании оказались в трудном положении. Конечно, сейчас они понимают, что новая система не лучшее вложение денег, но вынуждены держать свои обещания. Когда я пишу эти строки, "грандиозный план" в Японии по-прежнему движется к этой аналоговой системе, хотя никто уже не верит в его завершение. И все-таки по большому счету Япония выиграет от разработки телекамер и телевизоров высокой четкости, появившихся благодаря проекту Hi-Vision.

Построить информационную магистраль не значит просто сказать: "Проведите везде провода". Любому правительству или компании, занятым в этом строительстве, придется внимательно следить за новейшими достижениями и быть готовыми к смене курса. Подобная гибкость требует технологического опыта, и поэтому ее может обеспечить только промышленность, а не правительство.

Конкуренция в частном секторе рынка обещает быть жестокой. Кабельные, телефонные и другие компании будут соперничать за право создания и поддержки инфраструктуры волоконно-оптических, беспроводных и спутниковых линий связи. Производители оборудования будут сражаться за поставки серверов, AТМ-коммутаторов и телевизионных приставок сетевым компаниям, а также за продажи персональных компьютеров, цифровых телевизоров, телефонов и других информационных устройств потребителям. В то же время компании, которые выпускают программные продукты, в том числе Apple, AT&T, IBM, Microsoft, Oracle и Sun Microsystems, будут предлагать сетевым провайдерам свои программные компоненты. В результате вокруг формирующейся сети сложится мощная индустрия из миллионов компаний и частных лиц, чей товар - приложения и информация, в том числе развлекательная.

Я уже довольно подробно говорил о том, насколько важно создать физическую инфраструктуру, которая обеспечит подключение домашних систем к сетям с высокой пропускной способностью. Я рассказал о конкуренции в США и о стратегии основных игроков на рынке - телефонных и кабельных компаний. Кабельные компании моложе и компактнее телефонных, а потому, как правило, и предприимчивее. Системы кабельного телевидения, опутывая потребителей паутиной коаксиальных и - реже - волоконно-оптических кабелей, позволяют передавать высококачественное видео лишь в одну сторону. Хотя степень их распространения по всему миру довольно мала (189 миллионов подписчиков), кабельные системы, проложенные рядом с 70% американских домов, несут сигнал почти в 63 миллиона домов. Сейчас кабельные системы постепенно переходят на передачу цифровых сигналов, а некоторые кабельные компании работают над возможностью подключения пользователей ПК к Internet и оперативным службам. Они делают ставку на то, что многие из этих пользователей, которые привыкли к обмену информацией по телефонным линиям со скоростью 28800 бит в секунду, согласятся платить больше - за передачу данных по телевизионным кабелям со скоростью 3 миллиона бит в секунду.

Что касается телефонных компаний, их сильная сторона в другом: они гораздо прочнее в финансовом отношении. Американская телефонная система является крупнейшей в мире коммутируемой распределенной сетью, обеспечивающей парное (point-to-point) соединение абонентов. Объединенный рынок услуг местной телефонной связи, приносящий в год 100 миллиардов долларов прибыли, значительно выгоднее, чем кабельный бизнес с его 20 миллиардами. Семь региональных отделений компании Bell соперничают со своей бывшей колыбелью - компанией AT&T за право обеспечивать междугородную и сотовую связь, а также предоставлять ряд новых услуг. Но, как и другие телефонные компании мира, отделения Bell - новички в мире конкуренции, едва сбросившие ярмо жестких ограничений на свою деятельность.

Возросшая конкуренция будет подстегивать местные телефонные компании. Сейчас они занимают оборонительную позицию. На их территорию покушаются другие телефонные компании, а также кабельные; последние намерены предлагать весь спектр коммуникационных услуг. Новое законодательство снимет ограничения на их конкуренцию, а это, как я уже отмечал, приведет к значительному падению цен на междугородную телефонную связь. Если это случится, телефонным компаниям придется забыть о своих нынешних прибылях.

Местные компании слишком медлили с внедрением в свои сети новейших средств цифровой связи: нужды торопиться не было, так как от конкуренции их защищали мощные финансовые барьеры. Они знали, что потенциальному конкуренту придется сделать двойные вложения в оборудование (скажем, 100 миллионов долларов), чтобы соперничать с ними на данной территории. Но цены на коммутирующее оборудование и волоконно-оптические линии связи падают с каждым годом.

А это означает, что перед компаниями встают те же проблемы, что и перед человеком, который никак не может решиться на покупку компьютера. То ли ждать падения цен и роста производительности, то ли купить оборудование прямо сейчас и быстрее начать работу. С этой дилеммой столкнутся и некоторые сетевые компании. Они должны постоянно совершенствоваться. Компания выиграет, если не станет торопиться с затратами на приобретение кабелей и коммутаторов, но может навсегда потерять место на рынке, которое займут менее осторожные конкуренты.

Телефонные компании, несмотря на свои завидные прибыли, не всегда располагают необходимыми средствами для коренной модернизации сетей, а ограничения на прибыль не позволяют им повышать плату за телефонные услуги и даже использовать на финансирование нового вида деятельности прибыль от текущих услуг. И кто поручится, что держатели акций, привыкшие получать от Bell солидные дивиденды, согласятся пустить часть прибыли на создание информационной магистрали.

Почти сотню лет телефонные компании, как регулируемые монополии, потихоньку зарабатывали деньги. И вдруг отделениям Bell пришлось превратиться в рыночные компании - перемена столь же радикальная, как переделка трактора в гоночный автомобиль. Конечно, это возможно (спросите у ребят из компании Lamborghini, которая выпускает и то и другое), но задача не из легких.

А если телефонные компании обеспечат пользователям ПК доступ к ISDN-сетям, возникнет новый источник прибыли, и это может побудить их к снижению цен, чтобы завоевать массовый рынок. По моим ожиданиям, внедрение ISDN произойдет быстрее, чем кабельных сетей. Телефонные компании сейчас вовсю соображают, как использовать витые пары хотя бы на последних сотнях метров перед домами, сохранив при этом высокую пропускную способность передачи данных. Рост спроса на подобные услуги позволит преуспеть и телефонным, и кабельным компаниям, расширив возможность получения прибыли.

Амбиции кабельных и телефонных компаний идут дальше простого создания канала перекачки битов. Вообразите, что Вы - управляющий компании по доставке битов. Как зарабатывать больше денег, если Вы уже охватили свою территорию и провели провода в каждый дом ? Можно передавать больше битов, но клиенты не в состоянии сидеть перед телевизорами и компьютерами больше 24 часов в сутки. Остается альтернатива - извлекать выгоду из передаваемой информации. Многие видят в информационной магистрали своеобразную "пищевую цепочку", на нижнем конце которой - доставка и распределение битов, а на верхнем - разнообразные материалы, приложения и услуги. Компании, доставляющие биты, заинтересованы в продвижении по цепочке вверх, чтобы получать прибыль от владения битами, а не от их передачи. Вот почему кабельные компании, региональные телефонные компании и изготовители бытовой электроники так стремятся сотрудничать с голливудскими студиями, телекомпаниями и другими производителями интеллектуальной собственности.

Некоторые фирмы вкладывают деньги, потому что опасаются этого не делать. Долгое время дистрибуция информации была для них делом очень выгодным, в основном из-за монопольного положения, поддерживаемого правительством. Когда эти монополии ликвидировали и началась конкуренция, передача битов перестала приносить прежнюю прибыль. Компании, которые надеются через инвестиции и/или свое влияние участвовать в создании приложений и услуг, а также в подготовке материалов для информационной магистрали, должны поторопиться, пока возможности еще открыты. Отдельные из этих компаний могут выпускать сами или финансировать производство приставок для подключения телевизоров. Они могли бы предлагать (на условиях аренды с ежемесячной оплатой) подключение к информационной магистрали в комплексе с телевизионными приставками, сопутствующими пакетами программ и услугами. Так работают системы кабельного телевидения, так работали - до снятия ограничений и телефонные компании.

Сетевые операторы, которые включат телевизионную приставку в ежемесячную оплату стандартного набора услуг, сумеют привлечь клиентов, которые пока сомневаются, стоит ли им тратить несколько сотен долларов на эту приставку. Как я уже объяснял, в первые годы есть реальная опасность, что приставки будут быстро устаревать, - так зачем их покупать ? Хотя поставка этих аппаратов и потребует от сетевых операторов дополнительных начальных затрат, издержки окажутся не напрасны, если это поможет создать критическую массу пользователей. Однако правительство обеспокоено тем, что контроль над приставками поставит сетевых операторов в привилегированное положение, которое позволит им извлекать необоснованные прибыли. Сетевые операторы, получившие контроль над приставками, впоследствии захотят получить контроль и над программным обеспечением, приложениями и услугами, связанными с этими устройствами. В итоге у студий, продающих свои фильмы, окажется весьма ограниченный выбор. Один из самых сложных вопросов, который предстоит решить за счет демонополизации, - надо ли предоставлять разным службам равный доступ к линиям связи и приставкам. Аргумент "за" в том, что, если разные службы будут пользоваться одними линиями связи, правительству не придется заниматься соответствующими стандартами и вопросами совместимости.

Продажа клиентам приставок привлечет розничных торговцев - в конце концов продают же они телевизоры и персональные компьютеры ! Компании, которые выпускают бытовую электронику, наверняка захотят помериться силами в производстве приставок. Они предложат весь спектр моделей - от замысловатых и дорогих для толстосумов, до простых и дешевых для людей обычного достатка. Если телевизионные приставки будут устанавливать сетевые компании, розничные торговцы на этом ничего не заработают. В индустрии сотовых телефонных систем эта проблема решается частичным субсидированием: Вы покупаете сотовый телефон у розничного торговца, но в цену входит стоимость услуг той сотовой компании, которая Вас будет обслуживать.

Кабельные и телефонные компании станут основными (но не единственными) конкурентами в обеспечении доступа к сети. Железнодорожные компании в Японии, например, поняли, что принадлежащие им участки земли, по которым проложены рельсы, представляют собой идеальное место для прокладки волоконно-оптического кабеля. Поставщики электроэнергии, а также газовые и водопроводные службы во многих странах тоже сообразили, что и они могут проводить в жилые и служебные помещения не только свои коммуникации. Некоторые из них заявляют, что компьютеризация подачи тепла в домах сэкономит столько денег, что их с лихвой хватит на прокладку волоконно-оптических кабелей. А поскольку потребление электроэнергии снизится, то и необходимость в строительстве новых энергетических установок уже не будет такой острой. Скажем, во Франции большей частью кабельных линий владеют две водопроводные компании. Но, по крайней мере за пределами Франции, традиционные коммунальные службы вряд ли будут участвовать в строительстве магистрали.

Может быть, Вас удивило, почему я не упомянул о прямой спутниковой связи и других подобных технологиях - основных конкурентах кабельной и телефонной связи. Как я уже говорил, современная спутниковая технология пока занимает промежуточное положение. Она позволяет передавать вещательные видеосигналы прекрасного качества, но понадобится настоящий технологический рывок, прежде чем спутники смогут доносить эти сигналы до каждого телевизора или персонального компьютера. На рынке Соединенных Штатов этой технологии придется пройти путь от сегодняшних систем с 300 каналами на спутник до систем с 300000 каналами, даже если предположить, что одновременно надо обеспечивать сигналом менее 1% приемников.

Из-за того что спутники не обеспечивают канала обратной связи, т.е. не способны доставлять сигналы из домов в сеть, и тем самым не позволяют добиться настоящей интерактивности, приложения типа видеоконференций пока нельзя реализовать через спутниковую связь. Частичное решение этой проблемы - использование в качестве канала обратной связи телефонных линий. В некоторых спутниковых системах прямого вещания (например, в системе DIRECTV, принадлежащей Hughes Electronics) для передачи в учетный центр информации о платных программах, выбранных Вами, задействованы обычные телефонные линии. С помощью специальных дополнительных контуров вещательные спутники способны передавать информацию не только на телевизоры, но и на компьютеры. Для некоторых приложений передача данных по таким каналам может стать удачным промежуточным решением.

Компания Teledesic, в которую мы с моим другом Крейгом Мак-Ко (Craig McCaw) вложили средства, пытается преодолеть ограничения спутниковой технологии за счет применения большего числа спутников на низких орбитах. Предполагаемые масштабы системы весьма амбициозны. Она объединяет около 1000 спутников, вращающихся по орбитам в 50 раз ближе к Земле, чем традиционные геостационарные спутники. Близость к Земле означает, что этим спутникам понадобится в 2500 раз меньшая мощность и что они расширят возможности двусторонней связи. Это снимет проблему канала обратной связи. Удастся также избежать заметного запаздывания сигнала, неизбежного при использовании обычных спутников. Низкоорбитальные спутники смогут обеспечивать такую же скорость передачи на большие расстояния, как и волоконно-оптические линии. Сейчас перед компанией Teledesic стоит масса проблем законодательного, технического и финансового характера, и пройдет еще несколько лет, прежде чем их удастся преодолеть. Если это получится, Teledesic и аналогичные системы станут первыми дешевыми и, по сути, единственными системами, способными довести магистраль до многих участков планеты. Ведь большая часть населения Азии и Африки вряд ли получит в ближайшие 20 лет доступ к волоконно-оптическим сетям.

Еще одна быстро развивающаяся технология - наземная беспроводная связь. Телевизионные сигналы, которые передавались в диапазонах высоких и сверхвысоких частот, переведут в основном на волоконно-оптические линии. Цель этого перехода - предоставить каждому возможности приема персонального видеосигнала и работы в интерактивном режиме. Тем временем средства речевой и других низкоскоростных видов связи переводят с проводной на беспроводную передачу, чтобы обеспечить поддержку растущей мобильности общества. Здесь идеально подошел бы компьютер-бумажник, о котором я рассказывал. Но пока ни одна из существующих технологий не в состоянии соединить высококачественное видео с мобильностью: беспроводные системы не позволяют передавать широкополосный сигнал, его способны нести только сети на основе волоконно-оптических кабелей.

Поначалу конкуренция развернется за право первым предоставить населению интерактивные услуги, но как только все перспективные районы будут поделены между компаниями, начнется ожесточенная борьба за выход на "чужой" рынок. Любопытно, что в бизнесе, связанном с кабельным ТВ, редко возникают "альтернативные" системы: те, кто пришел позже, не зарабатывают денег. Если каждый дом подключить к двум или более универсальным кабельным системам, это создаст конкуренцию, но потребует неприемлемых затрат.

Серверы информационной магистрали должны быть очень мощными компьютерами с гигантскими объемами памяти; они будут работать по 24 часа 7 дней в неделю. Конкуренция за их поставку тоже будет ожесточенной. У разных компаний разные представления об архитектуре серверов и о стратегии их разработки. И неудивительно, что точки зрения потенциальных конкурентов на эти проблемы зависят от их опыта в тех или иных областях. Ведь если единственный инструмент, которым Вы располагаете, - молоток, то очень скоро любая новая проблема покажется Вам чем-то вроде гвоздя, который надо забить этим молотком. Производителям мини-компьютеров (скажем, Hewlett Packard) сервер представляется группой мини-компьютеров. Большинству компаний, выпускающих главным образом персональные компьютеры, кажется, что дешевле и надежнее объединить большое количество недорогих ПК. Специалисты по мэйнфреймам, например IBM, приспосабливают под серверы свои машины. Они лелеют надежду, что информационная магистраль станет последним бастионом мощных мэйнфреймов.

Разработчики программных средств видят выход, естественно, через призму своих продуктов. Стоимость дистрибуции программ настолько мала, что использование их вместо дорогостоящего оборудования снижает цену системы. Еще одна область конкурентной борьбы (а эта борьба уже разворачивается) - поставка программных платформ для серверов. Компания Oracle, специализирующаяся на базах данных и выпускающая программы для мэйнфреймов и мини-компьютеров, представляет в качестве серверов только мэйнфреймы или мини-компьютеры под управлением программного обеспечения от Oracle. AT&T, с ее опытом в сетевом бизнесе, вероятно, попытается перенести основной акцент на серверы и коммутирующее оборудование, оставив на долю информационной аппаратуры - персональных компьютеров и телевизионных приставок - сравнительно простые задачи.

У нас в Microsoft один "молоток" - программное обеспечение. Мы надеемся, что вычислительные мощности информационной магистрали будут поровну поделены между серверами и информационной аппаратурой. Такую схему иногда называют "клиент-серверной архитектурой", так как в данном случае информационная аппаратура (клиенты) и серверы будут совместно выполнять одни и те же программы. Мы не думаем, что понадобятся гигантские суперкомпьютеры, мэйнфреймы или даже группы мини-компьютеров. Вместо этого Microsoft - так же, как и многие представители индустрии персональных компьютеров, - видит серверы сетью из десятков или сотен компьютеров, принципиально не отличающихся от ПК. У них не будет привычных корпусов, мониторов и клавиатур, они могут быть смонтированы на стойках и расположены в центральном офисе кабельной или телефонной системы. Чтобы обуздать "лошадиные силы" тысяч таких машин, понадобится разработка специальной технологии программирования. Наш подход в том, чтобы возложить координацию компонентов магистрали на программное обеспечение и выполнять его на максимально большом числе серийных (а следовательно, и самых дешевых) машин - персональных компьютеров.

Наш подход ставит во главу угла использование всех преимуществ индустрии ПК, в том числе программного обеспечения. Персональный компьютер станет одним из основных устройств, применяемых на магистрали. Мы считаем, что телевизионная приставка должна позаимствовать у ПК максимум его технических функций; это облегчит создание программ, способных работать на устройствах обоих типов. Тогда Internet сможет постепенно эволюционировать в информационную магистраль, не вызывая проблем совместимости. Мы полагаем, что утилиты и приложения, написанные для сегодняшних ПК, могут быть использованы для разработки новых программ. Например, приставки, по нашему мнению, должны уметь работать с большей частью программ на CD-ROM-дисках для ПК, которые появятся в следующее десятилетие. Наверное, кто-то возразит, что мы мыслим слишком узко, воображая, будто новый мир будет держаться только на персональных компьютерах. Но каждый год во всем мире продается более 50 миллионов ПК. Парк этих машин образует серьезный рынок для любого разработчика программ и поставщика услуг.

Даже если у потребителей вдруг окажется миллион однотипных телеприставок, по сравнению с рынком персональных компьютеров этот рынок все равно будет просто ничтожен. На создание программ для специализированных приставок разработчик сможет расходовать лишь малую часть своих средств. Только самые крупные компании способны инвестировать средства в новые приложения, не слишком переживая за масштабы рынка для этих приложений в ближайшей перспективе. Поэтому мы считаем, что основная часть новшеств так или иначе будет связана с расширением существующих рынков и что прогресс в сторону интерактивного телевидения и информационной магистрали будет опираться скорее всего на рынок ПК/Internet. Правда, аналогичные аргументы можно привести и в пользу других компьютерных платформ или игровых приставок.

Остальные изготовители программного обеспечения тоже уверены в своей стратегии. При разработке программ для телевизионных приставок Apple предполагает и использовать технологию Macintosh, а Silicon Graphics намерена адаптировать для этих целей операционную систему своих рабочих станций - вариант UNIX. Одна небольшая фирма даже хочет приспособить для новых нужд операционную систему, которая сегодня в основном используется в системах антиблокировки тормозов на грузовиках !

Аналогичные решения относительно приставок принимают сейчас и производители компьютерного оборудования. А компании, которые выпускают бытовую электронику, раздумывают над тем, какие именно информационные устройства - от карманных компьютеров до телевизоров они будут производить и какими программами пользоваться.

Битва программных архитектур продлится достаточно долго и может вовлечь потенциальных конкурентов, не сформулировавших пока свои интересы. Все программные компоненты будут до какой-то степени совместимы - так же, как и нынешние компьютерные системы. Сейчас к Internet можно подключить практически любой компьютер, то же самое будет и на информационной магистрали.

Вопрос, насколько похожим будет у этих платформ пользовательский интерфейс, остается открытым. Единый пользовательский интерфейс - это прекрасно, если только он Вам нравится. Одинаковы ли вкусы у дошкольника, мамы, папы и бабушки ? Допустимо ли подходить ко всем с одной меркой ? Веских аргументов в пользу любой точки зрения вполне достаточно, так что и здесь придется поэкспериментировать, оставив рынку право на выбор.

Есть и другие вопросы, которые ждут решения рынка. Например, будет ли реклама играть важную роль в распространении информации и развлекательных материалов или большую часть услуг потребители станут оплачивать напрямую ? Будете ли Вы сами управлять тем, что увидите на экране, впервые включив телевизор или другое информационное устройство, или Вам поможет в этом сетевой провайдер ?

Рынок повлияет и на технические аспекты сети. Большинство экспертов полагает, что интерактивные сети будут использовать ATM (Asynchronous Transfer Mode - асинхронный режим передачи), но сегодня ATM-сети стоят слишком дорого. Если цены на ATM-оборудование, как в свое время цены на микроэлектронные компоненты, будут быстро падать, - это одно. Однако если по каким-то причинам они останутся высокими или будут снижаться слишком медленно, то, вероятно, придется преобразовывать сигналы в какую-то другую форму, прежде чем подавать их в дома потребителей.

Прокладка информационной магистрали, которая приведет к массовому рынку, потребует опыта и усилий самых разных фирм. Многопрофильным компаниям может показаться заманчивым самостоятельно создать все компоненты магистрали и собственными силами разжечь рынок, но, думаю, это было бы ошибкой.

Я всегда считал, что лучше всего идут дела у тех компаний, которые концентрируют свои усилия на узкой сфере ключевых задач. Один из основных уроков компьютерной индустрии - да и самой жизни - заключается в том, что практически невозможно все делать хорошо. IBM, DEC и другие компании компьютерной индустрии пытались браться за все, в том числе за микросхемы, программы, системы и консультации. Когда появились микропроцессоры и персональные компьютеры и темп технологического прогресса резко ускорился, эта стратегия оказалась уязвимой, тогда как внушительных успехов добились производители, сосредоточившиеся на каких-то отдельных областях. Одна компания выпускала хорошие микросхемы, другая прекрасно собирала ПК, третья преуспевала в дистрибуции и системной интеграции. Каждая новая компания, добившаяся успеха, выбирала узкий участок и фокусировала на нем свои усилия.

Так что будьте бдительны ! К тем, кто пытается объединить опыт работы по всем аспектам информационной магистрали в единой организации, следует относиться весьма скептически. В большинстве материалов, посвященных информационной магистрали, внимание прессы как раз и привлекают именно такие крупные коммерческие сделки. Компании - носители связи - сливаются и пробуют разные варианты. Некоторые телефонные компании покупают кабельные. Компания проводной связи AT&T приобрела компанию беспроводной связи McCaw Cellular. Корпорация Disney купила Capital Cities - ABC, а Time Warner хочет заполучить Turner Broadcasting. Пройдет еще немало времени, прежде чем компании, которые отчаиваются на такие вложения, смогут оценить, насколько правильно они поступили.

Подобные сделки, хороши они или плохи, всегда завораживают общество. Например, когда тридцатимиллиардная сделка между Bell Atlantic и TCI окончилась неудачей, в прессе долго муссировали тему: не окажет ли это пагубного влияния на информационную магистраль ? Мой ответ - нет. Обе компании продолжают разрабатывать весьма агрессивные планы инвестиций в строительство инфраструктуры магистрали.

Рождение информационной магистрали зависит от развития персональных компьютеров, Internet и новых приложений. Удачные или неудачные слияния компаний не являются индикатором прогресса или его отсутствия. Эти сделки похожи на фоновый шум: он есть независимо от того, слушает его кто-нибудь или нет. Microsoft планирует сотрудничество с сотнями компаний, в том числе с киностудиями, телевизионными сетями, издателями газет и журналов. Мы надеемся, что вместе нам удастся создать интереснейшие приложения для компакт-дисков, Internet и информационной магистрали.

Мы верим в альянсы и стремимся в них участвовать. Но свою ключевую миссию мы тем не менее видим в создании программных компонентов для информационной магистрали. Мы поставляем инструментальные средства для целого ряда производителей оборудования, работающих над новыми приложениями. Многие компании со всего мира будут сотрудничать с нами и наблюдать за тем, как потребители реагируют на новые приложения. Обратной связи с потребителями мы придаем большое значение.

Вы тоже сможете прочитать о результатах испытаний информационной магистрали. Понравятся ли пользователям новые игры с множеством участников ? Будут ли партнеры общаться по-новому ? Поможет ли им сеть работать вместе ? Станут ли они покупать что-то на новом рынке ? Появятся ли новые удивительные приложения, которые сейчас трудно даже вообразить ? Захотят ли люди платить за эти новые возможности ?

Ответы на эти вопросы - ключ к пониманию того, как пойдет развитие информационного века. Наблюдать за слияниями компаний и всеобщим ажиотажем весьма забавно. Но если Вас интересует не золотая лихорадка, а настоящее строительство магистрали, посматривайте время от времени на дисплей компьютера, подключенного к Internet, и следите за приложениями, которые пользуются там популярностью. По крайней мере, я собираюсь поступать именно так.


Глава 12 - Основные проблемы

Глава 12
Основные проблемы

Мы живем в удивительное время - в самом начале информационного века. Куда бы я ни приходил, с кем бы ни говорил (на конференции или за обедом), меня почти всегда спрашивают, какие перемены сулит информационная технология. Люди хотят знать, в какой мере она повлияет на нашу жизнь. Лучше она станет или хуже ?

Я уже говорил, что по натуре я - оптимист, и с оптимизмом смотрю в будущее. Новая технология обогатит наш досуг, активизирует культурную жизнь, расширив доступ к разнообразной информации. Появится возможность работать дома или в удаленных офисах, а это ослабит нагрузку на городские структуры. Снизится расход природных ресурсов, поскольку многие продукты будут выпускаться не в "вещественной" форме, а в виде последовательности битов. Новая технология поможет нам обрести независимость, шире обмениваться опытом и покупать товары, подогнанные под наши запросы. Гражданам информационного общества откроются беспрецедентные возможности для работы, образования и отдыха. Государства, смело идущие вперед, объединив свои усилия, получат несомненные экономические преимущества. Возникнут совершенно новые рынки и миллионы новых рабочих мест.

Экономика, если смотреть на нее сквозь призму десятилетий, всегда на подъеме. На протяжении последних веков поколение за поколением находило все более эффективные способы трудиться, накапливая колоссальный багаж знаний и опыта. Средний человек сегодня живет лучше, чем какой-нибудь аристократ пару столетий назад. Хорошо бы, конечно, владеть его землями, но что тогда делать с его болячками ? Ведь достижения одной только медицины существенно увеличили продолжительность жизни и повысили ее уровень.

Генри Форд на заре двадцатого века создал автомобильную промышленность, но сегодня Ваш автомобиль превосходит любую из машин, за рулем которых сидел он, один из самых богатых людей Америки того времени. Современные машины и безопаснее, и надежнее, а о стереосистемах и говорить нечего. Но совершенству нет предела. Постоянный рост производительности труда неуклонно движет общество по пути прогресса, и рядовой гражданин в развитой стране станет во многих отношениях "богаче" любого из нас сегодняшних - это всего лишь вопрос времени.

Мой оптимизм вовсе не означает, что я смотрю на будущее сквозь розовые очки. При создании информационного общества издержки неизбежны - как и при любых крупных переменах. Начнутся неурядицы в ряде секторов бизнеса, и занятым в них придется переучиваться на другие специальности. Доступность дешевых компьютеров и средств связи изменит взаимоотношения стран и социоэкономических групп внутри государств. Мощь цифровых технологий и универсальность их применения вызовут новые трудности в сохранении личных, коммерческих и государственных тайн. Общество вновь всколыхнется от вопросов, связанных с равенством всех его членов. Ведь информационная магистраль должна служить всем гражданам, а не только технической и экономической элите. Одним словом, есть над чем подумать. Я не претендую на раздачу готовых рецептов от всех проблем, но, как я уже говорил в начале книги, сейчас самое время приступить к их широкому обсуждению. Технический прогресс всегда ставит перед обществом новые, более сложные проблемы, многие из которых сегодня даже нельзя предвидеть. Темп изменений настолько высок, что иногда кажется, будто мир обновляется чуть ли не каждый день. На самом деле это, конечно, не так. Но к переменам надо готовиться заранее. Обществу предстоит трудный выбор в таких областях, как всеобщая доступность образования, его финансирование, разработка законодательных основ и соблюдение баланса между личной неприкосновенностью и безопасностью общества.

Однако, как ни важно думать о будущем, поостережемся поспешных действий. Пока мы в состоянии сформулировать лишь самые общие вопросы, а значит, сейчас нет смысла вдаваться в детальную проработку специфических законов. Еще есть время понаблюдать за развитием приближающейся революции, чтобы принять решения взвешенно и разумно, а не под влиянием эмоций.

Вероятно, очень многих волнует проблема: "Смогу ли я занять достойное место в новой экономике ?" И мужчины, и женщины опасаются, что их профессии устареют, что они не приспособятся к непривычным методам работы, что их дети могут связать свою жизнь с обреченными отраслями промышленности, что перемены в экономике приведут ко всеобщей безработице, особенно среди пожилых людей. Их беспокойство вполне оправданно. Действительно, забвение грозит как отдельным профессиям, так и целым отраслям индустрии. Однако на их месте возникнут другие, ранее не известные. Все это произойдет в ближайшие 2 - 3 десятилетия - по историческим меркам, очень быстро, - но может носить такой же мирный характер, как и "микропроцессорная" революция, коренным образом изменившая условия нашей работы.

Несмотря на то что микропроцессоры и созданные на их основе персональные компьютеры действительно изменили и даже ликвидировали некоторые рабочие места и компании, трудно найти хоть какой-то мало-мальски крупный сектор экономики, на котором это отразилось бы негативно. Конечно, компаниям, выпускающим мэйнфреймы, мини-компьютеры и пишущие машинки, пришлось потесниться, но компьютерная индустрия в целом выросла, а общее число рабочих мест значительно увеличилось. Многие сотрудники крупных компьютерных компаний вроде IBM или DEC, потеряв работу, находили ее в той же сфере - чаще всего в фирмах, так или иначе связанных с персональными компьютерами.

И за пределами компьютерной индустрии также трудно отыскать сектор экономики, пострадавший от персональных компьютеров. Многие работники типографий оказались не у дел из-за появления настольных издательских систем, однако на каждое ликвидированное рабочее место в этой отрасли теперь приходится несколько новых - как раз благодаря распространению настольного издательства. Перемены никогда не сулят благополучия всем сразу, но из всех революций, пережитых человечеством, одна - вызванная появлением персональных компьютеров - прошла на удивление безболезненно.

Некоторые уверены, что число рабочих мест в мире ограниченно, и человек, потерявший работу, останется за бортом. К счастью, экономика работает иначе. Это обширная взаимосвязанная система, в которой ресурсы, освободившиеся в одной области, становятся доступны в другой, где могут оказаться даже ценнее. Когда необходимость в том или ином рабочем месте отпадает, человек, занимавший его, волен приложить свои силы на другом рабочем месте. В итоге люди начинают зарабатывать даже больше, что в перспективе приводит к общему повышению уровня жизни. Развитие экономики идет, конечно, не по гладкой прямой - время от времени возникают и кризисы перепроизводства, и депрессии, что вызывает рост безработицы. Но технический прогресс, как правило, ведет к увеличению рабочих мест.

В развивающейся экономике потребность в тех или иных профессиях постоянно меняется. Вспомните, раньше все звонки проходили через телефонистку. Когда я был совсем маленьким, чтобы позвонить в другой город из дома, приходилось набирать "0" и называть телефонистке номер. Во времена моей юности многие компании все еще держали операторов, которые переадресовывали звонки абонентам, вручную переключая провода на коммутаторе. А в наши дни телефонисток почти не осталось, хотя число звонков выросло просто несоизмеримо. Управление взяла на себя автоматика.

До промышленной революции большая часть населения жила и работала на фермах. Производство продуктов питания - вот основное занятие тех поколений. Если бы тогда кто-нибудь предсказал, что через пару столетий в сельском хозяйстве будет занято всего лишь несколько процентов от общего числа жителей, крестьяне наверняка бы занервничали: чем они будут зарабатывать себе на жизнь ? В 1990 году U.S. Census Bureau (Американское бюро переписи) зарегистрировало 501 профессию, подавляющее большинство которых полвека назад даже и не существовало. И хотя сейчас нельзя предугадать, какие профессии появятся в будущем, вполне вероятно, что в основном они будут связаны с потребностями сферы образования, социального обеспечения и досуга.

Мы знаем: когда магистраль напрямую соединит покупателей и продавцов, те, кто сейчас выступает в роли посредников, окажутся не у дел. Нечто подобное уже наблюдалось, когда такие крупные торговые фирмы, как Wal-Mart или Price-Costco, а также другие компании, эффективно применяющие новые методы розничной торговли, начали теснить обычные магазины. Захват фирмой Wal-Mart сельских рынков больно ударил по торговцам в небольших городках. Кто-то из них выживает, кто-то - нет, но региональная экономика от этого не страдает. Можно сожалеть о потере каких-то традиций, но магазины-склады и сеть быстрого питания будут преуспевать и впредь, потому что потребитель долларом голосует за того, кто, снижая цены, позволяет им экономить деньги.

Сокращение числа посредников - еще один способ снизить цены. Он тоже ведет к сдвигам в экономике, но не более стремительным, чем перемены в розничной торговле, происшедшие за последнее десятилетие. Пройдут годы, прежде чем магистраль настолько широко вторгнется в область торговли, что это заметно отразится на количестве посредников. Впереди еще немало времени, чтобы успеть все обдумать и принять решение. Сейчас трудно сказать определенно, чем займутся те посредники, услуги которых больше не понадобятся. Не будем торопить события и посмотрим, какие виды созидательной деятельности откроет новая экономика. Так или иначе, работа в обществе найдется для всех.

Плоды технического прогресса вряд ли принесут радость и тем, чьи профессии окажутся в подвешенном состоянии. Человек долго учился, чтобы в совершенстве овладеть ею, и нельзя ожидать, что он вот так сразу откажется от нее и пойдет переучиваться чему-то другому. Адаптация всегда проходит болезненно, но ее не избежать. Не так-то просто подготовиться к наступающему веку. Ведь если почти нереально предугадать побочные эффекты даже тех перемен, которые мы еще можем как-то предвидеть, то что говорить о влиянии тех, которые мы и представить не в состоянии. Сто лет назад люди стали свидетелями появления первых автомобилей. Было ясно, что кто-то сколотит на них состояние, а кто-то останется без работы. Но предсказать, как развернутся конкретные события, не было дано никому. Вы, конечно, могли тогда посоветовать друзьям из компании Acme Buggy Whip (она занималась гужевыми перевозками) переключиться на "лакировку" своих резюме и изучение двигателей внутреннего сгорания, но откуда Вам было знать, что надо вкладывать деньги в прокладку газонов, разделяющих полосы встречного движения ?

Несомненно, что в будущем значительно поднимется роль образования, которое дает ключ к решению общих проблем. В быстро меняющемся мире именно образование поможет быстрее адаптироваться к новым условиям. Во времена экономических преобразований лучше всего дела идут у образованных людей. Знания и опыт общество будет все больше поощрять, поэтому мой Вам совет: получите хорошее образование и постоянно совершенствуйтесь, всю жизнь приобретая новые навыки, интересуясь всем новым.

Многие будут вынуждены покинуть насиженные места, однако это не значит, что общество отказывается от их знаний. Но и отдельным работникам, и целым компаниям придется переквалифицироваться - может быть, еще не раз. Правительства и фирмы окажут, конечно, какую-то помощь, но ответственность за свою судьбу, свое образование лежит прежде всего на самом человеке.

И первый шаг здесь - освоить компьютеры. Правда, почти всех новичков машина заставляет нервничать, прежде чем они хотя бы немножечко разберутся в том, как с ней работать. (Единственное исключение - дети.) Пользователь, впервые прикоснувшийся к клавиатуре, боится, что одно его неверное действие приведет к поломке компьютера и потере важной информации. Конечно, данные иногда утрачивают, но редко когда их не удается восстановить. Мы много работали над тем, чтобы потерять информацию было труднее, а восстановить - легче. В большинстве современных программ есть команда "Undo" ("Отменить"), которая позволяет вернуть документ к исходному состоянию, если сделано что-то не так. Видя, что ошибки не приводят к катастрофе, пользователи становятся увереннее и даже экспериментируют - персональные компьютеры к этому располагают. Набирая опыт в обращении с ПК, человек начинает понимать, что компьютер может, а чего - нет. Из коварного врага он превращается в инструмент. Как трактор или сеялка, компьютер - всего лишь машина, с помощью которой мы эффективнее решаем некоторые задачи.

Еще одно опасение: со временем компьютеры так "поумнеют", что возьмут на себя все, и человеческий разум больше не понадобится. Хотя я уверен, что со временем действительно появятся программы с элементами искусственного интеллекта, крайне сомнительно, что это произойдет при моей жизни. Десятилетиями ученые, которые исследуют проблему искусственного интеллекта, пытаются разработать компьютер, обладающий умственными способностями и здравым смыслом. В 1950 году Алан Тьюринг сформулировал постулат (впоследствии его назвали "тестом Тьюринга"): если Вы беседуете с человеком и с компьютером, не видя ни того, ни другого, и при этом не уверены, кто из них кто, значит, у этой машины действительно есть разум.

Все прогнозы относительно создания искусственного интеллекта оказались чрезмерно оптимистичными. Даже простейшие тесты на обучаемость пока не под силу самым мощным компьютерам мира. И если машины иногда кажутся нам разумными, то лишь потому, что они специально запрограммированы на решение какой-то задачи - совершенно прямолинейно, в соответствии с четко определенным алгоритмом. Например, компьютеры, играющие в шахматы на уровне гроссмейстера, в поисках верного хода, по сути, просто перебирают миллиарды его вариантов.

В обозримой перспективе компьютеры превратятся не более чем в инструмент человеческого интеллекта. Однако информационные устройства до тех пор не станут основным средством публикации, неотъемлемой частью общества, пока на магистраль не "выйдут" практически все пользователи, а не только элита. Было бы замечательно, если бы каждый - богат он или беден, стар или молод, горожанин или фермер - получил доступ к одному из информационных устройств. Но для большинства персональные компьютеры (единственный на сегодняшний день вид информационных устройств) - по-прежнему непозволительная роскошь. Как только основная часть населения установит у себя дома эту аппаратуру, те, у кого ее нет, воспользуются общественными информационными устройствами - в библиотеках, школах, на почте или в киосках. Не следует, однако, заблуждаться - вопрос об организации всеобщего доступа возникнет только тогда, когда популярность магистрали достигнет своего пика, причем такого значительного, о котором и не мечтают сегодня многие комментаторы. Как ни смешно, но некоторые из этих знатоков, недовольные тем, что чрезмерная популярность магистрали породит массу проблем, в то же время опасаются, что общество ее вообще не примет.

Полноценная информационная магистраль будет служить всем - в этом смысл ее названия. Дорогую систему, связывающую несколько крупных корпораций и отдельных богачей, просто нельзя назвать "информационной магистралью" - это всего лишь частная информационная дорога. Сеть, которая не сумеет "привлечь" достаточный объем интересных материалов, не выживет, и именно такой конец ждет ее, если она станет привилегией 10% населения. Авторские материалы всегда имеют фиксированную цену, и, чтобы сделать их общедоступными, нужна обширная аудитория. Если магистраль охватит основную часть потенциальных потребителей, ее не удержит на плаву даже реклама. Случись такое, надо будет немедленно снижать абонентную плату или приостанавливать развертывание магистрали вплоть до реорганизации ее структуры. Информационная магистраль - либо массовое явление, либо призрак.

В конце концов стоимость вычислительной техники и средств связи настолько снизится, а среда конкуренции станет настолько открытой, что цена информации на магистрали будет небольшой. Прибыль от рекламы позволит распространять многие материалы и вовсе даром. Однако большинство предлагающих свои услуги - рок-группы, инженеры-консультанты или книгоиздатели - по-прежнему будут брать с пользователей определенную плату. В общем, информационная магистраль каждому вполне по карману (при разумном ее использовании), но бесплатной она не станет.

Деньги, которые Вы потратите на услуги магистрали, Вы и сегодня расходуете на те же услуги - только в другой форме. Так было всегда. Вспомните, раньше Вы покупали грампластинки, теперь те же суммы уходят на компакт-диски, деньги, которые Вы когда-то откладывали на билеты в кино, теперь попадают в видеопрокат. Через какое-то время расходы на видеопрокат плавно перекочуют в систему "видео-по-заказу". Сегодня Вы платите за подписку на периодику, завтра перебросите часть этих денег на оплату услуг интерактивных информационных служб и сообществ. Ну а те немалые суммы, которые сегодня идут на оплату телефона и кабельного телевидения, можно потратить на пользование самой информационной магистралью.

Доступ к правительственной информации, консультативным медицинским службам, электронным доскам сообщений и некоторым учебным пособиям будет бесплатный. Ступив на магистраль, все люди получат равные права на обращение к жизненно важным оперативным материалам. Через два десятилетия, когда на магистраль придут торговые, образовательные и коммуникационные службы, статус человека как полноправного члена общества будет зависеть, по крайней мере частично, от того, насколько активно он пользуется магистралью. А самому обществу придется решать, как субсидировать равный - в географическом и социально-экономическом смысле - доступ всех пользователей к магистрали.

Образование - только часть ответа на вызов, брошенный информационным веком, ведь само по себе оно лишь частично решает проблемы общества. Герберт Уэллс, одаренный, как и всякий футурист, воображением и даром предвидения, пришел к этому выводу еще в 1920 году. "История человечества, - говорил он, - все больше напоминает гонку образования и катастрофы". Образование - один из величайших рычагов прогресса, и любой успех в этой области выравнивает стартовые возможности каждого человека. Например, красота электронного мира проявляется и в том, что дополнительные затраты на расширение круга людей, использующих образовательные материалы, практически равны нулю.

Учиться работе с персональными компьютерами можно и через игры. Я уже рассказывал, что мое увлечение компьютерами началось именно с игр, как и много лет спустя то же самое случилось с Уорреном Баффетом. А моего отца "зацепило", когда он обнаружил, что компьютер отлично справляется с подготовкой налогового отчета. И если компьютер пугает Вас, то почему бы не попробовать с малого ? Найдите, на что способен персональный компьютер и что может облегчить Вашу жизнь (или сделать ее чуточку интереснее), и займитесь этим, постепенно привыкая к машине. Сочините на компьютере пьесу, подсчитайте свои финансы, помогите детям справиться с домашним заданием. Рано или поздно Вы поймете, какую пользу приносит компьютер, и поверьте - Ваши усилия не пропадут даром. Дайте ему шанс, и он покорит Вас. Ну а если работа на компьютере все-таки покажется Вам чересчур трудной и непонятной, это вовсе не значит, что Вы не слишком сообразительны. Нет, это значит, что нам надо продолжать работу над тем, чтобы компьютеры стали еще проще.

Свои слова я обращаю прежде всего к молодым. Если Вам пятьдесят или больше, Вы, вероятно, уйдете на пенсию раньше, чем возникнет необходимость осваивать компьютер, хотя, на мой взгляд, отказавшись от него, Вы упустите массу удивительных вещей. А если Вам сегодня двадцать пять, но рядом с компьютером Вам неуютно, Вы рискуете оказаться на обочине жизни - чем бы Вы ни занимались. Кроме того, умеющему работать с компьютером гораздо легче найти работу.

Информационная магистраль, увы, не для моих сверстников, и уж тем более не для старшего поколения. Она принадлежит будущему. Развивать информационную технологию предстоит детям последнего десятилетия, которые рядом с компьютером росли, а взрослеть будут вместе с магистралью - в следующее десятилетие.

Особого внимания заслуживает проблема неравноправия полов. В дни моего детства казалось, что возле компьютеров вертятся одни парни. Сегодня девочки гораздо активнее общаются с компьютерами, чем 20 лет назад, но среди технических специалистов женщин по-прежнему очень мало. Если мы не будем противиться тому, чтобы девочки, как и мальчики, с раннего возраста привыкали к компьютерам, то можно не сомневаться: они займут достойное место в любой профессии, доступ к которой открывает компьютерная грамотность.

Вспоминая свое детство и глядя на подрастающих детей своих знакомых, я уверен: стоит ребенку сесть за компьютер, как тот сразу же приковывает все его внимание. Но мы должны предоставить ребенку такую возможность. Каждой школе надо обеспечить недорогой доступ к компьютерам, соединенным с информационной магистралью. Нужны и педагоги, свободно владеющие новыми инструментами.

Мы пока не оценили одно из самых замечательных свойств информационной магистрали: достичь в ней равенства гораздо проще, чем в реальном мире. Ведь чтобы в любой средней школе каждого бедного района была такая же библиотека, как в школах Беверли-Хилс, нужны колоссальные средства. Но соедините школы компьютерной сетью, и они получат одинаковый доступ к информации, где бы она ни хранилась. Равноправие в виртуальном мире непременно поможет решить некоторые социальные проблемы, стоящие перед нашим обществом. Конечно, компьютерные сети не снесут барьеры несправедливости и неравенства, но дадут мощный толчок этому процессу.

Многих интересует вопрос, как оценивать такую интеллектуальную собственность, как развлекательные и образовательные материалы. Экономисты прекрасно разбираются в ценообразовании товаров, произведенных классическим способом. Они могут объяснить, что обоснованные цены непосредственно отражают структуру издержек. Когда на рынке одновременно действуют конкурирующие производители, цены на их продукцию обычно падают до предельной себестоимости. Такова общая тенденция. Но эта модель не годится для интеллектуальной собственности.

Базовый курс экономики описывает кривые спроса и предложения - их пересечение и определяет цену продукта. Но когда речь заходит об интеллектуальной собственности, простая экономика бессильна, поскольку привычные нормы издержек производства здесь не применимы. Создание интеллектуальной собственности обычно требует больших затрат. Эти издержки фиксированны и не зависят от того, продан один ее экземпляр или миллион. Съемки Джорджем Лукасом (George Lucas) очередной серии Star Wars (Звездные войны) обходятся в миллионы долларов - независимо от того, сколько людей смотрит ее в кинотеатрах.

Ценообразование на интеллектуальную собственность осложняется еще и тем, что сегодня производство одного ее экземпляра (по сути, носителя) обычно обходится сравнительно недорого. Завтра, на информационной магистрали, стоимость доставки копии продукта (приблизительно равная стоимости ее производства) станет еще ниже и будет ежегодно снижаться в соответствии с законом Мура. Приобретая новое лекарство, Вы оплачиваете главным образом затраты фармацевтической фирмы на научные исследования, разработку и испытания этого лекарства. Даже если предельная себестоимость производства каждой таблетки минимальна, фармацевтические фирмы все равно вынуждены брать с Вас гораздо больше, особенно при узком рынке сбыта. Выручка от среднего пациента должна покрыть основную часть затрат на научные исследования и дать при этом достаточную прибыль, чтобы инвесторы, рискнувшие своими деньгами на создание нового лекарства, остались довольны. Когда лекарство закупает бедное государство, перед фармацевтикой встает моральная дилемма: отсрочить (или существенно снизить) плату за передачу патента или лишить эту нищую страну нового лекарства. Однако в любом случае, раз производитель должен вкладывать деньги в научно-исследовательские работы, кому-то надо платить за лекарство суммы, превышающие его предельную себестоимость. Поэтому цены на медицинские препараты сильно разнятся в разных странах, и от этого страдают малообеспеченные граждане богатых государств - если только их расходы на лекарства не возмещает правительство.

Одно из возможных решений - придумать схему, при которой лекарство, фильм или книга обходятся обеспеченному человеку дороже. Кому-то такой расклад покажется не самым удачным, однако именно так сегодня действует система налогообложения. Через подоходный и другие налоги лица с высокими доходами платят за содержание дорог, школ, армии и государственных учреждений больше, чем рядовой налогоплательщик. В прошлом году, продав часть акций Microsoft, я заплатил в виде налога на прибыль 100 миллионов долларов. Я не жалуюсь, но это пример тому, как одни и те же услуги могут стоить совершенно по-разному.

Плата за доступ к информационной магистрали может быть установлена исходя из политических соображений, без учета реальных затрат. Так, чтобы уравнять в "информационных правах" жителей удаленных районов, придется здорово раскошелиться - в связи с высокой стоимостью прокладки кабелей. Вполне вероятно, что компании не загорятся желанием вкладывать в это деньги, а абонирование за свой счет "географически неравноправным" гражданам будет просто не по карману. Следует ожидать жарких споров и вокруг того, должно ли правительство субсидировать подключение сельских районов или издавать постановления, по которым эта "повинность" ляжет на жителей крупных городов. Прецедент известен - доктрина "универсального обслуживания", разработанная специально для финансирования некоторых коммунальных услуг в сельских районах Соединенных Штатов. Согласно этой доктрине, стоимость почтовой, телефонной связи, а также электроэнергии не зависит от местожительства. Хотя в сельской местности, где дома и предприятия рассредоточены на больших площадях, эти услуги обходятся гораздо дороже, чем в городских районах.

По отношению к доставке газет и приему радио- и телесигналов такая политика не проводилась. Тем не менее эти средства массовой информации вошли в каждый дом, поэтому, очевидно, что в определенных обстоятельствах всеобщий доступ можно обеспечить и без вмешательства властей. Почтовое ведомство США было учреждено в составе правительства с одной целью: гарантировать действительное равенство всех граждан при обращении к почтовым услугам. Однако службы UPS и Federal Express могли бы не согласиться с этим, потому как сумели не только охватить большое количество потребителей, но и заработать на этом деньги. Видимо, ожесточенная полемика насчет того, должно ли правительство участвовать в обеспечении всеобщего доступа к информационной магистрали (и если да, то в какой степени), растянется на долгие годы.

Магистраль позволит тем, кто живет в отдаленных уголках, принимать активное участие в жизни большого мира и получать любую информацию. Совмещение деревенского образа жизни с городским информационным сервисом многие сочтут достаточно привлекательным, и поэтому не исключено, что у компаний, обслуживающих сеть, появится стимул провести волоконно-оптические линии в удаленные регионы с высоким уровнем доходов. Весьма вероятно, что некоторые штаты, города и даже частные застройщики станут активно финансировать подключение к магистрали, способствуя таким образом развитию своих регионов. Это приведет к тому, что можно назвать "Аспен-изацией" ("Aspen-ization") страны. Сельские сообщества, заинтересованные в повышении уровня жизни, будут специально подключать своих жителей к магистрали, чтобы привлечь к себе новый класс городской технической элиты. Но в целом города, конечно, подключатся к информационной магистрали раньше сельских районов.

Пересекая границы, магистраль принесет информацию и новые возможности в развивающиеся страны. При дешевой глобальной связи люди, где бы они ни находились, смогут работать в русле мировой экономики. Например, говорящий по-английски кандидат наук из Китая обратится за консультацией к своим коллегам в Лондоне. Интеллектуалам в промышленно развитых государствах грозят в каком-то смысле новые конкуренты - в последнее десятилетие это уже пережили рабочие некоторых отраслей индустрии, когда в западные страны хлынул поток дешевой рабочей силы из развивающихся государств. Тем самым информационная магистраль станет мощной движущей силой международного обмена интеллектуальными товарами и услугами, - как когда-то доставка грузов по воздуху и морские контейнерные перевозки помогли развитию международной торговли.

В итоге мир станет богаче, а значит, и стабильнее. Вероятно, развитые страны и их рабочий потенциал сохранят за собой ощутимое экономическое превосходство. Однако разрыв между сильными и слабыми (экономически) государствами сократится. Запоздалый старт иногда дает определенное преимущество. Он позволяет тем, кто начал позже, не делать лишних шагов и ошибок, допущенных первопроходцами. Эти страны перешагнут через этап индустриализации. Они вступят непосредственно в информационный век. Например, в Европе телевидение появилось на несколько лет позже, чем в США. А результат - более высокое качество телевизионной картинки, поскольку к тому времени, когда Европа выбирала свой стандарт, появились более совершенные разработки. И вот уже несколько десятилетий европейцы наслаждаются более качественным телевизионным изображением.

Телефонные системы - еще один пример того, как запоздалый старт может дать определенное преимущество. В Африке, Китае и других развивающихся странах мира многие жители пользуются сотовыми телефонами. Они быстро распространяются в Азии, Латинской Америке и других подобных государствах, так как не требуют прокладки медных проводов. Многие специалисты предсказывают, что совершенствование технологии сотовой связи позволит этим странам вообще обойтись без традиционных "проводных" телефонных систем. Им не придется рубить миллионы деревьев на телеграфные столбы или тянуть сотни тысяч миль медной проволоки только для того, чтобы потом все это разломать. Беспроводная система станет их первой телефонной сетью.

Совершенные средства связи обещают выровнять различия между государствами и уменьшить значение государственных границ. Факс, портативная видеокамера и CNN (Cable News Network), наряду с другими силами, приблизили крах коммунистических режимов и окончание холодной войны, потому что благодаря им информация легко прорывалась за "железный занавес".

Коммерческое спутниковое телевидение позволяет теперь гражданам таких государств, как Китай и Иран, ловить отблески окружающего мира без санкций своих правительств. Новый вид доступа к информации может сплотить людей, помогая им понять чужие культуры. Однако кое-кто полагает, что, когда бесправные народы узнают о более цивилизованных отношениях, это приведет к разочарованию и, хуже того, к "революции ожиданий". Или так. Информационная магистраль дает своим пользователям огромное преимущество, и из-за этого в отдельных обществах якобы нарушится баланс между традиционным и современным образом жизни. Дескать, некоторые культуры окажутся под угрозой, так как люди начнут больше интересоваться глобальными проблемами и мировыми культурами в ущерб национальному укладу.

"Тот факт, что одна и та же реклама может привлечь и ньюйоркца, и фермера из Айовы, и жителя африканской деревни, еще не значит, что эти люди одинаковы", - критиковал Билл Мак-Киббен (Bill McKibben) проявляющуюся, с его точки зрения, на телевидении тенденцию сглаживать единообразным подходом местное своеобразие. "Просто очевидно, что этих людей связывает очень немногое, и именно то немногое, что у них есть общего, лежит в основе мирового сообщества".

Тем не менее, если люди хотят смотреть рекламу или программу, которую она поддерживает, следует ли их лишать такой возможности ? Этот политический вопрос каждой стране придется решать самостоятельно. Однако фильтровать материалы, передаваемые по магистрали, будет весьма нелегко.

У американской массовой культуры оказался такой потенциал, что некоторые государства сейчас пытаются ограничить ее распространение. Они надеются, что местное телевидение выживет, если иностранному разрешить выходить в эфир лишь на несколько часов в неделю. Однако в Европе доступность спутникового и кабельного телевидения затрудняет правительственный контроль. А информационная магистраль вообще разрушит границы, и мировая культура (или отдельные ее ценности и традиции) станет достоянием всех народов. Магистраль поможет и патриотам (даже живущим вдали от исторической родины) обращаться к собратьям по крови или убеждениям. Укрепляя разнообразие культур, этнические сообщества, магистраль в какой-то мере будет противодействовать воцарению единой мировой культуры.

Если люди намеренно сужают круг своих интересов и сторонятся внешнего мира, если штангисты общаются только со штангистами, а латыши читают только латышские газеты, возникает риск утратить что-то из общечеловеческих ценностей и мирового опыта. Подобная ксенофобия может привести к раздроблению общества. Но уверен, этого не случится, потому что люди хотят ощутить свою принадлежность к разным сообществам, в том числе и к мировому. Обычно именно телевидение позволяет всем нам, американцам, вместе переживать какое-нибудь событие национального масштаба - будь то взрыв "Челленджера", розыгрыш Суперкубка, инаугурация президента, военные действия в Персидском заливе или автомобильные гонки. В такие моменты мы едины.

Кроме того, людей беспокоит, что мультимедиа превратится в такой доступный и привлекательный вид досуга, что некоторые будут пользоваться системой слишком часто, в ущерб всему остальному. Действительно, когда виртуальная реальность станет доступна всем, это может вырасти в серьезную проблему.

В один прекрасный день игра в виртуальную реальность позволит Вам зайти в виртуальный бар и переглянуться с какой-нибудь обворожительной незнакомкой. Она заметит Ваш интерес и подойдет, чтобы завязать разговор. Вы очаруете новую подругу своим шармом и остроумием. Возможно, вы оба решите тут же отправиться в Париж. У-ух ! И вот Вы уже в Париже, любуетесь витражами Нотр-Дам де Пари. "Вы никогда не катались на 'звездном пароме' (Star Ferry) в Гонконге ?" - может быть, спросите Вы у своей красотки, приглашая ее в новое путешествие... Да, виртуальная реальность - штука посильнее любой видеоигры, и можно запросто впасть от нее в зависимость.

Если Вы почувствуете, что слишком часто или слишком надолго уходите в эти - такие заманчивые ! - миры, и это начнет вас беспокоить, всегда можно найти "противоядие". Скажите системе: "Какой бы пароль я ни ввел, никогда не давай мне играть больше получаса в день". Небольшой ограничитель избавит вас от привыкания к тому, что стало навязчиво-желанным. Примерно так же, как если бы Вы наклеили на холодильник парочку снимков толстяков, чтобы отбить свой чрезмерный аппетит.

Ограничители всегда помогут совладать с теми привычками, которые потом вызывают только раскаяние и сожаление. Если кто-то предпочитает проводить свободное время, разглядывая витражи на модели собора Парижской богоматери или болтая в виртуальном баре с искусственным другом, то это его (или ее) право. Сегодня многие подолгу просиживают перед телевизором. Эти зрители только выиграют, если нам удастся заменить пассивные развлечения интерактивными. Честно говоря, меня не очень беспокоит, что люди будут "пропадать" на информационной магистрали. Мне кажется, ситуация будет не страшнее, чем с компьютерными или азартными играми. Ну а тем, кто чересчур увлечется виртуальной реальностью, помогут реабилитационные группы - примерно те же, что сегодня помогают наркоманам и алкоголикам.

Куда больше, чем излишняя склонность отдельных лиц к удовольствиям, меня волнует уязвимость общества, которое может слишком доверчиво во всем полагаться на магистраль.

Эта сеть и машины на базе компьютеров, подключенных к ней, станут для каждого человека новой игровой площадкой, новым рабочим местом, новым учебным классом. Сеть заменит обычные платежные средства. Она поглотит большую часть существующих видов связи. Она будет нашим фотоальбомом, дневником, телевизором. Сила магистрали - в ее гибкости, но это же означает, что мы будем очень сильно от нее зависеть.

Такая зависимость может стать опасна. При отключении электричества в Нью-Йорке в 1965 и 1977 годах миллионы людей несколько часов пребывали в панике. Электроэнергия - это свет, отопление, транспорт и безопасность. Когда она отключилась, застряли лифты, погасли светофоры, остановились водяные насосы. Город был парализован.

О возможности полного разрушения информационной магистрали стоит побеспокоиться заранее. Однако, благодаря сильной децентрализации системы, случайная авария вряд ли приведет к большим потерям. Если выйдет из строя один сервер, его заменят другим, и данные восстановят. Но система весьма уязвима. С ростом ее авторитета придется все чаще применять принцип избыточности - дублировать все ее важные компоненты. Уязвимость системы отчасти кроется в ее зависимости от криптографии - математических замков, предохраняющих информацию от несанкционированного доступа.

Ни одна из современных защитных систем - будь то замок на рулевом колесе или стальной сейф - не дает гарантий абсолютной надежности. В лучшем случае можно лишь максимально осложнить работу потенциальному взломщику. Вопреки всеобщему убеждению в обратном, безопасность компьютерной информации достаточно высока. Компьютеры способны настолько хорошо защищать свои данные, что даже самым изощренным хакерам нелегко добраться до них, если только кто-нибудь, работающий с этими данными, не допустит ошибку. Именно небрежность чаще всего пробивает брешь в безопасности компьютерных систем. На магистрали вероятность ошибок тоже довольно велика; при этом потоки информации будут куда значительнее. Кто-то распространит цифровые билеты на концерт, а они окажутся поддельными. И всякий раз, когда будет случаться нечто подобное, придется пересматривать не только систему, но, быть может, и законы.

Поскольку неприкосновенность цифровых денег всецело зависит от используемых шифров, любое достижение в математике или компьютерной науке, ниспровергающее очередную криптографическую систему, может обернуться настоящей катастрофой. Одним из таких открытий в математике может стать более эффективный способ разложения простых чисел на множители. Любой человек или организация, владеющие этим способом, смогут подделывать деньги, проникать в личные, коммерческие и государственные тайны, даже подрывать безопасность государств - вот почему систему надо разрабатывать очень тщательно. Наша задача в том, чтобы после краха одной системы шифрования немедленно осуществлялся переход на другую, альтернативную систему. Тут есть над чем поразмыслить, до совершенства пока далеко. Особенно трудно обеспечить безопасность информации, которую надо хранить в неприкосновенности целое десятилетие, а иногда и дольше.

Большую тревогу вызывает и угроза неприкосновенности личной жизни. О каждом из нас частные компании и правительственные службы уже собрали огромное количество информации, и зачастую мы совершенно не знаем, насколько она а верна и как используется. Многие сведения о нас содержат различные переписи. Медицинские карточки, документы на автомашины, библиотечные записи, школьные дневники, судебные протоколы, кредиты, налоговые декларации, финансовые документы, автобиографии и счета позволяют составить о нас и нашей жизни вполне определенное представление. Допустим, Вы часто звоните в магазины, торгующие мотоциклами, и, может быть, интересуетесь их рекламой. Этот факт, по сути, коммерческая информация, которую телефонная компания - теоретически - может продать. Информация о нас постоянно обрабатывается, на ее основе формируют списки для адресной рассылки рекламы (по почте). Некоторые ошибки и злоупотребления в этой сфере уже вынудили принять специальное законодательство, которое регулирует использование подобных баз данных. В Соединенных Штатах каждый имеет право знакомиться с некоторыми видами сведений о себе, а также узнавать (в ряде случаев) о фактах знакомства с этой информацией других лиц. Пока такие сведения разбросаны по организациям, это в определенной мере гарантирует конфиденциальность Вашей личной жизни, но когда все базы данных содержит единая сеть, компьютеры легко соберут разрозненные фрагменты в одно пухлое досье. И тогда информацию о взятых кредитах можно связать с занимаемой должностью и с записями о торговых операциях, выстроив тем самым абсолютно точную картину всей Вашей деятельности.

С расширением деловой активности на магистрали и увеличением объема хранящейся на ней информации правительствам придется выработать политику, направленную на охрану этих данных. Реализация этой политики ляжет на администраторов сети, которые не должны допустить, чтобы врачи заглядывали в налоговые декларации своих пациентов, чтобы государственные аудиторы читали записи об образовательном уровне налогоплательщиков и чтобы учителя листали медицинские карточки учащихся. Потенциальная проблема - в злоупотреблениях информацией, а не в самом факте ее существования.

Сейчас мы раскрываем наши медицинские карточки перед страховой компанией, которая решает, будет ли она страховать нас на случай смерти. Такие компании могут заинтересоваться и тем, не проводим ли мы время в каких-либо опасных предприятиях вроде полетов на дельтаплане и участия в авторалли, не слишком ли много курим. А имеет ли право страховой агент просматривать записи о наших покупках только затем, чтобы убедиться: ничто не указывает на нашу склонность к рискованному поведению. Можно ли будущему работодателю выяснять, с кем мы общаемся и как развлекаемся, чтобы нарисовать наш психологический портрет ? На какую информацию о Вас имеют право власти государства, штата или города ? Что может узнавать о Вас человек, сдающий Вам квартиру ? К каким сведениям допустить будущего супруга или супругу ? Нам придется выработать как юридические, так и практические рамки неприкосновенности личной жизни.

Все эти опасения крутятся вокруг того, может ли один человек завести досье на другого. Но магистраль позволит каждому следить и за собственной деятельностью - вести что-то вроде "задокументированного образа жизни".

Ваш компьютер-бумажник будет фиксировать время и место, вести аудио- и (когда-нибудь) видеозаписи всего, что Вы делаете. Он запишет каждое слово, сказанное вами, и каждое слово, сказанное Вам, а также температуру, кровяное и атмосферное давление и множество других данных о Вас и Вашем окружении. Он сможет отслеживать Ваше общение с магистралью: вводимые команды, отправляемые сообщения, кому Вы звоните и кто звонит Вам. Вряд ли найти лучший источник информации, если Вы хотите вести дневник или писать автобиографию. Если же ни то, ни другое Вам неинтересно, то, по крайней мере, Вы всегда выясните, где и когда сделана та или иная фотография, вставляемая в цифровой семейный фотоальбом.

Сложных технологий здесь не потребуется. Скоро человеческую речь будут сжимать до нескольких тысяч бит цифровой информации в секунду, а это значит, что часовой разговор превратится в 1 мегабайт цифровых данных. Небольшие кассеты, которые используют для резервного копирования информации с жестких дисков, уже сейчас вмещают по 10 и более гигабайт данных - вполне достаточно, чтобы записать порядка 10000 часов сжатого звука. Кассеты для нового поколения цифровых видеомагнитофонов смогут хранить более 100 гигабайт, т.е. на единственную ленту стоимостью в несколько долларов удастся записывать все разговоры, которые человек ведет на протяжении десяти лет, а то и всей жизни - в зависимости от того, насколько он разговорчив. Мои расчеты основаны, естественно, на сегодняшних возможностях, а в будущем хранение данных обойдется намного дешевле. Пока мы говорим только о звуке, но через несколько лет встанет вопрос и о записи полноскоростного видео.

Лично меня от перспективы задокументированного образа жизни немного лихорадит, но кого-то эта идея, напротив, согревает. Один из доводов - документирование является средством защиты. Карманный компьютер можно рассматривать как машину, создающую алиби, - шифрованные цифровые записи предоставят доказательства против ложных обвинений. Если кто-нибудь в чем-то Вас обвинит, Вы тут же парируете: "Извини, приятель, но моя жизнь задокументирована. Записано все до последнего бита. И я могу подтвердить, что говорил. Так что не шути со мной". С другой стороны, если Вы действительно совершили правонарушение или допустили промах, его уже не удастся скрыть. Любое преступление оставит след. Записи разговоров Ричарда Никсона в Белом доме, а потом и подозрения, что он пытался подменить эти пленки, сыграли определенную роль в его отставке с поста президента. Он решил вести задокументированную политическую жизнь, но прожил ее так, что пожалел о своем решении.

Дело Родни Кинга (Rodney King) продемонстрировало все плюсы и минусы такой улики, как видеозапись. А вскоре каждая полицейская машина, даже каждый полицейский будут вооружены цифровой видеокамерой, отмечающей время и место записи так, что их нельзя подделать. А на записи действий полиции скорее всего настоит общественное мнение. Да и полиция, вероятно, будет "за", чтобы защитить себя от обвинений в жестокости и злоупотреблениях, с одной стороны, и чтобы легче собирать улики - с другой. В некоторых полицейских подразделениях уже сегодня записывают на видеопленку все аресты. Этот вид видеозаписи коснется не только полиции. Страхование от медицинских ошибок можно сделать дешевле или разрешить только тем врачам, которые снимают на видеокамеру весь процесс лечения: от хирургической операции до обычного приема. Автобусные и таксомоторные компании, а также транспортные агентства, очевидно, заинтересованы в добросовестности своих водителей. Уже есть передовые компании, которые установили оборудование, записывающее километраж и среднюю скорость. Я не удивлюсь, если появится предложение оснащать каждый автомобиль, включая наши с Вами, не только записывающим устройством, но и передатчиком, который бы идентифицировал машину и ее местонахождение - номерной знак будущего. В конце концов, ставим же мы сегодня на самолеты "черные ящики". Если цены на них упадут, почему бы не установить их и в машины ? Вот тогда угнанный автомобиль немедленно сообщил бы Вам свое местонахождение. А при попытке лихача скрыться после аварии или наезда судья дал бы санкцию на запрос: "Какие транспортные средства находились в пределах двух кварталов от места происшествия в течение такого-то времени ?" Черный ящик способен регистрировать координаты и скорость всех машин, что наверняка дисциплинировало бы автолюбителей и привело к соблюдению правил движения. Но я бы голосовал против этого.

В мире, все больше насыщаемом приборами, может настать день, когда любые события в общественных местах будут фиксироваться видеокамерами. Ведь сейчас никого не удивляют видеокамеры на улицах. Они устанавливаются (зачастую скрытно) в банках, аэропортах, будках автоответчиков, больницах, на шоссе, в магазинах, лифтах, вестибюлях отелей и офисных зданий. Такое количество "глаз", постоянно следящих за нами лет пятьдесят назад напугало бы кого угодно, а не только Джорджа Оруэлла (George Orwell). Но сегодня мы привыкли к ним. В Соединенных Штатах и Европе жители кое-где даже приветствовали установку видеокамер на улицах и автомобильных стоянках. В Монако практически исчезла уличная преступность - благодаря тому, что за крошечным княжеством непрерывно наблюдают сотни видеокамер. Конечно, Монако - государство очень маленькое, его площадь всего 370 акров (150 гектаров), и ему вполне достаточно нескольких сотен подобных устройств. Но многие родители не возражали бы против их установки на школьных дворах, чтобы отпугнуть или переловить торговцев наркотиками, маньяков и просто хулиганов. Понадобятся сравнительно небольшие капиталовложения, чтобы установить видеокамеры на улицах и подключить их к информационной магистрали. Компьютеры смогут сканировать видеозаписи в поисках определенного человека или события - и стоить (лет через десять) это будет совсем недорого. В каждом городе общественная безопасность напрямую зависит от уличного освещения. Легко представить, что в будущем кто-то предложит, чтобы почти на каждом фонарном столбе висела как минимум одна видеокамера. Доступ к информации с этих камер получило бы только ответственное лицо, да и то в случае преступления, возможно, лишь с санкции суда. Кто-то, наверное, возразит, что каждому должно быть предоставлено право просмотра любых записей с любой видеокамеры. У меня это сразу вызывает протест - а как же насчет неприкосновенности личной жизни ? Правда, можно парировать - если видеокамеры установят только в общественных местах, ничего страшного не случится.

С исторической точки зрения, люди, живущие в западных демократиях, уже сейчас пользуются такой степенью неприкосновенности и личной свободы, которая не имеет прецедентов. Однако почти все готовы на какие-то ограничения в обмен на безопасность. Если испытания докажут, что видеокамеры, установленные повсеместно и связанные с информационной магистралью, существенно препятствуют серьезным преступлениям, могут разгореться споры о том, чего бояться больше: преступлений или надсмотра. Трудно представить, чтобы правительство Соединенных Штатов санкционировало подобный эксперимент, поскольку он затрагивает неприкосновенность личной жизни и, может быть, даже противоречит конституции. Однако общественное мнение может меняться. Еще несколько таких событий, как взрыв в Оклахома-Сити, и все. Что кажется сегодня чем-то вроде Старшего Брата (только в цифровой форме), однажды может стать нормой, если в ином случае нам придется сдаться на милость бандитов и террористов. Я не защищаю ни одну из этих точек зрения, но техника позволит обществу сделать политический выбор.

Техника не только сделает видеозапись, но и сохранит личные документы и переписку в тайне. Программы для шифрования, которые любой может скачать из Internet, превратят компьютер почти в крепость. А по мере развертывания магистрали будут защищены все виды цифровой информации: телефонные звонки, файлы, базы данных и т.д. Пока вы держите свой пароль в секрете, информация, хранящаяся на компьютере, находится под прочнейшим из когда-либо существовавших замков. Ни у одного человека еще не было такой степени защиты личной информации.

Многие члены правительства возражают против распространения шифровальных технологий, так как это мешает им собирать информацию. Как ни печально для них, но технический прогресс остановить нельзя. Агентство национальной безопасности (National Security Agency, АНБ) - одна из оборонных и разведывательных служб США, которая защищает секретную государственную связь и расшифровывает переговоры по иностранным линиям связи с целью сбора разведданных, - не хочет, чтобы программы, где реализованы новейшие алгоритмы шифрования, распространялись за пределами Соединенных Штатов. Тем не менее такие программы уже есть во всем мире, их можно запустить на любом компьютере. И никакое политическое решение не вернет правительству те возможности подслушивания, которыми оно располагало в прошлом.

Современное законодательство, запрещающее экспорт программного обеспечения с мощным шифровальным потенциалом, может повредить американским компаниям, производителям компьютерного оборудования и программных продуктов. Эти ограничения ставят иностранных конкурентов в выгодные условия. Правда, американские компании почти единодушно соглашаются, что нынешние ограничения на экспорт шифровальных технологий просто не срабатывают.

Каждое достижение в развитии средств связи заметно отражается на взаимоотношениях народа со своим правительством. Печатный пресс и, как следствие, массовое распространение газет изменили природу политических споров. Радио, а потом и телевидение позволили лидерам напрямую и доверительно Обращаться к населению. Информационная магистраль тоже приведет к новым отношениям в политике. Впервые политические деятели смогут моментально узнавать итоги репрезентативных опросов общественного мнения (и реагировать на них). Избиратели будут голосовать дома или через карманный компьютер при меньшем риске подтасовок результатов выборов или ошибок. Создание магистрали повлияет на управление государством, может быть, не меньше, чем на промышленность.

Если даже предположить, что общая схема принятия политических решений существенно не изменится, магистраль придаст политической жизни новые краски. Большую активность смогут развить граждане, выдвигая своего кандидата или организуя обсуждение какого-то вопроса. Возрастет число общественных групп со специфическими интересами, а возможно, и число политических партий. Сегодня организация политического движения требует огромных координирующих усилий. Как найти людей, разделяющих Вашу точку зрения ? Как воздействовать на их убеждения ? Как, наконец, общаться с ними ? Телефоны и факс-аппараты - отличное средство связи, но только в том случае, если вы знаете, куда и кому звонить. Благодаря телевидению один человек может обратиться к миллионам, но это и дорого, и неэффективно, если Ваши идеи не разделяет большая часть зрителей.

Политические организации нуждаются в тысячах добровольцев. Ведь нужно заклеивать конверты с призывами, отправлять их по почте и всеми возможными способами находить единомышленников. А лишь немногие проблемы (например, экологические) могут привлечь такое количество союзников, которое обеспечит жизнеспособность политической организации.

Информационная магистраль упростит все виды связи. Электронные доски сообщений и другие сетевые форумы создадут превосходные условия для контакта "один на один" и по принципу "один со многими" или "многие со многими". Единомышленники и просто энтузиасты какого-то дела будут встречаться в компьютерных сетях, дебатировать, учреждать партии или объединения без особых на то усилий. Так же легко можно организовать и политическое движение. Я думаю, что в период президентских выборов 1996 года в США сеть Internet впервые привлечет значительное внимание всех кандидатов и политических групп. А впоследствии магистраль превратится в важнейший канал обмена политическими мнениями.

По некоторым государственным вопросам в США уже проходит прямое голосование. Но такой способ (а он весьма дорогостоящий) применяют только тогда, когда основные варианты выбора уже определены. Информационная магистраль позволит проводить такие голосования чаще, поскольку они резко подешевеют.

Кое-кто, несомненно, предложит "прямую демократию", при которой на голосование будут ставиться все вопросы. Лично я не думаю, что прямое голосование - хороший способ управления государством. В управлении должны участвовать представители народа - своеобразные посредники, создающие добавленную стоимость. Их работа именно в том и состоит, чтобы изучать сложные вопросы во всех нюансах. Политика немыслима без компромиссов, которых нельзя достичь, если принимать решения всем обществом, а не через его представителей. Искусство управления - компанией или государством - заключается в выработке квалифицированных решений о выделении ресурсов. Аналогичные решения принимают и профессиональные политики. Лучшие из них предлагают неочевидные решения, которые бы никогда не одержали верх при прямой демократии, поскольку избиратели могут просто не владеть ситуацией, не понимать всех условий, необходимых для достижения успеха.

Как и всем посредникам в новом электронном мире, политикам придется перестроиться. Информационная магистраль поставит их в центр всеобщего внимания. Вместо того чтобы любоваться их фотографиями и выслушивать от них афоризмы, избиратели оперативно узнают, чем заняты в данный момент их избранники или как они проголосовали. Не далек тот день, когда сенатор будет получать по электронной почте миллион писем по какому-нибудь вопросу или выяснять результаты опроса своих избирателей в режиме реального времени.

Несмотря на проблемы, возникающие со строительством информационной магистрали, мой энтузиазм все равно безграничен. Информационная технология уже глубоко проникает в нашу жизнь, о чем свидетельствует хотя бы электронное сообщение, присланное мне в июне 1995 года читателем моей газетной колонки. "Мистер Гейтс, я - поэт, страдающий от дислексии, т.е. чертовски путаюсь в правописании, и у меня не было бы ни малейшей надежды опубликовать свои произведения, если бы не возможность проверки орфографии на компьютере. Может быть, я буду плохим литератором, но благодаря Вам мой успех или провал теперь зависит только от моего таланта (или его отсутствия), а не от болезни".

Мы становимся свидетелями чего-то поистине исторического, что сотрясет весь мир, как научное открытие, изобретение печатного станка или промышленная революция. Если информационная магистраль поможет гражданам одной страны лучше понять соседние страны, снизив тем самым международную напряженность, уже одно это оправдает затраты на ее строительство. Если ею воспользуются только ученые, чтобы активнее сотрудничать в поиске лекарств от неизлечимых пока болезней, этот факт трудно будет переоценить. Если система превратится в умного и заботливого наставника детей, помогая им расширять круг своих интересов в школе и за ее пределами, это само по себе изменит человечество к лучшему. Информационная магистраль не решит всех проблем, но даст позитивный толчок к их решению во многих сферах.

Магистраль не расстелют перед нами, как ковровую дорожку, по заранее намеченному сценарию. Будут и задержки, и внезапные аварии. Некоторые ухватятся за эти неудачи и станут говорить, что магистраль всегда была чистой фантазией. Но первые неудачи пойдут лишь на пользу, если из них извлекут уроки. Магистраль - явление неизбежное.

Крупные изменения длятся не одно столетие. А это произойдет гораздо быстрее, хотя и не за одну ночь. Первые признаки информационной магистрали в Соединенных Штатах будут различимы уже к концу тысячелетия. Пройдет еще лет десять, и ее влияние проявится повсеместно. В этой книге я только пытаюсь угадать, какие области применения магистрали войдут в нашу жизнь очень скоро, а какие - в отдаленной перспективе, и наверняка я в чем-то ошибся. В ближайшие 20 лет почти все, о чем я говорил, в развитых государствах будет доступно всем, а в развивающихся - лишь деловым кругам и школам. Сначала установят и настроят нужное оборудование, а потом все будет зависеть от того, что люди будут делать с магистралью, - иначе говоря, какими программами они будут пользоваться.

Информационная магистраль станет частью Вашей жизни в тот момент, когда однажды Вы вдруг удивитесь, почему это в сети нет такой-то информации. Или в один прекрасный день Вы будете искать руководство по ремонту велосипедов и ворчать: "Кто это догадался напечатать его на бумаге, ведь его так легко потерять ?" Вы пожалеете, что оно не интерактивный электронный документ с мультроликами и видеоучебником, всегда доступный в сети.

Сеть сблизит нас, если мы того захотим, или поможет нам рассеяться на миллионы сообществ. Но важнее то, что информационная магистраль позволит все делать новому - по-новому проводить свободное время, по-новому искать информацию, по-новому общаться друг с другом.

Мне кажется, Антуан де Сент-Экзюпери, который сумел опоэтизировать отношение людей к паровозам и другой прогрессивной технике, приветствовал бы информационную магистраль и не согласился бы с доводами тех, кто сопротивляется ее прокладке. Полвека назад он писал: "Передача почты, передача человеческого голоса, передача мерцающих изображений - величайшие достижения этого века, как и прежде, ведущие к единственной цели: сплочению людей. Неужели наши мечтатели полагают, что человеческий дух деградировал после изобретения письменности, печатного дела или парусного корабля ?"

У информационной магистрали не один пункт назначения. Мне было интересно поразмышлять о некоторых из них. Не сомневаюсь: какие-то предсказания глупы, я лишь надеюсь на то, что их не слишком много. Так это или не так, но я с удовольствием отправляюсь в путешествие вместе с Вами.


Послесловие

Предыдущая глава

Послесловие

Информационная магистраль многое изменит в нас и нашей жизни. Как я предположил в девятой главе, наибольший выигрыш от применения этой технологии мы получим в образовании - формальном и неформальном. Желая внести свой скромный вклад, я передаю гонорар за книгу на поддержку учителей, внедряющих компьютеры в школьные классы. Эти средства (через организацию National Foundation for the Improvement of Education в Соединенных Штатах и аналогичные организации во всем мире) помогут учителям открыть школьникам новые возможности, как открыл их передо мной лейксайдский Клуб матерей.

Долгие часы я провел за этой книгой. Я работаю очень много, потому что люблю свою работу. Я - не "трудоголик", мне нравится заниматься и многими другими вещами, но работа мне очень интересна. Главная моя цель - постоянно обновляя Microsoft, удержать ее на передовых позициях. Чуть-чуть пугает, что в истории развития компьютерной технологии еще не было прецедента, когда бы лидер одной эпохи сумел остаться таковым и в другой. Microsoft была лидером в эпоху персональных компьютеров. Поэтому я понимаю, что история лишает Microsoft права на лидерство в век информации - на информационной магистрали. Но я не хочу склонять голову перед традицией. Где-то впереди нас ждет невидимый порог, переступив который, мы попадем из эпохи персональных компьютеров в эпоху информационной магистрали. Я стремлюсь быть среди первых, кто его переступит, - когда придет время. Тенденцию, по которой преуспевающие компании теряют способность к обновлению, я считаю всего лишь тенденцией, не более того. Слишком сосредоточившись на своем бизнесе, трудно переломить себя и заняться чем-то абсолютно новым.

Лично я всегда любил нанимать и работать с умными людьми. Мне нравится учиться у них. Некоторые из тех, кого мы сейчас берем на работу, гораздо моложе меня. Я завидую им: они выросли в окружении более совершенных компьютеров. Они очень талантливы и генерируют множество новых идей. Если Microsoft сумеет соединить эти идеи с пожеланиями клиентов, у нас появится шанс сохранить лидерство. Тогда мы сможем по-прежнему предлагать все более и более совершенные программы, которые превратят персональный компьютер в универсальный инструмент. Я часто говорил, что у меня лучшая в мире работа, и я говорил это вполне серьезно.

Мне кажется, наступают интересные времена. Никогда еще не было столько возможностей делать то, что раньше казалось просто невероятным. Сейчас лучшая пора, чтобы открывать новое дело, двигать вперед науки (например, медицину, которая улучшает качество жизни), не терять контакта с друзьями и родными. И хорошие, и плохие стороны технического прогресса очень важно обсуждать как можно шире, чтобы его направление определяло все общество, а не только специалисты.

Ну вот и все. В предисловии я говорил, что хочу этой книгой начать диалог, привлечь внимание к тем возможностям и проблемам, которые возникнут перед отдельными людьми, большими компаниями и целыми странами. Надеюсь, что, прочитав эту книгу, Вы разделите часть моего оптимизма и присоединитесь к дискуссии о том, как нам строить будущее.

Предыдущая глава